Loading ...
Sorry, an error occurred while loading the content.
 

Re: [viavoice] Re: getting ViaVoice to work on Debian

Expand Messages
  • Karen
    Mark Sutton writes ... Sorry this is long time ago no but RL interfered with my attempts to get ViaVoice ... I ve now identified at least 5
    Message 1 of 1 , Mar 6 11:15 AM
      Mark Sutton <mes@...> writes

      >Dean writes:


      Sorry this is long time ago no but RL interfered with my attempts to get
      ViaVoice
      >>
      >>>I have the stock debian version of jdk installed, that is 1.1.8.
      >>No-one has been able to get viavoice to work on Debian potato.

      I've now identified at least 5 Debian Potato users of ViaVoice, and as
      far as I can tell they were all using Sun JDK 1.3. And several have
      actively or passively supplied me with useful information, and a couple
      I owe email updates as a result - they will come please take this as
      interim.

      I'm actually trying to document [briefly] some of the hurdles I fell
      over, some are Debian specific but by no means all. Some of the mistakes
      were things which I could have avoided. If its useful I'll post it
      here. I'm cross posting this to the XVoice list as the 'Debian' issue
      has cropped up on both a number of times.

      I added myself briefly to that success list using the Sun JDK with 2.2
      but had persistent sound quality problems and a few other niggles. I
      also has a persistent problem with the enlightenment sound demon which I
      suspect may be related to the Helix desktop I had installed. Nice
      desktop but the esd would insist on firing up on load and was very
      reluctant to be disabled. I know that people run the Enlightenment
      window manager with ViaVoice but I haven't yet heard of anyone running
      Helix with it. I'd be interested to hear if they have. Firing up an
      XSession worked just fine, and sure enough there was no esd running.

      I could have carried on just using a regular window manager but I wanted
      a desktop because its easier to manage on bad hands days.

      So KDE was worth a try, and that with the sound niggles was the push to
      upgrade to 2.4.1 kernel for the better sound support and Woody [Debian
      test version], and I've now gone onto 2.4.2 and Sid [Debian unstable].
      Along the way I upgraded my OSS sound drivers to the new version and
      sound really rocks - best I have had under Linux.

      >There
      >>are java and c library issues.

      The only issue that was a major problem in the end was getting a version
      of Java which would work. I had a few other problems along way but these
      turned out to be related to problems porting across voice models more
      than anything else, and change in length of user id's.

      > We have a ViaVoice Dictation user that
      >>has been able to get viavoice to work on the latest Debian(I think
      >>that was debian2.2 and Sun1.3JDK with native threads). I'm not sure
      >>what happens when you run the UserGuru on jdk1.1.8. That may be another
      >>no-no. I know ViaVoice Dictation uses java classes that aren't in
      >>blackdown 1.1.8(but are in 1.2.2) but I'm not positive that is true for
      >>the UserGuru too.
      >>DeanO
      >
      >Works just fine for me. Has for a year and a half.
      >Potato is Debian2.2, that is, libc2.1.3

      I did get it going with Potato, then Woody 2.4 and now Sid 2.4.2, all
      with Sun JDK 1.3.

      >The problem is sloppy file permissions by the rpm. There doesn't seem
      >to be any file permission consistency. About half are mode 777, like
      >/usr/lib/ViaVoice/samples/userguru/readme.userguru.txt
      >World writable, and executable, and living in /usr/lib!
      >chmod -R 755 /usr/lib/ViaVoice would be a good start.
      >
      >Userguru writes a PID file in /usr/lib/ViaVoice/UWiz
      >Which is 755 root:root by default. If your not root this fails.
      >If you have made the group audio and are part of it.
      >chown root:audio /usr/lib/ViaVoice/UWiz
      >chmod 775 /usr/lib/ViaVoice/UWiz
      >Should let you run as a normal user.

      Ok I have tried this and find that as 'root' everything including
      training works just great.

      However as user 'karen' if I run vvstartenrollment, the only user option
      I have is to train 'root'. This despite explicitly creating user
      'karen'. If I go ahead and try to train the 'root' under 'karen's
      home/karen/viavoice directories it lets me read the stories, and
      processes them but then when I try to start dictation it tells me that
      I haven't enrolled, and sure enough I fire up enrollment and none of the
      stories are marked as 'processed'. No error messages appear, the
      enrollment simply doesn't seem to get written to either 'karen' or
      'root' users.

      So I can use everything as root but not as 'karen'. Any suggestions as
      to where I may have bad permissions?


      >
      >For the JDK
      >Sun's jdk-1_2_2_006-linux-i386.tar.gz works

      This is the only one I could get to work with Potato, the only one I
      have tried subsequently.

      >IBM's IBMJava2-SDK-13.tgz works if you remove the -native switch
      >Neither one does native threads but that doesn't seem to matter.

      That interests me because I actually tried this and it made no
      difference at all. Java bombed out every time until I switched to Sun
      1.3.

      My current challenge is to get user 'karen' functioning and also Xvoice
      working with either user since at the moment it is reluctant to Dictate
      into the target window.

      Does anyone have Xvoice 0.9.5 running with the KDE 2.1 desktop as yet?
      [or any other KDE desktop for that matter]. 0.8.1 Worked just fine with
      Debian Potato in an Xsession, and I am not entirely sure which change is
      the problem here or whether I should just regress versions.

      It would be useful to know if anyone has it working with KDE at least.


      regards,
      --
      Karen Hunter-Jones karen@...
    Your message has been successfully submitted and would be delivered to recipients shortly.