Loading ...
Sorry, an error occurred while loading the content.

comma gets appended while retrieving numeric data from dbms

Expand Messages
  • rajadayalan
    Hi, I m new to xmldbms. When i retrieve numeric data from sql server using xmldbms2.0 , gets appended to the data. For eg an id 1065697033878 gets retreived as
    Message 1 of 2 , Nov 3, 2003
    • 0 Attachment
      Hi,

      I'm new to xmldbms. When i retrieve numeric data from sql server using xmldbms2.0 , gets appended to the data. For eg an id 1065697033878 gets retreived as 1,065,697,033,878. How do i remove these commas. Is there any step i should do to strip these commas.

      Any help is appreciated. Thanks in advance.

      Note:- Yahoo groups is banned in India. I can send/receive mails from yahoo groups. I'll not be able to browse the archives. So when u reply for this mail please send a copy of it to me.

      regards
      dayalan



      ---------------------------------
      Do you Yahoo!?
      Exclusive Video Premiere - Britney Spears

      [Non-text portions of this message have been removed]
    • xmldbms
      By default, XML-DBMS formats numbers and dates according to the current locale. You can override this with the formatting elements -- DecimalFormat,
      Message 2 of 2 , Nov 7, 2003
      • 0 Attachment
        By default, XML-DBMS formats numbers and dates according to the
        current locale. You can override this with the formatting elements --
        DecimalFormat, NumberFormat, DateFormat, TimeFormat, DateTimeFormat,
        and SimpleDateFormat. You will use the DecimalFormat element.

        If you want to specify a single format for all columns of a
        particular type, then you can use the DefaultForTypes attribute of
        the DecimalFormat element. For example:

        <Options>
        <!-- I think this pattern will work. See the JavaDocs
        for the java.text.DecimalFormat class if it doesn't. -->
        <DecimalFormat Pattern="#" DefaultForTypes="INTEGER" />
        </Options>

        You can also specify a format for a particular column by naming the
        format and using that name in the Format attribute of the Column
        element. For example:

        <Options>
        <!-- Define and name a format here. -->
        <DecimalFormat Pattern="#" Name="IDFormat" />
        </Options>
        <Databases>
        <Database>
        <Catalog>
        <Schema>
        <Table Name="MyTable">
        ...
        <!-- Reference the format here -->
        <Column Name="ID" DataType="INTEGER"
        Format="IDFormat" />
        ...
        </Table>
        </Schema>
        </Catalog>
        </Database>
        </Databases>

        -- Ron

        --- In xml-dbms@yahoogroups.com, rajadayalan <rajadhayalan@y...>
        wrote:
        > Hi,
        >
        > I'm new to xmldbms. When i retrieve numeric data from sql server
        using
        xmldbms2.0 , gets appended to the data. For eg an id 1065697033878
        gets
        retreived as 1,065,697,033,878. How do i remove these commas. Is
        there any step
        i should do to strip these commas.
        >
        > Any help is appreciated. Thanks in advance.
        >
        > Note:- Yahoo groups is banned in India. I can send/receive mails
        from yahoo
        groups. I'll not be able to browse the archives. So when u reply for
        this mail
        please send a copy of it to
        me.
      Your message has been successfully submitted and would be delivered to recipients shortly.