Loading ...
Sorry, an error occurred while loading the content.
 

Re: RE: [xml-dev] Java: interface methods with same name and signature]

Expand Messages
  • Sean
    Yes, I agree this is a prob. Look at this for more info:http://groups.google.com/groups?hl=en&rnum=1&selm=31BBBD2D.3B45%40eidolon.co mBad, bad. But I don t
    Message 1 of 2 , Oct 26 7:57 PM
      Yes, I agree this is a prob. Look at this for more info:

      http://groups.google.com/groups?hl=en&rnum=1&selm=31BBBD2D.3B45%40eidolon.co
      m

      Bad, bad. But I don't know if it's a prob in this case. I don't think that
      Connection and PooledConnection are meant to be implemented on the same
      object.

      Consider the fact that PooledConnection has a getConnection method. The docs
      say that this returns a Connection interface which is to be used
      temporarily.

      Just thought that was interesting.

      Sean


      ----- Original Message -----
      From: "Ronald Bourret" <rpbourret@...>
      To: <sean0x77@...>
      Sent: Friday, October 26, 2001 16:12
      Subject: [Fwd: RE: [xml-dev] Java: interface methods with same name and
      signature]


      > Looks like we're out of luck. I think what we'll do is define our own
      > interface similar to PooledConnection but change the name of the close()
      > method to closeUnderlyingConnection(). Same thing on PooledStatement
      > interface.
      >
      > -- Ron
      >




      _________________________________________________________
      Do You Yahoo!?
      Get your free @... address at http://mail.yahoo.com
    • Ronald Bourret
      ... They re not designed to be implemented on the same object, but doing so fits well in our design. Let s just change the name of PooledConnection to
      Message 2 of 2 , Oct 27 11:56 AM
        Sean wrote:
        > I don't think that
        > Connection and PooledConnection are meant to be implemented on the same
        > object.

        They're not designed to be implemented on the same object, but doing so
        fits well in our design. Let's just change the name of PooledConnection
        to PooledConn and change the names of the colliding methods to
        closeActualConnection and getActualConnection. We'll need to make the
        same changes in PooledStatement (rename to PooledStmt for consistency).

        -- Ron
      Your message has been successfully submitted and would be delivered to recipients shortly.