Loading ...
Sorry, an error occurred while loading the content.

Re: [xenu-usergroup] Re: New ...

Expand Messages
  • Tilman Hausherr
    ... http://www.cityasburypark.com/ does not work (no such host) http://www.cityofasburypark.com/ does work and it has 109 URLs Tilman
    Message 1 of 14 , Apr 14, 2008
    • 0 Attachment
      On Tue, 15 Apr 2008 03:13:20 -0000, wernerapnj wrote:

      >--- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@...> wrote:
      >
      >>
      >> Last time I checked the (longer) URLs you gave me. But I see that you
      >> have a different problem:
      >> http://www.cityofasburypark.com/content/80/default.aspx
      >> links to
      >> http://www.cityasburypark.com/
      >> The "of" is missing.
      >>
      >> http://www.njtransit.com/sf_train_timetables.shtm
      >> does not exist.
      >=====================================================================
      >
      >Different Problem ?? not sure what you mean.

      http://www.cityasburypark.com/ does not work (no such host)


      http://www.cityofasburypark.com/ does work and it has 109 URLs

      Tilman

      >I scan
      >cityofasburypark.com and it only reports those 2 errors when clearly
      >there are more errors then that.
      >
      >Thats what I'm asking about, why does it not report the other errors??
      >Werner
      >
      >
      >------------------------------------
      >
      >Yahoo! Groups Links
      >
      >
      >
    • wernerapnj
      ... ================================================================ ????? OK ????????? Whats the point? Clearly the first one does not exist and is duly
      Message 2 of 14 , Apr 15, 2008
      • 0 Attachment
        --- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@...> wrote:
        >
        > On Tue, 15 Apr 2008 03:13:20 -0000, wernerapnj wrote:
        >
        > >--- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@> wrote:
        > >
        > >>
        > >> Last time I checked the (longer) URLs you gave me. But I see that you
        > >> have a different problem:
        > >> http://www.cityofasburypark.com/content/80/default.aspx
        > >> links to
        > >> http://www.cityasburypark.com/
        > >> The "of" is missing.
        > >>
        > >> http://www.njtransit.com/sf_train_timetables.shtm
        > >> does not exist.
        > >=====================================================================
        > >
        > >Different Problem ?? not sure what you mean.
        >
        > http://www.cityasburypark.com/ does not work (no such host)
        >
        >
        > http://www.cityofasburypark.com/ does work and it has 109 URLs
        >
        > Tilman
        >
        ================================================================

        ????? OK ?????????

        Whats the point?

        Clearly the first one does not exist and is duly reported.
        What are you saying in the second case ? Too many links for xenu ?

        I am asking why the broken links on the other pages are not reported.

        Werner
      • Tilman Hausherr
        What I have been saying is that 1) One of the URLs http://www.cityasburypark.com does indeed not exist. 2) The other URL http://www.cityofasburypark.com does
        Message 3 of 14 , Apr 15, 2008
        • 0 Attachment
          What I have been saying is that

          1) One of the URLs http://www.cityasburypark.com does indeed not exist.
          2) The other URL http://www.cityofasburypark.com does exist and shows
          109 links. (You said it would show only one).
          3) Other URLs you said that didn't work do work.

          What I suggest is this:
          0) Get the latest version.
          1) Correct the broken link, i.e. the one that links to
          cityasburypark.com (without the "of").
          2) Scan the site again from the beginning. Save your work in a .XEN file.
          3) e-mail me to tilman at snafu dot de, with the .XEN file and with
          a) the URLs that you don't find there although they should be there, and
          with the URLs of the page where they are
          b) the URLs that are reported wrongly as broken
          c) the URLs that are reported wrongly as correct although they are broken.

          Tilman

          On Tue, 15 Apr 2008 10:34:08 -0000, wernerapnj <wernerapnj@...> wrote:

          > --- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@...>
          > wrote:
          > >
          > > On Tue, 15 Apr 2008 03:13:20 -0000, wernerapnj wrote:
          > >
          > > >--- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@>
          > > >wrote:
          > > >
          > > >>
          > > >> Last time I checked the (longer) URLs you gave me. But I see that
          > > >> you have a different problem:
          > > >> http://www.cityofasburypark.com/content/80/default.aspx
          > > >> links to
          > > >> http://www.cityasburypark.com/
          > > >> The "of" is missing.
          > > >>
          > > >> http://www.njtransit.com/sf_train_timetables.shtm
          > > >> does not exist.
          > > >=====================================================================
          > > >
          > > >Different Problem ?? not sure what you mean.
          > >
          > > http://www.cityasburypark.com/ does not work (no such host)
          > >
          > > http://www.cityofasburypark.com/ does work and it has 109 URLs
          > >
          > > Tilman
          > >
          > ================================================================
          >
          > ????? OK ?????????
          >
          > Whats the point?
          >
          > Clearly the first one does not exist and is duly reported.
          > What are you saying in the second case ? Too many links for xenu ?
          >
          > I am asking why the broken links on the other pages are not reported.
          >
          > Werner
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >
        • wernerapnj
          I think we are misunderstanding each other. My issue that I scan the site using: http://cityofasburypark.com/ I ASSUME that the entire site will the spidered
          Message 4 of 14 , Apr 15, 2008
          • 0 Attachment
            I think we are misunderstanding each other.

            My issue that I scan the site using:

            http://cityofasburypark.com/

            I ASSUME that the entire site will the spidered and reported on
            is that not correct?

            Clearly some PAGES on that site have problems,( I posted a few
            previously) those are not reported by the scan.

            Am I not understanding what xenu should do? I thought it should start
            at the root and work through all the branches and report.

            (BTW - I never said is showed only one link, kindly re-read my posts,
            I've already pointed out some of the issues)

            Thanks Werner


            --- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@...> wrote:
            >
            > What I have been saying is that
            >
            > 1) One of the URLs http://www.cityasburypark.com does indeed not exist.
            > 2) The other URL http://www.cityofasburypark.com does exist and shows
            > 109 links. (You said it would show only one).
            > 3) Other URLs you said that didn't work do work.
            >
            > What I suggest is this:
            > 0) Get the latest version.
            > 1) Correct the broken link, i.e. the one that links to
            > cityasburypark.com (without the "of").
            > 2) Scan the site again from the beginning. Save your work in a .XEN
            file.
            > 3) e-mail me to tilman at snafu dot de, with the .XEN file and with
            > a) the URLs that you don't find there although they should be there, and
            > with the URLs of the page where they are
            > b) the URLs that are reported wrongly as broken
            > c) the URLs that are reported wrongly as correct although they are
            broken.
            >
          • wernerapnj
            For anyone else reading this group.... Tilman has informed me that xenu does not parse Java Script embedded links. That is the cause on my difficulties.
            Message 5 of 14 , Apr 15, 2008
            • 0 Attachment
              For anyone else reading this group....

              Tilman has informed me that xenu does not parse Java Script embedded
              links. That is the cause on my difficulties.

              Regards - Werner
            • Stephen Gazard
              If I may suggest something. your links in your events section are of the format text Having your links in this
              Message 6 of 14 , Apr 15, 2008
              • 0 Attachment
                If I may suggest something.  your links in your events section are of the format <a onclick="window.open(.....)" href="#">text></a>

                Having your links in this format is not friendly to search engines/xenu which parse text, and don't interpret the JavaScript.  So for that reason alone you would want to generate links where you include the
                href="http://some.link.here" so that the links can be spidered/parsed.  If you've been having problems with the pop-up window opening and the page from which the link was opened also going to that link, simply alter your onclick statement to:  onclick="window.open(.....);return false;"  <-- the return false makes all the difference stopping the browser from following the link, while only executing the code which opens a new window.  So now your pop-up windows work fine, and the site can be spidered.   Both of which are a benefit to you.

                Apologies if you receive this in HTML and prefer text; I was trying to be clearer, and have sent in both formats
                Stephen

                wernerapnj wrote:
                For anyone else reading this group....

                Tilman has informed me that xenu does not parse Java Script embedded
                links. That is the cause on my difficulties.

                Regards - Werner
              Your message has been successfully submitted and would be delivered to recipients shortly.