Loading ...
Sorry, an error occurred while loading the content.

Re: [xenu-usergroup] javascript link checking

Expand Messages
  • Tilman Hausherr
    Please mention also an URL that uses that link, so that friendly people can test it. (unless they do already see trouble in the JS string) Tilman
    Message 1 of 4 , Jan 17, 2007
    • 0 Attachment
      Please mention also an URL that uses that link, so that "friendly
      people" can test it. (unless they do already see trouble in the JS
      string)

      Tilman

      On Wed, 17 Jan 2007 19:23:36 -0000, Barb Schmid wrote:

      >I have a link on a webpage with a format like:
      >
      ><a
      >href="javascript:new_openStoryWindow('../../Fresh/fresh_story/2007/01/2007-01-17-3251875472.html','_blank','blankName','status=no,scrollbars=yes,resizable=yes,width=500,height=500,left=100,top=50')">Story
      >title</a>
      >
      >I have put the javascript option in the .ini file, and I'm running
      >Xenu 1.2i
      >
      >
      >[Options]
      >javascript=javascript: *[_a-zA-Z0-9]+ *\(['"]([^'"]* +)['"]
      >
      >When I run Xenu, I still get the 'skip type' message on the javascript
      >links.
      >
      >I'd appreaciate any ideas I could try to get them checked without
      >creating new files for them.
      >
      >Barb
      >
      >
      >
      >
      >
      >Yahoo! Groups Links
      >
      >
      >
    • Tono
      I think the option must be: [Options] javascript=javascript: *[_a-zA-Z0-9]+ * ([ ]([^ ]* *)[ ] At the end there must be an * instead of +. If you put +
      Message 2 of 4 , Jan 17, 2007
      • 0 Attachment
        I think the option must be:
         

        [Options]
        javascript=javascript: *[_a-zA-Z0-9]+ *\(['"]([^'"]* *)['"]
         
        At the end there must be an * instead of +. If you put + should be one or more blank. With * it should be cero or one or more blank.

         
         
        ----- Original Message -----
        Sent: Wednesday, January 17, 2007 9:23 PM
        Subject: Re: [xenu-usergroup] javascript link checking

        Please mention also an URL that uses that link, so that "friendly
        people" can test it. (unless they do already see trouble in the JS
        string)

        Tilman

        On Wed, 17 Jan 2007 19:23:36 -0000, Barb Schmid wrote:

        >I have a link on a webpage with a format like:
        >
        ><a
        >href="javascript: new_openStoryWin dow('../. ./Fresh/fresh_ story/2007/ 01/2007-01- 17-3251875472. html','_blank' ,'blankName' ,'status= no,scrollbars= yes,resizable= yes,width= 500,height= 500,left= 100,top=50' )">Story
        >title</a>
        >
        >I have put the javascript option in the .ini file, and I'm running
        >Xenu 1.2i
        >
        >
        >[Options]
        >javascript= javascript: *[_a-zA-Z0-9] + *\(['"]([^'" ]* +)['"]
        >
        >When I run Xenu, I still get the 'skip type' message on the javascript
        >links.
        >
        >I'd appreaciate any ideas I could try to get them checked without
        >creating new files for them.
        >
        >Barb
        >
        >
        >
        >
        >
        >Yahoo! Groups Links
        >
        >
        >

      • Barb Schmid
        Thanks, Tono. I still haven t got it working, but I ll try to get something together and post the URL to see if anyone can see what I m doing wrong. Barb ...
        Message 3 of 4 , Jan 22, 2007
        • 0 Attachment
          Thanks, Tono. I still haven't got it working, but I'll try to get
          something together and post the URL to see if anyone can see what I'm
          doing wrong.

          Barb

          --- In xenu-usergroup@yahoogroups.com, "Tono" <tonospa@...> wrote:
          >
          > I think the option must be:
          >
          >
          > [Options]
          > javascript=javascript: *[_a-zA-Z0-9]+ *\(['"]([^'"]* *)['"]
          >
          > At the end there must be an * instead of +. If you put + should be
          one or more blank. With * it should be cero or one or more blank.
          >
          >
          >
          >
          > ----- Original Message -----
          > From: Tilman Hausherr
          > To: xenu-usergroup@yahoogroups.com
          > Sent: Wednesday, January 17, 2007 9:23 PM
          > Subject: Re: [xenu-usergroup] javascript link checking
          >
          >
          > Please mention also an URL that uses that link, so that "friendly
          > people" can test it. (unless they do already see trouble in the JS
          > string)
          >
          > Tilman
        Your message has been successfully submitted and would be delivered to recipients shortly.