Loading ...
Sorry, an error occurred while loading the content.

Xenu misses links on pages with base href

Expand Messages
  • sujan8739286
    Hi, Xenu seems to miss some links on pages with in the if the URI is missing the trailing slash. Quick & Dirty Examples:
    Message 1 of 5 , Jul 20 12:58 PM
    • 0 Attachment
      Hi,

      Xenu seems to miss some links on pages with <base href= ... > in the
      <head> if the URI is missing the trailing slash.

      Quick & Dirty Examples:

      <base href="http://example.org"><a href="foo.htm">Bar!</a>
      The Link to foo.htm doesn't appear in Xenu.

      <base href="http://example.org/"><a href="foo.htm">Bar!</a>
      Now it does.

      Seems to be a bug, right?

      Greetings,
      Jan
    • Tilman Hausherr
      ... Yes. It is corrected in the current beta. Do you need it (do you have a lot of pages with this?)
      Message 2 of 5 , Jul 20 1:07 PM
      • 0 Attachment
        On Thu, 20 Jul 2006 19:58:07 -0000, sujan8739286 wrote:

        >Hi,
        >
        >Xenu seems to miss some links on pages with <base href= ... > in the
        ><head> if the URI is missing the trailing slash.
        >
        >Quick & Dirty Examples:
        >
        ><base href="http://example.org"><a href="foo.htm">Bar!</a>
        >The Link to foo.htm doesn't appear in Xenu.
        >
        ><base href="http://example.org/"><a href="foo.htm">Bar!</a>
        >Now it does.
        >
        >Seems to be a bug, right?

        Yes. It is corrected in the current beta. Do you need it (do you have a
        lot of pages with this?)
      • sujan8739286
        ... I don t, I only wanted to make sure this will be fixed in one of the future builds. But a friend of mine could use it, because one of the sites he monitors
        Message 3 of 5 , Jul 20 1:24 PM
        • 0 Attachment
          > Yes. It is corrected in the current beta. Do you need it (do you have
          > a lot of pages with this?)

          I don't, I only wanted to make sure this will be fixed in one of the
          future builds. But a friend of mine could use it, because one of the
          sites he monitors causes this error.

          / Jan
        • Tilman Hausherr
          ... He could use this version http://home.snafu.de/tilman/tmp/xenu-parsetest.zip it also handles % in URLs differently (may be better for some sites). Tilman
          Message 4 of 5 , Jul 20 1:30 PM
          • 0 Attachment
            On Thu, 20 Jul 2006 20:24:57 -0000, sujan8739286 wrote:

            >> Yes. It is corrected in the current beta. Do you need it (do you have
            >> a lot of pages with this?)
            >
            >I don't, I only wanted to make sure this will be fixed in one of the
            >future builds. But a friend of mine could use it, because one of the
            >sites he monitors causes this error.

            He could use this version
            http://home.snafu.de/tilman/tmp/xenu-parsetest.zip

            it also handles "%" in URLs differently (may be better for some sites).

            Tilman
          • sujan8739286
            ... I forwarded the link to him. Thanks a lot. / Jan
            Message 5 of 5 , Jul 20 1:35 PM
            • 0 Attachment
              > He could use this version
              > http://home.snafu.de/tilman/tmp/xenu-parsetest.zip
              >
              > it also handles "%" in URLs differently (may be better for
              > some sites).

              I forwarded the link to him. Thanks a lot.

              / Jan
            Your message has been successfully submitted and would be delivered to recipients shortly.