Loading ...
Sorry, an error occurred while loading the content.

RE: [xenu-usergroup] Peugeot site - false alarm

Expand Messages
  • John Kelly
    They might have added the BASE HREF to the document instead of changing a lot of links. Adding a few lines of javascript? Or who knows how many lines of link
    Message 1 of 11 , Oct 4, 2005
    • 0 Attachment
      They might have added the BASE HREF to the document instead of changing a
      lot of links. Adding a few lines of javascript? Or who knows how many
      lines of link fixes.

      Just my guess,

      John

      -----Original Message-----
      From: xenu-usergroup@yahoogroups.com [mailto:xenu-usergroup@yahoogroups.com]
      On Behalf Of frank visser
      Sent: Tuesday, October 04, 2005 11:29 AM
      To: xenu-usergroup@yahoogroups.com
      Subject: [xenu-usergroup] Peugeot site - false alarm

      hi all,

      i encountered a weird phenomenon on a site i was linkchecking:
      peugeot.com

      for example, on this page:
      http://www.peugeot.com/sport/sport_auto/rallye/fr/saison/default.htm

      there's an image coded like this:
      <img src="saison/images/drap_nouv-ze.gif" hspace="2" border="0"
      alt="Nouvele Zélande">

      note the double occurrence of the "saison" folder!

      in the IE browser the link shows up as:
      http://www.peugeot.com/sport/sport_auto/rallye/fr/saison/images/drap_
      nouv-ze.gif
      200 ok

      in xenu it is displayed as:
      http://www.peugeot.com/sport/sport_auto/rallye/fr/saison/saison/image
      s/drap_nouv-ze.gif
      404 not found

      following the html, Xenu seems to be correct, and still, the image is not
      broken on the web page.

      i looked into the code and noticed a BASE HREF code at the top of the page:

      <script language=javascript>document.write ('<BASE HREF="http://' + serveur
      + racineSite + 'sport/sport_auto/rallye/' + document.lang
      + '/">');</script>

      in a js file these variables were set:
      var serveur = "www.peugeot.com"
      var racineSite = "/"

      so that leads to the correct and working URL:
      http://www.peugeot.com/sport/sport_auto/rallye/fr/saison/saison/image
      s/drap_nouv-ze.gif

      so the HTML code is "overruled" by the BASE HREF tag.

      does anyone have any idea why this page is coded like this?

      frank






      Yahoo! Groups Links







      --
      No virus found in this incoming message.
      Checked by AVG Anti-Virus.
      Version: 7.0.344 / Virus Database: 267.11.9/118 - Release Date: 10/3/2005
    • Tilman Hausherr
      Hello, There s a new beta in http://home.snafu.de/tilman/tmp/xenubeta.zip The ZIP file has the setup, plus a manifest file. After setup, please copy this
      Message 2 of 11 , Oct 6, 2005
      • 0 Attachment
        Hello,

        There's a new beta in http://home.snafu.de/tilman/tmp/xenubeta.zip

        The ZIP file has the setup, plus a "manifest" file. After setup, please
        copy this manifest file manually in your Xenu directory, then start
        Xenu. If you're running Windows XP, Xenu should look more "modern".
        E-mail me if there is any trouble. (I tried such a "manifest" file for
        something at work, but it resulted in a crash; however my application at
        work is more complicated, it has a DLL that outputs an MDI window).

        Tilman
      • Tilman Hausherr
        ... I should add that this manifest file isn t code, it s just an XML description, which is explained here:
        Message 3 of 11 , Oct 6, 2005
        • 0 Attachment
          On Thu, 06 Oct 2005 20:43:53 +0200, Tilman Hausherr wrote:

          >Hello,
          >
          >There's a new beta in http://home.snafu.de/tilman/tmp/xenubeta.zip
          >
          >The ZIP file has the setup, plus a "manifest" file. After setup, please
          >copy this manifest file manually in your Xenu directory, then start
          >Xenu. If you're running Windows XP, Xenu should look more "modern".
          >E-mail me if there is any trouble. (I tried such a "manifest" file for
          >something at work, but it resulted in a crash; however my application at
          >work is more complicated, it has a DLL that outputs an MDI window).

          I should add that this "manifest" file isn't code, it's just an XML
          description, which is explained here:
          http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/commctls/userex/cookbook.asp
        • Clive Sabey [CS]
          Hello, The GUI is an improvement. No problems with the beta version to report. To retrieve your personal settings find and copy the old xenu.ini into the new
          Message 4 of 11 , Oct 6, 2005
          • 0 Attachment
            Hello,
            The GUI is an improvement. No problems with the beta version to report.
            To retrieve your personal settings find and copy the 'old' xenu.ini into
            the new XENU folder. It worked for me.

            Bye, Clive
            ------------------------------------------------------------------------

            Tilman Hausherr wrote:
            > On Thu, 06 Oct 2005 20:43:53 +0200, Tilman Hausherr wrote:
            >
            > >Hello,
            > >
            > >There's a new beta in http://home.snafu.de/tilman/tmp/xenubeta.zip
            > >
            > >The ZIP file has the setup, plus a "manifest" file. After setup, please
            > >copy this manifest file manually in your Xenu directory, then start
            > >Xenu. If you're running Windows XP, Xenu should look more "modern".
            > >E-mail me if there is any trouble. (I tried such a "manifest" file for
            > >something at work, but it resulted in a crash; however my application at
            > >work is more complicated, it has a DLL that outputs an MDI window).
            >
            > I should add that this "manifest" file isn't code, it's just an XML
            > description, which is explained here:
            > http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/commctls/userex/cookbook.asp
            >
            >
            >
            > ------------------------------------------------------------------------
            > YAHOO! GROUPS LINKS
            >
            > * Visit your group "xenu-usergroup
            > <http://groups.yahoo.com/group/xenu-usergroup>" on the web.
            >
            > * To unsubscribe from this group, send an email to:
            > xenu-usergroup-unsubscribe@yahoogroups.com
            > <mailto:xenu-usergroup-unsubscribe@yahoogroups.com?subject=Unsubscribe>
            >
            > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            > Service <http://docs.yahoo.com/info/terms/>.
            >
            >
            > ------------------------------------------------------------------------
            >


            [Non-text portions of this message have been removed]
          • Stephen Gazard
            just tried it, and I see nothing new, apart from a tips box that shows a grey screen until I press next tip , whereupon the tip is there, but nothing else
            Message 5 of 11 , Oct 6, 2005
            • 0 Attachment
              just tried it, and I see nothing new, apart from a "tips" box that shows
              a grey screen until I press "next tip", whereupon the tip is there, but
              nothing else (I see only a white box


              Tilman Hausherr wrote:
              > On Thu, 06 Oct 2005 20:43:53 +0200, Tilman Hausherr wrote:
              >
              >
              >> Hello,
              >>
              >> There's a new beta in http://home.snafu.de/tilman/tmp/xenubeta.zip
              >>
              >> The ZIP file has the setup, plus a "manifest" file. After setup, please
              >> copy this manifest file manually in your Xenu directory, then start
              >> Xenu. If you're running Windows XP, Xenu should look more "modern".
              >> E-mail me if there is any trouble. (I tried such a "manifest" file for
              >> something at work, but it resulted in a crash; however my application at
              >> work is more complicated, it has a DLL that outputs an MDI window).
              >>
              >
              > I should add that this "manifest" file isn't code, it's just an XML
              > description, which is explained here:
              > http://msdn.microsoft.com/library/default.asp?url=/library/en-us/shellcc/platform/commctls/userex/cookbook.asp
            • Tilman Hausherr
              ... Please try to make a screenshot of that. (IrfanView can do this with the C key) Tilman
              Message 6 of 11 , Oct 6, 2005
              • 0 Attachment
                On Thu, 06 Oct 2005 20:02:02 +0100, Stephen Gazard wrote:

                >just tried it, and I see nothing new, apart from a "tips" box that shows
                >a grey screen until I press "next tip", whereupon the tip is there, but
                >nothing else (I see only a white box

                Please try to make a screenshot of that. (IrfanView can do this with the
                "C" key)

                Tilman
              • Stephen Gazard
                three attachments; the names ought to be self explanatory xenu_empty_tips_box.jpg xenu_tip_box_partial.jpg xenu_empty_tips_no_manifest_change.jpg I ve got
                Message 7 of 11 , Oct 7, 2005
                • 0 Attachment
                  three attachments; the names ought to be self explanatory

                  xenu_empty_tips_box.jpg
                  xenu_tip_box_partial.jpg
                  xenu_empty_tips_no_manifest_change.jpg

                  I've got WinXP SP2 (patched up and latest drivers)
                  I installed Xenu directly over the other version. I'll not be around
                  for the weekend, so won't be able to help on this for a it, but I hope
                  the screenshots help you out


                  Tilman Hausherr wrote:
                  > On Thu, 06 Oct 2005 20:02:02 +0100, Stephen Gazard wrote:
                  >
                  >
                  >> just tried it, and I see nothing new, apart from a "tips" box that shows
                  >> a grey screen until I press "next tip", whereupon the tip is there, but
                  >> nothing else (I see only a white box
                  >>
                  >
                  > Please try to make a screenshot of that. (IrfanView can do this with the
                  > "C" key)
                  >
                  > Tilman
                  >
                  >
                  >
                  >
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >


                  [Non-text portions of this message have been removed]
                • Tilman Hausherr
                  This isn t found in the Xenu FAQ: http://www.comics.com/comics/dilbert/archive/images/dilbert2005114651007.gif
                  Message 8 of 11 , Oct 7, 2005
                  • 0 Attachment
                  • Stephen Gazard
                    ** resending to just tilman ** three attachments; the names ought to be self explanatory xenu_empty_tips_box.jpg xenu_tip_box_partial.jpg
                    Message 9 of 11 , Oct 8, 2005
                    • 0 Attachment
                      ** resending to just tilman **

                      three attachments; the names ought to be self explanatory

                      xenu_empty_tips_box.jpg
                      xenu_tip_box_partial.jpg
                      xenu_empty_tips_no_manifest_change.jpg

                      I've got WinXP SP2 (patched up and latest drivers)
                      I installed Xenu directly over the other version. I'll not be around
                      for the weekend, so won't be able to help on this for a it, but I hope
                      the screenshots help you out


                      Tilman Hausherr wrote:
                      > On Thu, 06 Oct 2005 20:02:02 +0100, Stephen Gazard wrote:
                      >
                      >
                      >> just tried it, and I see nothing new, apart from a "tips" box that shows
                      >> a grey screen until I press "next tip", whereupon the tip is there, but
                      >> nothing else (I see only a white box
                      >>
                      >
                      > Please try to make a screenshot of that. (IrfanView can do this with the
                      > "C" key)
                      >
                      > Tilman
                      >
                      >
                      >
                      >
                      >
                      > Yahoo! Groups Links
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                    • Tilman Hausherr
                      ... Sadly, the problem with the tips box is directly related to the manifest file :-( So I d advise to delete it.
                      Message 10 of 11 , Oct 16, 2005
                      • 0 Attachment
                        On Thu, 06 Oct 2005 20:02:02 +0100, Stephen Gazard wrote:

                        >just tried it, and I see nothing new, apart from a "tips" box that shows
                        >a grey screen until I press "next tip", whereupon the tip is there, but
                        >nothing else (I see only a white box

                        Sadly, the problem with the "tips" box is directly related to the
                        manifest file :-( So I'd advise to delete it.
                      Your message has been successfully submitted and would be delivered to recipients shortly.