Loading ...
Sorry, an error occurred while loading the content.

Re: Checking local files

Expand Messages
  • frank visser
    what i did notice is that doing a local link report, xenu hanged after requesting the browser report -- did not happen in the beta version. frank ... my ...
    Message 1 of 11 , Mar 24 4:03 AM
    • 0 Attachment
      what i did notice is that doing a local link report, xenu hanged
      after requesting the browser report -- did not happen in the beta
      version.

      frank

      --- In xenu-usergroup@yahoogroups.com, "frank visser"
      <f.visser3@c...> wrote:
      >
      > hi clive,
      >
      > i can check local links with the Local File button all right, but
      my
      > start URL appears as this in the link report:
      >
      > file:///G:/FTAF-START.HTM
      >
      > so it starts with a drive: after file:///
      >
      > frank
      >
      >
      > --- In xenu-usergroup@yahoogroups.com, "Clive Sabey [CS]"
      > <stfcs@l...> wrote:
      > >
      > > The original problem was generated using the 'Local file ' button.
      > > A sample of the 'Report'
      > >
      > >
      > > Xenu's broken link report
      > >
      > > Created on March 24, 2005 at 08:53:37
      > >
      > >
      > > Root URL: file://///lcc-svr-01/STFCS$/My%
      20L2L/Upload/index.html
      > > <cid:part1.06030508.08010505@l...>
      > >
      > >
      > > Table of contents
      > >
      > > * Broken links, ordered by link <#bylink>
      > > * Broken links, ordered by page <#bypage>
      > > * List of redirected URLs <#redir>
      > > * List of ftp and gopher URLs <#ftpgopher>
      > > * List of valid URLs you can submit to a search engine
      <#valid>
      > > * Site Map of HTML pages with a Title <#sitemap>
      > > * Broken page-local links <#targets>
      > > * Orphan files <#orphans>
      > > * Statistics for managers <#stats>
      > >
      > >
      > > Broken links, ordered by link:
      > >
      > > file://///lcc-svr-01/STFCS$/My%20L2L/Upload/index.html
      > <cid:part1.06030508.08010505@l...>
      > > error code: 2 (file not found), linked from page(s):
      > >
      > > 0 broken link(s) reported
      > >
      > > The path "file://///lcc-svr-01/STFCS$/My%20L2L/Upload/index.html
      > <cid:part1.06030508.08010505@l...>"
      > > works Ok in IE.
      > >
      > > Can anybody else reproduce the problem?
      > > Clive
      > >
      > >
      > > Tilman Hausherr wrote:
      > >
      > > > On Wed, 23 Mar 2005 18:40:10 -0000, stfcs wrote:
      > > >
      > > > >I think that the latest version 1.2g has introduced a problem
      > when
      > > > >checking local files. I select the Local file button select the
      > > > >correct file for checking and the path "file:///\\lcc-svr-01
      > > > >\STFCS$\My L2L\Upload\index.html" is entered. This produces a
      > file
      > > > >not found error message. Exactly the same text for the path is
      > > > >entered into IE and the web page appears. I guess it is to do
      > with
      > > > >the way in which the UNC paths are defined. I looked up the
      > > > >conventions and... "On Microsoft Windows platforms, Tcl
      supports
      > > > >both drive-relative and UNC style names. Both / and \ may be
      > used as
      > > > >directory separators in either type of name. Drive-relative
      names
      > > > >consist of an optional drive specifier followed by an absolute
      or
      > > > >relative path. UNC paths follow the general form
      > > > >\\servername\sharename\path\file, but must at the very least
      > contain
      > > > >the server and share components, i.e. \\servername\sharename."
      It
      > > > >would appear that the double back slash is common to all UNC
      > paths.
      > > > >So is a tweak to 1.2g required for the local file option?
      > > >
      > > > I don't know why it doesn't work for you. Try chosing it from
      > the "Local
      > > > file..." button.
      > > >
      > > > Tilman
      > > >
      > > >
      > > >
      > > > *Yahoo! Groups Sponsor*
      > > > ADVERTISEMENT
      > > > click here
      > > >
      >
      <http://us.ard.yahoo.com/SIG=129td2ajj/M=298184.6191685.7192823.300117
      >
      6/D=groups/S=1705005512:HM/EXP=1111692841/A=2593423/R=0/SIG=11el9gslf/
      > *http://www.netflix.com/Default?mqso=60190075>
      > > >
      > > >
      > > >
      > > > ----------------------------------------------------------------
      --
      > ------
      > > > *Yahoo! Groups Links*
      > > >
      > > > * To visit your group on the web, go to:
      > > > http://groups.yahoo.com/group/xenu-usergroup/
      > > >
      > > > * To unsubscribe from this group, send an email to:
      > > > xenu-usergroup-unsubscribe@yahoogroups.com
      > > > <mailto:xenu-usergroup-unsubscribe@yahoogroups.com?
      > subject=Unsubscribe>
      > > >
      > > > * Your use of Yahoo! Groups is subject to the Yahoo! Terms
      of
      > > > Service <http://docs.yahoo.com/info/terms/>.
      > > >
      > > >
      > >
      > >
      > > [Non-text portions of this message have been removed]
    • Tilman Hausherr
      ... That isn t a UNC name. I was able to test it with UNC names... click on Network places (or whatever it is called in your country), then chose a hostname,
      Message 2 of 11 , Mar 24 5:16 AM
      • 0 Attachment
        On Thu, 24 Mar 2005 11:55:41 -0000, frank visser wrote:

        >
        >i can check local links with the Local File button all right, but my
        >start URL appears as this in the link report:
        >
        >file:///G:/FTAF-START.HTM
        >
        >so it starts with a drive: after file:///

        That isn't a UNC name. I was able to test it with UNC names... click on
        "Network places" (or whatever it is called in your country), then chose
        a hostname, then a share name, then a directory, then a HTML file.
      • Tilman Hausherr
        ... It works for me... maybe Xenu is making the site map?
        Message 3 of 11 , Mar 24 5:17 AM
        • 0 Attachment
          On Thu, 24 Mar 2005 12:03:33 -0000, frank visser wrote:

          >what i did notice is that doing a local link report, xenu hanged
          >after requesting the browser report -- did not happen in the beta
          >version.

          It works for me... maybe Xenu is making the site map?
        • Tilman Hausherr
          ... I tested it again. I see that the test I made yesterday wasn t actually on the network. A new test with file://///tilman/SharedDocs/test.htm gives a file
          Message 4 of 11 , Mar 24 5:47 AM
          • 0 Attachment
            On Thu, 24 Mar 2005 08:59:25 +0000, Clive Sabey [CS] wrote:

            >Created on March 24, 2005 at 08:53:37
            >
            >
            > Root URL: file://///lcc-svr-01/STFCS$/My%20L2L/Upload/index.html
            > <cid:part1.06030508.08010505@...>

            I tested it again. I see that the test I made yesterday wasn't actually
            on the network. A new test with

            file://///tilman/SharedDocs/test.htm

            gives a "file not found" for me too :-( No idea what's going on.
            Entering this in IE works. I suspect that the correct way to do it would
            be

            file://tilman/SharedDocs/test.htm

            I'll analyse this in the next few days / weeks. In the meantime, you'll
            have to use drives.

            Tilman
          • Tilman Hausherr
            ... I ve just sent a corrected version... I see that it was the recursion protection (the check for // ) again. I ve now corrected this. The only problem
            Message 5 of 11 , Mar 24 8:36 AM
            • 0 Attachment
              On Thu, 24 Mar 2005 08:59:25 +0000, Clive Sabey [CS] wrote:

              >The original problem was generated using the 'Local file ' button.
              >A sample of the 'Report'
              >
              >
              > Xenu's broken link report
              >
              >Created on March 24, 2005 at 08:53:37
              >
              >
              > Root URL: file://///lcc-svr-01/STFCS$/My%20L2L/Upload/index.html
              > <cid:part1.06030508.08010505@...>
              >
              >
              > Table of contents
              >
              > * Broken links, ordered by link <#bylink>
              > * Broken links, ordered by page <#bypage>
              > * List of redirected URLs <#redir>
              > * List of ftp and gopher URLs <#ftpgopher>
              > * List of valid URLs you can submit to a search engine <#valid>
              > * Site Map of HTML pages with a Title <#sitemap>
              > * Broken page-local links <#targets>
              > * Orphan files <#orphans>
              > * Statistics for managers <#stats>
              >
              >
              > Broken links, ordered by link:
              >
              >file://///lcc-svr-01/STFCS$/My%20L2L/Upload/index.html <cid:part1.06030508.08010505@...>
              >error code: 2 (file not found), linked from page(s):
              >
              >0 broken link(s) reported
              >
              >The path "file://///lcc-svr-01/STFCS$/My%20L2L/Upload/index.html <cid:part1.06030508.08010505@...>"
              >works Ok in IE.
              >
              >Can anybody else reproduce the problem?
              >Clive

              I've just sent a corrected version... I see that it was the "recursion
              protection" (the check for "//") again. I've now corrected this. The
              only problem now is that my URL doesn't work with Opera.

              Tilman
            • frank visser
              on my home PC it does work, so probably a local thing - no worries.
              Message 6 of 11 , Mar 24 11:14 AM
              • 0 Attachment
                on my home PC it does work, so probably a local thing - no worries.

                --- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@s...>
                wrote:
                > On Thu, 24 Mar 2005 12:03:33 -0000, frank visser wrote:
                >
                > >what i did notice is that doing a local link report, xenu hanged
                > >after requesting the browser report -- did not happen in the beta
                > >version.
                >
                > It works for me... maybe Xenu is making the site map?
              Your message has been successfully submitted and would be delivered to recipients shortly.