Loading ...
Sorry, an error occurred while loading the content.

Re: [xenu-usergroup] Re: Xenu checks nothing and every file appears as an orphan

Expand Messages
  • Tilman Hausherr
    I d still search for another cause. Please save your work into a .XEN file and send both to tilman at snafu dot de. This would show me the settings. Tilman
    Message 1 of 5 , Mar 4, 2013
    View Source
    • 0 Attachment
      I'd still search for another cause. Please save your work into a .XEN
      file and send both to tilman at snafu dot de. This would show me the
      settings.

      Tilman

      Am 04.03.2013 21:04, schrieb sydwool:
      > --- In xenu-usergroup@yahoogroups.com, Tilman Hausherr <tilman@...> wrote:
      >> Hi,
      >>
      >> I don't know about wininet.dll versions. The best approach would be to
      >> find out why Xenu "completes almost immediately". Could it be a
      >> difference related to international charsets?
      >>
      >> Tilman
      > I've been pursuing all kinds of reason for the immediate completion but none have made any difference. W2K is reading the same file over the LAN and processing successfully. I've tried the reverse, moved the directory to W2K and run Xenu from XP but still get immediate completion.
      >
      > Here's what has me bamboozled:
      >
      > - W2K 1.3.8 looks at index.htm, generates the list of links, and completes with a valid report
      > - XP 1.3.8 looks at index.htm, completes immediately with index.htm as the only entry in the list of links, and completes with a report that lists every other link as an orphan
      >
      > I've done uninstall/re-install of Xenu twice with no difference in behavior.
      >
      > Microsoft's penchant to change the names of settings between releases is annoying at best but on charsets went far further by turning clear and unambiguous settings into muddy and obscure.
      >
      > W2K
      > Control Panel/Regional Options/Advanced
      > English (United States)
      > Control Panel/Regional Options/Advanced
      > [grayed out] Western Europe and USA (default)
      >
      > XP
      > Control Panel/Regional and Language
      > English (United States)
      > Control Panel/Regional and Language/Advanced
      > [grayed out] 10000 (MAC-Roman)
      >
      > I don't believe charset has anything to do with the problem, based on the assumption that charset is the same between the two though I can't really be sure. W2K's "Western Europe and USA (default)" is unambiguous but XP's "10000 (MAC-Roman)" is not.
      >
      > The reason I picked on the WININET.DLL is that Xenu has had issues in the past with some versions of it.
      >
      >
      >
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
    • Tilman Hausherr
      Hi all, The cause was a broken registry on the XP system, the MIME type text/html was missing. Thus the file was not looked into. Tilman
      Message 2 of 5 , Mar 6, 2013
      View Source
      • 0 Attachment
        Hi all,

        The cause was a broken registry on the XP system, the MIME type "text/html" was missing. Thus the file was not looked into.

        Tilman

        Am 03.03.2013 17:48, schrieb Porter Woolcott:
        Xenu 1.3.8 is used to check a local disk which has htm-driven documentation that is distributed via CDs. No problems with W2K but when Xenu opens index.htm under XP SP3 it completes almost immediately and every file is reported as an Orphan.

        The behavior has has not been a problem because it was easy to KVM to a W2K machine and run Xenu there. That convenience is about to end, so am now faced with making Xenu functional under XP SP3.

        Apart from the OS, the primary difference between the two machines is the level of Explorer being run and the versions of WININET.DLL (the starred dll is in /SYSTEM32). I do not know the version numbers of the DLLs, but can list the dates and size from a DIR.

        W2K is Explorer 6 and has two versions in 3 directories:

          06/19/2003  12:05p             466,704 wininet.dll
        * 08/29/2002  07:14a             585,728 wininet.dll

        XP is Explorer 8 and several versions in 13 directories.

          04/14/2008  01:42 AM           666,112
          03/08/2009  12:34 AM           914,944
          05/06/2010  02:36 AM           919,040
          09/09/2010  09:57 PM           919,552
        * 09/09/2010  09:58 PM           916,480

        If the problem is WININET.DLL, which version/date is needed to run Xenu on XP and how can it be replaced?

        I've tried delete/replace the 9/9/2010 dll with an earlier version but XP reinstates 9/9/2010 .

        If not WININET, what else could be a cause?

      Your message has been successfully submitted and would be delivered to recipients shortly.