Loading ...
Sorry, an error occurred while loading the content.

Re: [xenu-usergroup] Local files ending in php

Expand Messages
  • Tono
    How must I do to put a local web server? Before, I only say to Xenu http://127.0.0.1:800/WH5/divinecats.co.uk/members/index.php and with some files works and
    Message 1 of 24 , May 24 12:11 AM
    • 0 Attachment
      How must I do to put a local web server? Before, I only say to Xenu  http://127.0.0.1:800/WH5/divinecats.co.uk/members/index.php  and with some files works and with another not.
       
       
      ----- Original Message -----
      Sent: Tuesday, May 24, 2011 12:14 AM
      Subject: Re: [xenu-usergroup] Local files ending in php

       

      On Mon, 23 May 2011 23:03:53 +0200, Tono wrote:

      >It does not work fine. For example, Xenu give "no conection" for: http://127.0.0.1:800/WH5/divinecats.co.uk/members/bio.php@name=Bounty
      >
      >but the file exists when I put in a browser like file:///K:/WH5/divinecats.co.uk/members/bio.php@name=Bounty

      That isn't the same, and it isn't a Xenu problem, rather a problem of
      setting up your local server. "file:///K:" is your file system.
      "http://127.0.0.1:800" is a local web server. First check whether you
      can open that URL within a browser. If you can't, then your server
      doesn't work (or you don't have any server at all), or you're using the
      wrong port.

      >And so on. With this, Xenu does not put the orphan files.
      >
      >For local files from Offline Explorer Pro, Xenu does not work fine. The files are something like: picture.php@page=45&name=3 and so on.

      Ok, so these aren't your files, you just downloaded them from the
      internet, from the site that is NSFW, and you want to use Xenu to see if
      it is complete. I think the problem is that this "Offline Explorer Pro"
      didn't rename them to .html. Look at the options of that software.

      Tilman

      >
      >
      >
      > ----- Original Message -----
      > From: Tilman Hausherr
      > To: xenu-usergroup@yahoogroups.com
      > Sent: Sunday, May 22, 2011 1:19 PM
      > Subject: Re: [xenu-usergroup] Local files ending in php
      >
      >
      >
      > On Sun, 22 May 2011 10:52:20 +0200, Tono wrote:
      >
      > >What happens if the file is something like index.php@name=34
      >
      > Nothing, because it isn't .php.
      >
      > I strongly suggest you don't mess with the registry and install a local
      > web server on your pc. Its address would then start with
      > http://127.0.0.1 .
      >
      > Tilman
      >
      > >
      > >
      > >
      > > ----- Original Message -----
      > > From: Tilman Hausherr
      > > To: xenu-usergroup@yahoogroups.com
      > > Sent: Saturday, May 21, 2011 12:19 AM
      > > Subject: Re: [xenu-usergroup] Local files ending in php
      > >
      > >
      > >
      > > On Fri, 20 May 2011 23:49:46 +0200, Tono wrote:
      > >
      > > >How can I set up that php files get the text/html MIME type?
      > >
      > > In the registry, go to
      > >
      > > HKEY_CLASSES_ROOT\.php
      > >
      > > there, change the "Content Type" key to "text/html".
      > >
      > > Tilman
      > >
      > > >
      > > >
      > > > ----- Original Message -----
      > > > From: Tono
      > > > To: xenu-usergroup@yahoogroups.com
      > > > Sent: Friday, May 20, 2011 5:30 PM
      > > > Subject: Re: [xenu-usergroup] Local files ending in php
      > > >
      > > >
      > > >
      > > >
      > > >
      > > > Or set up that .php files get the text/html MIME type. Of course, it
      > > > might happen that your php software will be broken...
      > > >
      > > > Tilman
      > > >
      > > >
      > > >
      > >
      > >
      > >
      >
      >
      >

    • Tono
      How must I do to put a local web server? Before, I only say to Xenu http://127.0.0.1:800/WH5/divinecats.co.uk/members/index.php and with some files works and
      Message 2 of 24 , May 24 1:21 AM
      • 0 Attachment
        How must I do to put a local web server? Before, I only say to Xenu  http://127.0.0.1:800/WH5/divinecats.co.uk/members/index.php  and with some files works and with another not.
         
        ----- Original Message -----
        Sent: Tuesday, May 24, 2011 12:14 AM
        Subject: Re: [xenu-usergroup] Local files ending in php

         

        On Mon, 23 May 2011 23:03:53 +0200, Tono wrote:

        >It does not work fine. For example, Xenu give "no conection" for: http://127.0.0.1:800/WH5/divinecats.co.uk/members/bio.php@name=Bounty
        >
        >but the file exists when I put in a browser like file:///K:/WH5/divinecats.co.uk/members/bio.php@name=Bounty

        That isn't the same, and it isn't a Xenu problem, rather a problem of
        setting up your local server. "file:///K:" is your file system.
        "http://127.0.0.1:800" is a local web server. First check whether you
        can open that URL within a browser. If you can't, then your server
        doesn't work (or you don't have any server at all), or you're using the
        wrong port.

        >And so on. With this, Xenu does not put the orphan files.
        >
        >For local files from Offline Explorer Pro, Xenu does not work fine. The files are something like: picture.php@page=45&name=3 and so on.

        Ok, so these aren't your files, you just downloaded them from the
        internet, from the site that is NSFW, and you want to use Xenu to see if
        it is complete. I think the problem is that this "Offline Explorer Pro"
        didn't rename them to .html. Look at the options of that software.

        Tilman

        >
        >
        >
        > ----- Original Message -----
        > From: Tilman Hausherr
        > To: xenu-usergroup@yahoogroups.com
        > Sent: Sunday, May 22, 2011 1:19 PM
        > Subject: Re: [xenu-usergroup] Local files ending in php
        >
        >
        >
        > On Sun, 22 May 2011 10:52:20 +0200, Tono wrote:
        >
        > >What happens if the file is something like index.php@name=34
        >
        > Nothing, because it isn't .php.
        >
        > I strongly suggest you don't mess with the registry and install a local
        > web server on your pc. Its address would then start with
        > http://127.0.0.1 .
        >
        > Tilman
        >
        > >
        > >
        > >
        > > ----- Original Message -----
        > > From: Tilman Hausherr
        > > To: xenu-usergroup@yahoogroups.com
        > > Sent: Saturday, May 21, 2011 12:19 AM
        > > Subject: Re: [xenu-usergroup] Local files ending in php
        > >
        > >
        > >
        > > On Fri, 20 May 2011 23:49:46 +0200, Tono wrote:
        > >
        > > >How can I set up that php files get the text/html MIME type?
        > >
        > > In the registry, go to
        > >
        > > HKEY_CLASSES_ROOT\.php
        > >
        > > there, change the "Content Type" key to "text/html".
        > >
        > > Tilman
        > >
        > > >
        > > >
        > > > ----- Original Message -----
        > > > From: Tono
        > > > To: xenu-usergroup@yahoogroups.com
        > > > Sent: Friday, May 20, 2011 5:30 PM
        > > > Subject: Re: [xenu-usergroup] Local files ending in php
        > > >
        > > >
        > > >
        > > >
        > > >
        > > > Or set up that .php files get the text/html MIME type. Of course, it
        > > > might happen that your php software will be broken...
        > > >
        > > > Tilman
        > > >
        > > >
        > > >
        > >
        > >
        > >
        >
        >
        >

      • Fischer, Thomas
        Hi Tono, I sent this letter this morning and it didn t appear on the list, so I give it a second try. As far as I see your download tool Offline Explorer Pro
        Message 3 of 24 , May 24 7:03 AM
        • 0 Attachment
          Hi Tono,
           
          I sent this letter this morning and it didn't appear on the list, so I give it a second try.
           
          As far as I see your download tool "Offline Explorer Pro" will download pages from a website. If these are dynamic pages, created by some script (cgi or php or whatever), the respective parameters will be encoded using an "@" in place of the standard "?" and will be treated by "Offline Explorer Pro" as regular files (something like this has to be done to work with them at all, since the scripts themselves are not available for download).
          "Offline Explorer Pro" seems to contain a custom service, which will be installed on port 800 to access these files through a standard web browser.
          And as far as I see, Xenu will happily check those URLs (for me it is: http://127.0.0.1:800/Standard/www.mathguide.de/cgi-bin/ssgfi/navigator2.pl@db=math_2Ftype=subj) if you start it with the appropriate port and link.
           
          Cheers
          Thomas
        • Tono
          If OE does not produce .html files but I can browse offline with them. It would be very nice to be able to check such a downloaded website. I think it would be
          Message 4 of 24 , May 28 2:55 AM
          • 0 Attachment
            If OE does not produce .html files but I can browse offline with them. It would be very nice to be able to check such a downloaded website.
             
            I think it would be nice a feature like:  Consider as HTML files the ones like: *.php@*
             
             
             
             
            ----- Original Message -----
            Sent: Tuesday, May 24, 2011 2:04 PM
            Subject: Re: [xenu-usergroup] Local files ending in php

             

            On Tue, 24 May 2011 11:37:18 +0200, Tono wrote:

            >Well, nice feature for next release:
            >
            >Consider as HTML files the ones like theese (with wildcards): *.php@*

            No, because in your case - if I've understood the problem correctly - it
            is another piece of software that is alleged to be broken. You should
            contact THEM that they produce .html files. Renaming files is something
            they can do, sometimes:

            http://forum.metaproducts.com/Post.aspx?ID=5219&AspxAutoDetectCookieSupport=1

            Tilman

            >
            >
            >
            >
            > ----- Original Message -----
            > From: Tilman Hausherr
            > To: xenu-usergroup@yahoogroups.com
            > Sent: Tuesday, May 24, 2011 10:13 AM
            > Subject: Re: [xenu-usergroup] Local files ending in php
            >
            >
            >
            > You download something for the web. Thus you don't get php source code,
            > but the result from the php server, thus normal HTML. So "Offline
            > Explorer Pro" should rename all these files to .html and also correct
            > the internal links. Otherwise, that tool is worthless for this case.
            >
            > Tilman
            >
            > On Tue, 24 May 2011 09:09:31 +0200, Tono wrote:
            >
            > >The @ is what Offline Explorer Pro put in the downloaded php files instead of ?
            > >
            > >
            > >
            > > ----- Original Message -----
            > > From: Deborah Rorabaugh
            > > To: xenu-usergroup@yahoogroups.com
            > > Sent: Sunday, May 22, 2011 4:45 PM
            > > Subject: RE: [xenu-usergroup] Local files ending in php
            > >
            > >
            > >
            > >
            > > I can attest that Wamp and Xamp are easy enough to configure. They both render .php files. Although from what I'm reading @ is an error suppressor operator - not the designator for a query string. That is a ? so index.php@name=34 should read index.php?name=34
            > >
            > > But is still needs to be run through a local server.
            > >
            > >
            > >
            > >
            > >----------------------------------------------------------
            > >
            > > From: xenu-usergroup@yahoogroups.com [mailto:xenu-usergroup@yahoogroups.com] On Behalf Of Stephen Gazard
            > > Sent: Sunday, May 22, 2011 2:06 AM
            > > To: xenu-usergroup@yahoogroups.com
            > > Subject: Re: [xenu-usergroup] Local files ending in php
            > >
            > >
            > >
            > >
            > >
            > > Right, the PHP files you're trying to deal with need to be run through a web server so that the part after the @ is used.
            > >
            > > Do you have these files setup on a webserver (e.g. Apache). If not, thats what needs doing first. To set that up, look up a wamp installation. Xamp is apparently quite good and requires little in the way of configuration to get it running properly.
            > >
            > > Regards,
            > > Stephen
            > >
            > > Tono <tonospa@...> wrote:
            > >
            > >
            > >
            > > What happens if the file is something like index.php@name=34
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > > ----- Original Message -----
            > >
            > > From: Tilman Hausherr
            > >
            > > To: xenu-usergroup@yahoogroups.com
            > >
            > > Sent: Saturday, May 21, 2011 12:19 AM
            > >
            > > Subject: Re: [xenu-usergroup] Local files ending in php
            > >
            > >
            > >
            > >
            > > On Fri, 20 May 2011 23:49:46 +0200, Tono wrote:
            > >
            > > >How can I set up that php files get the text/html MIME type?
            > >
            > > In the registry, go to
            > >
            > > HKEY_CLASSES_ROOT\.php
            > >
            > > there, change the "Content Type" key to "text/html".
            > >
            > > Tilman
            > >
            > > >
            > > >
            > > > ----- Original Message -----
            > > > From: Tono
            > > > To: xenu-usergroup@yahoogroups.com
            > > > Sent: Friday, May 20, 2011 5:30 PM
            > > > Subject: Re: [xenu-usergroup] Local files ending in php
            > > >
            > > >
            > > >
            > > >
            > > >
            > > > Or set up that .php files get the text/html MIME type. Of course, it
            > > > might happen that your php software will be broken...
            > > >
            > > > Tilman
            > > >
            > > >
            > > >
            > >
            > >
            > >
            > >
            > >
            > > Regards,
            > > Stephen
            > >
            > >
            > >
            >
            >
            >

          • Tilman Hausherr
            ... Probably, because OE keeps an internal list of files that have the text/html MIME type. ... You can, if you use the local webserver that OE provides
            Message 5 of 24 , May 28 3:20 AM
            • 0 Attachment
              On Sat, 28 May 2011 11:55:43 +0200, Tono wrote:

              >If OE does not produce .html files but I can browse offline with them.

              Probably, because OE keeps an internal list of files that have the
              text/html MIME type.

              >It would be very nice to be able to check such a downloaded website.

              You can, if you use the local webserver that OE provides apparently. You
              mentioned that you can access them with http://127.0.0.1:800/

              >I think it would be nice a feature like: Consider as HTML files the ones like: *.php@*

              Rather not. This would be about one day of work just so that you can
              check whether your NSFW download is complete :-) This feature isn't
              really something that will help anyone else that you, I think.

              Tilman


              >
              >
              >
              >
              > ----- Original Message -----
              > From: Tilman Hausherr
              > To: xenu-usergroup@yahoogroups.com
              > Sent: Tuesday, May 24, 2011 2:04 PM
              > Subject: Re: [xenu-usergroup] Local files ending in php
              >
              >
              >
              > On Tue, 24 May 2011 11:37:18 +0200, Tono wrote:
              >
              > >Well, nice feature for next release:
              > >
              > >Consider as HTML files the ones like theese (with wildcards): *.php@*
              >
              > No, because in your case - if I've understood the problem correctly - it
              > is another piece of software that is alleged to be broken. You should
              > contact THEM that they produce .html files. Renaming files is something
              > they can do, sometimes:
              >
              > http://forum.metaproducts.com/Post.aspx?ID=5219&AspxAutoDetectCookieSupport=1
              >
              > Tilman
              >
              > >
              > >
              > >
              > >
              > > ----- Original Message -----
              > > From: Tilman Hausherr
              > > To: xenu-usergroup@yahoogroups.com
              > > Sent: Tuesday, May 24, 2011 10:13 AM
              > > Subject: Re: [xenu-usergroup] Local files ending in php
              > >
              > >
              > >
              > > You download something for the web. Thus you don't get php source code,
              > > but the result from the php server, thus normal HTML. So "Offline
              > > Explorer Pro" should rename all these files to .html and also correct
              > > the internal links. Otherwise, that tool is worthless for this case.
              > >
              > > Tilman
              > >
              > > On Tue, 24 May 2011 09:09:31 +0200, Tono wrote:
              > >
              > > >The @ is what Offline Explorer Pro put in the downloaded php files instead of ?
              > > >
              > > >
              > > >
              > > > ----- Original Message -----
              > > > From: Deborah Rorabaugh
              > > > To: xenu-usergroup@yahoogroups.com
              > > > Sent: Sunday, May 22, 2011 4:45 PM
              > > > Subject: RE: [xenu-usergroup] Local files ending in php
              > > >
              > > >
              > > >
              > > >
              > > > I can attest that Wamp and Xamp are easy enough to configure. They both render .php files. Although from what I'm reading @ is an error suppressor operator - not the designator for a query string. That is a ? so index.php@name=34 should read index.php?name=34
              > > >
              > > > But is still needs to be run through a local server.
              > > >
              > > >
              > > >
              > > >
              > > >----------------------------------------------------------
              > > >
              > > > From: xenu-usergroup@yahoogroups.com [mailto:xenu-usergroup@yahoogroups.com] On Behalf Of Stephen Gazard
              > > > Sent: Sunday, May 22, 2011 2:06 AM
              > > > To: xenu-usergroup@yahoogroups.com
              > > > Subject: Re: [xenu-usergroup] Local files ending in php
              > > >
              > > >
              > > >
              > > >
              > > >
              > > > Right, the PHP files you're trying to deal with need to be run through a web server so that the part after the @ is used.
              > > >
              > > > Do you have these files setup on a webserver (e.g. Apache). If not, thats what needs doing first. To set that up, look up a wamp installation. Xamp is apparently quite good and requires little in the way of configuration to get it running properly.
              > > >
              > > > Regards,
              > > > Stephen
              > > >
              > > > Tono <tonospa@...> wrote:
              > > >
              > > >
              > > >
              > > > What happens if the file is something like index.php@name=34
              > > >
              > > >
              > > >
              > > >
              > > >
              > > >
              > > >
              > > > ----- Original Message -----
              > > >
              > > > From: Tilman Hausherr
              > > >
              > > > To: xenu-usergroup@yahoogroups.com
              > > >
              > > > Sent: Saturday, May 21, 2011 12:19 AM
              > > >
              > > > Subject: Re: [xenu-usergroup] Local files ending in php
              > > >
              > > >
              > > >
              > > >
              > > > On Fri, 20 May 2011 23:49:46 +0200, Tono wrote:
              > > >
              > > > >How can I set up that php files get the text/html MIME type?
              > > >
              > > > In the registry, go to
              > > >
              > > > HKEY_CLASSES_ROOT\.php
              > > >
              > > > there, change the "Content Type" key to "text/html".
              > > >
              > > > Tilman
              > > >
              > > > >
              > > > >
              > > > > ----- Original Message -----
              > > > > From: Tono
              > > > > To: xenu-usergroup@yahoogroups.com
              > > > > Sent: Friday, May 20, 2011 5:30 PM
              > > > > Subject: Re: [xenu-usergroup] Local files ending in php
              > > > >
              > > > >
              > > > >
              > > > >
              > > > >
              > > > > Or set up that .php files get the text/html MIME type. Of course, it
              > > > > might happen that your php software will be broken...
              > > > >
              > > > > Tilman
              > > > >
              > > > >
              > > > >
              > > >
              > > >
              > > >
              > > >
              > > >
              > > > Regards,
              > > > Stephen
              > > >
              > > >
              > > >
              > >
              > >
              > >
              >
              >
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.