Loading ...
Sorry, an error occurred while loading the content.

strange output on report - Url write to browser is wrong+status bar is right

Expand Messages
  • Al Guevara
    v 1.35 strangeness http://tucson-webdesign.com/xenu.gif (118k) Hi Tilman For best quality viewing, make sure your browser is - FULL screen - AutoZoom is OFF
    Message 1 of 3 , May 16, 2010
    • 0 Attachment
      v 1.35 strangeness
      http://tucson-webdesign.com/xenu.gif (118k)

      Hi Tilman

      For best quality viewing, make sure your browser is
      - FULL screen
      - AutoZoom is OFF
      -so you see the .gif correctly.

      I thought you might want to see this Tilman. Please note the HAND cursor on the 2nd to top Url. Comparing the top Url, and the bottom status bar Url, see that the two Urls differ. The top Url has the ( /../ ) extra folder, (for lack of a correct name) and the bottom Url does not. Its like Xenu is not functioning correctly in the report mode. But is in the status bar.

      What is the /../ in the top (report) Url? Xenu is reporting a broke link where none exists?

      In attached the .xen file for you.


      Al Guevara
      Tucson, AZ
    • Fischer, Thomas
      Hi Al, this is not so strange after all. A browser will evaluate http://www.samhughes.org/../images/banner-images/225backgnd-without.gif as
      Message 2 of 3 , May 17, 2010
      • 0 Attachment
        Hi Al,
         
        this is not so strange after all.
         
        A browser will evaluate
        as
        because "../" means "One directory up", but since this is already in the top position, there is no way to go but to stay.
        This is the link you see in the status bar.
        On the other hand
        would evaluate to
        and thus will fail.
         
        But Xenu is not a browser, it takes the link verbatim and sends it to the server.
        And the server answers:
        "400 Bad Request text/html; charset=iso-8859-1"
        Hence the error.
         
        Hope this helps
        Thomas


        Von: xenu-usergroup@yahoogroups.com [mailto:xenu-usergroup@yahoogroups.com] Im Auftrag von Al Guevara
        Gesendet: Montag, 17. Mai 2010 01:43
        An: xenu-usergroup@yahoogroups.com
        Betreff: [xenu-usergroup] strange output on report - Url write to browser is wrong+status bar is right

         

        v 1.35 strangeness
        http://tucson-webdesign.com/xenu.gif (118k)

        Hi Tilman

        For best quality viewing, make sure your browser is
        - FULL screen
        - AutoZoom is OFF
        -so you see the .gif correctly.

        I thought you might want to see this Tilman. Please note the HAND cursor on the 2nd to top Url. Comparing the top Url, and the bottom status bar Url, see that the two Urls differ. The top Url has the ( /../ ) extra folder, (for lack of a correct name) and the bottom Url does not. Its like Xenu is not functioning correctly in the report mode. But is in the status bar.

        What is the /../ in the top (report) Url? Xenu is reporting a broke link where none exists?

        In attached the .xen file for you.

        Al Guevara
        Tucson, AZ

      • Tilman Hausherr
        This is by design, Xenu will simulate an error 404 (see the error text in the xenu window) when you have /../ , i.e. that you link to something that is too
        Message 3 of 3 , May 17, 2010
        • 0 Attachment
          This is by design, Xenu will simulate an error 404 (see the error text
          in the xenu window) when you have "/../", i.e. that you link to
          something that is "too high". Even if a browser would be able to get
          that url correctly.

          Tilman

          On Sun, 16 May 2010 16:42:30 -0700, Al Guevara wrote:

          >v 1.35 strangeness
          >http://tucson-webdesign.com/xenu.gif (118k)
          >
          >Hi Tilman
          >
          >For best quality viewing, make sure your browser is
          >- FULL screen
          >- AutoZoom is OFF
          > -so you see the .gif correctly.
          >
          >I thought you might want to see this Tilman. Please note the HAND cursor on the 2nd to top Url. Comparing the top Url, and the bottom status bar Url, see that the two Urls differ. The top Url has the ( /../ ) extra folder, (for lack of a correct name) and the bottom Url does not. Its like Xenu is not functioning correctly in the report mode. But is in the status bar.
          >
          >What is the /../ in the top (report) Url? Xenu is reporting a broke link where none exists?
          >
          >In attached the .xen file for you.
          >
          >
          >Al Guevara
          >Tucson, AZ
          >
          >
          >------------------------------------
          >
          >Yahoo! Groups Links
          >
          >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.