Loading ...
Sorry, an error occurred while loading the content.

RE: [xenu-usergroup] Question about my Xenu results

Expand Messages
  • KWhite
    Oh.GoDaddy disables error logs by default, so I just enabled them. I will check them later today. And I can wait a few days and check Google Webmaster tools to
    Message 1 of 18 , Oct 26, 2009
    • 0 Attachment
    • Tony Zampini
      Kim, You should have some sort of File Viewer to look at the files on your site. This would be through a control panel of some sort on GoDaddy (I don t use
      Message 2 of 18 , Oct 26, 2009
      • 0 Attachment
        Kim,
        You should have some sort of File Viewer to look at the files on your site.
        This would be through a control panel of some sort on GoDaddy (I don't use GoDaddy,
        so I don't know the exact way they do it).
         
        I'd be interested in knowing what file types (extensions) are in the failing directories.
         
        Tony
         
        ----- Original Message -----
        From: KWhite
        Sent: Monday, October 26, 2009 3:27 PM
        Subject: RE: [xenu-usergroup] Question about my Xenu results

         

        Thanks, Tony. I’m not sure what the exact file name is though, because it’s a WordPress site. Can tell me how to find the file name?

        Or maybe it’s a permalink issue?

        I did have a bad .htaccess file that I deleted before this happened.

        Also, it’s hosted on GoDaddy, and I built some 301 redirects in their system for a /blog page that is now /blog-make-a- slideshow.

        This is all the info I can think to give you, but please let me know if there is something else I can tell you that will help you help me ;)

        Kim

        -----Original Message-----
        From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tony Zampini
        Sent: Monday, October 26, 2009 12:18 PM
        To: xenu-usergroup@ yahoogroups. com
        Subject: Re: [xenu-usergroup] Question about my Xenu results

         

        Hi,

        I ran your website through Xenu and I see what you mean. Not sure

        exactly what's going on, but I noticed that all the failed links do not

        specify a target file, they only specify a directory. Perhaps Xenu

        doesn't recognize the extension of the default filename for each of those

        pages.

        What is the actual file name extension of one of those files. I'll try it

        on my website and see if Xenu has trouble with it.

        Tony

        ----- Original Message -----

        From: AL Guevara

        Sent: Monday, October 26, 2009 1:54 PM

        Subject: RE: [xenu-usergroup] Question about my Xenu results

         

        Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as broken links? My links actually work, but Xenu reports them as broken, so I am worried there is something wrong with the site structure. My site is fauxflix.com.

        Thanks!

      • KWhite
        Hey Tony, I guess they are .php files. They are created by my WordPress theme, and I believe they are all delivered up via css and php. I can t see the actual
        Message 3 of 18 , Oct 26, 2009
        • 0 Attachment
        • Tony Zampini
          Kim, Try running Xenu with the following URL: http://fauxflix.com/privacy Very interesting result... Tony ... From: KWhite To: xenu-usergroup@yahoogroups.com
          Message 4 of 18 , Oct 26, 2009
          • 0 Attachment
            Kim,
            Try running Xenu with the following URL:
             
             
            Very interesting result...
             
            Tony
             
            ----- Original Message -----
            From: KWhite
            Sent: Monday, October 26, 2009 3:45 PM
            Subject: RE: [xenu-usergroup] Question about my Xenu results

             

            Oh…GoDaddy disables error logs by default, so I just enabled them. I will check them later today.

            And I can wait a few days and check Google Webmaster tools to see if Google sees the links as broken.

            Maybe it is a GoDaddy issue, and they don’t like Xenu, as you suggested. They have really improved their WordPress hosting, but sometimes there are glitches. I will let the group know the results.

            Thank you, and I will watch for other suggestions from you all, just in case!

            -----Original Message-----
            From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tilman Hausherr
            Sent:
            Monday, October 26, 2009 12:30 PM
            To: xenu-usergroup@ yahoogroups. com
            Subject: Re: [xenu-usergroup] Question about my Xenu results

             

            Its weird indeed... look into the logfiles of your server. I suspect
            that the server doesn't like the Xenu user agent, sometimes.

            Tilman

            On Mon, 26 Oct 2009 10:42:05 -0700, KWhite wrote:

            >Hello, I am wondering if someone can tell me why Xenu sees all of my
            >main pages as broken links? My links actually work, but Xenu reports
            >them as broken, so I am worried there is something wrong with the site
            >structure. My site is fauxflix.com.
            >
            >Thanks!

          • Tony Zampini
            My site uses .php files and Xenu works fine. Tilman s idea of looking at the logs might shed some light as to why certain page requests were rejected by your
            Message 5 of 18 , Oct 26, 2009
            • 0 Attachment
              My site uses .php files and Xenu works fine.
               
              Tilman's idea of looking at the logs might shed some light
              as to why certain page requests were rejected by your web server.
               
              Tony
               
              ----- Original Message -----
              From: KWhite
              Sent: Monday, October 26, 2009 4:02 PM
              Subject: RE: [xenu-usergroup] Question about my Xenu results

               

              Hey Tony, I guess they are .php files. They are created by my WordPress theme, and I believe they are all delivered up via css and php. I can’t see the actual pages in my file manager. Sorry, that’s all I know!

              Kim

              -----Original Message-----
              From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tony Zampini
              Sent: Monday, October 26, 2009 12:46 PM
              To: xenu-usergroup@ yahoogroups. com
              Subject: Re: [xenu-usergroup] Question about my Xenu results

               

              Kim,

              You should have some sort of File Viewer to look at the files on your site.

              This would be through a control panel of some sort on GoDaddy (I don't use GoDaddy,

              so I don't know the exact way they do it).

              I'd be interested in knowing what file types (extensions) are in the failing directories.

              Tony

              ----- Original Message -----

              From: KWhite

              Sent: Monday, October 26, 2009 3:27 PM

              Subject: RE: [xenu-usergroup] Question about my Xenu results

               

              Thanks, Tony. I’m not sure what the exact file name is though, because it’s a WordPress site. Can tell me how to find the file name?

              Or maybe it’s a permalink issue?

              I did have a bad .htaccess file that I deleted before this happened.

              Also, it’s hosted on GoDaddy, and I built some 301 redirects in their system for a /blog page that is now /blog-make-a- slideshow.

              This is all the info I can think to give you, but please let me know if there is something else I can tell you that will help you help me ;)

              Kim

              -----Original Message-----
              From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tony Zampini
              Sent: Monday, October 26, 2009 12:18 PM
              To: xenu-usergroup@ yahoogroups. com
              Subject: Re: [xenu-usergroup] Question about my Xenu results

               

              Hi,

              I ran your website through Xenu and I see what you mean. Not sure

              exactly what's going on, but I noticed that all the failed links do not

              specify a target file, they only specify a directory. Perhaps Xenu

              doesn't recognize the extension of the default filename for each of those

              pages.

              What is the actual file name extension of one of those files. I'll try it

              on my website and see if Xenu has trouble with it.

              Tony

              ----- Original Message -----

              From: AL Guevara

              Sent: Monday, October 26, 2009 1:54 PM

              Subject: RE: [xenu-usergroup] Question about my Xenu results

               

              Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as broken links? My links actually work, but Xenu reports them as broken, so I am worried there is something wrong with the site structure. My site is fauxflix.com.

              Thanks!

            • tOM Trottier
              Your links all go to directories. Change them to go to the actual files rather than the default, e.g., index.htm, index.html, index.php or whatever you are
              Message 6 of 18 , Oct 26, 2009
              • 0 Attachment
                Your links all go to directories.

                Change them to go to the actual files rather than the default, e.g.,
                index.htm, index.html, index.php or whatever you are using.

                See http://en.wikipedia.org/wiki/Webserver_directory_index

                tOM

                > ----- Original Message -----
                >
                > From: AL Guevara
                >
                > To: xenu-usergroup@yahoogroups.com
                >
                > Sent: Monday, October 26, 2009 1:54 PM
                >
                > Subject: RE: [xenu-usergroup] Question about my Xenu results
                >
                >
                > Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as
                > broken links? My links actually work, but Xenu reports them as broken, so I am
                > worried there is something wrong with the site structure. My site is fauxflix.com.
                > Thanks!

                -- Absum! --
                tOM Trottier, +1 613 860-6633
                469 Ancaster Ave, Ottawa, ON K2B 5B6 Canada
                http://Information.Architecture.Abacurial.com
                Est-ce c'est necessaire d'imprimer ce courriel?
                Do you really need to print this email?
              • Shiner
                Did you put back the WordPress .htaccess defaults? This is especially required if you have changed the permalink structure of your site to use a certain
                Message 7 of 18 , Oct 26, 2009
                • 0 Attachment
                  Did you put back the WordPress .htaccess defaults?
                  This is especially required if you have changed the permalink structure of your site to use a 'certain' types of link structure.
                  Also, do you use the WP Super Cache plugin which again, also requires the use of some modifications to your .htaccess.

                  The WP Super Cache plugin also has some settings for handling different 'user agents' which might effect how it handles a Xenu crawl.
                  Depending on whether you are using the WP Super Cache plugin, there could be up to 2 .htaccess files required for WP to function correctly.

                  Regards

                  Chris

                  KWhite wrote:
                   

                  Thanks, Tony. I’m not sure what the exact file name is though, because it’s a WordPress site. Can tell me how to find the file name?

                   

                  Or maybe it’s a permalink issue?

                   

                  I did have a bad .htaccess file that I deleted before this happened.

                   

                  Also, it’s hosted on GoDaddy, and I built some 301 redirects in their system for a /blog page that is now /blog-make-a- slideshow.

                   

                  This is all the info I can think to give you, but please let me know if there is something else I can tell you that will help you help me ;)

                   

                  Kim

                   

                  -----Original Message-----
                  From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tony Zampini
                  Sent: Monday, October 26, 2009 12:18 PM
                  To: xenu-usergroup@ yahoogroups. com
                  Subject: Re: [xenu-usergroup] Question about my Xenu results

                   

                   

                  Hi,

                   

                  I ran your website through Xenu and I see what you mean. Not sure

                  exactly what's going on, but I noticed that all the failed links do not

                  specify a target file, they only specify a directory. Perhaps Xenu

                  doesn't recognize the extension of the default filename for each of those

                  pages.

                   

                  What is the actual file name extension of one of those files. I'll try it

                  on my website and see if Xenu has trouble with it.

                   

                  Tony

                   

                  ----- Original Message -----

                  From: AL Guevara

                  Sent: Monday, October 26, 2009 1:54 PM

                  Subject: RE: [xenu-usergroup] Question about my Xenu results

                   

                   

                  Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as broken links? My links actually work, but Xenu reports them as broken, so I am worried there is something wrong with the site structure. My site is fauxflix.com.

                   

                  Thanks!


                • Shiner
                  Kim, Just had another thought.... In your Wordpress control panel under the Privacy Settings, what do you have set for Blog Visability. You might have to have
                  Message 8 of 18 , Oct 26, 2009
                  • 0 Attachment
                    Kim,

                    Just had another thought....

                    In your Wordpress control panel under the Privacy Settings, what do you have set for Blog Visability.
                    You might have to have it set to the 1st option (the 2nd option is default).

                    The first option being: "I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers"

                    WordPress will redirect all enquiries to non-accessable pages to the temp page (hence the 302 redirect).
                    This happens when a crawler is denied access (such as Xenu) and/or the page is blocked to a members only page (in which case the user is redirected to the login page).

                    Regards

                    Chris


                    KWhite wrote:
                     

                    Thanks, Tony. I’m not sure what the exact file name is though, because it’s a WordPress site. Can tell me how to find the file name?

                     

                    Or maybe it’s a permalink issue?

                     

                    I did have a bad .htaccess file that I deleted before this happened.

                     

                    Also, it’s hosted on GoDaddy, and I built some 301 redirects in their system for a /blog page that is now /blog-make-a- slideshow.

                     

                    This is all the info I can think to give you, but please let me know if there is something else I can tell you that will help you help me ;)

                     

                    Kim

                     

                    -----Original Message-----
                    From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tony Zampini
                    Sent: Monday, October 26, 2009 12:18 PM
                    To: xenu-usergroup@ yahoogroups. com
                    Subject: Re: [xenu-usergroup] Question about my Xenu results

                     

                     

                    Hi,

                     

                    I ran your website through Xenu and I see what you mean. Not sure

                    exactly what's going on, but I noticed that all the failed links do not

                    specify a target file, they only specify a directory. Perhaps Xenu

                    doesn't recognize the extension of the default filename for each of those

                    pages.

                     

                    What is the actual file name extension of one of those files. I'll try it

                    on my website and see if Xenu has trouble with it.

                     

                    Tony

                     

                    ----- Original Message -----

                    From: AL Guevara

                    Sent: Monday, October 26, 2009 1:54 PM

                    Subject: RE: [xenu-usergroup] Question about my Xenu results

                     

                     

                    Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as broken links? My links actually work, but Xenu reports them as broken, so I am worried there is something wrong with the site structure. My site is fauxflix.com.

                     

                    Thanks!


                  • Shiner
                    That s how WordPress works when you use the Permalink structure option. What you say would be true if the URL s did not have the trailing slash, but you ll
                    Message 9 of 18 , Oct 26, 2009
                    • 0 Attachment
                      That's how WordPress works when you use the Permalink structure option.
                      What you say would be true if the URL's did not have the trailing slash, but you'll note that they all end with / which IRC indicates that it is not a directory, but a file.

                      So
                      http://fauxflix.com/blog-make-a-slideshow/
                      indicates a file
                      where as
                      http://fauxflix.com/blog-make-a-slideshow
                      would indicate a directory

                      So the file structure it is returning is correct, it is her .htaccess (via settings on her WordPress dashboard) which is causing the server to return not founds when in fact they do exist.

                      Regards

                      Chris

                      tOM Trottier wrote:
                       

                      Your links all go to directories.

                      Change them to go to the actual files rather than the default, e.g.,
                      index.htm, index.html, index.php or whatever you are using.

                      See http://en.wikipedia .org/wiki/ Webserver_ directory_ index

                      tOM

                      > ----- Original Message -----
                      >
                      > From: AL Guevara
                      >
                      > To: xenu-usergroup@ yahoogroups. com
                      >
                      > Sent: Monday, October 26, 2009 1:54 PM
                      >
                      > Subject: RE: [xenu-usergroup] Question about my Xenu results
                      >
                      >
                      > Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as
                      > broken links? My links actually work, but Xenu reports them as broken, so I am
                      > worried there is something wrong with the site structure. My site is fauxflix.com.
                      > Thanks!

                      -- Absum! --
                      tOM Trottier, +1 613 860-6633
                      469 Ancaster Ave, Ottawa, ON K2B 5B6 Canada
                      http://Information. Architecture. Abacurial. com
                      Est-ce c'est necessaire d'imprimer ce courriel?
                      Do you really need to print this email?


                    • Shiner
                      Kim, Ignore the part about 302 redirect, I think for search engines, it returns the page as not found , so I reckon you do have the privacy option set to
                      Message 10 of 18 , Oct 26, 2009
                      • 0 Attachment
                        Kim,

                        Ignore the part about 302 redirect, I think for search engines, it returns the page as "not found", so I reckon you do have the privacy option set to block search engines.

                        Regards

                        Chris


                        Shiner wrote:
                         

                        Kim,

                        Just had another thought....

                        In your Wordpress control panel under the Privacy Settings, what do you have set for Blog Visability.
                        You might have to have it set to the 1st option (the 2nd option is default).

                        The first option being: "I would like my blog to be visible to everyone, including search engines (like Google, Sphere, Technorati) and archivers"

                        WordPress will redirect all enquiries to non-accessable pages to the temp page (hence the 302 redirect).
                        This happens when a crawler is denied access (such as Xenu) and/or the page is blocked to a members only page (in which case the user is redirected to the login page).

                        Regards

                        Chris


                        KWhite wrote:

                         

                        Thanks, Tony. I’m not sure what the exact file name is though, because it’s a WordPress site. Can tell me how to find the file name?

                         

                        Or maybe it’s a permalink issue?

                         

                        I did have a bad .htaccess file that I deleted before this happened.

                         

                        Also, it’s hosted on GoDaddy, and I built some 301 redirects in their system for a /blog page that is now /blog-make-a- slideshow.

                         

                        This is all the info I can think to give you, but please let me know if there is something else I can tell you that will help you help me ;)

                         

                        Kim

                         

                        -----Original Message-----
                        From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Tony Zampini
                        Sent: Monday, October 26, 2009 12:18 PM
                        To: xenu-usergroup@ yahoogroups. com
                        Subject: Re: [xenu-usergroup] Question about my Xenu results

                         

                         

                        Hi,

                         

                        I ran your website through Xenu and I see what you mean. Not sure

                        exactly what's going on, but I noticed that all the failed links do not

                        specify a target file, they only specify a directory. Perhaps Xenu

                        doesn't recognize the extension of the default filename for each of those

                        pages.

                         

                        What is the actual file name extension of one of those files. I'll try it

                        on my website and see if Xenu has trouble with it.

                         

                        Tony

                         

                        ----- Original Message -----

                        From: AL Guevara

                        Sent: Monday, October 26, 2009 1:54 PM

                        Subject: RE: [xenu-usergroup] Question about my Xenu results

                         

                         

                        Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as broken links? My links actually work, but Xenu reports them as broken, so I am worried there is something wrong with the site structure. My site is fauxflix.com.

                         

                        Thanks!



                      • KWhite
                        Okay, did the following: Deleted all my redirects (didn t work) Checked privacy settings, and they are set to be visible to everyone I don t currently have an
                        Message 11 of 18 , Oct 26, 2009
                        • 0 Attachment
                        • Shiner
                          If you can t find your old .htaccess file, download and install the WP Super Cache plugin and that should create a new .htaccess for you. (Never tried that
                          Message 12 of 18 , Oct 26, 2009
                          • 0 Attachment
                            If you can't find your old .htaccess file, download and install the WP Super Cache plugin and that "should" create a new .htaccess for you.  (Never tried that before, but I know it does create a new .htaccess file)

                            Chris

                            KWhite wrote:
                             

                            Okay, did the following:

                             

                            Deleted all my redirects (didn’t work)

                            Checked privacy settings, and they are set to be visible to everyone

                             

                            I don’t currently have an .htaccess file, so I am looking in history for the last one that worked to restore it.

                             

                            (So far, my .htaccess has been the source of most of my aggravation. )

                             

                             

                            -----Original Message-----
                            From: xenu-usergroup@ yahoogroups. com [mailto:xenu- usergroup@ yahoogroups. com] On Behalf Of Shiner
                            Sent: Monday, October 26, 2009 2:01 PM
                            To: xenu-usergroup@ yahoogroups. com
                            Subject: Re: [xenu-usergroup] Question about my Xenu results

                             

                             

                            That's how WordPress works when you use the Permalink structure option.
                            What you say would be true if the URL's did not have the trailing slash, but you'll note that they all end with / which IRC indicates that it is not a directory, but a file.

                            So
                            http://fauxflix. com/blog- make-a-slideshow /
                            indicates a file
                            where as
                            http://fauxflix. com/blog- make-a-slideshow
                            would indicate a directory

                            So the file structure it is returning is correct, it is her .htaccess (via settings on her WordPress dashboard) which is causing the server to return not founds when in fact they do exist.

                            Regards

                            Chris

                            tOM Trottier wrote:

                             

                            Your links all go to directories.

                            Change them to go to the actual files rather than the default, e.g.,
                            index.htm, index.html, index.php or whatever you are using.

                            See http://en.wikipedia .org/wiki/ Webserver_ directory_ index

                            tOM

                            > ----- Original Message -----
                            >
                            > From: AL Guevara
                            >
                            > To: xenu-usergroup@ yahoogroups. com
                            >
                            > Sent: Monday, October 26, 2009 1:54 PM
                            >
                            > Subject: RE: [xenu-usergroup] Question about my Xenu results
                            >
                            >
                            > Hello, I am wondering if someone can tell me why Xenu sees all of my main pages as
                            > broken links? My links actually work, but Xenu reports them as broken, so I am
                            > worried there is something wrong with the site structure. My site is fauxflix.com.
                            > Thanks!

                            -- Absum! --
                            tOM Trottier, +1 613 860-6633
                            469 Ancaster Ave, Ottawa, ON K2B 5B6 Canada
                            http://Information. Architecture. Abacurial. com
                            Est-ce c'est necessaire d'imprimer ce courriel?
                            Do you really need to print this email?

                             


                          • KWhite
                            DING! And the winner is.Chris! It WAS the .htaccess file. I thought I had deleted it, but it was still lurking in there somewhere. I went into GoDaddy s
                            Message 13 of 18 , Oct 26, 2009
                            • 0 Attachment
                            Your message has been successfully submitted and would be delivered to recipients shortly.