Loading ...
Sorry, an error occurred while loading the content.

La Crosse Support

Expand Messages
  • powerstar64
    I had to send my 2315 display back after 6 months, it failed. All of the digits were lit up. They send a new one that came cracked, I took a picture and sent
    Message 1 of 4 , Aug 30, 2007
    • 0 Attachment
      I had to send my 2315 display back after 6 months, it failed. All of
      the digits were lit up. They send a new one that came cracked, I took a
      picture and sent it in an e-mail to the support. They sent another
      display that work great. Great job to the La Crosse support. I received
      the new console display and I'm very satisfied, with La Crosse
      response. A+ for La Crosse, Thanks for you help.
    • Shawn Parker
      When my anemometer died they sent me a new one within a couple days of receiving my old broken one.
      Message 2 of 4 , Aug 30, 2007
      • 0 Attachment
        When my anemometer died they sent me a new one within a couple days of
        receiving
        my old broken one.


        powerstar64 wrote:
        >
        > I had to send my 2315 display back after 6 months, it failed. All of
        > the digits were lit up. They send a new one that came cracked, I took a
        > picture and sent it in an e-mail to the support. They sent another
        > display that work great. Great job to the La Crosse support. I received
        > the new console display and I'm very satisfied, with La Crosse
        > response. A+ for La Crosse, Thanks for you help.
        >
        >
      • fortonb
        My rain gauge stopped working just past the year warranty. They let me send it back for repairs under warranty. After they received and tested it, they
        Message 3 of 4 , Aug 31, 2007
        • 0 Attachment
          My rain gauge stopped working just past the year warranty. They let
          me send it back for repairs under warranty. After they received and
          tested it, they determined that the problem was in the main display
          as the rain gauge seemed to work fine. They sent me a new display
          within a week. Great Job, they know the meaning of "Customer
          Service". Not many companies do now days….

          --- In wuhu_software_group@yahoogroups.com, Shawn Parker
          <kamakzie@...> wrote:
          >
          > When my anemometer died they sent me a new one within a couple days
          of
          > receiving
          > my old broken one.
          >
          >
          > powerstar64 wrote:
          > >
          > > I had to send my 2315 display back after 6 months, it failed. All
          of
          > > the digits were lit up. They send a new one that came cracked, I
          took a
          > > picture and sent it in an e-mail to the support. They sent another
          > > display that work great. Great job to the La Crosse support. I
          received
          > > the new console display and I'm very satisfied, with La Crosse
          > > response. A+ for La Crosse, Thanks for you help.
          > >
          > >
          >
        • mahep
          I had a problem with my wind sensor sent it off to them they fixed it and a week later it broke again and once again sent it back to them they sent me a new
          Message 4 of 4 , Aug 31, 2007
          • 0 Attachment
            I had a problem with my wind sensor sent it off to them they fixed
            it and a week later it broke again and once again sent it back to
            them they sent me a new one and did not charge me any thing. They
            are a great company and have shown the same thing to others.

            --- In wuhu_software_group@yahoogroups.com, "fortonb"
            <fortondad@...> wrote:
            >
            > My rain gauge stopped working just past the year warranty. They
            let
            > me send it back for repairs under warranty. After they received
            and
            > tested it, they determined that the problem was in the main
            display
            > as the rain gauge seemed to work fine. They sent me a new display
            > within a week. Great Job, they know the meaning of "Customer
            > Service". Not many companies do now days….
            >
            > --- In wuhu_software_group@yahoogroups.com, Shawn Parker
            > <kamakzie@> wrote:
            > >
            > > When my anemometer died they sent me a new one within a couple
            days
            > of
            > > receiving
            > > my old broken one.
            > >
            > >
            > > powerstar64 wrote:
            > > >
            > > > I had to send my 2315 display back after 6 months, it failed.
            All
            > of
            > > > the digits were lit up. They send a new one that came cracked,
            I
            > took a
            > > > picture and sent it in an e-mail to the support. They sent
            another
            > > > display that work great. Great job to the La Crosse support. I
            > received
            > > > the new console display and I'm very satisfied, with La Crosse
            > > > response. A+ for La Crosse, Thanks for you help.
            > > >
            > > >
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.