Loading ...
Sorry, an error occurred while loading the content.

v215, Communication errors patch.

Expand Messages
  • wuhu_software
    For those of you that have been having a problem with WS-23XX direct serial communications errors. where the console refuses to communicate after some period
    Message 1 of 11 , Feb 27, 2007
    • 0 Attachment
      For those of you that have been having a problem with WS-23XX direct
      serial communications errors. where the console refuses to
      communicate after some period of time, please download and test this
      new version, v215.

      Looking at the Portmon capture that Tom had sent me, I noticed that
      WUHU was attempting to send a character to the WS-23XX that resulted
      in a timeout. This should never happen. My guess is that some type of
      flow control was enabled by default.

      Looking at the code, I found that the serial port configuration was
      not completely overwritten by WUHU when it was initially opened. This
      could result in flow control (DSR, Xon/Xoff) being enabled depending
      on how the users machine was configured.

      This version attempts to turn off all handshaking mechanisms on the
      port regardless of the serial port configuration on the users machine.

      I sent a patch to Tom last night and he wrote me this morning telling
      me that it was able to run overnight whereas it normally locked up
      within a couple of hours.

      Please let me know if this addresses com. errors on your setup.

      ---

      Download Page:

      http://tech.groups.yahoo.com/group/wuhu_software_group/

      ---
    • Keith Walters
      I have now ran close to 16 hours with out the error message unable to communicate.... and so on. I think you may have found the issue, I could not go 5 min
      Message 2 of 11 , Feb 28, 2007
      • 0 Attachment
        I have now ran close to 16 hours with out the error message unable to communicate.... and so on. I think you may have found the issue, I could not go 5 min before the V215 update with out receiving the communication error message. So far so good!!

        Keith


        On 2/27/07, wuhu_software <wuhu_software@...> wrote:
        For those of you that have been having a problem with WS-23XX direct
        serial communications errors. where the console refuses to
        communicate after some period of time, please download and test this
        new version, v215.

        Looking at the Portmon capture that Tom had sent me, I noticed that
        WUHU was attempting to send a character to the WS-23XX that resulted
        in a timeout. This should never happen. My guess is that some type of
        flow control was enabled by default.

        Looking at the code, I found that the serial port configuration was
        not completely overwritten by WUHU when it was initially opened. This
        could result in flow control (DSR, Xon/Xoff) being enabled depending
        on how the users machine was configured.

        This version attempts to turn off all handshaking mechanisms on the
        port regardless of the serial port configuration on the users machine.

        I sent a patch to Tom last night and he wrote me this morning telling
        me that it was able to run overnight whereas it normally locked up
        within a couple of hours.

        Please let me know if this addresses com. errors on your setup.

        ---

        Download Page:

        http://tech.groups.yahoo.com/group/wuhu_software_group/

        ---




        ------------------------ Yahoo! Groups Sponsor --------------------~-->
        Check out the new improvements in Yahoo! Groups email.
        http://us.click.yahoo.com/4It09A/fOaOAA/yQLSAA/RLYolB/TM
        --------------------------------------------------------------------~->

        To visit your group on the web, go to:
        http://groups.yahoo.com/group/wuhu_software_group/

        Want more or less group messages (Special notices as a minimum)?http://groups.yahoo.com/group/wuhu_software_group/join

        To unsubscribe from this group, send an email to:
        wuhu_software_group-unsubscribe@yahoogroups.com

        WUHU Download page:
        http://home.comcast.net/~wuhu_software/
        Yahoo! Groups Links

        <*> To visit your group on the web, go to:
            http://groups.yahoo.com/group/wuhu_software_group/

        <*> Your email settings:
            Individual Email | Traditional

        <*> To change settings online go to:
            http://groups.yahoo.com/group/wuhu_software_group/join
            (Yahoo! ID required)

        <*> To change settings via email:
            mailto:wuhu_software_group-digest@yahoogroups.com
            mailto: wuhu_software_group-fullfeatured@yahoogroups.com

        <*> To unsubscribe from this group, send an email to:
            wuhu_software_group-unsubscribe@yahoogroups.com

        <*> Your use of Yahoo! Groups is subject to:
            http://docs.yahoo.com/info/terms/


      • wuhu_software
        Keith, Thanks for the feedback. Hopefully that is the end of the communication errors for WS-23XX direct serial users! ... to ... could not ... communication
        Message 3 of 11 , Feb 28, 2007
        • 0 Attachment
          Keith,

          Thanks for the feedback.

          Hopefully that is the end of the communication errors for WS-23XX
          direct serial users!


          --- In wuhu_software_group@yahoogroups.com, "Keith Walters"
          <keith.walt@...> wrote:
          >
          > I have now ran close to 16 hours with out the error message unable
          to
          > communicate.... and so on. I think you may have found the issue, I
          could not
          > go 5 min before the V215 update with out receiving the
          communication error
          > message. So far so good!!
          >
          > Keith
          >
          >
          > On 2/27/07, wuhu_software <wuhu_software@...> wrote:
          > >
          > > For those of you that have been having a problem with WS-23XX
          direct
          > > serial communications errors. where the console refuses to
          > > communicate after some period of time, please download and test
          this
          > > new version, v215.
          > >
          > > Looking at the Portmon capture that Tom had sent me, I noticed
          that
          > > WUHU was attempting to send a character to the WS-23XX that
          resulted
          > > in a timeout. This should never happen. My guess is that some
          type of
          > > flow control was enabled by default.
          > >
          > > Looking at the code, I found that the serial port configuration
          was
          > > not completely overwritten by WUHU when it was initially opened.
          This
          > > could result in flow control (DSR, Xon/Xoff) being enabled
          depending
          > > on how the users machine was configured.
          > >
          > > This version attempts to turn off all handshaking mechanisms on
          the
          > > port regardless of the serial port configuration on the users
          machine.
          > >
          > > I sent a patch to Tom last night and he wrote me this morning
          telling
          > > me that it was able to run overnight whereas it normally locked up
          > > within a couple of hours.
          > >
          > > Please let me know if this addresses com. errors on your setup.
          > >
          > > ---
          > >
          > > Download Page:
          > >
          > > http://tech.groups.yahoo.com/group/wuhu_software_group/
          > >
          > > ---
          > >
          > >
          > >
          > >
          > >
          > > To visit your group on the web, go to:
          > > http://groups.yahoo.com/group/wuhu_software_group/
          > >
          > > Want more or less group messages (Special notices as a
          > > minimum)?http://groups.yahoo.com/group/wuhu_software_group/join
          > >
          > > To unsubscribe from this group, send an email to:
          > > wuhu_software_group-unsubscribe@yahoogroups.com
          > >
          > > WUHU Download page:
          > > http://home.comcast.net/~wuhu_software/
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > >
          >
        • michrina1
          And I m now over 36 hours. I think this is fixed. Thanks for your quick response to this. Tom ... unable ... I ... test ... configuration ... opened. ... on
          Message 4 of 11 , Feb 28, 2007
          • 0 Attachment
            And I'm now over 36 hours. I think this is fixed. Thanks for your
            quick response to this.

            Tom

            --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
            <wuhu_software@...> wrote:
            >
            > Keith,
            >
            > Thanks for the feedback.
            >
            > Hopefully that is the end of the communication errors for WS-23XX
            > direct serial users!
            >
            >
            > --- In wuhu_software_group@yahoogroups.com, "Keith Walters"
            > <keith.walt@> wrote:
            > >
            > > I have now ran close to 16 hours with out the error message
            unable
            > to
            > > communicate.... and so on. I think you may have found the issue,
            I
            > could not
            > > go 5 min before the V215 update with out receiving the
            > communication error
            > > message. So far so good!!
            > >
            > > Keith
            > >
            > >
            > > On 2/27/07, wuhu_software <wuhu_software@> wrote:
            > > >
            > > > For those of you that have been having a problem with WS-23XX
            > direct
            > > > serial communications errors. where the console refuses to
            > > > communicate after some period of time, please download and
            test
            > this
            > > > new version, v215.
            > > >
            > > > Looking at the Portmon capture that Tom had sent me, I noticed
            > that
            > > > WUHU was attempting to send a character to the WS-23XX that
            > resulted
            > > > in a timeout. This should never happen. My guess is that some
            > type of
            > > > flow control was enabled by default.
            > > >
            > > > Looking at the code, I found that the serial port
            configuration
            > was
            > > > not completely overwritten by WUHU when it was initially
            opened.
            > This
            > > > could result in flow control (DSR, Xon/Xoff) being enabled
            > depending
            > > > on how the users machine was configured.
            > > >
            > > > This version attempts to turn off all handshaking mechanisms
            on
            > the
            > > > port regardless of the serial port configuration on the users
            > machine.
            > > >
            > > > I sent a patch to Tom last night and he wrote me this morning
            > telling
            > > > me that it was able to run overnight whereas it normally
            locked up
            > > > within a couple of hours.
            > > >
            > > > Please let me know if this addresses com. errors on your setup.
            > > >
            > > > ---
            > > >
            > > > Download Page:
            > > >
            > > > http://tech.groups.yahoo.com/group/wuhu_software_group/
            > > >
            > > > ---
            > > >
            > > >
            > > >
            > > >
            > > >
            > > > To visit your group on the web, go to:
            > > > http://groups.yahoo.com/group/wuhu_software_group/
            > > >
            > > > Want more or less group messages (Special notices as a
            > > > minimum)?http://groups.yahoo.com/group/wuhu_software_group/join
            > > >
            > > > To unsubscribe from this group, send an email to:
            > > > wuhu_software_group-unsubscribe@yahoogroups.com
            > > >
            > > > WUHU Download page:
            > > > http://home.comcast.net/~wuhu_software/
            > > > Yahoo! Groups Links
            > > >
            > > >
            > > >
            > > >
            > >
            >
          • James Mason
            I am still having the communication problem. I m getting error messagesin uploading to WU, CWOP and AWEKAS. I checked to make sure I have v215 installed and
            Message 5 of 11 , Mar 1, 2007
            • 0 Attachment
              I am still having the communication problem.  I'm getting error messagesin uploading to WU, CWOP and AWEKAS.  I checked to make sure I have v215 installed and I do.  What can I do or what settings do I need checked just in case they did set correctly when I reinstalled?


               


              Never miss an email again!
              Yahoo! Toolbar
              alerts you the instant new Mail arrives. Check it out.
            • wuhu_software
              James, If you are having upload issues, that would be more of an Internet connectivity problem than a serial communications problem that v215 is intended to
              Message 6 of 11 , Mar 1, 2007
              • 0 Attachment
                James,

                If you are having upload issues, that would be more of an Internet
                connectivity problem than a serial communications problem that v215
                is intended to fix.

                Are you having problems surfing the net? Any other Internet
                reliability issues?

                Also, which operating system are you running?
                It is a fairly new machine?
                Dial-up or Cable?

                Any other clues as to why there might be Internet problems on that
                machine?

                Thanks.



                --- In wuhu_software_group@yahoogroups.com, James Mason
                <masonjh1@...> wrote:
                >
                > I am still having the communication problem. I'm getting error
                messagesin uploading to WU, CWOP and AWEKAS. I checked to make sure
                I have v215 installed and I do. What can I do or what settings do I
                need checked just in case they did set correctly when I reinstalled?
                >
                >
                >
                >
                >
                > ---------------------------------
                > Never miss an email again!
                > Yahoo! Toolbar alerts you the instant new Mail arrives. Check it
                out.
                >
              • masonjh1
                I don t have problems surfing the Internet--I m running Windows XP Professional and my computer is less than a year old. It s a Compaq Presario with 1GB RAM
                Message 7 of 11 , Mar 1, 2007
                • 0 Attachment
                  I don't have problems surfing the Internet--I'm running Windows XP
                  Professional and my computer is less than a year old. It's a Compaq
                  Presario with 1GB RAM and 250GB Hard Drive. My WU software stopped
                  uploading about 2 PM yesterday afternoon. I saw where you havd a fix
                  for communications so I downlaoded and installed v215. I saw where
                  Keith had written and said he had run it for longer than a half day
                  without having any failures to upload. I was hoping mine would do
                  the same--I am running a LaCrosse WS-2317CP and have been since Feb 8
                  or 14th last year. Haven't had any problems--well a minor one here
                  and there--but not like this. I deleted the email that had the
                  settings for direct serial access--and I'm hoping the settings didn't
                  change when I began having the problems. Do you have those
                  settings? Here's what I have--WS23XX DirectSerial Access with the
                  box checked that reads Write Heavyweather Pro compatible History.dat
                  file-- Are those the correct settings or do I need more? Thanks,
                  James







                  --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
                  <wuhu_software@...> wrote:
                  >
                  > James,
                  >
                  > If you are having upload issues, that would be more of an Internet
                  > connectivity problem than a serial communications problem that v215
                  > is intended to fix.
                  >
                  > Are you having problems surfing the net? Any other Internet
                  > reliability issues?
                  >
                  > Also, which operating system are you running?
                  > It is a fairly new machine?
                  > Dial-up or Cable?
                  >
                  > Any other clues as to why there might be Internet problems on that
                  > machine?
                  >
                  > Thanks.
                  >
                  >
                  >
                  > --- In wuhu_software_group@yahoogroups.com, James Mason
                  > <masonjh1@> wrote:
                  > >
                  > > I am still having the communication problem. I'm getting error
                  > messagesin uploading to WU, CWOP and AWEKAS. I checked to make
                  sure
                  > I have v215 installed and I do. What can I do or what settings do
                  I
                  > need checked just in case they did set correctly when I reinstalled?
                  > >
                  > >
                  > >
                  > >
                  > >
                  > > ---------------------------------
                  > > Never miss an email again!
                  > > Yahoo! Toolbar alerts you the instant new Mail arrives. Check it
                  > out.
                  > >
                  >
                • schaka1
                  Curiously, my pc also stopped uploading about 2 pm yesterday. I didn t detect it until I looked at my WU data. The problem lasted about 2 hrs
                  Message 8 of 11 , Mar 1, 2007
                  • 0 Attachment
                    Curiously, my pc also stopped uploading about 2 pm yesterday. I didn't
                    detect it until I looked at my WU data. The problem lasted about 2 hrs

                    --- In wuhu_software_group@yahoogroups.com, "masonjh1" <masonjh1@...>
                    wrote:
                    >
                    >
                    > I don't have problems surfing the Internet--I'm running Windows XP
                    > Professional and my computer is less than a year old. It's a Compaq
                    > Presario with 1GB RAM and 250GB Hard Drive. My WU software stopped
                    > uploading about 2 PM yesterday afternoon. I saw where you havd a fix
                    > for communications so I downlaoded and installed v215. I saw where
                    > Keith had written and said he had run it for longer than a half day
                    > without having any failures to upload. I was hoping mine would do
                    > the same--I am running a LaCrosse WS-2317CP and have been since Feb 8
                    > or 14th last year. Haven't had any problems--well a minor one here
                    > and there--but not like this. I deleted the email that had the
                    > settings for direct serial access--and I'm hoping the settings didn't
                    > change when I began having the problems. Do you have those
                    > settings? Here's what I have--WS23XX DirectSerial Access with the
                    > box checked that reads Write Heavyweather Pro compatible History.dat
                    > file-- Are those the correct settings or do I need more? Thanks,
                    > James
                    >
                    >
                    >
                    >
                    >
                    >
                    >
                    > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
                    > <wuhu_software@> wrote:
                    > >
                    > > James,
                    > >
                    > > If you are having upload issues, that would be more of an Internet
                    > > connectivity problem than a serial communications problem that v215
                    > > is intended to fix.
                    > >
                    > > Are you having problems surfing the net? Any other Internet
                    > > reliability issues?
                    > >
                    > > Also, which operating system are you running?
                    > > It is a fairly new machine?
                    > > Dial-up or Cable?
                    > >
                    > > Any other clues as to why there might be Internet problems on that
                    > > machine?
                    > >
                    > > Thanks.
                    > >
                    > >
                    > >
                    > > --- In wuhu_software_group@yahoogroups.com, James Mason
                    > > <masonjh1@> wrote:
                    > > >
                    > > > I am still having the communication problem. I'm getting error
                    > > messagesin uploading to WU, CWOP and AWEKAS. I checked to make
                    > sure
                    > > I have v215 installed and I do. What can I do or what settings do
                    > I
                    > > need checked just in case they did set correctly when I reinstalled?
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > > > ---------------------------------
                    > > > Never miss an email again!
                    > > > Yahoo! Toolbar alerts you the instant new Mail arrives. Check it
                    > > out.
                    > > >
                    > >
                    >
                  • wuhu_software
                    If you are in direct serial, and data is shown in left column of the history and stats data, then the console is talking. The errors uploading to the servers
                    Message 9 of 11 , Mar 1, 2007
                    • 0 Attachment
                      If you are in direct serial, and data is shown in left column of the
                      history and stats data, then the console is talking.

                      The errors uploading to the servers are not related to serial
                      communications errors.

                      Upload errors are related to Internet connectivity.

                      It may be a temporary condition.

                      Let me know if the problem goes away.

                      There have been no changes made to the upload related code.

                      Thanks.



                      --- In wuhu_software_group@yahoogroups.com, "masonjh1" <masonjh1@...>
                      wrote:
                      >
                      >
                      > I don't have problems surfing the Internet--I'm running Windows XP
                      > Professional and my computer is less than a year old. It's a
                      Compaq
                      > Presario with 1GB RAM and 250GB Hard Drive. My WU software stopped
                      > uploading about 2 PM yesterday afternoon. I saw where you havd a
                      fix
                      > for communications so I downlaoded and installed v215. I saw where
                      > Keith had written and said he had run it for longer than a half day
                      > without having any failures to upload. I was hoping mine would do
                      > the same--I am running a LaCrosse WS-2317CP and have been since Feb
                      8
                      > or 14th last year. Haven't had any problems--well a minor one here
                      > and there--but not like this. I deleted the email that had the
                      > settings for direct serial access--and I'm hoping the settings
                      didn't
                      > change when I began having the problems. Do you have those
                      > settings? Here's what I have--WS23XX DirectSerial Access with the
                      > box checked that reads Write Heavyweather Pro compatible
                      History.dat
                      > file-- Are those the correct settings or do I need more? Thanks,
                      > James
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
                      > <wuhu_software@> wrote:
                      > >
                      > > James,
                      > >
                      > > If you are having upload issues, that would be more of an
                      Internet
                      > > connectivity problem than a serial communications problem that
                      v215
                      > > is intended to fix.
                      > >
                      > > Are you having problems surfing the net? Any other Internet
                      > > reliability issues?
                      > >
                      > > Also, which operating system are you running?
                      > > It is a fairly new machine?
                      > > Dial-up or Cable?
                      > >
                      > > Any other clues as to why there might be Internet problems on
                      that
                      > > machine?
                      > >
                      > > Thanks.
                      > >
                      > >
                      > >
                      > > --- In wuhu_software_group@yahoogroups.com, James Mason
                      > > <masonjh1@> wrote:
                      > > >
                      > > > I am still having the communication problem. I'm getting error
                      > > messagesin uploading to WU, CWOP and AWEKAS. I checked to make
                      > sure
                      > > I have v215 installed and I do. What can I do or what settings
                      do
                      > I
                      > > need checked just in case they did set correctly when I
                      reinstalled?
                      > > >
                      > > >
                      > > >
                      > > >
                      > > >
                      > > > ---------------------------------
                      > > > Never miss an email again!
                      > > > Yahoo! Toolbar alerts you the instant new Mail arrives. Check
                      it
                      > > out.
                      > > >
                      > >
                      >
                    • wuhu_software
                      Let me know if you continue to see issues. Bad weather all over today. ... didn t ... hrs ... XP ... Compaq ... stopped ... fix ... where ... day ... do ...
                      Message 10 of 11 , Mar 1, 2007
                      • 0 Attachment
                        Let me know if you continue to see issues.

                        Bad weather all over today.



                        --- In wuhu_software_group@yahoogroups.com, "schaka1" <blkguy@...>
                        wrote:
                        >
                        > Curiously, my pc also stopped uploading about 2 pm yesterday. I
                        didn't
                        > detect it until I looked at my WU data. The problem lasted about 2
                        hrs
                        >
                        > --- In wuhu_software_group@yahoogroups.com, "masonjh1" <masonjh1@>
                        > wrote:
                        > >
                        > >
                        > > I don't have problems surfing the Internet--I'm running Windows
                        XP
                        > > Professional and my computer is less than a year old. It's a
                        Compaq
                        > > Presario with 1GB RAM and 250GB Hard Drive. My WU software
                        stopped
                        > > uploading about 2 PM yesterday afternoon. I saw where you havd a
                        fix
                        > > for communications so I downlaoded and installed v215. I saw
                        where
                        > > Keith had written and said he had run it for longer than a half
                        day
                        > > without having any failures to upload. I was hoping mine would
                        do
                        > > the same--I am running a LaCrosse WS-2317CP and have been since
                        Feb 8
                        > > or 14th last year. Haven't had any problems--well a minor one
                        here
                        > > and there--but not like this. I deleted the email that had the
                        > > settings for direct serial access--and I'm hoping the settings
                        didn't
                        > > change when I began having the problems. Do you have those
                        > > settings? Here's what I have--WS23XX DirectSerial Access with
                        the
                        > > box checked that reads Write Heavyweather Pro compatible
                        History.dat
                        > > file-- Are those the correct settings or do I need more? Thanks,
                        > > James
                        > >
                        > >
                        > >
                        > >
                        > >
                        > >
                        > >
                        > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
                        > > <wuhu_software@> wrote:
                        > > >
                        > > > James,
                        > > >
                        > > > If you are having upload issues, that would be more of an
                        Internet
                        > > > connectivity problem than a serial communications problem that
                        v215
                        > > > is intended to fix.
                        > > >
                        > > > Are you having problems surfing the net? Any other Internet
                        > > > reliability issues?
                        > > >
                        > > > Also, which operating system are you running?
                        > > > It is a fairly new machine?
                        > > > Dial-up or Cable?
                        > > >
                        > > > Any other clues as to why there might be Internet problems on
                        that
                        > > > machine?
                        > > >
                        > > > Thanks.
                        > > >
                        > > >
                        > > >
                        > > > --- In wuhu_software_group@yahoogroups.com, James Mason
                        > > > <masonjh1@> wrote:
                        > > > >
                        > > > > I am still having the communication problem. I'm getting
                        error
                        > > > messagesin uploading to WU, CWOP and AWEKAS. I checked to make
                        > > sure
                        > > > I have v215 installed and I do. What can I do or what settings
                        do
                        > > I
                        > > > need checked just in case they did set correctly when I
                        reinstalled?
                        > > > >
                        > > > >
                        > > > >
                        > > > >
                        > > > >
                        > > > > ---------------------------------
                        > > > > Never miss an email again!
                        > > > > Yahoo! Toolbar alerts you the instant new Mail arrives. Check
                        it
                        > > > out.
                        > > > >
                        > > >
                        > >
                        >
                      • James Mason
                        The problem evidently cleared itself. I m back. James ... Never miss an email again! Yahoo! Toolbar alerts you the instant new Mail arrives. Check it out.
                        Message 11 of 11 , Mar 1, 2007
                        • 0 Attachment
                          The problem evidently cleared itself.  I'm back.
                          James



                           


                          Never miss an email again!
                          Yahoo! Toolbar
                          alerts you the instant new Mail arrives. Check it out.
                        Your message has been successfully submitted and would be delivered to recipients shortly.