Loading ...
Sorry, an error occurred while loading the content.

Re: Unable to Upload to Weather Underground

Expand Messages
  • wuhu_software
    Jason, To answer your question, WUHU does not store anything in the registry. After looking in to it a bit, I am guessing there is a problem with the
    Message 1 of 3 , Nov 19, 2006
    • 0 Attachment


      To answer your question, WUHU does not store anything in the registry.

      After looking in to it a bit, I am guessing there is a problem with the Wininet.dll. This DLL is used by WUHU to access Internet web pages like those used by WU and AWEKAS. This DLL should be located in your c:\windows\system32 directory.

      The interface to CWOP uses raw sockets, so that explains why those uploads are Ok while the WU and AWEKAS uploads are not.

      Although I have not tried it myself, there is a debug version of this DLL available for download. This debug version will create a log file that may help you debug the problem.

      At the MS webpage, you download the .EXE that is an self-extracting compressed file. One you uncompress the file, it has instructions and various copies of the debug version of this DLL (version is dependent on the version of Internet explorer you are using). See the instructions on how to install the new DLL.

      Here is the MS download:


      You will probably need to boot in to safe mode to replace your Wininet.dll. I tried to do it on my machine, but I could not get in to safe mode (some bad hardware is giving me a blue-screen at boot time). Be sure to save away your original Wininet.dll so you can restore it later if needed.

      Once you have the debug version in place, you have to follow the instructions in the DLL that state to set an environment variable then launch WUHU from the command prompt. You will want to launch WUHU from within the C:\Program files\WUHU directory as this is where the log file will be created.

      After WUHU attempts to upload to WU, you will want to shut down WUHU and view the contents of the log file. This file should be created in the WUHU directory.

      If you are able to capture a log file that this debug version creates, send it off to my email address and I will have a look. Send to wuhu_software@...

      --- In wuhu_software_group@yahoogroups.com, "aurigarivervale" <jasona@...> wrote:
      > Current Status:
      > 1. No firewall software.
      > 2. Turned off router firewall just in case
      > 3. Restored winsock libraries
      > 4. Reinstalled tcp/ip
      > 5. uninstalled wuhu
      > 6. uninstalled heavy weather (verified it's v. 2.0 beta)
      > 7. signed-up for an AWEKAS account, verified those settings as well
      > 8. reinstalled just WUHU
      > 9. configured WUHU to use direct comport connection without reinstalling Heavy Weather
      > in case Heavy Weather was interfering.
      > Result:
      > Same problem. Though CWOP receives transmissions and I verified I can ping WU from the
      > PC in question (running winxp sp2), neither WU nor AWEKAS receive any data. I verified
      > WUHU is receiving data from the WS-2310 with no lost packets and CWOP similarly has no
      > lost packets either.
      > Question:
      > Does WUHU install any files in the Registry, Windows, or System32 folders that the
      > uninstaller might not clean out?
      > I'm baffled as to what's causing this. I have no other network problems save just this one.
      > It worked perfectly with an older version of WUHU until at one moment it just stopped. I
      > tried reviving through the same process as above but that failed so downloaded the latest
      > version of WUHU and went through the same process.
      > Thank you again for your help. I'm at a loss, particularly since I can ping WU without
      > problem. If you have any other ideas, particularly about left-behind files which may have
      > gotten corrupted, I shall be obliged.
      > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@>
      > wrote:
      > >
      > > Jason,
      > >
      > > I am not sure what to make of the problem.
      > >
      > > You might try enabling rapid-fire to see if that makes a difference.
      > >
      > > I am guessing that your ISP is unable to reach the WU server for
      > > whatever reason.
      > >
      > > Try opening a command prompt and ping the WU server.
      > >
      > > You should see something like this after you execute the ping:
      > >
      > > Microsoft Windows 2000 [Version 5.00.2195]
      > > (C) Copyright 1985-2000 Microsoft Corp.
      > >
      > > C:\>ping weatherstation.wunderground.com
      > >
      > > Pinging rtupdate.wunderground.com [] with 32 bytes of
      > > data:
      > >
      > > Reply from bytes=32 time=82ms TTL=47
      > > Reply from bytes=32 time=74ms TTL=47
      > > Reply from bytes=32 time=81ms TTL=47
      > > Reply from bytes=32 time=75ms TTL=47
      > >
      > > Ping statistics for
      > >     Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
      > > Approximate round trip times in milli-seconds:
      > >     Minimum = 74ms, Maximum =  82ms, Average =  78ms
      > >
      > > C:\>
      > >
      > > --- In wuhu_software_group@yahoogroups.com, "aurigarivervale"
      > > <jasona@> wrote:
      > > >
      > > > Hi all,
      > > >
      > > > WUHU cannot upload to Weather Underground. I uninstalled old WUHU,
      > > > installed the latest version, uninstalled/reinstalled Heavy Weather,
      > > > tried direct serial, tried file reading, went to WU and confirmed my
      > > > account name, password (replaced by me manually with asterisks), and
      > > > settings. Nothing works. I can reach CWOP, but Weather Underground
      > > > will not acknowledge.
      > > >
      > > > Thank you for your kind assistance!
      > > >
      > >

    Your message has been successfully submitted and would be delivered to recipients shortly.