Loading ...
Sorry, an error occurred while loading the content.

Re: Anyone else have a problem with COM port and XP?

Expand Messages
  • wuhu_software
    James, I have heard of others on the Internet that have experienced the same problem that you have. You are not alone. I would suspect that there is some type
    Message 1 of 3 , Mar 31 5:55 PM
    • 0 Attachment
      James,

      I have heard of others on the Internet that have experienced the
      same problem that you have. You are not alone.

      I would suspect that there is some type of resource conflict such
      as multiple devices attempting to be "com1", like modems or other
      devices.

      Another problem may be a shared IRQ conflict. If possible, do not
      share the com port IRQ with another device. If other devices are
      sharing the same IRQ, and they cannot be moved to other IRQs, try
      removing the device from the computer.

      Finally, another device may be using the I/O addresses used by com1.
      Make sure there are no I/O conflicts (especially with modems). See
      your BIOS settings to determine which addresses are used, see device
      manager devices for potential conflicts.

      If all attempt fail, I would try a different USB to serial device.
      I have used one made by IO Gear without difficulty.

      ----

      Here is a snippet from a page I found on the net:

      A) In most PCs, Com Ports can be enabled or disabled through the
      BIOS. If appropriate, confirm that the Com Ports are enabled.

      B) Com Port conflicts can arise when a Port's IRQ or I/O addresses
      are being shared by another device such as an internal modem, mouse,
      scanner, or other external peripheral. The standard IRQ and I/O
      address's are listed below:

      Com Port I/O address IRQ
      (8 bytes needed)
      ----------------------------------
      COM1 O3F8 4
      COM2 O2F8 3
      COM3 O3E8 4
      COM4 O2E8 3

      C) IRQ or I/O addresses can be changed via the following procedures:

      1)click on the ` START MENU `
      2) Select ` SETTINGS `
      3) Select ` CONTROL PANEL `
      4) Click on the ` SYSTEM ICON `
      5) Select the ` DEVICE MANAGER ` tab.
      6) Select ` PORTS (COM & LPT) `
      7) Select the appropriate Com Port.
      8) Click on ` PROPERTIES `
      9) Adjust the Port settings accordingly.
      10) Restart Windows

      D) If the above procedures yield no success and the Com Port seems to
      be set up properly and free of conflicts it may be necessary to
      disable FIFO buffers on your PC Com Port.

      1) click on the ` START MENU `
      2) Select ` SETTINGS `
      3) Select ` CONTROL PANEL `
      4) Click on the ` SYSTEM ICON `
      5) Select the ` DEVICE MANAGER ` tab.
      6) Select ` PORTS (COM & LPT) `
      7) Select the appropriate Com Port.
      8) Click on ` PROPERTIES `
      9) Select the ` PORT SETTINGS ` tab.
      10) Select ` ADVANCED `
      11) Uncheck the box titled ` USE FIFO BUFFERS `
      12) Restart Windows
    • Springer,James C.
      ... addressee(s) and may contain confidential and/or legally privileged information. If you are not the intended recipient of this message or if this message
      Message 2 of 3 , Apr 1, 2005
      • 0 Attachment
        > From: wuhu_software [mailto:wuhu_software@...]
        >
        > I would suspect that there is some type of resource conflict such
        > as multiple devices attempting to be "com1", like modems or other
        > devices.
        >
        > Another problem may be a shared IRQ conflict. If possible, do not
        > share the com port IRQ with another device. If other devices are
        > sharing the same IRQ, and they cannot be moved to other IRQs, try
        > removing the device from the computer.

        Thanks for your suggestions. I highly doubt it is a conflict though
        because I currently have no other devices on the COMs. Device Manager
        doesn't report a conflict either. But nonetheless I'll reverify this
        info.

        Also, I'll give the FIFO buffer mod a shot too. Frankly not too hopeful
        here either as I can talk to the weather station (with FIFO buffers on)
        but only after that manual uninstall of the com port and reboot.
        Definitely worth a shot though.

        Just as a reference, I thought Microsoft's knowledge base article
        #283063 had similarities to this problem, though not exactly (and it was
        Win2K, not XP). I did however try the registry change to no avail.

        I'll also have to look into that IO Gear USB/Serial you mentioned.

        Again, thanks for the input, I'll explore a little more.

        Jim

        E-MAIL CONFIDENTIALITY NOTICE: The contents of this e-mail message and any attachments are intended solely for the
        addressee(s) and may contain confidential and/or legally privileged information. If you are not the
        intended recipient of this message or if this message has been addressed to you in error, please
        immediately alert the sender by reply e-mail and then delete this message and any attachments. If you
        are not the intended recipient, you are notified that any use, dissemination, distribution, copying, or
        storage of this message or any attachment is strictly prohibited.
      Your message has been successfully submitted and would be delivered to recipients shortly.