Loading ...
Sorry, an error occurred while loading the content.

Re: [wuhu_software_group] Re: Why WUHU uploading 5 times in a row?

Expand Messages
  • H. Smith
    Your web server needs to return success to the http:// request sent to it. ________________________________ From: Rogo To:
    Message 1 of 37 , May 15, 2013
    • 0 Attachment
      Your web server needs to return "success" to the http:// request sent to it.


      From: Rogo <steve.rogowski@...>
      To: wuhu_software_group@yahoogroups.com
      Sent: Tuesday, May 14, 2013 10:03 PM
      Subject: [wuhu_software_group] Re: Why WUHU uploading 5 times in a row?

       
      So I posted a sample chart (T/Td/Humidity) to a new photo album called Rogo that needs to be approved by the moderator. I thought it was an excellent visual example of my data reliability issues with WUHU. The chart is created with live updates of a XML file that my action file converts from template and uploads via FTP each time an update is created by WUHU.

      The chart shows that data comes in every 3-8 seconds pretty reliably for a bit. Then, a long data lapse. Then data is available only every 30 seconds or so. I can attest that when this occurs, WUHU software is very unresponsive. I dont even chart in WUHU now, just the basic display. Try to move the display or open setup (etc) and it freezes.

      Anyway, this along with the php script updating 5 times per ob (below) are my current issues. Note, I commented out the php update in the action file until I get some further help so this is not contributing to my data update fluctuations.

      Thanks,
      Steve (Rogo)

      --- In wuhu_software_group@yahoogroups.com, "Rogo" <steve.rogowski@...> wrote:
      >
      > WUHU has been unresponsive (when operating) since I started ftping to my web server. It is fine when stopped. I see from the FTP log that it is actually uploading (successfully) every second or so, even though I see file updates on my server every 10-30 seconds. Should I adjust any settings to fix this?
      >
      > Here is my log file for the php file uploads...
      >
      > Tue May 14 09:18:57 2013 > WUHU monitoring started (WUHU216DAVISVP2).
      > Tue May 14 09:18:57 2013 > Weather Underground ID: KUTBOUNT14
      > Tue May 14 09:18:57 2013 > CWOP ID: EW2533
      > Tue May 14 09:18:59 2013 > Opened serial port COM4 successfully.
      > Tue May 14 09:19:04 2013 > Sending to Web Service: http://www.rogowx.org/wxstation/managedata.php?update=Tue%20May%2014%2009:19:04%20AM%202013&temp=70.3
      > Tue May 14 09:19:05 2013 > WebService Final Fatal Error (No more retries) Response:
      > Tue May 14 09:19:05 2013 > Web Service Upload has Failed.
      > Tue May 14 09:19:13 2013 > Sending to Web Service: http://www.rogowx.org/wxstation/managedata.php?update=Tue%20May%2014%2009:19:13%20AM%202013&temp=70.3
      > Tue May 14 09:19:14 2013 > WebService Final Fatal Error (No more retries) Response:
      > Tue May 14 09:19:14 2013 > Web Service Upload has Failed.
      > Tue May 14 09:19:46 2013 > Sending to Web Service: http://www.rogowx.org/wxstation/managedata.php?update=Tue%20May%2014%2009:19:46%20AM%202013&temp=70.4
      > Tue May 14 09:19:47 2013 > WebService Final Fatal Error (No more retries) Response:
      > Tue May 14 09:19:47 2013 > Web Service Upload has Failed.
      > Tue May 14 09:20:20 2013 > WUHU monitoring stopped.
      >
      > Thanks,
      > Steve (Rogo)
      >
      >
      > --- In wuhu_software_group@yahoogroups.com, "H. Smith" <wuhu_software@> wrote:
      > >
      > >
      > >
      > > WUHU is expecting the server to return "success".
      > >
      > > If you go to the log screen, un-check Errors Only, un-check everything expect for web service, you will see what is sent and the response from the server. Let me know what the response is. It might be an issue with case sensitivity where "success" is not the same as "Success".
      > >
      >



    • nwschi80
      RESOLVED!! (I think) WUHU has been running like a champ for the last 15 hours, on each Weather Update (yes I know, but I love data). I still write to both
      Message 37 of 37 , May 20, 2013
      • 0 Attachment
        RESOLVED!! (I think)

        WUHU has been running like a champ for the last 15 hours, on each Weather Update (yes I know, but I love data). I still write to both files, execute my original action file (plus more scripts now), and upload to WUnderground (including RapidFire) and CWOP.

        Control Panel (classic view)-->System-->Device Manager. Found My new driver for the COM port-->Properties-->Port Settings. I did the following 3 things at the same time...

        1) Increased Baud rate from 9600 to 128000
        2) Changed Flow Control to Hardware

        On the Power Management Tab...
        3) Unchecked allow cpu to turn off device to save power.

        That was it. WUHU has been humming ever since then.

        Thanks all for your help!!

        Steve
      Your message has been successfully submitted and would be delivered to recipients shortly.