Loading ...
Sorry, an error occurred while loading the content.

Re: [wuhu_software_group] Why WUHU uploading 5 times in a row?

Expand Messages
  • H. Smith
    WUHU is expecting the server to return success . If you go to the log screen, un-check Errors Only, un-check everything expect for web service, you will see
    Message 1 of 37 , May 14, 2013
    • 0 Attachment

      WUHU is expecting the server to return "success".

      If you go to the log screen, un-check Errors Only, un-check everything expect for web service, you will see what is sent and the response from the server. Let me know what the response is. It might be an issue with case sensitivity where "success" is not the same as "Success".


      From: Rogo <steve.rogowski@...>
      To: wuhu_software_group@yahoogroups.com
      Sent: Monday, May 13, 2013 11:41 PM
      Subject: [wuhu_software_group] Why WUHU uploading 5 times in a row?

       
      So I have an action file that activates On Weather Update. There are 3 actions in this file...

      template:"C:\Users\Steve\Desktop\WUHU\templates\data.txt" "C:\Users\Steve\Desktop\WUHU\HTML\data.xml"

      ftp://rogowxor:4daa0979@69.72.240.58 BINARY "C:\Users\Steve\Desktop\WUHU\HTML\data.xml" "\www\wxstation\data.xml"

      http://www.rogowx.org/wxstation/managedata.php?update=%[time2]time_12hr_verbose%&temp=%[outdoor_temperature]deg_F%

      The third item is a php file I wrote to dynamically create a XML file on my server, by appending the latest ob to a XML file. But in testing it, it runs 5 times per ob. I was expected once. I know this because I send the update time along with the observed temperature. Every ob it repeats 5 times! Its not my php code because when I run it from the browser sending dummy data it runs once. How can I make WUHU only execute this once per Weather Update??

      Thanks,
      Steve (Rogo)



    • nwschi80
      RESOLVED!! (I think) WUHU has been running like a champ for the last 15 hours, on each Weather Update (yes I know, but I love data). I still write to both
      Message 37 of 37 , May 20, 2013
      • 0 Attachment
        RESOLVED!! (I think)

        WUHU has been running like a champ for the last 15 hours, on each Weather Update (yes I know, but I love data). I still write to both files, execute my original action file (plus more scripts now), and upload to WUnderground (including RapidFire) and CWOP.

        Control Panel (classic view)-->System-->Device Manager. Found My new driver for the COM port-->Properties-->Port Settings. I did the following 3 things at the same time...

        1) Increased Baud rate from 9600 to 128000
        2) Changed Flow Control to Hardware

        On the Power Management Tab...
        3) Unchecked allow cpu to turn off device to save power.

        That was it. WUHU has been humming ever since then.

        Thanks all for your help!!

        Steve
      Your message has been successfully submitted and would be delivered to recipients shortly.