Loading ...
Sorry, an error occurred while loading the content.
 

Re: [wuhu_software_group] Re: Request for NOAA climate record feature

Expand Messages
  • Don Lafferty
    Well, you don t actually lose them. They just print on the 2nd page. But that s the main reason I made it default to using Landscape mode. It all fits if
    Message 1 of 103 , Apr 20 4:14 PM
      Well, you don't actually lose them.  They just print on the 2nd page.  But that's the main reason I made it default to using Landscape mode.  It all fits if you do.


      On Sat, Apr 20, 2013 at 4:04 PM, KNHBRIST1 <steve_03222@...> wrote:
       

      You do want to print landscape as you will loose on the 1st page the statistics at the bottom on Portrait

      --- In wuhu_software_group@yahoogroups.com, "KNHBRIST1" <steve_03222@...> wrote:
      >
      > Look great Don ! Interesting how you actually get more data when you print vs. review on the program screen. Totals now print bold...
      > Very nice job.
      > Steve
      >
      > --- In wuhu_software_group@yahoogroups.com, Don Lafferty <don@> wrote:
      > >
      > > I believe this has the majority of the desired functions for the Monthly
      > > report. Try it out and let me know what it's missing.
      > >
      > > http://donlafferty.com/NOAAReportMaker0009.zip
      > >
      > > Don
      > >
      > >
      > > On Fri, Apr 19, 2013 at 5:34 PM, Rogo <steve.rogowski@> wrote:
      > >
      > > > **
      > > >
      > > >
      > > > Don - I will also take a look at it early next week (working long hours
      > > > through Sunday).
      > > >
      > > > Thanks!
      > > > Steve
      > > >
      > > > --- In wuhu_software_group@yahoogroups.com, Don Lafferty <don@> wrote:
      > > > >
      > > > > Yes, there's basically no information on it other than the grid and a
      > > > > header and footer.
      > > > >
      > > > >
      > > > > On Fri, Apr 19, 2013 at 3:59 PM, KNHBRIST1 <steve_03222@> wrote:
      > > > >
      > > > > > **
      > > > > >
      > > > > >
      > > > > > Just noticed that no station information is on print out.I know you
      > > > just
      > > > > > put it together quickly but thought I would mention it.
      > > > > > Steve
      > > > > >
      > > > > > --- In wuhu_software_group@yahoogroups.com, Don Lafferty <don@> wrote:
      > > > > > >
      > > > > > > Yeah I put that together last night and didn't do any formatting of
      > > > the
      > > > > > > print. Just put it out to make sure it would work on other folks
      > > > > > machines.
      > > > > > >
      > > > > > >
      > > > > > >
      > > > > > >
      > > > > > > On Fri, Apr 19, 2013 at 2:34 PM, KNHBRIST1 <steve_03222@> wrote:
      > > > > > >
      > > > > > > > **
      > > > > > > >
      > > > > > > >
      > > > > > > > OK put everything on my new "Dons NOAA Program" folder and it works
      > > > > > slick.
      > > > > > > > I printed out 1 month with 31 days and it fit on page both
      > > > landscape
      > > > > > and
      > > > > > > > Portrait.
      > > > > > > > I like the way it does not print the zeros.
      > > > > > > > Only thing I noticed is that the "Bold" type at the column totals
      > > > did
      > > > > > not
      > > > > > > > print bold.
      > > > > > > > Nice job.
      > > > > > > >
      > > > > > > > Steve
      > > > > > > >
      > > > > > > > --- In wuhu_software_group@yahoogroups.com, "KNHBRIST1"
      > > > <steve_03222@>
      > > > > > > > wrote:
      > > > > > > > >
      > > > > > > > > Everything I have from you is in my "Dons Weather File" folder
      > > > except
      > > > > > > > for the .dat file.
      > > > > > > > > Oh wait I just copied the .exe file like the last time.
      > > > > > > > > I'll make a new folder and unzip to it.
      > > > > > > > > Wil be a bot
      > > > > > > > > Steve
      > > > > > > > >
      > > > > > > > > --- In wuhu_software_group@yahoogroups.com, Don Lafferty <don@>
      > > > > > wrote:
      > > > > > > > > >
      > > > > > > > > > Steve,
      > > > > > > > > >
      > > > > > > > > > You do need to have those DLL files in the same folder as the
      > > > > > program.
      > > > > > > > If
      > > > > > > > > > you did then I'll have to check some other things.
      > > > > > > > > >
      > > > > > > > > > Don
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > > > On Fri, Apr 19, 2013 at 4:20 AM, KNHBRIST1 <steve_03222@>
      > > > wrote:
      > > > > > > > > >
      > > > > > > > > > > **
      > > > > > > > > > >
      > > > > > > > > > >
      > > > > > > > > > > Don, I tried it quick this morning, have to head to work.
      > > > > > > > > > > But I could not print, I tried to capture the detail section
      > > > of
      > > > > > the
      > > > > > > > error
      > > > > > > > > > > message.
      > > > > > > > > > > I was able to get to set up page, but can not print.
      > > > > > > > > > > I can check it out again when I get home if you want.
      > > > > > > > > > >
      > > > > > > > > > > Steve
      > > > > > > > > > >
      > > > > > > > > > > See the end of this message for details on invoking
      > > > > > > > > > > just-in-time (JIT) debugging instead of this dialog box.
      > > > > > > > > > >
      > > > > > > > > > > ************** Exception Text **************
      > > > > > > > > > > System.BadImageFormatException: Could not load file or
      > > > assembly
      > > > > > > > > > > 'MigraDoc.Rendering, Version=1.32.3885.0, Culture=neutral,
      > > > > > > > > > > PublicKeyToken=f94615aa0424f9eb' or one of its dependencies.
      > > > The
      > > > > > > > module was
      > > > > > > > > > > expected to contain an assembly manifest.
      > > > > > > > > > > File name: 'MigraDoc.Rendering, Version=1.32.3885.0,
      > > > > > Culture=neutral,
      > > > > > > > > > > PublicKeyToken=f94615aa0424f9eb'
      > > > > > > > > > > at
      > > > > > > > > > >
      > > > > > > >
      > > > > >
      > > > NOAA_Report_Maker.Form1.PrintPreviewActiveMonthToolStripMenuItem_Click(Object
      > > > > > > > > > > sender, EventArgs e)
      > > > > > > > > > > at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key,
      > > > > > > > EventArgs e)
      > > > > > > > > > > at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs
      > > > e)
      > > > > > > > > > > at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs
      > > > e)
      > > > > > > > > > > at
      > > > > > System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)
      > > > > > > > > > > at
      > > > > > System.Windows.Forms.ToolStripItem.FireEventInteractive(EventArgs
      > > > > > > > e,
      > > > > > > > > > > ToolStripItemEventType met)
      > > > > > > > > > > at System.Windows.Forms.ToolStripItem.FireEvent(EventArgs e,
      > > > > > > > > > > ToolStripItemEventType met)
      > > > > > > > > > > at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs
      > > > mea)
      > > > > > > > > > > at
      > > > > > System.Windows.Forms.ToolStripDropDown.OnMouseUp(MouseEventArgs
      > > > > > > > mea)
      > > > > > > > > > > at System.Windows.Forms.Control.WmMouseUp(Message& m,
      > > > > > MouseButtons
      > > > > > > > button,
      > > > > > > > > > > Int32 clicks)
      > > > > > > > > > > at System.Windows.Forms.Control.WndProc(Message& m)
      > > > > > > > > > > at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
      > > > > > > > > > > at System.Windows.Forms.ToolStrip.WndProc(Message& m)
      > > > > > > > > > > at System.Windows.Forms.ToolStripDropDown.WndProc(Message& m)
      > > > > > > > > > > at
      > > > > > > >
      > > > System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
      > > > > > > > > > > at
      > > > > > System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message&
      > > > > > > > m)
      > > > > > > > > > > at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd,
      > > > Int32
      > > > > > msg,
      > > > > > > > > > > IntPtr wparam, IntPtr lparam)
      > > > > > > > > > >
      > > > > > > > > > > WRN: Assembly binding logging is turned OFF.
      > > > > > > > > > > To enable assembly bind failure logging, set the registry
      > > > value
      > > > > > > > > > > [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
      > > > > > > > > > > Note: There is some performance penalty associated with
      > > > assembly
      > > > > > bind
      > > > > > > > > > > failur
      > > > > > > > > > >
      > > > > > > > > > > --- In wuhu_software_group@yahoogroups.com, Don Lafferty
      > > > <don@>
      > > > > > > > wrote:
      > > > > > > > > > > >
      > > > > > > > > > > > If anyone wants to try it out I've got printing working (I
      > > > > > think,
      > > > > > > > my
      > > > > > > > > > > > printer is broken).
      > > > > > > > > > > >
      > > > > > > > > > > > You probably should set it to Landscape.
      > > > > > > > > > > >
      > > > > > > > > > > > You won't see the option to print or print preview until
      > > > you
      > > > > > > > create a
      > > > > > > > > > > month
      > > > > > > > > > > > to print and then switch to that month.
      > > > > > > > > > > >
      > > > > > > > > > > > If anyone tries it out let me know if it works for you.
      > > > This is
      > > > > > > > also how
      > > > > > > > > > > > it will look when I make it so you can save a PDF (but
      > > > that's
      > > > > > not
      > > > > > > > done
      > > > > > > > > > > yet
      > > > > > > > > > > > either).
      > > > > > > > > > > >
      > > > > > > > > > > > http://donlafferty.com/NOAAReportMaker0008.zip
      > > > > > > > > > > >
      > > > > > > > > > > > Don
      > > > > > > > > > > >
      > > > > > > > > > > > On Sun, Apr 14, 2013 at 7:00 PM, Don Lafferty <don@>
      > > > wrote:
      > > > > > > > > > > >
      > > > > > > > > > > > > Last update this weekend.
      > > > > > > > > > > > >
      > > > > > > > > > > > > http://donlafferty.com/NOAAReportMaker0007.zip
      > > > > > > > > > > > >
      > > > > > > > > > > > > Don
      > > > > > > > > > > > >
      > > > > > > > > > > > >
      > > > > > > > > > > > > On Sun, Apr 14, 2013 at 6:07 PM, Rogo <steve.rogowski@>
      > > > > > wrote:
      > > > > > > > > > > > >
      > > > > > > > > > > > >> **
      > > > > > > > > > > > >>
      > > > > > > > > > > > >>
      > > > > > > > > > > > >> Don,
      > > > > > > > > > > > >>
      > > > > > > > > > > > >> Makes sense.
      > > > > > > > > > > > >>
      > > > > > > > > > > > >> Steve
      > > > > > > > > > > > >>
      > > > > > > > > > > > >> --- In wuhu_software_group@yahoogroups.com, Don
      > > > Lafferty
      > > > > > <don@>
      > > > > > > > > > > wrote:
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> > The error on Jan/Mar is due to me not counting the
      > > > last
      > > > > > day
      > > > > > > > of the
      > > > > > > > > > > > >> month.
      > > > > > > > > > > > >> > I'll fix it in the next version.
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> > As for the red 0 that denotes the station was reset on
      > > > > > that
      > > > > > > > day.
      > > > > > > > > > > I'm not
      > > > > > > > > > > > >> > quite sure how to handle when that happens. I can
      > > > probably
      > > > > > > > come up
      > > > > > > > > > > with
      > > > > > > > > > > > >> > the logic needed but it's low on my priority since
      > > > most
      > > > > > > > people only
      > > > > > > > > > > > >> reset
      > > > > > > > > > > > >> > once a year.
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> > On Sun, Apr 14, 2013 at 5:57 PM, Don Lafferty <don@>
      > > > > > wrote:
      > > > > > > > > > > > >> >
      > > > > > > > > > > > >> > > The name fits fine in the new version. It was length
      > > > > > even
      > > > > > > > though
      > > > > > > > > > > it
      > > > > > > > > > > > >> shows
      > > > > > > > > > > > >> > > in the front box just fine.
      > > > > > > > > > > > >> > >
      > > > > > > > > > > > >> > > http://donlafferty.com/NOAAReportMaker0006.zip
      > > > > > > > > > > > >> > >
      > > > > > > > > > > > >> > >
      > > > > > > > > > > > >> > >
      > > > > > > > > > > > >> > >
      > > > > > > > > > > > >> > > On Sun, Apr 14, 2013 at 5:06 PM, Rogo
      > > > <steve.rogowski@>
      > > > > > > > wrote:
      > > > > > > > > > > > >> > >
      > > > > > > > > > > > >> > >> **
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >> Don,
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >> I have had mixed success.
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >> I have not been able to get "EW2533_KUTBOUNT14" to
      > > > work
      > > > > > > > (doesnt
      > > > > > > > > > > > >> appear to
      > > > > > > > > > > > >> > >> be length either).
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >> Thanks for the file.
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >> Steve
      > > > > > > > > > > > >> > >>
      > > > > > > > > > > > >> > >> --- In wuhu_software_group@yahoogroups.com, Don
      > > > > > Lafferty
      > > > > > > > <don@>
      > > > > > > > > > > > >> wrote:
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > You should be able to use any character you want
      > > > on
      > > > > > the
      > > > > > > > name (I
      > > > > > > > > > > > >> > >> believe).
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > http://screencast.com/t/IU5dYDyh
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > I've put a file with a few months at:
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > http://donlafferty.com/2013HWPHistory.zip
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > Don
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > On Sun, Apr 14, 2013 at 3:23 PM, Rogo
      > > > > > <steve.rogowski@>
      > > > > > > > wrote:
      > > > > > > > > > > > >> > >> >
      > > > > > > > > > > > >> > >> > > **
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > > Don,
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > > Looking good. Only issue I had was assigning a
      > > > > > station
      > > > > > > > name
      > > > > > > > > > > with
      > > > > > > > > > > > >> a
      > > > > > > > > > > > >> > >> special
      > > > > > > > > > > > >> > >> > > character _,:,(, etc would yield a blank name
      > > > on
      > > > > > the
      > > > > > > > report.
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > > Otherwise coming together nicely!
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > > Could someone post their .dat file so I can
      > > > use it
      > > > > > in
      > > > > > > > my
      > > > > > > > > > > testing?
      > > > > > > > > > > > >> > >> Mine is
      > > > > > > > > > > > >> > >> > > only 3 days long.
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > > Thanks,
      > > > > > > > > > > > >> > >> > > Steve
      > > > > > > > > > > > >> > >> > >
      > > > > > > > > > > > >> > >> > > --- In wuhu_software_group@yahoogroups.com,
      > > > Don
      > > > > > > > Lafferty
      > > > > > > > > > > <don@>
      > > > > > > > > > > > >> > >> wrote:
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > > There is a new version with a few more bells
      > > > and
      > > > > > > > whistles.
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > >
      > > > http://donlafferty.com/NOAAReportMaker0005.zip
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > > On Sun, Apr 7, 2013 at 7:02 PM, KNHBRIST1
      > > > > > > > <steve_03222@>
      > > > > > > > > > > > >> wrote:
      > > > > > > > > > > > >> > >> > > >
      > > > > > > > > > > > >> > >> > > > > **
      > > > > > > > > > > > >> > >> > > > >
      > > > > > > > > > > > >> > >> > > > >
      > > > > > > > > > > > >> > >> > > > > A quick look and it looks great, I did
      > > > notice
      > > > > > the
      > > > > > > > red
      > > > > > > > > > > zeros
      > > > > > > > > > > > >> > >> indicating
      > > > > > > > > > > > >> > >> > > a
      > > > > > > > > > > > >> > >> > > > > console reset.
      > > > > > > > > > > > >> > >> > > > > Shutting down for the night will check
      > > > back in
      > > > > > > > when I get
      > > > > > > > > > > > >> home
      > > > > > > > > > > > >> > >> from
      > > > > > > > > > > > >> > >> > > work
      > > > > > > > > > > > >> > >> > > > > tomorrow night.
      > > > > > > > > > > > >> > >> > > > > Thanks for all you do for us Don.
      > > > > > > > > > > > >> > >> > > > > Steve
      > > > > > > > > > > > >> > >> > > > >
      > > > > > > > > > > > >> > >> > > > > --- In wuhu_software_group@yahoogroups.com
      > > > ,
      > > > > > Don
      > > > > > > > Lafferty
      > > > > > > > > > > > >> <don@>
      > > > > > > > > > > > >> > >> wrote:
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > Okay I think I've got all the bugs we
      > > > found.
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > http://donlafferty.com/NOAAReportMaker0003.zip
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > Once I'm (fairly) sure of that I'll start
      > > > > > adding
      > > > > > > > some
      > > > > > > > > > > of
      > > > > > > > > > > > >> the
      > > > > > > > > > > > >> > >> fluff it
      > > > > > > > > > > > >> > >> > > > > needs
      > > > > > > > > > > > >> > >> > > > > > and I'll look at doing the yearly report.
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > I can also look at importing the CSV
      > > > files
      > > > > > John
      > > > > > > > posted
      > > > > > > > > > > the
      > > > > > > > > > > > >> link
      > > > > > > > > > > > >> > >> too.
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > I found a file in my archive that is
      > > > about 4
      > > > > > > > years
      > > > > > > > > > > long.
      > > > > > > > > > > > >> It's
      > > > > > > > > > > > >> > >> almost
      > > > > > > > > > > > >> > >> > > 1 GB
      > > > > > > > > > > > >> > >> > > > > > in size.
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > Don
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > On Sun, Apr 7, 2013 at 5:03 PM, Don
      > > > Lafferty
      > > > > > > > <don@>
      > > > > > > > > > > wrote:
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > > Yes I've noticed that on a few files.
      > > > It's
      > > > > > > > obviously
      > > > > > > > > > > a
      > > > > > > > > > > > >> bug in
      > > > > > > > > > > > >> > >> the
      > > > > > > > > > > > >> > >> > > code.
      > > > > > > > > > > > >> > >> > > > > > > I'll take a look and see what's doing
      > > > it.
      > > > > > > > > > > > >> > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > > On Sun, Apr 7, 2013 at 4:56 PM,
      > > > KNHBRIST1
      > > > > > > > > > > <steve_03222@>
      > > > > > > > > > > > >> > >> wrote:
      > > > > > > > > > > > >> > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> **
      > > > > > > > > > > > >> > >> > > > > > >>
      > > > > > > > > > > > >> > >> > > > > > >>
      > > > > > > > > > > > >> > >> > > > > > >> Don, also of note is that it shows May
      > > > > > 2013
      > > > > > > > and
      > > > > > > > > > > when I
      > > > > > > > > > > > >> open
      > > > > > > > > > > > >> > >> May it
      > > > > > > > > > > > >> > >> > > > > shows
      > > > > > > > > > > > >> > >> > > > > > >> one entry with various symbols.
      > > > > > > > > > > > >> > >> > > > > > >> Steve
      > > > > > > > > > > > >> > >> > > > > > >>
      > > > > > > > > > > > >> > >> > > > > > >>
      > > > > > > > > > > > >> > >> > > > > > >> --- In
      > > > > > wuhu_software_group@yahoogroups.com,
      > > > > > > > > > > "KNHBRIST1"
      > > > > > > > > > > > >> > >> > > <steve_03222@
      > > > > > > > > > > > >> > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> wrote:
      > > > > > > > > > > > >> > >> > > > > > >> >
      > > > > > > > > > > > >> > >> > > > > > >> > Great,Let me know if I can any more
      > > > > > testing.
      > > > > > > > > > > > >> > >> > > > > > >> >
      > > > > > > > > > > > >> > >> > > > > > >> > Steve
      > > > > > > > > > > > >> > >> > > > > > >> >
      > > > > > > > > > > > >> > >> > > > > > >> > --- In
      > > > > > wuhu_software_group@yahoogroups.com,
      > > > > > > > Don
      > > > > > > > > > > > >> Lafferty
      > > > > > > > > > > > >> > >> <don@>
      > > > > > > > > > > > >> > >> > > > > wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > >
      > > > > > > > > > > > >> > >> > > > > > >> > > Yeah I didn't see any recorded on
      > > > your
      > > > > > > > page so I
      > > > > > > > > > > > >> figured
      > > > > > > > > > > > >> > >> that
      > > > > > > > > > > > >> > >> > > was
      > > > > > > > > > > > >> > >> > > > > the
      > > > > > > > > > > > >> > >> > > > > > >> case.
      > > > > > > > > > > > >> > >> > > > > > >> > >
      > > > > > > > > > > > >> > >> > > > > > >> > > I added logic to ignore if
      > > > rainfall
      > > > > > has
      > > > > > > > been
      > > > > > > > > > > reset
      > > > > > > > > > > > >> but I
      > > > > > > > > > > > >> > >> also
      > > > > > > > > > > > >> > >> > > make
      > > > > > > > > > > > >> > >> > > > > > >> the cell
      > > > > > > > > > > > >> > >> > > > > > >> > > have a red letter.
      > > > > > > > > > > > >> > >> > > > > > >> > >
      > > > > > > > > > > > >> > >> > > > > > >> > >
      > > > > > > > > > > > >> > >> > > > > > >> > > On Sun, Apr 7, 2013 at 3:24 PM,
      > > > > > KNHBRIST1
      > > > > > > > > > > > >> <steve_03222@>
      > > > > > > > > > > > >> > >> > > wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > **
      > > > > > > > > > > > >> > >> > > > > > >> > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > No rain days in February here,
      > > > only
      > > > > > > > snow and
      > > > > > > > > > > I do
      > > > > > > > > > > > >> not
      > > > > > > > > > > > >> > >> have a
      > > > > > > > > > > > >> > >> > > > > heater
      > > > > > > > > > > > >> > >> > > > > > >> on my
      > > > > > > > > > > > >> > >> > > > > > >> > > > LaCrosse rain gauge. It is
      > > > possible
      > > > > > > > that I
      > > > > > > > > > > reset
      > > > > > > > > > > > >> at
      > > > > > > > > > > > >> > >> that
      > > > > > > > > > > > >> > >> > > time
      > > > > > > > > > > > >> > >> > > > > as I
      > > > > > > > > > > > >> > >> > > > > > >> did have
      > > > > > > > > > > > >> > >> > > > > > >> > > > rain in January. I keep it
      > > > covered
      > > > > > when
      > > > > > > > > > > snowing. I
      > > > > > > > > > > > >> > >> reset
      > > > > > > > > > > > >> > >> > > each
      > > > > > > > > > > > >> > >> > > > > > >> month, not
      > > > > > > > > > > > >> > >> > > > > > >> > > > always on th e1st although I
      > > > > > try...LOL
      > > > > > > > > > > > >> > >> > > > > > >> > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > Steve
      > > > > > > > > > > > >> > >> > > > > > >> > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > --- In
      > > > > > > > wuhu_software_group@yahoogroups.com,
      > > > > > > > > > > Don
      > > > > > > > > > > > >> > >> Lafferty
      > > > > > > > > > > > >> > >> > > <don@>
      > > > > > > > > > > > >> > >> > > > > > >> wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > Yes my earlier logic stopped
      > > > > > looking
      > > > > > > > once it
      > > > > > > > > > > > >> saw a 0
      > > > > > > > > > > > >> > >> in
      > > > > > > > > > > > >> > >> > > the
      > > > > > > > > > > > >> > >> > > > > > >> month. The
      > > > > > > > > > > > >> > >> > > > > > >> > > > new
      > > > > > > > > > > > >> > >> > > > > > >> > > > > logic just keeps looking but
      > > > > > ignores
      > > > > > > > records
      > > > > > > > > > > > >> with a
      > > > > > > > > > > > >> > >> > > timedate
      > > > > > > > > > > > >> > >> > > > > > >> stamp of 0.
      > > > > > > > > > > > >> > >> > > > > > >> > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > I also see the Rain in Feb is
      > > > > > messed
      > > > > > > > up.
      > > > > > > > > > > That's
      > > > > > > > > > > > >> kind
      > > > > > > > > > > > >> > >> of
      > > > > > > > > > > > >> > >> > > odd in
      > > > > > > > > > > > >> > >> > > > > > >> that you
      > > > > > > > > > > > >> > >> > > > > > >> > > > > didn't have any measured
      > > > > > > > precipitation in
      > > > > > > > > > > Feb
      > > > > > > > > > > > >> when I
      > > > > > > > > > > > >> > >> look
      > > > > > > > > > > > >> > >> > > at
      > > > > > > > > > > > >> > >> > > > > your
      > > > > > > > > > > > >> > >> > > > > > >> > > > > Wunderground page. Did you
      > > > > > possibly
      > > > > > > > reset
      > > > > > > > > > > the
      > > > > > > > > > > > >> rain
      > > > > > > > > > > > >> > >> total
      > > > > > > > > > > > >> > >> > > > > around
      > > > > > > > > > > > >> > >> > > > > > >> Feb 4th
      > > > > > > > > > > > >> > >> > > > > > >> > > > or
      > > > > > > > > > > > >> > >> > > > > > >> > > > > 5th?
      > > > > > > > > > > > >> > >> > > > > > >> > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > On Sun, Apr 7, 2013 at 3:09
      > > > PM,
      > > > > > > > KNHBRIST1
      > > > > > > > > > > > >> > >> <steve_03222@>
      > > > > > > > > > > > >> > >> > > > > wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > **
      > > > > > > > > > > > >> > >> > > > > > >> > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > Don, That work fine. Not
      > > > sure
      > > > > > what
      > > > > > > > is
      > > > > > > > > > > going on
      > > > > > > > > > > > >> > >> though
      > > > > > > > > > > > >> > >> > > the #
      > > > > > > > > > > > >> > >> > > > > > >> rtecords on
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > the days that were missing
      > > > > > before
      > > > > > > > are in
      > > > > > > > > > > th
      > > > > > > > > > > > >> > >> e9,000's
      > > > > > > > > > > > >> > >> > > only
      > > > > > > > > > > > >> > >> > > > > one
      > > > > > > > > > > > >> > >> > > > > > >> was in
      > > > > > > > > > > > >> > >> > > > > > >> > > > the
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > 8,000's
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > Shows all days now and no
      > > > 30th
      > > > > > of
      > > > > > > > FEB
      > > > > > > > > > > > >> > >> > > > > > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > Steve
      > > > > > > > > > > > >> > >> > > > > > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > --- In
      > > > > > > > > > > wuhu_software_group@yahoogroups.com,
      > > > > > > > > > > > >> Don
      > > > > > > > > > > > >> > >> > > Lafferty
      > > > > > > > > > > > >> > >> > > > > <don@>
      > > > > > > > > > > > >> > >> > > > > > >> wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > I don't understand why
      > > > there
      > > > > > are
      > > > > > > > bad
      > > > > > > > > > > points
      > > > > > > > > > > > >> but
      > > > > > > > > > > > >> > >> maybe
      > > > > > > > > > > > >> > >> > > > > Heath
      > > > > > > > > > > > >> > >> > > > > > >> can shed
      > > > > > > > > > > > >> > >> > > > > > >> > > > some
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > light on it.
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > At any rate I've made some
      > > > > > > > changes.
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> http://donlafferty.com/NOAAReportMaker0002.zip
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > If you right click on any
      > > > of
      > > > > > the
      > > > > > > > monthly
      > > > > > > > > > > > >> reports
      > > > > > > > > > > > >> > >> you
      > > > > > > > > > > > >> > >> > > have
      > > > > > > > > > > > >> > >> > > > > a
      > > > > > > > > > > > >> > >> > > > > > >> choice to
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > remove the selected tab or
      > > > > > show a
      > > > > > > > column
      > > > > > > > > > > > >> that
      > > > > > > > > > > > >> > >> has a
      > > > > > > > > > > > >> > >> > > count
      > > > > > > > > > > > >> > >> > > > > of
      > > > > > > > > > > > >> > >> > > > > > >> the
      > > > > > > > > > > > >> > >> > > > > > >> > > > records
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > in
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > a given measurement. On
      > > > your
      > > > > > file
      > > > > > > > they
      > > > > > > > > > > were
      > > > > > > > > > > > >> > >> typically
      > > > > > > > > > > > >> > >> > > a
      > > > > > > > > > > > >> > >> > > > > bit
      > > > > > > > > > > > >> > >> > > > > > >> over 9000
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > measurements per day. If
      > > > you
      > > > > > have
      > > > > > > > a day
      > > > > > > > > > > > >> that has
      > > > > > > > > > > > >> > >> a
      > > > > > > > > > > > >> > >> > > small
      > > > > > > > > > > > >> > >> > > > > > >> amount of
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > measurements in the record
      > > > > > it's
      > > > > > > > probably
      > > > > > > > > > > > >> not a
      > > > > > > > > > > > >> > >> > > reliable
      > > > > > > > > > > > >> > >> > > > > > >> record.
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > I only included the actual
      > > > > > > > program file
      > > > > > > > > > > in
      > > > > > > > > > > > >> this
      > > > > > > > > > > > >> > >> one.
      > > > > > > > > > > > >> > >> > > Just
      > > > > > > > > > > > >> > >> > > > > > >> copy over
      > > > > > > > > > > > >> > >> > > > > > >> > > > the
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > other one.
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > Don
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > On Sun, Apr 7, 2013 at
      > > > 2:18
      > > > > > PM,
      > > > > > > > > > > KNHBRIST1
      > > > > > > > > > > > >> > >> > > <steve_03222@>
      > > > > > > > > > > > >> > >> > > > > > >> wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > **
      > > > > > > > > > > > >> > >> > > > > > >> > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > I wonder why it has bad
      > > > > > > > datapoints?
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > I don;t touch it at all,
      > > > > > just
      > > > > > > > have
      > > > > > > > > > > WUHU
      > > > > > > > > > > > >> > >> generate the
      > > > > > > > > > > > >> > >> > > > > file.
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > Steve
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > --- In
      > > > > > > > > > > > >> wuhu_software_group@yahoogroups.com,
      > > > > > > > > > > > >> > >> Don
      > > > > > > > > > > > >> > >> > > > > Lafferty
      > > > > > > > > > > > >> > >> > > > > > >> <don@>
      > > > > > > > > > > > >> > >> > > > > > >> > > > wrote:
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > >
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > > I got it and it's
      > > > helping
      > > > > > a
      > > > > > > > lot. The
      > > > > > > > > > > > >> file
      > > > > > > > > > > > >> > >> has some
      > > > > > > > > > > > >> > >> > > > > date
      > > > > > > > > > > > >> > >> > > > > > >> entries
      > > > > > > > > > > > >> > >> > > > > > >> > > > that
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > are
      > > > > > > > > > > > >> > >> > > > > > >> > > > > > > > > basically = 0 so I've

      (Message over 64 KB, truncated)

    • Steve Rogowski
      Probably. But I was able to grab them from version 9. Now printing works well. Thanks, Steve
      Message 103 of 103 , May 12, 2013
        Probably. But I was able to grab them from version 9. Now printing works well.

        Thanks,
        Steve


        On Sun, May 12, 2013 at 5:05 PM, Don Lafferty <don@...> wrote:
         

        Yes you need the files that were in the earlier versions.  Perhaps I should include them each time?


        On Sun, May 12, 2013 at 3:22 PM, Steve Rogowski <steve.rogowski@...> wrote:
         

        Don,

        Nice! It picked up data for both April and May now.

        I especially appreciate being able to edit the data before generating the webpage. I had a day with bad rainfall data and was able to correct it and the monthly total in your GUI. The only figure I could not correct was the max daily rainfall calculated at the bottom.

        I was unable to print, I don't know if that feature was supposed to work in this version. Got an error when attempting print preview and print...perhaps I am just missing some files?

        Thanks,
        Steve



        On Sun, May 12, 2013 at 12:39 PM, Don Lafferty <don@...> wrote:
         

        There's a new version that has the changes to the columns suggested by Steve (Rogo) and a decent web page maker.  If you use the web page then make sure you put the noaastyle.css in the same folder as you put the html file.  You can change lots of things using the CSS file.


        Don




        --
        The day Microsoft starts making vacuum cleaners is the day they start making something that doesn't suck.


      Your message has been successfully submitted and would be delivered to recipients shortly.