Loading ...
Sorry, an error occurred while loading the content.

Re: History Retrieval Not Working

Expand Messages
  • wuhu_software
    The only fix is to detect it and declare a history read error. I was considering adding some retry logic but I have not done that yet.
    Message 1 of 15 , Apr 13, 2013
    • 0 Attachment
      The only fix is to detect it and declare a history read error.

      I was considering adding some retry logic but I have not done that yet.


      --- In wuhu_software_group@yahoogroups.com, "Eternal Danation" <weatherbear@...> wrote:
      >
      > Heath, still getting that "-1 new archive records retrieved from console" remark with one of my wuhus. Did you say you had a fix for that available?
      >
      > Thanx, Dan
      >
      >
      >
      > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
      > >
      > >
      > > Yes although I have not yet uploaded that minor tweak yet.
      > >
      > >
      > > --- In wuhu_software_group@yahoogroups.com, "Eternal Danation" <weatherbear@> wrote:
      > > >
      > > > Nah, I wait for one to load before starting the other. :D Do I go to the usual WUHU software page to get the latest update?
      > > >
      > > > db
      > > >
      > > >
      > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
      > > > >
      > > > >
      > > > > Interesting... Are you starting them at the same time?
      > > > >
      > > > > Maybe introduce a small delay, perhaps with a batch file to let one load up and complete the retrieval process before starting the next?
      > > > >
      > > > > Let me know if you see this again.
      > > > >
      > > > >
      > > > > --- In wuhu_software_group@yahoogroups.com, "Eternal Danation" <weatherbear@> wrote:
      > > > > >
      > > > > > Thanks, I'll see if that works. I don't have them load on reboot, mainly because of the problem of com ports changing all the time. So, the computer was settled at the time when I manually started WUHU.
      > > > > >
      > > > > > Dan
      > > > > >
      > > > > >
      > > > > >
      > > > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
      > > > > > >
      > > > > > >
      > > > > > > Here is the function that failed. It returned a -1 that is not documented. I have added code to report this as a retrieval failure in the next version.
      > > > > > >
      > > > > > > ---
      > > > > > >
      > > > > > > int DownloadData_V(DateTimeStamp dateTimeStamp)
      > > > > > >
      > > > > > > Description
      > > > > > >
      > > > > > > Starts the download of the archive data, after the date-time passed. Returns the number of records transferred.
      > > > > > >
      > > > > > > Parameter
      > > > > > >
      > > > > > > dateTimeStamp contains the time stamp after which you are interested to download the records.
      > > > > > >
      > > > > > > Return Values
      > > > > > >
      > > > > > > COM_ERROR if an error occurs.
      > > > > > > 0 if no new records to download.
      > > > > > > # of records transferred, if successful.
      > > > > > >
      > > > > > > ---
      > > > > > >
      > > > > > > Perhaps you need to add a boot up delay, for your machine to settle down before attempting to talk to the console. There is an INI setting for that. I would try say make a delay of 2-5 minutes to let the machine settle down on boot.
      > > > > > >
      > > > > > >
      > > > > > > --- In wuhu_software_group@yahoogroups.com, "Eternal Danation" <weatherbear@> wrote:
      > > > > > > >
      > > > > > > > Yep, the other one worked as it should.
      > > > > > > >
      > > > > > > > db
      > > > > > > >
      > > > > > > >
      > > > > > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > Dan,
      > > > > > > > >
      > > > > > > > > That is odd, the -1 records read is a clue. I will take a look at the source.
      > > > > > > > >
      > > > > > > > > It looks like the other one worked fine?
      > > > > > > > >
      > > > > > > > > Thanks.
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > --- In wuhu_software_group@yahoogroups.com, "Eternal Danation" <weatherbear@> wrote:
      > > > > > > > > >
      > > > > > > > > > Hey Heath, something odd is going on with one of my Vue's. As you may know, I run 2 vantage vue's on the same Windows 7 PC. Anyway, I forgot to start the stations before going to bed last night. When I started them this morning I noticed only one of them was able to retrieve the history. I've noticed this before, but I usually run them pretty much 24/7 so I rarely need to get the history. Anyway, here is a copy of the logs with the applicable messages. As you can see, the first one shows -1 records retrieved, while the other station worked fine and shows 2559 records retrieved. Both stations and versions of software are identical.
      > > > > > > > > >
      > > > > > > > > > Any ideas?
      > > > > > > > > >
      > > > > > > > > > Thanx, Dan
      > > > > > > > > >
      > > > > > > > > > Fri Mar 29 08:56:01 2013 > WUHU Application Started (1,0,216,210)
      > > > > > > > > > Fri Mar 29 08:56:02 2013 > WUHU monitoring started (WUHU216DAVISVP2).
      > > > > > > > > > Fri Mar 29 08:56:02 2013 > Weather Underground ID: KUTSOUTH3
      > > > > > > > > > Fri Mar 29 08:56:02 2013 > WeatherBug ID: p07129
      > > > > > > > > > Fri Mar 29 08:56:02 2013 > PWSWeather ID: SOGDENUT
      > > > > > > > > > Fri Mar 29 08:56:02 2013 > CWOP ID: CW5505
      > > > > > > > > > Fri Mar 29 08:56:05 2013 > Opened serial port COM6 successfully.
      > > > > > > > > > Fri Mar 29 08:56:17 2013 > Proceeding to history retrieval immediately.
      > > > > > > > > > Fri Mar 29 08:56:17 2013 > Clock sync. enabled. Waiting for console's minute time to change to accurately determine clock time. Please wait.
      > > > > > > > > > Fri Mar 29 08:56:33 2013 > Detected console clock minute marker, continuing to analyze.
      > > > > > > > > > Fri Mar 29 08:56:33 2013 > The PC clock and console clock are set to within 45 seconds of one another (Measured Drift <= 33 seconds).
      > > > > > > > > > Fri Mar 29 08:56:39 2013 > Current Absolute Pressure = 25.45, Relative Pressure = 30.16, Calculated Offset 4.71.
      > > > > > > > > > Fri Mar 29 08:56:39 2013 > Current Rain Total at start of retrieval = 0.00 IN, 0.00 MM.
      > > > > > > > > > Fri Mar 29 08:56:58 2013 > -1 new archive records were retrieved from console.
      > > > > > > > > > Fri Mar 29 08:56:58 2013 > Console history read completed succesfully. 0 records were collected. 0 records were stored. 0 records were uploaded to Weather Underground, 0 records were uploaded to PWSWeather, 0 records were uploaded to WeatherBug.
      > > > > > > > > > Fri Mar 29 08:57:01 2013 > Console Battery Voltage: 4.75
      > > > > > > > > > Fri Mar 29 08:57:01 2013 > All transmitter batteries are Ok.
      > > > > > > > > > Fri Mar 29 08:57:01 2013 > All repeater batteries are Ok.
      > > > > > > > > > Fri Mar 29 08:57:03 2013 > Transmitter ID #5 is of type "ISS_TX - An ISS station configured as an ISS.", No repeater
      > > > > > > > > > Fri Mar 29 08:57:07 2013 > Use of time limiter (time():) in an action or actionfile conflicts with an 'On Update Interval' of 60 seconds. See Alerts/Actions then 'On Update Seconds' setting.
      > > > > > > > > > Fri Mar 29 11:10:47 2013 > WUHU monitoring stopped.
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > > > Fri Mar 29 08:51:18 2013 > WUHU monitoring started (WUHU216DAVISVP2).
      > > > > > > > > > Fri Mar 29 08:51:18 2013 > Weather Underground ID: KUTSOUTH13
      > > > > > > > > > Fri Mar 29 08:51:22 2013 > Opened serial port COM9 successfully.
      > > > > > > > > > Fri Mar 29 08:51:24 2013 > Proceeding to history retrieval immediately.
      > > > > > > > > > Fri Mar 29 08:51:24 2013 > The PC clock and console clock are set to within 45 seconds of one another (Measured Drift <= 24 seconds).
      > > > > > > > > > Fri Mar 29 08:51:30 2013 > Current Absolute Pressure = 25.52, Relative Pressure = 30.16, Calculated Offset 4.64.
      > > > > > > > > > Fri Mar 29 08:51:30 2013 > Current Rain Total at start of retrieval = 0.00 IN, 0.00 MM.
      > > > > > > > > > Fri Mar 29 08:52:50 2013 > 2559 new archive records were retrieved from console.
      > > > > > > > > > Fri Mar 29 08:52:52 2013 > Console history read completed succesfully. 23 records were collected. 23 records were stored. 23 records were uploaded to Weather Underground, 0 records were uploaded to PWSWeather, 0 records were uploaded to WeatherBug.
      > > > > > > > > > Fri Mar 29 08:52:56 2013 > Console Battery Voltage: 4.69
      > > > > > > > > > Fri Mar 29 08:52:56 2013 > All transmitter batteries are Ok.
      > > > > > > > > > Fri Mar 29 08:52:56 2013 > All repeater batteries are Ok.
      > > > > > > > > > Fri Mar 29 08:52:58 2013 > Transmitter ID #6 is of type "ISS_TX - An ISS station configured as an ISS.", No repeater
      > > > > > > > > > Fri Mar 29 08:53:01 2013 > Use of time limiter (time():) in an action or actionfile conflicts with an 'On Update Interval' of 60 seconds. See Alerts/Actions then 'On Update Seconds' setting.
      > > > > > > > > > Fri Mar 29 11:10:48 2013 > WUHU monitoring stopped.
      > > > > > > > > >
      > > > > > > > >
      > > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.