Loading ...
Sorry, an error occurred while loading the content.

WUHU + VirtualVP

Expand Messages
  • brentlz
    Not able to get WUHU 1,0,216,210 to communicate with a Davis VP2 using VirtualVP. WUHU works fine directly connected to the VP2 (com10) without VirtualVP.
    Message 1 of 6 , Oct 17, 2012
    • 0 Attachment
      Not able to get WUHU 1,0,216,210 to communicate with a Davis VP2 using VirtualVP. WUHU works fine directly connected to the VP2 (com10) without VirtualVP. Weatherlink 6.0.0 works fine whether through VirtualVP or directly to com10(with VirtualVP off). Seeing the same results using either com0com or N8VBvCOM to create the virtual serial port pairings(com11-com21 + com12-com22). Would really like to be able to run WUHU & Weatherlink simultaneously and wonder if anyone might have some thoughts as to how to get this combo working?

      TIA, Brent / KE7JGM

      FWIW, here's a snip of what I'm seeing in the WUHU log:
      Wed Oct 17 19:11:38 2012 > Opened serial port COM11 successfully.
      Wed Oct 17 19:12:17 2012 > Proceeding to history retrieval immediately.
      Wed Oct 17 19:12:18 2012 > Retrieving Console Units.
      Wed Oct 17 19:12:19 2012 > Retrieving of Console Units Complete.
      Wed Oct 17 19:12:19 2012 > Calling Read().
      Wed Oct 17 19:12:24 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:24 2012 > Console history was not read completely. 0 records were collected. 0 records were stored. 0 records were uploaded to Weather Underground, 0 records were uploaded to PWSWeather, 0 records were uploaded to WeatherBug.
      Wed Oct 17 19:12:24 2012 > Retrieving Console Units.
      Wed Oct 17 19:12:25 2012 > Retrieving of Console Units Complete.
      Wed Oct 17 19:12:25 2012 > Calling Read().
      Wed Oct 17 19:12:30 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:31 2012 > Calling Read().
      Wed Oct 17 19:12:36 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:36 2012 > Calling Read().
      Wed Oct 17 19:12:42 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:42 2012 > Calling Read().
      Wed Oct 17 19:12:47 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:47 2012 > Calling Read().
      Wed Oct 17 19:12:52 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:52 2012 > Calling Read().
      Wed Oct 17 19:12:57 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:12:57 2012 > Calling Read().
      Wed Oct 17 19:13:02 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:13:02 2012 > Detected consecutive communications failures. Attempting to recover by re-opening the port.
      Wed Oct 17 19:13:12 2012 > Attempting to re-open port COM11.
      Wed Oct 17 19:13:14 2012 > Port COM11 re-opened successfully, attempting to resume communications.
      Wed Oct 17 19:13:14 2012 > Calling Read().
      Wed Oct 17 19:13:19 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
      Wed Oct 17 19:13:19 2012 > Calling Read().
    • marcelcanine
      I tried to duplicate that error but could not. As I understand what I see It downloads the history file but stops and does not get any current data. Mine works
      Message 2 of 6 , Oct 18, 2012
      • 0 Attachment
        I tried to duplicate that error but could not.

        As I understand what I see It downloads the history file but stops and does not get any current data.

        Mine works fine. I use ComOcom with the coms paired 6-16, 7-17.
        The console is on com 3. None of that should matter.

        I assume your running WUHU on com 11 and WL on com 12 with the console on com 10.

        The console should be set to serial mode.
        I do not use a password for the console.
        I use 1 second updates for VVP.
        I do not use protect console.

        Have you tried using Wl in IP mode and WUHU in com mode?





        --- In wuhu_software_group@yahoogroups.com, "brentlz" <brentlz@...> wrote:
        >
        > Not able to get WUHU 1,0,216,210 to communicate with a Davis VP2 using VirtualVP. WUHU works fine directly connected to the VP2 (com10) without VirtualVP. Weatherlink 6.0.0 works fine whether through VirtualVP or directly to com10(with VirtualVP off). Seeing the same results using either com0com or N8VBvCOM to create the virtual serial port pairings(com11-com21 + com12-com22). Would really like to be able to run WUHU & Weatherlink simultaneously and wonder if anyone might have some thoughts as to how to get this combo working?
        >
        > TIA, Brent / KE7JGM
        >
        > FWIW, here's a snip of what I'm seeing in the WUHU log:
        > Wed Oct 17 19:11:38 2012 > Opened serial port COM11 successfully.
        > Wed Oct 17 19:12:17 2012 > Proceeding to history retrieval immediately.
        > Wed Oct 17 19:12:18 2012 > Retrieving Console Units.
        > Wed Oct 17 19:12:19 2012 > Retrieving of Console Units Complete.
        > Wed Oct 17 19:12:19 2012 > Calling Read().
        > Wed Oct 17 19:12:24 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:24 2012 > Console history was not read completely. 0 records were collected. 0 records were stored. 0 records were uploaded to Weather Underground, 0 records were uploaded to PWSWeather, 0 records were uploaded to WeatherBug.
        > Wed Oct 17 19:12:24 2012 > Retrieving Console Units.
        > Wed Oct 17 19:12:25 2012 > Retrieving of Console Units Complete.
        > Wed Oct 17 19:12:25 2012 > Calling Read().
        > Wed Oct 17 19:12:30 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:31 2012 > Calling Read().
        > Wed Oct 17 19:12:36 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:36 2012 > Calling Read().
        > Wed Oct 17 19:12:42 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:42 2012 > Calling Read().
        > Wed Oct 17 19:12:47 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:47 2012 > Calling Read().
        > Wed Oct 17 19:12:52 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:52 2012 > Calling Read().
        > Wed Oct 17 19:12:57 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:12:57 2012 > Calling Read().
        > Wed Oct 17 19:13:02 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:13:02 2012 > Detected consecutive communications failures. Attempting to recover by re-opening the port.
        > Wed Oct 17 19:13:12 2012 > Attempting to re-open port COM11.
        > Wed Oct 17 19:13:14 2012 > Port COM11 re-opened successfully, attempting to resume communications.
        > Wed Oct 17 19:13:14 2012 > Calling Read().
        > Wed Oct 17 19:13:19 2012 > Read() Failed. Aborting further attempts to retrieve data from station.
        > Wed Oct 17 19:13:19 2012 > Calling Read().
        >
      • brentlz
        Yep. -VP2 wireless to Weather Envoy w/ CP210x USB to UART bridge driver v6.5.3.0 (latest I could find) on com10 -WUHU on com11 com21 via comocom
        Message 3 of 6 , Oct 18, 2012
        • 0 Attachment
          Yep.
          -VP2 wireless to Weather Envoy w/ CP210x USB to UART bridge driver v6.5.3.0 (latest I could find) on com10
          -WUHU on com11 <-> com21 via comocom <-> VirtualVP console2
          -Weatherlink on com12 <-> com21 via comocom <-> VirtualVP console2

          Doesn't seem to matter whether WL is running or not, which virtual port WUHU is on (com11 or com12), nor if WL is using IP mode. Also tried moving all com ports to < com9, based on a posting I saw that suggested that a WL .dll has issues with com ports > com9. Still get the lack of connectivity for WUHU.

          Looking at the VirtualVP activity window, just noticed that it's displaying:
          "Sent response to wake up console
          Sent response to unknown command"
          At about the same time that the WUHU log is showing:
          "Calling Read().
          Read() Failed. Aborting further attempts to retrieve data from station."

          Will be "playing around" with it more tonight to see if I can get it working.

          Brent.


          --- In wuhu_software_group@yahoogroups.com, "marcelcanine"
          marcelcanine@...> wrote:
          >
          > I tried to duplicate that error but could not.
          >
          > As I understand what I see It downloads the history file but stops and does not get any current data.
          >
          > Mine works fine. I use ComOcom with the coms paired 6-16, 7-17.
          > The console is on com 3. None of that should matter.
          >
          > I assume your running WUHU on com 11 and WL on com 12 with the console on com 10.
          >
          > The console should be set to serial mode.
          > I do not use a password for the console.
          > I use 1 second updates for VVP.
          > I do not use protect console.
          >
          > Have you tried using Wl in IP mode and WUHU in com mode?
          >
        • wuhu_software
          A couple of questions for you: 1) Are you sure the station type is set to Davis Pro, Pro2, Vue, Envoy and not the Davis Classic setting in the General
          Message 4 of 6 , Oct 21, 2012
          • 0 Attachment
            A couple of questions for you:

            1) Are you sure the station type is set to "Davis Pro, Pro2, Vue, Envoy" and not the "Davis Classic" setting in the General Settings?

            2) What is your console firmware version #?


            --- In wuhu_software_group@yahoogroups.com, "brentlz" <brentlz@...> wrote:
            >
            > Yep.
            > -VP2 wireless to Weather Envoy w/ CP210x USB to UART bridge driver v6.5.3.0 (latest I could find) on com10
            > -WUHU on com11 <-> com21 via comocom <-> VirtualVP console2
            > -Weatherlink on com12 <-> com21 via comocom <-> VirtualVP console2
            >
            > Doesn't seem to matter whether WL is running or not, which virtual port WUHU is on (com11 or com12), nor if WL is using IP mode. Also tried moving all com ports to < com9, based on a posting I saw that suggested that a WL .dll has issues with com ports > com9. Still get the lack of connectivity for WUHU.
            >
            > Looking at the VirtualVP activity window, just noticed that it's displaying:
            > "Sent response to wake up console
            > Sent response to unknown command"
            > At about the same time that the WUHU log is showing:
            > "Calling Read().
            > Read() Failed. Aborting further attempts to retrieve data from station."
            >
            > Will be "playing around" with it more tonight to see if I can get it working.
            >
            > Brent.
            >
            >
            > --- In wuhu_software_group@yahoogroups.com, "marcelcanine"
            > marcelcanine@> wrote:
            > >
            > > I tried to duplicate that error but could not.
            > >
            > > As I understand what I see It downloads the history file but stops and does not get any current data.
            > >
            > > Mine works fine. I use ComOcom with the coms paired 6-16, 7-17.
            > > The console is on com 3. None of that should matter.
            > >
            > > I assume your running WUHU on com 11 and WL on com 12 with the console on com 10.
            > >
            > > The console should be set to serial mode.
            > > I do not use a password for the console.
            > > I use 1 second updates for VVP.
            > > I do not use protect console.
            > >
            > > Have you tried using Wl in IP mode and WUHU in com mode?
            > >
            >
          • brentlz
            WUHU is set to Davis Pro, Pro2, Vue, Envoy . Console Diagnostics in Weatherlink reports firmware version 2.00 Assuming that s for the Wireless Weather
            Message 5 of 6 , Oct 22, 2012
            • 0 Attachment
              WUHU is set to "Davis Pro, Pro2, Vue, Envoy".

              "Console Diagnostics" in Weatherlink reports firmware version 2.00 Assuming that's for the Wireless Weather Envoy (that's what is connected to the PC running WUHU & Weatherlink at least)? Can check the VP2 console version when home later today.

              Brent.
              --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
              >
              >
              > A couple of questions for you:
              >
              > 1) Are you sure the station type is set to "Davis Pro, Pro2, Vue, Envoy" and not the "Davis Classic" setting in the General Settings?
              >
              > 2) What is your console firmware version #?
            • brentlz
              The VP2 console is firmware rev 1.90 Moved the USB data logger from the Wireless Weather Envoy into the VP2 console and WUHU + VirtualVP now works. Debating
              Message 6 of 6 , Oct 22, 2012
              • 0 Attachment
                The VP2 console is firmware rev 1.90

                Moved the USB data logger from the Wireless Weather Envoy into the VP2 console and WUHU + VirtualVP now works. Debating whether to try downgrading the Wireless Weather Envoy 6316 firmware to 1.90 (latest available for download on Davis' web site)...I'd rather keep the VP2 console in the living room & the Envoy in the data closet. ;)

                Brent.

                --- In wuhu_software_group@yahoogroups.com, "brentlz" <brentlz@...> wrote:
                >
                > WUHU is set to "Davis Pro, Pro2, Vue, Envoy".
                >
                > "Console Diagnostics" in Weatherlink reports firmware version 2.00 Assuming that's for the Wireless Weather Envoy (that's what is connected to the PC running WUHU & Weatherlink at least)? Can check the VP2 console version when home later today.
                >
                > Brent.
                > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                > >
                > >
                > > A couple of questions for you:
                > >
                > > 1) Are you sure the station type is set to "Davis Pro, Pro2, Vue, Envoy" and not the "Davis Classic" setting in the General Settings?
                > >
                > > 2) What is your console firmware version #?
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.