Loading ...
Sorry, an error occurred while loading the content.
 

Rain data via WUHU

Expand Messages
  • David Higgins
    There may be a problem with the WS-3600 version of Heavyweather. 0.5mm of rain is recorded by the unit and in the history.dat file and current.1st holds 0.5 in
    Message 1 of 4 , Sep 14, 2005
      There may be a problem with the WS-3600 version of Heavyweather.
      0.5mm of rain is recorded by the unit and in the history.dat file and
      current.1st holds 0.5 in the mm field but 0.00 in the inch field.

      Weather underground shows 0.00 as a result (since they only upload the
      inch value). If my calculations are correct, 0.5mm = 0.02in! If this
      is indeed a problem then it wouldbe good for Heavyweather to fix it -
      but in the short term can WUHU fix it?

      Cheers

      David
    • wuhu_software
      David, That is interesting. The inch field is always zero? I can patch the code to use the mm values over the in values if needed. Do we know how many fields
      Message 2 of 4 , Sep 14, 2005
        David,

        That is interesting. The inch field is always zero?

        I can patch the code to use the mm values over the in values if needed.

        Do we know how many fields are affected? Per hour, 24 hour, total?

        Can you post a clipping of the currdat.lst file so I can see it?

        Thanks.

        --- In wuhu_software_group@yahoogroups.com, "David Higgins"
        <higginsdj@b...> wrote:
        > There may be a problem with the WS-3600 version of Heavyweather.
        > 0.5mm of rain is recorded by the unit and in the history.dat file and
        > current.1st holds 0.5 in the mm field but 0.00 in the inch field.
        >
        > Weather underground shows 0.00 as a result (since they only upload
        the
        > inch value). If my calculations are correct, 0.5mm = 0.02in! If
        this
        > is indeed a problem then it wouldbe good for Heavyweather to fix it -
        > but in the short term can WUHU fix it?
        >
        > Cheers
        >
        > David
      • David Higgins
        Yes and all 3 of them show 0.00 for the Inch value where the mm values (right above the Inch values in the file) are 0.5, 2.5, 2.5 respectively. I switched the
        Message 3 of 4 , Sep 14, 2005
          Yes and all 3 of them show 0.00 for the Inch value where the mm
          values (right above the Inch values in the file) are 0.5, 2.5, 2.5
          respectively.

          I switched the unit over to Inch units and will check tonight to see
          if this has made any difference.

          Cheers

          David

          --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
          <wuhu_software@y...> wrote:
          >
          > David,
          >
          > That is interesting. The inch field is always zero?
          >
          > I can patch the code to use the mm values over the in values if
          needed.
          >
          > Do we know how many fields are affected? Per hour, 24 hour, total?
          >
          > Can you post a clipping of the currdat.lst file so I can see it?
          >
          > Thanks.
          >
          > --- In wuhu_software_group@yahoogroups.com, "David Higgins"
          > <higginsdj@b...> wrote:
          > > There may be a problem with the WS-3600 version of
          Heavyweather.
          > > 0.5mm of rain is recorded by the unit and in the history.dat
          file and
          > > current.1st holds 0.5 in the mm field but 0.00 in the inch field.
          > >
          > > Weather underground shows 0.00 as a result (since they only
          upload
          > the
          > > inch value). If my calculations are correct, 0.5mm = 0.02in!
          If
          > this
          > > is indeed a problem then it wouldbe good for Heavyweather to fix
          it -
          > > but in the short term can WUHU fix it?
          > >
          > > Cheers
          > >
          > > David
        • David Higgins
          Some further information: 1. Setting WS3600 Heavyweather Rain units to inches writes the correct value to current.1st (at least the 2 total fields) 2. At
          Message 4 of 4 , Sep 15, 2005
            Some further information:

            1. Setting WS3600 Heavyweather Rain units to inches writes the
            correct value to current.1st (at least the 2 total fields)

            2. At 2.5mm current.1st displayed 0.00in. At 3.1mm current 1st
            wrote 0.10mm (still not the correct value) - so it does eventually
            write something but it would appear that at least 3mm of rain is
            needed before it will write anything!

            It would seem to be a conversion/rounding problem (3.1mm = 1.2in)

            **************Changed Rain units to Inches************
            [rain_total]
            mm="3.1"
            inch="0.12"

            [rain_24h]
            mm="3.1"
            inch="0.12"

            [rain_1h]
            mm="0.0"
            inch="0.00"

            **************Pre change units to Inches at 3.1mm************
            [rain_total]
            mm="3.1"
            inch="0.10"

            [rain_24h]
            mm="3.1"
            inch="0.10"

            [rain_1h]
            mm="0.0"
            inch="0.00"


            ****************At 2.5mm units set to mm****************
            [rain_total]
            mm="2.5"
            inch="0.00"

            [rain_24h]
            mm="2.5"
            inch="0.00"

            [rain_1h]
            mm="0.5"
            inch="0.00"



            Cheers

            David



            --- In wuhu_software_group@yahoogroups.com, "David Higgins"
            <higginsdj@b...> wrote:
            > Yes and all 3 of them show 0.00 for the Inch value where the mm
            > values (right above the Inch values in the file) are 0.5, 2.5, 2.5
            > respectively.
            >
            > I switched the unit over to Inch units and will check tonight to
            see
            > if this has made any difference.
            >
            > Cheers
            >
            > David
            >
            > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
            > <wuhu_software@y...> wrote:
            > >
            > > David,
            > >
            > > That is interesting. The inch field is always zero?
            > >
            > > I can patch the code to use the mm values over the in values if
            > needed.
            > >
            > > Do we know how many fields are affected? Per hour, 24 hour,
            total?
            > >
            > > Can you post a clipping of the currdat.lst file so I can see it?
            > >
            > > Thanks.
            > >
            > > --- In wuhu_software_group@yahoogroups.com, "David Higgins"
            > > <higginsdj@b...> wrote:
            > > > There may be a problem with the WS-3600 version of
            > Heavyweather.
            > > > 0.5mm of rain is recorded by the unit and in the history.dat
            > file and
            > > > current.1st holds 0.5 in the mm field but 0.00 in the inch
            field.
            > > >
            > > > Weather underground shows 0.00 as a result (since they only
            > upload
            > > the
            > > > inch value). If my calculations are correct, 0.5mm = 0.02in!
            > If
            > > this
            > > > is indeed a problem then it wouldbe good for Heavyweather to
            fix
            > it -
            > > > but in the short term can WUHU fix it?
            > > >
            > > > Cheers
            > > >
            > > > David
          Your message has been successfully submitted and would be delivered to recipients shortly.