Loading ...
Sorry, an error occurred while loading the content.

Re: WUHU does not honor main display wind unit setting set in INI-file

Expand Messages
  • J.Laiho
    Hi Eugen, Here s the translation of the step-by-step instructions I gave to finnish WUHU users in my forum: 1. Stop WUHU and exit it completely. 2. Download
    Message 1 of 17 , Mar 14 5:57 AM
    • 0 Attachment
      Hi Eugen,

      Here's the translation of the step-by-step instructions I gave to finnish WUHU users in my forum:

      1. Stop WUHU and exit it completely.
      2. Download and install the latest version of WUHU (at the writing of this, the latest version is B183). While installing, take off the tick mark from the "I would like to launch WUHU". After that, exit the installer normally.
      3. Navigate to the folder you installed WUHU to. Open the WUHU Configuration Data.ini file using Notepad.
      4. From [General Settings], find the line beginning with

      Display Wind Units=

      The line probably has a numeric value assigned to it. Change the number to MPS, so the line reads:

      Display Wind Units=MPS

      If you can't find the line, you can type it in yourself. Just make sure it is found under [General Settings].
      5. Save the file and close Notepad.
      6. Start WUHU. The main display should now show wind speeds in meters per second (m/s).

      Eugen, in your case, please follow the instructions at step 1 and steps 3 to 6.

      Best Regards,
      Juha Laiho
      Weather Station Operator
      Finland Weather Exchange (FinWX)
      Helsinki, Finland
      CW4473 / IUUSIMAA2


      --- In wuhu_software_group@yahoogroups.com, Radu Eugen <eugenraduoradea@...> wrote:
      >
      > I read carefully all that you wrote but I still don't understand how can I make
      > the wuhu to show me the wind speed in meters per second.
      > I also installed the newest version B183.
      > I need a guidance, what to insert in ini file and where to go to make the wuhu
      > to show me the wind speed in meters per second.
      > Thanks
      > Best regards, Eugen Radu, Oradea
      >
      >
      >
      > ________________________________
      > From: J.Laiho <jjantti2@...>
      > To: wuhu_software_group@yahoogroups.com
      > Sent: Sun, March 13, 2011 11:09:33 PM
      > Subject: [wuhu_software_group] Re: WUHU does not honor main display wind unit
      > setting set in INI-file
      >
      >
      >
      >
      > Hi.
      >
      > In my case, the value MPS was changed to 3 after I closed WUHU.
      >
      > So I tested the newer refresh of B183 and it now retains the MPS as the value,
      > as it should do. I have informed all WUHU users to install the latest version of
      > B183 and before starting WUHU, to edit the numeric value back to MPS or whatever
      > they wish it to be.
      >
      > Glad to see that the problem is now solved. Thank you very much for your effort!
      >
      > Best Regards,
      > Juha Laiho
      > Weather Station Operator
      > Finland Weather Exchange (FinWX)
      > Helsinki, Finland
      > CW4473 / IUUSIMAA2
      >
      > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@>
      > wrote:
      > >
      > >
      > > Juha,
      > > After your last post, I realized what is going on. The format that is
      > > used to load the setting was using text (MPH, KPH, etc), but the routine
      > > that was used to save the internal setting was saving a numeric value.
      > > If a user had hit Stop at some point then re-started processing, the
      > > incorrect value was saved to the INI file.
      > > To correct please have users install this refreshed copy of B183
      > > <http://home.comcast.net/~wuhu_software/files/WUHU216_32_B183.zip> .
      > > Either do not start the program at the end of the install or exit the
      > > program.
      > > Verify the setting in the WUHU Configuration.ini using Notepad. If you
      > > find a numeric value for this setting (0, 1, 2, etc), change it to text
      > > (MPH, KPH, MPS, etc).
      > > Then start WUHU.
      > > Thanks.
      > >
      > > --- In wuhu_software_group@yahoogroups.com, "J.Laiho" <jjantti2@>
      > > wrote:
      > > >
      > > >
      > > >
      > > > Hi.
      > > >
      > > > No. I've asked all the users having this problem where this line is
      > > located and all of them replied saying it's found under [General
      > > Settings].
      > > >
      > > > In addition to that, all of them are stating that they never had to
      > > manually enter that line to the ini file. Instead, they found this line
      > > in their .ini file:
      > > > Display Wind Units=0
      > > >
      > > > and simply edited that to:
      > > > Display Wind Units=MPS
      > > >
      > > > However, it still didn't work.
      > > >
      > > > And to make this whole thing a bit more interesting, two out of three
      > > operators claimed they did things exactly like I did, but the wind
      > > speeds are still shown at km/h... and they're all running B182.
      > > >
      > > > I have to admit, I'm truly lost now. How on earth it's working for me
      > > but not for most of them?
      > > >
      > > > Best Regards,
      > > > Juha Laiho
      > > > Weather Station Operator
      > > > Finland Weather Exchange (FinWX)
      > > > Helsinki, Finland
      > > > CW4473 / IUUSIMAA2
      > > >
      > > >
      > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
      > > wuhu_software@ wrote:
      > > > >
      > > > >
      > > > > That is interesting. I do not suppose those users accidentally
      > > posted the line in a different section?
      > > > >
      > > > > --- In wuhu_software_group@yahoogroups.com, "J.Laiho" <jjantti2@>
      > > wrote:
      > > > > >
      > > > > >
      > > > > >
      > > > > >
      > > > > > Hi.
      > > > > > I just got word from other PWS operators using WUHU that having
      > > the line
      > > > > >
      > > > > > Display Wind Units=MPS
      > > > > >
      > > > > > as one of the last lines in [General Settings] section of the ini
      > > file, (where it seems to be originally placed), results in failure to
      > > change the value.
      > > > > >
      > > > > > Moving that line towards the beginning of the section seems to
      > > make it work after WUHU is upgraded to B182.
      > > > > >
      > > > > > I set mine like this:
      > > > > > [General Settings]
      > > > > > Minimum Period=300
      > > > > > Weather Station Input File Type=9
      > > > > > Serial Communications Port=COM1
      > > > > > Display Units Type=1
      > > > > > Display Wind Units=MPS
      > > > > > Write Currentdat=1
      > > > > > Write Extended Currentdat=1
      > > > > > Write Historydat=0
      > > > > > Tweak Windspeed=1.0000
      > > > > > Tweak Temperature=1.0000
      > > > > > Tweak Humidity=1.0000
      > > > > > .
      > > > > > .
      > > > > > .
      > > > > > .
      > > > > >
      > > > > >
      > > > > > After that, it started working as it should.
      > > > > > What causes this particular behavior is beyond me, but this may
      > > serve as a clue.
      > > > > >
      > > > > > All in all, I just want to share this bit of information with you
      > > all, just in case if you happen to agonise with the very same problem.
      > > > > >
      > > > > > Best Regards,
      > > > > > Juha Laiho
      > > > > > Weather Station Operator
      > > > > > Finland Weather Exchange (FinWX)
      > > > > > Helsinki, Finland
      > > > > > CW4473 / IUUSIMAA2
      > > > > >
      > > > > >
      > > > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
      > > <wuhu_software@> wrote:
      > > > > > >
      > > > > > >
      > > > > > > No worries, glad to hear that it is working.
      > > > > > >
      > > > > > > --- In wuhu_software_group@yahoogroups.com, "J.Laiho"
      > > <jjantti2@> wrote:
      > > > > > > >
      > > > > > > > Ok, back with the results.
      > > > > > > > After installing B182, WUHU now shows wind speed units as per
      > > INI file settings (=MPS).
      > > > > > > >
      > > > > > > > What is strange is that it seemed not to work with B181 at all
      > > and if I remember correctly, this feature was introduced somewhere
      > > between B127 and B150. I suspect this problem was at our end.
      > > > > > > >
      > > > > > > > At any rate, I'll recommend people updating their WUHU's to
      > > B182. Should any problems arise, I'll let you know. I am sorry for
      > > jumping the gun on this matter.
      > > > > > > >
      > > > > > > > Best Regards,
      > > > > > > > Juha Laiho
      > > > > > > > Weather Station Operator
      > > > > > > > Finland Weather Exchange (FinWX)
      > > > > > > > Helsinki, Finland
      > > > > > > > CW4473 / IUUSIMAA2
      > > > > > > >
      > > > > > > >
      > > > > > > > --- In wuhu_software_group@yahoogroups.com, "J.Laiho"
      > > <jjantti2@> wrote:
      > > > > > > > >
      > > > > > > > > Hi.
      > > > > > > > >
      > > > > > > > > I was running B181, the same version is ran by other station
      > > operators as well.
      > > > > > > > >
      > > > > > > > > Just a few moments ago I updated WUHU from B181 to B182, but
      > > there's no wind at the moment, so I can't verify if the update has
      > > provided any changes.
      > > > > > > > >
      > > > > > > > > I will report back once the wind picks up.
      > > > > > > > >
      > > > > > > > > Best Regards,
      > > > > > > > > Juha Laiho
      > > > > > > > > Weather Station Operator
      > > > > > > > > Finland Weather Exchange (FinWX)
      > > > > > > > > Helsinki, Finland
      > > > > > > > > CW4473 / IUUSIMAA2
      > > > > > > > >
      > > > > > > > >
      > > > > > > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software"
      > > <wuhu_software@> wrote:
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > > > That is very odd. I have run the debugger on my setup and
      > > it works as expected.
      > > > > > > > > >
      > > > > > > > > > Are you running the latest version (B182) or an earlier
      > > version?
      > > > > > > > > >
      > > > > > > > > >
      > > > > > > > > > --- In wuhu_software_group@yahoogroups.com, "J.Laiho"
      > > <jjantti2@> wrote:
      > > > > > > > > > >
      > > > > > > > > > > Hi.
      > > > > > > > > > >
      > > > > > > > > > > Yes, I'm absolutely positive.
      > > > > > > > > > > This line is located under [General Settings] and there
      > > are no double entries under that category or the file. Same goes for the
      > > rest of the people I received replies from.
      > > > > > > > > > >
      > > > > > > > > > > As a safe bet, I double-checked the file's contents
      > > before replying you and the result's the same:
      > > > > > > > > > > Despite the line, wind speed units are still shown at
      > > km/h in WUHU's main display.
      > > > > > > > > > >
      > > > > > > > > > > Best Regards,
      > > > > > > > > > > Juha Laiho
      > > > > > > > > > > Weather Station Operator
      > > > > > > > > > > Finland Weather Exchange (FinWX)
      > > > > > > > > > > Helsinki, Finland
      > > > > > > > > > > CW4473 / IUUSIMAA2
      > > > > > > > > > >
      > > > > > > > > > >
      > > > > > > > > > > --- In wuhu_software_group@yahoogroups.com, "H. Smith"
      > > <wuhu_software@> wrote:
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Are you sure that the setting is being place in the
      > > [General Settings] section of the file and that there is not a duplicate
      > > line for this setting? If there are duplicates, I would guess that the
      > > first one will be used and the second would be ignored.
      > > > > > > > > > > >
      > > > > > > > > > > > --- On Fri, 3/11/11, J.Laiho <jjantti2@> wrote:
      > > > > > > > > > > >
      > > > > > > > > > > > From: J.Laiho <jjantti2@>
      > > > > > > > > > > > Subject: [wuhu_software_group] WUHU does not honor
      > > main display wind unit setting set in INI-file
      > > > > > > > > > > > To: wuhu_software_group@yahoogroups.com
      > > > > > > > > > > > Date: Friday, March 11, 2011, 5:59 AM
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Â
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Hi all!
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > I have received reports from several WUHU users, that
      > > the following feature seem not to work as planned:
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > ------------------
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > 102) Added a new variable to the [General Settings]
      > > section of the INI file that allows you to choose the units for wind
      > > speed on the main display.
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Example: Change the wind speed units to Meters Per
      > > Second.
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > [General Settings]
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > …
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Display Wind Units=MPS
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Allowable values are MPH, KPH, MPS, FPS (Feet Per
      > > Second).
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > --------------------
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Users are reporting that changing the INI-file's line:
      > > > > > > > > > > >
      > > > > > > > > > > > Display Wind Units=0
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > to:
      > > > > > > > > > > >
      > > > > > > > > > > > Display Wind Units=MPS
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > does not change the wind speed values to meters per
      > > second as expected. Instead, the displayed values on the main display
      > > remain at km/h.
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > All users have shut down WUHU before editing the INI
      > > file and their main display values set to Metric from the radio button
      > > on the upper left corner of the main display.
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Have we missed something important here?
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > >
      > > > > > > > > > > > Best Regards,
      > > > > > > > > > > >
      > > > > > > > > > > > Juha Laiho
      > > > > > > > > > > >
      > > > > > > > > > > > Weather Station Operator
      > > > > > > > > > > >
      > > > > > > > > > > > Finland Weather Exchange (FinWX)
      > > > > > > > > > > >
      > > > > > > > > > > > Helsinki, Finland
      > > > > > > > > > > >
      > > > > > > > > > > > CW4473 / IUUSIMAA2
      > > > > > > > > > > >
      > > > > > > > > > >
      > > > > > > > > >
      > > > > > > > >
      > > > > > > >
      > > > > > >
      > > > > >
      > > > >
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.