Loading ...
Sorry, an error occurred while loading the content.

Re: PWS Errors

Expand Messages
  • wuhu_software
    It almost sounds like a firewall issue where the software thinks the upload fails because it is not seeing the response from the website but the website did
    Message 1 of 16 , May 2, 2010
    • 0 Attachment
      It almost sounds like a firewall issue where the software thinks the upload fails because it is not seeing the response from the website but the website did apparently get the data.

      The software will continue to attempt to upload the data over and over as a background update.

      Check your firewall setup, on the PC and router if you have one to make sure that there is not a funky setting somewhere that would block the response.

      The upload will use the http port (80) to send the data to their server.


      --- In wuhu_software_group@yahoogroups.com, "marlin1792" <marlin1792@...> wrote:
      >
      >
      >
      > Very strange, lol. After I uninstalled and reinstalled PWS worked for about 30 minutes. I have noticed that instead of the 6-8 minute intervals that PWS ran when it worked, it now tries updating every minute. I still have 300 second update. Once the minute updates start it quits gathering data and keeps repeating the last good upload so it looks like my station reports the same readings no matter what time day or night.
      >
      > I'm going to create a 2nd PWS station and see if it does the same with the new station. I don't think it is WUHU but something PWS does not like about that station.
      >
      > Thanks,
      >
      > Mark
      >
      > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
      > >
      > >
      > > That is odd, I am not seeing any problems here.
      > >
      > > Try flushing out any uploads that were previously queued up but not sent... Exit WUHU, goto the C:\Progam Files\WUHU folder, delete the file WUHU Unsent URLs.dat, re-start WUHU.
      > >
      > > Perhaps there was some type of corruption in the data.
      > >
      > >
      > > --- In wuhu_software_group@yahoogroups.com, "marlin1792" <marlin1792@> wrote:
      > > >
      > > > This started on April 7th around 1AM. Every since I can not upload to PWS. All other sites work fine.
      > > >
      > > > Sun May 02 10:06:51 2010 > PWSWeather Background Upload: Final Fatal Eror (No more retries) InternetOpenUrl() returned error 0x00002ee2 (12002), ERROR_INTERNET_TIMEOUT.
      > > >
      > > > These errors occur on the previous and current versions of WUHU.
      > > >
      > > > Is anyone else getting these errors at this time? The previous thread was from 2009 and was a server error at PWS.
      > > >
      > > > I have noticed PWS seems to be updating the web page every minute. Even with the errors every 5 minutes it will show the correct data (most times) even with the failures.
      > > >
      > > > I'm running Windows 7 64 bit, NIS 2010 with all ports open for WUHU.
      > > >
      > > > Weather Underground works fine: KGABLUER4
      > > > PWS Fails: BLUERIDGE1
      > > >
      > > >
      > > > Thanks,
      > > >
      > > > Mark
      > > >
      > >
      >
    • marlin1792
      Found It!!! Yes, the router had updated firmware and change two settings on the router. UDP and TCP endpoint filtering was set to address restricted instead
      Message 2 of 16 , May 7, 2010
      • 0 Attachment
        Found It!!!

        Yes, the router had updated firmware and change two settings on the router. UDP and TCP endpoint filtering was set to address restricted instead of endpoint independent. What this does is not allow communications if the return (ack) is from a different address than the sendto address. This is why I could get the data to PWS but it could not ACK my packets.

        Thanks for the assistance. PWS is now 10/10 on the updates instead of 0/300...

        Mark

        --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
        >
        >
        > It almost sounds like a firewall issue where the software thinks the upload fails because it is not seeing the response from the website but the website did apparently get the data.
        >
        > The software will continue to attempt to upload the data over and over as a background update.
        >
        > Check your firewall setup, on the PC and router if you have one to make sure that there is not a funky setting somewhere that would block the response.
        >
        > The upload will use the http port (80) to send the data to their server.
        >
        >
        > --- In wuhu_software_group@yahoogroups.com, "marlin1792" <marlin1792@> wrote:
        > >
        > >
        > >
        > > Very strange, lol. After I uninstalled and reinstalled PWS worked for about 30 minutes. I have noticed that instead of the 6-8 minute intervals that PWS ran when it worked, it now tries updating every minute. I still have 300 second update. Once the minute updates start it quits gathering data and keeps repeating the last good upload so it looks like my station reports the same readings no matter what time day or night.
        > >
        > > I'm going to create a 2nd PWS station and see if it does the same with the new station. I don't think it is WUHU but something PWS does not like about that station.
        > >
        > > Thanks,
        > >
        > > Mark
        > >
        > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
        > > >
        > > >
        > > > That is odd, I am not seeing any problems here.
        > > >
        > > > Try flushing out any uploads that were previously queued up but not sent... Exit WUHU, goto the C:\Progam Files\WUHU folder, delete the file WUHU Unsent URLs.dat, re-start WUHU.
        > > >
        > > > Perhaps there was some type of corruption in the data.
        > > >
        > > >
        > > > --- In wuhu_software_group@yahoogroups.com, "marlin1792" <marlin1792@> wrote:
        > > > >
        > > > > This started on April 7th around 1AM. Every since I can not upload to PWS. All other sites work fine.
        > > > >
        > > > > Sun May 02 10:06:51 2010 > PWSWeather Background Upload: Final Fatal Eror (No more retries) InternetOpenUrl() returned error 0x00002ee2 (12002), ERROR_INTERNET_TIMEOUT.
        > > > >
        > > > > These errors occur on the previous and current versions of WUHU.
        > > > >
        > > > > Is anyone else getting these errors at this time? The previous thread was from 2009 and was a server error at PWS.
        > > > >
        > > > > I have noticed PWS seems to be updating the web page every minute. Even with the errors every 5 minutes it will show the correct data (most times) even with the failures.
        > > > >
        > > > > I'm running Windows 7 64 bit, NIS 2010 with all ports open for WUHU.
        > > > >
        > > > > Weather Underground works fine: KGABLUER4
        > > > > PWS Fails: BLUERIDGE1
        > > > >
        > > > >
        > > > > Thanks,
        > > > >
        > > > > Mark
        > > > >
        > > >
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.