Loading ...
Sorry, an error occurred while loading the content.

RE: [wuhu_software_group] WUHU stops getting new data

Expand Messages
  • Rob Reab
    Since you mentioned the computer having a PIII processor, I m wondering about RAM. How much does your system have? You might want to check, via task manager,
    Message 1 of 9 , Mar 17, 2010
    • 0 Attachment

      Since you mentioned the computer having a PIII processor, I’m wondering about RAM. How much does your system have? You might want to check, via task manager, how much memory your system is using after a reboot, then again when the problems begin to appear. Might be worth verifying that you have enough disk space also. - Rob

       

      From: wuhu_software_group@yahoogroups.com [mailto:wuhu_software_group@yahoogroups.com] On Behalf Of medicmjc
      Sent: Wednesday, March 17, 2010 9:31 AM
      To: wuhu_software_group@yahoogroups.com
      Subject: [wuhu_software_group] WUHU stops getting new data

       

       

      I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.

      I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.

      Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).

      The program apparently then slows until it freezes up after a couple more hours.

      I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.

      Any ideas would be helpful. Thanks in advance.

    • wuhu_software
      I would lean toward the port replicator as the problem. Anytime you have USB to serial adapters, this can be an issue. It is possible that the Davis DLL is
      Message 2 of 9 , Mar 17, 2010
      • 0 Attachment
        I would lean toward the port replicator as the problem.

        Anytime you have USB to serial adapters, this can be an issue.

        It is possible that the Davis DLL is stuck somehow.

        Try checking "Show console Com. Errors" in the log window, perhaps that will lead to a clue.


        --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@...> wrote:
        >
        > I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.
        >
        > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.
        >
        > Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).
        >
        > The program apparently then slows until it freezes up after a couple more hours.
        >
        > I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.
        >
        > Any ideas would be helpful. Thanks in advance.
        >
      • medicmjc
        Rob, thank you for replying. Right now I am suspecting the port replicator has decided to fail. Nice that it chose to do so at the same time I made a
        Message 3 of 9 , Mar 18, 2010
        • 0 Attachment
          Rob, thank you for replying. Right now I am suspecting the port replicator has decided to fail. Nice that it chose to do so at the same time I made a software change!

          I did check the things you suggested. It has 384MB RAM and the 20GB hard drive has 11.4 GB open; I don't see any problems there.

          The performance shows the CPU less than 10% and the page file is 324 of 922 MB with it running normally. I swapped out the port replicator with another USB to serial I have, if it fails again I'll recheck.

          Thanks again, Mike.

          --- In wuhu_software_group@yahoogroups.com, "Rob Reab" <robreab@...> wrote:
          >
          > Since you mentioned the computer having a PIII processor, I'm wondering
          > about RAM. How much does your system have? You might want to check, via task
          > manager, how much memory your system is using after a reboot, then again
          > when the problems begin to appear. Might be worth verifying that you have
          > enough disk space also. - Rob
          >
          >
          >
          > From: wuhu_software_group@yahoogroups.com
          > [mailto:wuhu_software_group@yahoogroups.com] On Behalf Of medicmjc
          > Sent: Wednesday, March 17, 2010 9:31 AM
          > To: wuhu_software_group@yahoogroups.com
          > Subject: [wuhu_software_group] WUHU stops getting new data
          >
          >
          >
          >
          >
          > I am a new WUHU user and am having a problem that I hope someone can help
          > with, but I cannot find a similar post.
          >
          > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS.
          > My device is a Davis Weather Monitor II and I have a Targus PA070 port
          > replicator providing the COM port to USB. The laptop has a "clean" install
          > and is running virtually nothing else.
          >
          > Here's the problem: After several hours, WUHU quits getting new data from
          > the Weather Monitor, but reports the last dataset as new data to the
          > internet servers. (Results in 'flatline' on any charts).
          >
          > The program apparently then slows until it freezes up after a couple more
          > hours.
          >
          > I then need to force the program to close. When the program restarts,
          > everything seems to "catch up" including posting the correct data during the
          > "flatline" period.
          >
          > Any ideas would be helpful. Thanks in advance.
          >
        • medicmjc
          I think you are leaning the right way! While trying a few things I noted the external keyboard acting weird. (The keyboard also connects to the port
          Message 4 of 9 , Mar 18, 2010
          • 0 Attachment
            I think you are leaning the right way! While trying a few things I noted the external keyboard acting weird. (The keyboard also connects to the port replicator through a KVM switch). I disconnected it and connected the WMII through the only other USB to serial I have on hand, a Belkin F5U409; so far, so good. We will see by tomorrow if the problem resolves.

            I had checked the log before, however, I did not see anything listed.

            Thanks for the reply and suggestions!

            -Mike

            --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
            >
            >
            > I would lean toward the port replicator as the problem.
            >
            > Anytime you have USB to serial adapters, this can be an issue.
            >
            > It is possible that the Davis DLL is stuck somehow.
            >
            > Try checking "Show console Com. Errors" in the log window, perhaps that will lead to a clue.
            >
            >
            > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
            > >
            > > I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.
            > >
            > > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.
            > >
            > > Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).
            > >
            > > The program apparently then slows until it freezes up after a couple more hours.
            > >
            > > I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.
            > >
            > > Any ideas would be helpful. Thanks in advance.
            > >
            >
          • medicmjc
            Well, back to square one. Worked for about 5 and 1/2 hours, then it stopped getting new data. Internet updates went from every 5 minutes to about a couple
            Message 5 of 9 , Mar 18, 2010
            • 0 Attachment
              Well, back to square one. Worked for about 5 and 1/2 hours, then it stopped getting new data. Internet updates went from every 5 minutes to about a couple times an hour at a variable interval, but repeatedly the giving the same data as a current reading.

              There was no noticeable change to CPU usage or pagefile size. There was nothing noted in the log.

              This was with the port replicator disconnected and using the Belkin device for USB to serial instead.

              Any other ideas?

              --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
              >
              >
              > I would lean toward the port replicator as the problem.
              >
              > Anytime you have USB to serial adapters, this can be an issue.
              >
              > It is possible that the Davis DLL is stuck somehow.
              >
              > Try checking "Show console Com. Errors" in the log window, perhaps that will lead to a clue.
              >
              >
              > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
              > >
              > > I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.
              > >
              > > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.
              > >
              > > Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).
              > >
              > > The program apparently then slows until it freezes up after a couple more hours.
              > >
              > > I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.
              > >
              > > Any ideas would be helpful. Thanks in advance.
              > >
              >
            • wuhu_software
              Are you running the latest version? I would try this, assuming you have enough HD space. Go to log screen, un-check Errors Only as well as all the of check
              Message 6 of 9 , Mar 19, 2010
              • 0 Attachment
                Are you running the latest version?

                I would try this, assuming you have enough HD space.

                Go to log screen, un-check "Errors Only" as well as all the of check boxes associated with the servers.

                Check "Show Console Com. Errors".

                Check "Save to File".

                After it locks up the next time, go to the C:\Program Files\WUHU directory, you will find a file called "WUHU Log.txt" that you can open in Notepad. Maybe that will show more detail.

                I may need to create a special version that logs every call made to the DLL to determine where it is getting stuck.

                Lets try this first.


                --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@...> wrote:
                >
                > Well, back to square one. Worked for about 5 and 1/2 hours, then it stopped getting new data. Internet updates went from every 5 minutes to about a couple times an hour at a variable interval, but repeatedly the giving the same data as a current reading.
                >
                > There was no noticeable change to CPU usage or pagefile size. There was nothing noted in the log.
                >
                > This was with the port replicator disconnected and using the Belkin device for USB to serial instead.
                >
                > Any other ideas?
                >
                > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                > >
                > >
                > > I would lean toward the port replicator as the problem.
                > >
                > > Anytime you have USB to serial adapters, this can be an issue.
                > >
                > > It is possible that the Davis DLL is stuck somehow.
                > >
                > > Try checking "Show console Com. Errors" in the log window, perhaps that will lead to a clue.
                > >
                > >
                > > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
                > > >
                > > > I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.
                > > >
                > > > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.
                > > >
                > > > Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).
                > > >
                > > > The program apparently then slows until it freezes up after a couple more hours.
                > > >
                > > > I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.
                > > >
                > > > Any ideas would be helpful. Thanks in advance.
                > > >
                > >
                >
              • medicmjc
                I am running version 216, log is now set up as requested. There is plenty of HD space, 11 GB open. Let me express my thanks for your efforts, this is
                Message 7 of 9 , Mar 19, 2010
                • 0 Attachment
                  I am running version 216, log is now set up as requested. There is plenty of HD space, 11 GB open.

                  Let me express my thanks for your efforts, this is obviously a unique issue. I like the software and one way or another, I'll get it working. I am looking at old computers in my basement to see if there are any other candidates to host the program!

                  Mike

                  --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
                  >
                  >
                  > Are you running the latest version?
                  >
                  > I would try this, assuming you have enough HD space.
                  >
                  > Go to log screen, un-check "Errors Only" as well as all the of check boxes associated with the servers.
                  >
                  > Check "Show Console Com. Errors".
                  >
                  > Check "Save to File".
                  >
                  > After it locks up the next time, go to the C:\Program Files\WUHU directory, you will find a file called "WUHU Log.txt" that you can open in Notepad. Maybe that will show more detail.
                  >
                  > I may need to create a special version that logs every call made to the DLL to determine where it is getting stuck.
                  >
                  > Lets try this first.
                  >
                  >
                  > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
                  > >
                  > > Well, back to square one. Worked for about 5 and 1/2 hours, then it stopped getting new data. Internet updates went from every 5 minutes to about a couple times an hour at a variable interval, but repeatedly the giving the same data as a current reading.
                  > >
                  > > There was no noticeable change to CPU usage or pagefile size. There was nothing noted in the log.
                  > >
                  > > This was with the port replicator disconnected and using the Belkin device for USB to serial instead.
                  > >
                  > > Any other ideas?
                  > >
                  > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                  > > >
                  > > >
                  > > > I would lean toward the port replicator as the problem.
                  > > >
                  > > > Anytime you have USB to serial adapters, this can be an issue.
                  > > >
                  > > > It is possible that the Davis DLL is stuck somehow.
                  > > >
                  > > > Try checking "Show console Com. Errors" in the log window, perhaps that will lead to a clue.
                  > > >
                  > > >
                  > > > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
                  > > > >
                  > > > > I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.
                  > > > >
                  > > > > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.
                  > > > >
                  > > > > Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).
                  > > > >
                  > > > > The program apparently then slows until it freezes up after a couple more hours.
                  > > > >
                  > > > > I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.
                  > > > >
                  > > > > Any ideas would be helpful. Thanks in advance.
                  > > > >
                  > > >
                  > >
                  >
                • wuhu_software
                  No worries, we will get to the bottom of it one way or another.
                  Message 8 of 9 , Mar 19, 2010
                  • 0 Attachment
                    No worries, we will get to the bottom of it one way or another.


                    --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@...> wrote:
                    >
                    > I am running version 216, log is now set up as requested. There is plenty of HD space, 11 GB open.
                    >
                    > Let me express my thanks for your efforts, this is obviously a unique issue. I like the software and one way or another, I'll get it working. I am looking at old computers in my basement to see if there are any other candidates to host the program!
                    >
                    > Mike
                    >
                    > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                    > >
                    > >
                    > > Are you running the latest version?
                    > >
                    > > I would try this, assuming you have enough HD space.
                    > >
                    > > Go to log screen, un-check "Errors Only" as well as all the of check boxes associated with the servers.
                    > >
                    > > Check "Show Console Com. Errors".
                    > >
                    > > Check "Save to File".
                    > >
                    > > After it locks up the next time, go to the C:\Program Files\WUHU directory, you will find a file called "WUHU Log.txt" that you can open in Notepad. Maybe that will show more detail.
                    > >
                    > > I may need to create a special version that logs every call made to the DLL to determine where it is getting stuck.
                    > >
                    > > Lets try this first.
                    > >
                    > >
                    > > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
                    > > >
                    > > > Well, back to square one. Worked for about 5 and 1/2 hours, then it stopped getting new data. Internet updates went from every 5 minutes to about a couple times an hour at a variable interval, but repeatedly the giving the same data as a current reading.
                    > > >
                    > > > There was no noticeable change to CPU usage or pagefile size. There was nothing noted in the log.
                    > > >
                    > > > This was with the port replicator disconnected and using the Belkin device for USB to serial instead.
                    > > >
                    > > > Any other ideas?
                    > > >
                    > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                    > > > >
                    > > > >
                    > > > > I would lean toward the port replicator as the problem.
                    > > > >
                    > > > > Anytime you have USB to serial adapters, this can be an issue.
                    > > > >
                    > > > > It is possible that the Davis DLL is stuck somehow.
                    > > > >
                    > > > > Try checking "Show console Com. Errors" in the log window, perhaps that will lead to a clue.
                    > > > >
                    > > > >
                    > > > > --- In wuhu_software_group@yahoogroups.com, "medicmjc" <michael.j.cahill@> wrote:
                    > > > > >
                    > > > > > I am a new WUHU user and am having a problem that I hope someone can help with, but I cannot find a similar post.
                    > > > > >
                    > > > > > I have WUHU running on an older Pentium III laptop with Win XP (SP3) as OS. My device is a Davis Weather Monitor II and I have a Targus PA070 port replicator providing the COM port to USB. The laptop has a "clean" install and is running virtually nothing else.
                    > > > > >
                    > > > > > Here's the problem: After several hours, WUHU quits getting new data from the Weather Monitor, but reports the last dataset as new data to the internet servers. (Results in 'flatline' on any charts).
                    > > > > >
                    > > > > > The program apparently then slows until it freezes up after a couple more hours.
                    > > > > >
                    > > > > > I then need to force the program to close. When the program restarts, everything seems to "catch up" including posting the correct data during the "flatline" period.
                    > > > > >
                    > > > > > Any ideas would be helpful. Thanks in advance.
                    > > > > >
                    > > > >
                    > > >
                    > >
                    >
                  Your message has been successfully submitted and would be delivered to recipients shortly.