Loading ...
Sorry, an error occurred while loading the content.

Graphs resetting to defaults

Expand Messages
  • redred1
    Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I d like to
    Message 1 of 9 , May 18, 2009
    • 0 Attachment
      Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.

      I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."

      I don't see any graph configuration in the WUHU Configuration Data.ini file.

      I am running WUHU 1,0,216,76.

      Any help would be appreciated! Thanks.

      (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
    • oldcessna21
      WUHU_Software, This appears to me to be another problem caused by the graphics program you are using. I would like to propose that the members of this forum
      Message 2 of 9 , May 18, 2009
      • 0 Attachment
        WUHU_Software,
        This appears to me to be another problem caused by the graphics program you are using.
        I would like to propose that the members of this forum donate a few bucks to purchase a better program. I am a retiree, living on a fixed income, but I will start this effort off by pledging $10.00 to the effort. Simply give me a PayPal account and I will send the money. The software you provide us for free is certainly worth that amount and more. Other members-- please respond!
        Dennis




        --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@...> wrote:
        >
        > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
        >
        > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
        >
        > I don't see any graph configuration in the WUHU Configuration Data.ini file.
        >
        > I am running WUHU 1,0,216,76.
        >
        > Any help would be appreciated! Thanks.
        >
        > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
        >
      • wuhu_software
        I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph
        Message 3 of 9 , May 18, 2009
        • 0 Attachment
          I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph INI variables, again, that would need to be created to support restoring the settings.

          Does the machine have a printer? That the usual suspect for run time errors at start up.


          --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@...> wrote:
          >
          > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
          >
          > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
          >
          > I don't see any graph configuration in the WUHU Configuration Data.ini file.
          >
          > I am running WUHU 1,0,216,76.
          >
          > Any help would be appreciated! Thanks.
          >
          > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
          >
        • wuhu_software
          Dennis, I would need to go back and figure out what the upgrade cost of the Tee chart control is. I can probably track that down over the next few days. Since
          Message 4 of 9 , May 18, 2009
          • 0 Attachment
            Dennis,

            I would need to go back and figure out what the upgrade cost of the Tee chart control is. I can probably track that down over the next few days. Since my version is quite old, I doubt that it would be much of a discount.

            Thanks.

            --- In wuhu_software_group@yahoogroups.com, "oldcessna21" <oldcessna21@...> wrote:
            >
            > WUHU_Software,
            > This appears to me to be another problem caused by the graphics program you are using.
            > I would like to propose that the members of this forum donate a few bucks to purchase a better program. I am a retiree, living on a fixed income, but I will start this effort off by pledging $10.00 to the effort. Simply give me a PayPal account and I will send the money. The software you provide us for free is certainly worth that amount and more. Other members-- please respond!
            > Dennis
            >
            >
            >
            >
            > --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@> wrote:
            > >
            > > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
            > >
            > > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
            > >
            > > I don't see any graph configuration in the WUHU Configuration Data.ini file.
            > >
            > > I am running WUHU 1,0,216,76.
            > >
            > > Any help would be appreciated! Thanks.
            > >
            > > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
            > >
            >
          • redred1
            Thanks for the reply. No problem... I just wanted to make sure I wasn t missing something! And yes, there are printers configured on the machine... I only get
            Message 5 of 9 , May 18, 2009
            • 0 Attachment
              Thanks for the reply. No problem... I just wanted to make sure I wasn't missing something!

              And yes, there are printers configured on the machine... I only get the error when I try to run WUHU.exe as an Administrator, which I don't normally do. So it's not a problem.

              I'm a fairly new user of WUHU (couple weeks), and I really like it... I was glad to find s/w that supports WUnderground without forking over $100+! So thanks for all your work on it.

              --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
              >
              >
              > I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph INI variables, again, that would need to be created to support restoring the settings.
              >
              > Does the machine have a printer? That the usual suspect for run time errors at start up.
              >
              >
            • craigoneil
              Hi wuhu_software, Resurrecting a thread from May 2009. I haven t done exhaustive testing but I see some graph settings survive across sessions (eg. which data
              Message 6 of 9 , Jan 27, 2010
              • 0 Attachment
                Hi wuhu_software,

                Resurrecting a thread from May 2009.

                I haven't done exhaustive testing but I see some graph settings survive across sessions (eg. which data series to plot, minimums and maximums on left axis) whilst other settings appear to be reset each time (eg. X axis date format).

                I can see the .tee file being updated with the changes I make, but if I close the graphs and go back in again the .tee file is overwitten by the app, but only some settings are set back to default.

                Now, I'm just guessing at the steps the app is taking, but it seems there might be a spot in there to decide to use the .tee file that already exists rather than calling the bit that does the .tee file rebuild.

                So rather than needing lots of INI file settings for lots of chart variables, you might be able to have just one that said to rebuild or not rebuild the .tee on calling the graph displays, and maybe a "Save graph settings" check box that just changes that INI file value.

                I don't know the inner workings of TeeChart so it might not be possible. Anyway, just a suggestion.

                Apologies for bumping this thread if it truly is dead, but if you're looking for enhancement suggestions this one gets my vote.

                Great app by the way :)
                Cheers, Craig.

                --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
                >
                >
                > I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph INI variables, again, that would need to be created to support restoring the settings.
                >
                > Does the machine have a printer? That the usual suspect for run time errors at start up.
                >
                >
                > --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@> wrote:
                > >
                > > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
                > >
                > > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
                > >
                > > I don't see any graph configuration in the WUHU Configuration Data.ini file.
                > >
                > > I am running WUHU 1,0,216,76.
                > >
                > > Any help would be appreciated! Thanks.
                > >
                > > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
                > >
                >
              • wuhu_software
                About the only default that is imposed that I can recall is to un-zoom the charts and if they are in un-zoomed (all four shown), then the legend is removed.
                Message 7 of 9 , Jan 27, 2010
                • 0 Attachment
                  About the only default that is imposed that I can recall is to un-zoom the charts and if they are in "un-zoomed" (all four shown), then the legend is removed. Other than that, I do not recall any other settings that are set back to the defaults.

                  The Axis scales are probably set to Auto otherwise, if someone changed the scales, they would not be able to see the big picture.

                  Is that what you are referring to?

                  Thanks.


                  --- In wuhu_software_group@yahoogroups.com, "craigoneil" <wobblycoates@...> wrote:
                  >
                  >
                  >
                  > Hi wuhu_software,
                  >
                  > Resurrecting a thread from May 2009.
                  >
                  > I haven't done exhaustive testing but I see some graph settings survive across sessions (eg. which data series to plot, minimums and maximums on left axis) whilst other settings appear to be reset each time (eg. X axis date format).
                  >
                  > I can see the .tee file being updated with the changes I make, but if I close the graphs and go back in again the .tee file is overwitten by the app, but only some settings are set back to default.
                  >
                  > Now, I'm just guessing at the steps the app is taking, but it seems there might be a spot in there to decide to use the .tee file that already exists rather than calling the bit that does the .tee file rebuild.
                  >
                  > So rather than needing lots of INI file settings for lots of chart variables, you might be able to have just one that said to rebuild or not rebuild the .tee on calling the graph displays, and maybe a "Save graph settings" check box that just changes that INI file value.
                  >
                  > I don't know the inner workings of TeeChart so it might not be possible. Anyway, just a suggestion.
                  >
                  > Apologies for bumping this thread if it truly is dead, but if you're looking for enhancement suggestions this one gets my vote.
                  >
                  > Great app by the way :)
                  > Cheers, Craig.
                  >
                  > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                  > >
                  > >
                  > > I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph INI variables, again, that would need to be created to support restoring the settings.
                  > >
                  > > Does the machine have a printer? That the usual suspect for run time errors at start up.
                  > >
                  > >
                  > > --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@> wrote:
                  > > >
                  > > > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
                  > > >
                  > > > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
                  > > >
                  > > > I don't see any graph configuration in the WUHU Configuration Data.ini file.
                  > > >
                  > > > I am running WUHU 1,0,216,76.
                  > > >
                  > > > Any help would be appreciated! Thanks.
                  > > >
                  > > > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
                  > > >
                  > >
                  >
                • craigoneil
                  The setting I m trying to keep at the moment is the label format on the bottom X axis. I want to use d/m hh:nn , but each time I close the graphs and reopen
                  Message 8 of 9 , Jan 27, 2010
                  • 0 Attachment
                    The setting I'm trying to keep at the moment is the label format on the bottom X axis. I want to use "d/m hh:nn", but each time I close the graphs and reopen them it resets to "hh:nn:ss"

                    Conversely, the settings I've changed for min and max on the left axis of the pressure chart (980 to 1030) stay from session to session.

                    Maybe there is something I can do in the graphs | edit panel to save my config for next time?

                    cheers, craig.

                    --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@...> wrote:
                    >
                    >
                    > About the only default that is imposed that I can recall is to un-zoom the charts and if they are in "un-zoomed" (all four shown), then the legend is removed. Other than that, I do not recall any other settings that are set back to the defaults.
                    >
                    > The Axis scales are probably set to Auto otherwise, if someone changed the scales, they would not be able to see the big picture.
                    >
                    > Is that what you are referring to?
                    >
                    > Thanks.
                    >
                    >
                    > --- In wuhu_software_group@yahoogroups.com, "craigoneil" <wobblycoates@> wrote:
                    > >
                    > >
                    > >
                    > > Hi wuhu_software,
                    > >
                    > > Resurrecting a thread from May 2009.
                    > >
                    > > I haven't done exhaustive testing but I see some graph settings survive across sessions (eg. which data series to plot, minimums and maximums on left axis) whilst other settings appear to be reset each time (eg. X axis date format).
                    > >
                    > > I can see the .tee file being updated with the changes I make, but if I close the graphs and go back in again the .tee file is overwitten by the app, but only some settings are set back to default.
                    > >
                    > > Now, I'm just guessing at the steps the app is taking, but it seems there might be a spot in there to decide to use the .tee file that already exists rather than calling the bit that does the .tee file rebuild.
                    > >
                    > > So rather than needing lots of INI file settings for lots of chart variables, you might be able to have just one that said to rebuild or not rebuild the .tee on calling the graph displays, and maybe a "Save graph settings" check box that just changes that INI file value.
                    > >
                    > > I don't know the inner workings of TeeChart so it might not be possible. Anyway, just a suggestion.
                    > >
                    > > Apologies for bumping this thread if it truly is dead, but if you're looking for enhancement suggestions this one gets my vote.
                    > >
                    > > Great app by the way :)
                    > > Cheers, Craig.
                    > >
                    > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                    > > >
                    > > >
                    > > > I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph INI variables, again, that would need to be created to support restoring the settings.
                    > > >
                    > > > Does the machine have a printer? That the usual suspect for run time errors at start up.
                    > > >
                    > > >
                    > > > --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@> wrote:
                    > > > >
                    > > > > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
                    > > > >
                    > > > > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
                    > > > >
                    > > > > I don't see any graph configuration in the WUHU Configuration Data.ini file.
                    > > > >
                    > > > > I am running WUHU 1,0,216,76.
                    > > > >
                    > > > > Any help would be appreciated! Thanks.
                    > > > >
                    > > > > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
                    > > > >
                    > > >
                    > >
                    >
                  • wuhu_software
                    The label format should stay as you select it. When you close the editor, it should save the .tee file at that moment. That is loaded up the next time you
                    Message 9 of 9 , Jan 28, 2010
                    • 0 Attachment
                      The label format should stay as you select it. When you close the editor, it should save the .tee file at that moment. That is loaded up the next time you start the application. I will double check to see whether the labels are somehow reset at start up. It is possible that there is a bug in the control so far as the .tee file is concerned.

                      The range on the pressure chart is probably reset. If I do not turn on auto scaling, you can bet there will be many posts about people who cannot see all of their data as the scaling is not automatic.


                      --- In wuhu_software_group@yahoogroups.com, "craigoneil" <wobblycoates@...> wrote:
                      >
                      >
                      >
                      >
                      >
                      >
                      >
                      > The setting I'm trying to keep at the moment is the label format on the bottom X axis. I want to use "d/m hh:nn", but each time I close the graphs and reopen them it resets to "hh:nn:ss"
                      >
                      > Conversely, the settings I've changed for min and max on the left axis of the pressure chart (980 to 1030) stay from session to session.
                      >
                      > Maybe there is something I can do in the graphs | edit panel to save my config for next time?
                      >
                      > cheers, craig.
                      >
                      > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                      > >
                      > >
                      > > About the only default that is imposed that I can recall is to un-zoom the charts and if they are in "un-zoomed" (all four shown), then the legend is removed. Other than that, I do not recall any other settings that are set back to the defaults.
                      > >
                      > > The Axis scales are probably set to Auto otherwise, if someone changed the scales, they would not be able to see the big picture.
                      > >
                      > > Is that what you are referring to?
                      > >
                      > > Thanks.
                      > >
                      > >
                      > > --- In wuhu_software_group@yahoogroups.com, "craigoneil" <wobblycoates@> wrote:
                      > > >
                      > > >
                      > > >
                      > > > Hi wuhu_software,
                      > > >
                      > > > Resurrecting a thread from May 2009.
                      > > >
                      > > > I haven't done exhaustive testing but I see some graph settings survive across sessions (eg. which data series to plot, minimums and maximums on left axis) whilst other settings appear to be reset each time (eg. X axis date format).
                      > > >
                      > > > I can see the .tee file being updated with the changes I make, but if I close the graphs and go back in again the .tee file is overwitten by the app, but only some settings are set back to default.
                      > > >
                      > > > Now, I'm just guessing at the steps the app is taking, but it seems there might be a spot in there to decide to use the .tee file that already exists rather than calling the bit that does the .tee file rebuild.
                      > > >
                      > > > So rather than needing lots of INI file settings for lots of chart variables, you might be able to have just one that said to rebuild or not rebuild the .tee on calling the graph displays, and maybe a "Save graph settings" check box that just changes that INI file value.
                      > > >
                      > > > I don't know the inner workings of TeeChart so it might not be possible. Anyway, just a suggestion.
                      > > >
                      > > > Apologies for bumping this thread if it truly is dead, but if you're looking for enhancement suggestions this one gets my vote.
                      > > >
                      > > > Great app by the way :)
                      > > > Cheers, Craig.
                      > > >
                      > > > --- In wuhu_software_group@yahoogroups.com, "wuhu_software" <wuhu_software@> wrote:
                      > > > >
                      > > > >
                      > > > > I understand your issue with charting. Added features to retain which variables you have displayed is doable but takes time to implement. There are no graph INI variables, again, that would need to be created to support restoring the settings.
                      > > > >
                      > > > > Does the machine have a printer? That the usual suspect for run time errors at start up.
                      > > > >
                      > > > >
                      > > > > --- In wuhu_software_group@yahoogroups.com, "redred1" <redred1@> wrote:
                      > > > > >
                      > > > > > Every time WUHU starts, the selected graphs are reset to the defaults (e.g., Outdoor Temperature, Outdoor Humidity, Outdoor Dewpoint selected). I'd like to not have to select my desired graphs every time the program starts.
                      > > > > >
                      > > > > > I am running Vista x64 and thought it might be because the program isn't run as administrator, but when I try to run it as administrator, I get "Runtime Error 217 at 00021AEE"... and then "Unable to Create Chart Dialog."
                      > > > > >
                      > > > > > I don't see any graph configuration in the WUHU Configuration Data.ini file.
                      > > > > >
                      > > > > > I am running WUHU 1,0,216,76.
                      > > > > >
                      > > > > > Any help would be appreciated! Thanks.
                      > > > > >
                      > > > > > (P.S. I searched the message forum for a solution to this problem but didn't find any... so apologies if this has already been covered!)
                      > > > > >
                      > > > >
                      > > >
                      > >
                      >
                    Your message has been successfully submitted and would be delivered to recipients shortly.