Loading ...
Sorry, an error occurred while loading the content.

19847Re: [wuhu_software_group] Re: Memory usage by WUHU

Expand Messages
  • David Lipper
    Oct 30, 2011
    • 0 Attachment
      Okay, with the file path corrected, the memory usage grew by about 4MB in 24 hours from startup; 16 to 20MB.
      This is running .198.  It's more than an order of magnitude better than before.
      The growth may be attributed to me using graphs and wind rose -- it seemed to increase the first time I used those,

      and then stabilized.  I think the problem is solved.  I am now going to restart using .200.
      ...
      .200 is 24 MB right after startup.

      On 2011-10-29 13:59, wuhu_software wrote:
       

      Well that helps explain a lot.

      As it turns out, the Microsoft MFC library was throwing exceptions. Although the exceptions were caught, preventing a program crash, the memory associated with the exception was not released back, resulting in memory leaks. Because there were many many attempts to write the currdat.lst file, as it can be hundreds of lines, many leaks happened.

      I have gone through the code and released the memory when these file exceptions occur.

      Thanks for getting to the bottom of the problem.

      See:



      --- In wuhu_software_group@yahoogroups.com, David Lipper <glenvilleweather@...> wrote:
      >
      > An excellent suggestion! I did that, and collected a large number of events.
      > On first examination, I found that many of them were failures to write to the OutputDataFilePath,
      > which was a setting in "WUHU Configuration Data.ini" I left when copied from another computer.
      > The path did not exist on the new computer, so it could not open it.
      >
      > I changed the setting (required me to exit the program; start/stop did not work).
      > Now, those error events are gone, and the computer seems (subjectively) less loaded.
      >
      > I still do see some errors in the event log like RegQueryValue and RegOpenKey returning NAME NOT FOUND.
      > The keys in question are ...\EnableAutodial and ...\Http Filters\RPA. I assume these types of errors are okay?
      >
      > Memory usage is a bit less than 15+ MB at the start. I am hopeful that it will not grow without bound.
      >
      > Thanks again!

    • Show all 46 messages in this topic