Loading ...
Sorry, an error occurred while loading the content.

Getting transmit to work

Expand Messages
  • Tim Gimmel
    I have wsjtx r3222 compiled and working, receives just fine, rigcat is working, I can get frequency fb. But cannot get it to transmit. Using Rigblaster plug
    Message 1 of 5 , Apr 25 4:36 PM
    • 0 Attachment
      I have wsjtx r3222 compiled and working, receives just fine, rigcat is
      working, I can get frequency fb. But cannot get it to transmit. Using
      Rigblaster plug 'n Play and USB serial for rigcat. Anyone have suggestions?
      (Running Ubuntu 12.04LTS on a old thinkpad)

      Thanks much!
      73,
      Tim
      KY4J
    • Tim Gimmel
      ... Mike, I was able to get my transmit to work, first thing I had to do was pull out my Rigblaster Plug n Play and go back to my old style of interface. I
      Message 2 of 5 , Apr 26 11:32 AM
      • 0 Attachment
        On 04/26/2013 11:40 AM, mike.k0ter wrote:
        >
        > --- In wsjtgroup@yahoogroups.com, Tim Gimmel <tim@...> wrote:
        >> I have wsjtx r3222 compiled and working, receives just fine, rigcat is
        >> working, I can get frequency fb. But cannot get it to transmit. Using
        >> Rigblaster plug 'n Play and USB serial for rigcat. Anyone have suggestions?
        >> (Running Ubuntu 12.04LTS on a old thinkpad)
        > Same thing with me. So far I haven't heard of anyone getting
        > the transmit to work.
        >
        > I'm using a core 2 duo desktop with a SignaLink USB sound card
        > device.
        >
        > Mike, K0TER
        >
        >
        Mike,
        I was able to get my transmit to work, first thing I had to do was
        pull out my Rigblaster Plug 'n Play and go back to my old style of
        interface. I have a Yaesu FT-950 and I can put into packet mode and the
        tone from the program will activate the VOX. It appears the subsystem
        on the PTT using /dev/ttyUSBXX or /dev/ttySXX is not complete yet for
        Linux. The CAT interface will not make the PTT work on the FT-950 for
        some reason.

        Also I created an .asoundrc file in my home directory:
        pcm.radio {
        type hw
        card 0
        device 0
        }
        pcm_slave.radioslave {
        pcm radio
        rate 48000
        }
        pcm.radioconv {
        type rate
        slave radioslave
        }
        So in set-up my audio in is "radio" and my audio out is "radioconv". I
        am not convinced how much difference this makes, but everything is so
        fragile rite now I have not done too much experimenting. I just ticked
        I have it all working!
        So I have been on vacation this week and have put a lot of hours into
        making this work, hopefully as time progresses it will all get easier.
        Hope this help!
        73,
        Tim
        KY4J
      • Tim Gimmel
        ... Mike, I need to make a correction in my statements above, the CAT IS actually causing the PTT to work. It became clear to me because after r3222 it has
        Message 3 of 5 , Apr 26 12:26 PM
        • 0 Attachment
          On 04/26/2013 01:32 PM, Tim Gimmel wrote:
          > On 04/26/2013 11:40 AM, mike.k0ter wrote:
          >>
          >> --- In wsjtgroup@yahoogroups.com, Tim Gimmel <tim@...> wrote:
          >>> I have wsjtx r3222 compiled and working, receives just fine, rigcat is
          >>> working, I can get frequency fb. But cannot get it to transmit. Using
          >>> Rigblaster plug 'n Play and USB serial for rigcat. Anyone have
          >>> suggestions?
          >>> (Running Ubuntu 12.04LTS on a old thinkpad)
          >> Same thing with me. So far I haven't heard of anyone getting
          >> the transmit to work.
          >>
          >> I'm using a core 2 duo desktop with a SignaLink USB sound card
          >> device.
          >>
          >> Mike, K0TER
          >>
          >>
          > Mike,
          > I was able to get my transmit to work, first thing I had to do was
          > pull out my Rigblaster Plug 'n Play and go back to my old style of
          > interface. I have a Yaesu FT-950 and I can put into packet mode and
          > the tone from the program will activate the VOX. It appears the
          > subsystem on the PTT using /dev/ttyUSBXX or /dev/ttySXX is not
          > complete yet for Linux. The CAT interface will not make the PTT work
          > on the FT-950 for some reason.
          >
          > Also I created an .asoundrc file in my home directory:
          > pcm.radio {
          > type hw
          > card 0
          > device 0
          > }
          > pcm_slave.radioslave {
          > pcm radio
          > rate 48000
          > }
          > pcm.radioconv {
          > type rate
          > slave radioslave
          > }
          > So in set-up my audio in is "radio" and my audio out is "radioconv".
          > I am not convinced how much difference this makes, but everything is
          > so fragile rite now I have not done too much experimenting. I just
          > ticked I have it all working!
          > So I have been on vacation this week and have put a lot of hours into
          > making this work, hopefully as time progresses it will all get easier.
          > Hope this help!
          > 73,
          > Tim
          > KY4J
          Mike,
          I need to make a correction in my statements above, the CAT IS actually
          causing the PTT to work. It became clear to me because after r3222 it
          has been broke and I can see more clearly how the rig is being keyed.
          For most of the calls to hamlib you will see the results in the terminal
          window, but for whatever reason the PTT call does not show up.
          Sorry for the misinformation above.

          73,
          Tim
          KY4J
        • Tim Gimmel
          ... This is for Linux, you can get the source: svn co svn://svn.berlios.de/wsjt/branches/wsjtx -r 3222 You will need to have subversion installed. Have fun!
          Message 4 of 5 , Apr 26 1:41 PM
          • 0 Attachment
            On 04/26/2013 03:14 PM, randy376582512 wrote:
            > WSJTX r3222? Is this the latest revision? Is it for Windows?
            > If so, where can I download it? The latest version I find on WSJT homepage is r2195.
            >
            > Thanks & 73
            > Randy
            > K5RCD
            This is for Linux, you can get the source:
            svn co svn://svn.berlios.de/wsjt/branches/wsjtx -r 3222

            You will need to have subversion installed.

            Have fun!
            73,
            Tim
            KY4J

            >
            > --- In wsjtgroup@yahoogroups.com, Tim Gimmel <tim@...> wrote:
            >> On 04/26/2013 01:32 PM, Tim Gimmel wrote:
            >>> On 04/26/2013 11:40 AM, mike.k0ter wrote:
            >>>> --- In wsjtgroup@yahoogroups.com, Tim Gimmel <tim@> wrote:
            >>>>> I have wsjtx r3222 compiled and working, receives just fine, rigcat is
            >>>>> working, I can get frequency fb. But cannot get it to transmit. Using
            >>>>> Rigblaster plug 'n Play and USB serial for rigcat. Anyone have
            >>>>> suggestions?
            >>>>> (Running Ubuntu 12.04LTS on a old thinkpad)
            >>>> Same thing with me. So far I haven't heard of anyone getting
            >>>> the transmit to work.
            >>>>
            >>>> I'm using a core 2 duo desktop with a SignaLink USB sound card
            >>>> device.
            >>>>
            >>>> Mike, K0TER
            >>>>
            >>>>
            >>> Mike,
            >>> I was able to get my transmit to work, first thing I had to do was
            >>> pull out my Rigblaster Plug 'n Play and go back to my old style of
            >>> interface. I have a Yaesu FT-950 and I can put into packet mode and
            >>> the tone from the program will activate the VOX. It appears the
            >>> subsystem on the PTT using /dev/ttyUSBXX or /dev/ttySXX is not
            >>> complete yet for Linux. The CAT interface will not make the PTT work
            >>> on the FT-950 for some reason.
            >>>
            >>> Also I created an .asoundrc file in my home directory:
            >>> pcm.radio {
            >>> type hw
            >>> card 0
            >>> device 0
            >>> }
            >>> pcm_slave.radioslave {
            >>> pcm radio
            >>> rate 48000
            >>> }
            >>> pcm.radioconv {
            >>> type rate
            >>> slave radioslave
            >>> }
            >>> So in set-up my audio in is "radio" and my audio out is "radioconv".
            >>> I am not convinced how much difference this makes, but everything is
            >>> so fragile rite now I have not done too much experimenting. I just
            >>> ticked I have it all working!
            >>> So I have been on vacation this week and have put a lot of hours into
            >>> making this work, hopefully as time progresses it will all get easier.
            >>> Hope this help!
            >>> 73,
            >>> Tim
            >>> KY4J
            >> Mike,
            >> I need to make a correction in my statements above, the CAT IS actually
            >> causing the PTT to work. It became clear to me because after r3222 it
            >> has been broke and I can see more clearly how the rig is being keyed.
            >> For most of the calls to hamlib you will see the results in the terminal
            >> window, but for whatever reason the PTT call does not show up.
            >> Sorry for the misinformation above.
            >>
            >> 73,
            >> Tim
            >> KY4J
            >>
            >
          • Tim Gimmel
            ... My audio is going into the rig via the accessory jack of the FT-950 via my old home brew interface, completely bypassing rigblaster. That is the secret
            Message 5 of 5 , Apr 26 6:26 PM
            • 0 Attachment
              On 04/26/2013 08:09 PM, Mike Stansberry wrote:
              > KY4J
              >> Mike,
              >> I need to make a correction in my statements above, the CAT IS
              >> actually causing the PTT to work. It became clear to me because
              >> after r3222 it has been broke and I can see more clearly how the rig
              >> is being keyed. For most of the calls to hamlib you will see the
              >> results in the terminal window, but for whatever reason the PTT call
              >> does not show up.
              >> Sorry for the misinformation above.
              >
              > I'm not getting enough TX audio for my SignaLink's built in VOX to
              > work. I'll work with it some more tomorrow.
              >
              > Thanks and 73,
              >
              > Mike, K0TER
              >
              My audio is going into the rig via the accessory jack of the FT-950 via
              my old home brew interface, completely bypassing rigblaster. That is the
              secret sauce. Check to see if you have audio coming out of the headset
              jack.

              73,
              Tim
              KY4J
            Your message has been successfully submitted and would be delivered to recipients shortly.