Loading ...
Sorry, an error occurred while loading the content.
 

Re: [wsjtgroup] Re: CAT CONTROL NOT WORKING.- K3

Expand Messages
  • Joe Subich, W4TV
    I took a look at wsjtx 0.8r3113 and microHAM MK II this evening. CAT control works correctly with microHAM Router 8.3.1 and the K3. The primary CAT port is
    Message 1 of 22 , Apr 1, 2013
      I took a look at wsjtx 0.8r3113 and microHAM MK II this evening.
      CAT control works correctly with microHAM Router 8.3.1 and the K3.
      The primary CAT port is DXLab Suite (CI-V Commander) at 38.400 bps.
      WSJTx is configured to use the 2nd CAT port also at 38,400 bps.
      The K3 changes bands flawlessly as I change bands in the drop-down.

      CU-V Commander must be set to a Command Interval >= 300 msec or it will
      monopolize the K3's serial capacity and cause intermittent (erratic)
      operation when sharing the serial capability. It is important to have
      at least 300 msec between commands with the K3 - particularly for band
      changes - as the K3 can stop responding to the serial port for up to
      250 msec following a command that results in a band change. If microHAM
      Router sees a command without a matching response from the K3, it must
      flush the buffers and resynchronize to assure that the responses from
      the K3 are routed to the virtual port that issued the command/poll that
      generated the response.

      This poll/response matching is important to prevent problems when using
      simultaneous control of one transceiver by two applications.

      73,

      ... Joe, W4TV


      On 3/28/2013 10:30 PM, Joe Subich, W4TV wrote:
      >
      > I am away at the moment ... I will check the new CAT interface with
      > the K3 and microHAM interfaces when I get back to the rig next week.
      > However, it is likely that a quick - open the port, send a data burst,
      > close the port will be problematic with virtual ports like the Eltima
      > ports used by microHAM Router - particularly if you are trying to use
      > two COM ports (logger and WSJT-x) - due to critical timing issues.
      >
      > 73,
      >
      > ... Joe Subich, W4TV
      > microHAM America, LLC.
      > http://www.microHAM-USA.com
      > http://groups.yahoo.com/group/microHAM
      >
      >
      > On 3/28/2013 9:55 PM, dachema wrote:
      >> Thanks for the replies. I am still unable to get CAT working on the K3. I tried selecting the Kenwood TS-2000 from the list of rigs but still no luck. CAT works with N1MM and Commander, just not with WSJT-X. I don't know what else to try. I am not using an LP Bridge. I realize that when I select a different band from the dropdown in WSJT-X that the radio should change to the chosen band and frequency. That is not happening here with the K3. As stated before, I am using a microHAM MK II and it works with Commander and JT65-HF flawlessly. It just isn't working with WSJT-X.
      >>
      >> Dave, KC8V
      >>
      >> --- In wsjtgroup@yahoogroups.com, "KD8LCD Cinci" <kd8lcd@...> wrote:
      >>>
      >>> Switch to that band and frequency Is pretty much all it was setup to do
      >>>
      >>>
      >>>
      >>> Band and frequency, it's not meant to be a full blown Cat control,
      >>>
      >>>
      >>>
      >>> It is just a quick convince frequency/band switching control
      >>>
      >>>
      >>>
      >>>
      >>>
      >>> KD8LCD
      >>>
      >>> From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf
      >>> Of Dan Bates
      >>> Sent: Thursday, March 28, 2013 8:49 PM
      >>> To: 'Sebastian, W4AS'; 'WSJT Group'
      >>> Subject: RE: [wsjtgroup] CAT CONTROL NOT WORKING.
      >>>
      >>>
      >>>
      >>>
      >>>
      >>> Well it does seem to be working on the K3 now. Don't know what I did, but
      >>> When I select a new band on the dropdown, it switches the K3 to that band
      >>> and frequency.
      >>>
      >>>
      >>>
      >>> Dan n5tm
      >>>
      >>>
      >>>
      >>> From: Sebastian, W4AS [mailto:w4as@...]
      >>> Sent: Thursday, March 28, 2013 7:11 PM
      >>> To: WSJT Group
      >>> Subject: Re: [wsjtgroup] CAT CONTROL NOT WORKING.
      >>>
      >>>
      >>>
      >>>
      >>>
      >>> Yes and no.
      >>>
      >>> If I select K3 from the list of rigs, CAT doesn't work for me on my K3.
      >>> However, if I select Kenwood TS-2000, then it does work. I think I read
      >>> somewhere the CAT commands for the K3 are similar to a TS-2000.
      >>>
      >>> However, I'm using LP Bridge so perhaps that has something to do with it.
      >>>
      >>> 73 de Sebastian, W4AS
      >>>
      >>> On Mar 28, 2013, at 6:08 PM, dachema <dchema@...
      >>> <mailto:dchema%40gmail.com> > wrote:
      >>>
      >>>>
      >>>>
      >>>> Has anyone had any luck getting CAT control to work with the Elecraft K3?
      >>> It is not working for me. When I change the frequency in the dropdown in
      >>> WSJT-X, the display on the radio does not change. My settings are COM2,
      >>> 38400, N81 using Commander from DXLab and a microham MK II. It appears there
      >>> is no communication between the software and the K3.
      >>>>
      >>>> 73,
      >>>> Dave, KC8V
      >>>>
      >>>> --- In wsjtgroup@yahoogroups.com <mailto:wsjtgroup%40yahoogroups.com> ,
      >>> "g4ilo" <julian.g4ilo@> wrote:
      >>>>>
      >>>>> It doesn't work properly with my K3 under WinXP either. You can change
      >>> band using the drop-down above the level control but if you use the VFO or
      >>> band buttons on the rig the changes are not reflected in the program.
      >>>>>
      >>>>> I tried K2 and some of the Kenwood options as well with the same result.
      >>> Perhaps it isn't meant to work in that direction?
      >>>>>
      >>>>> Julian, G4ILO
      >>>>>
      >>>>> --- In wsjtgroup@yahoogroups.com <mailto:wsjtgroup%40yahoogroups.com> ,
      >>> "Dan Bates" <n5tm@> wrote:
      >>>>>>
      >>>>>> Same thing here trying to run with K3. PTT works fine, but there appears
      >>> to
      >>>>>> be no communications with the radio. I would assume the frequency would
      >>>>>> indicate the K3 dial frequency but it just stays on the dropdown setting
      >>> (ie
      >>>>>> 14078).
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>> K3 com settings: 38400 N,8,1
      >>>>>>
      >>>>>>
      >>>>>>
      >>>>>> Dan n5tm
      >>>
      >>
      >>
      >>
      >>
      >> ------------------------------------
      >>
      >> To unsubscribe, send an email to:
      >> wsjtgroup-unsubscribe@yahoogroups.com
      >>
      >> WSJTGroup HomePage http://www.meteorscatter.org/
      >>
      >>
      >>
      >>
      >>
      >> Yahoo! Groups Links
      >>
      >>
      >>
      >>
      >
      >
      > ------------------------------------
      >
      > To unsubscribe, send an email to:
      > wsjtgroup-unsubscribe@yahoogroups.com
      >
      > WSJTGroup HomePage http://www.meteorscatter.org/
      >
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    • David Chema
      Joe, Thanks for your response. I finally have CAT control working with WSJTx, Commander, and the K3. My primary CAT port in the microHAM router is COM2. I
      Message 2 of 22 , Apr 2, 2013
        Joe,
         
        Thanks for your response.  I finally have CAT control working with WSJTx, Commander, and the K3.  My primary CAT port in the microHAM router is COM2.  I created a second virtual port COM4 in the router and assigned the secondary CAT port to it.  Once I pointed WSJTx to COM4 for CAT I had CAT control between WSJTx, Commander, and the K3.  All is working well now for me with CAT control.  My Command Interval is set to 300 msec, so I was okay there.
         
        Thanks again for your help.  It's much appreciated!
         
        73,
         
        Dave, KC8V


        On Mon, Apr 1, 2013 at 7:52 PM, Joe Subich, W4TV <lists@...> wrote:

        I took a look at wsjtx 0.8r3113 and microHAM MK II this evening.
        CAT control works correctly with microHAM Router 8.3.1 and the K3.
        The primary CAT port is DXLab Suite (CI-V Commander) at 38.400 bps.
        WSJTx is configured to use the 2nd CAT port also at 38,400 bps.
        The K3 changes bands flawlessly as I change bands in the drop-down.

        CU-V Commander must be set to a Command Interval >= 300 msec or it will
        monopolize the K3's serial capacity and cause intermittent (erratic)
        operation when sharing the serial capability.  It is important to have
        at least 300 msec between commands with the K3 - particularly for band
        changes - as the K3 can stop responding to the serial port for up to
        250 msec following a command that results in a band change.  If microHAM
        Router sees a command without a matching response from the K3, it must
        flush the buffers and resynchronize to assure that the responses from
        the K3 are routed to the virtual port that issued the command/poll that
        generated the response.

        This poll/response matching is important to prevent problems when using
        simultaneous control of one transceiver by two applications.

        73,

           ... Joe, W4TV



        On 3/28/2013 10:30 PM, Joe Subich, W4TV wrote:

        I am away at the moment ...  I will check the new CAT interface with
        the K3 and microHAM interfaces when I get back to the rig next week.
        However, it is likely that a quick - open the port, send a data burst,
        close the port will be problematic with virtual ports like the Eltima
        ports used by microHAM Router - particularly if you are trying to use
        two COM ports (logger and WSJT-x) - due to critical timing issues.

        73,

             ... Joe Subich, W4TV
                 microHAM America, LLC.
                 http://www.microHAM-USA.com
                 http://groups.yahoo.com/group/microHAM


        On 3/28/2013 9:55 PM, dachema wrote:
        Thanks for the replies.  I am still unable to get CAT working on the K3.  I tried selecting the Kenwood TS-2000 from the list of rigs but still no luck.  CAT works with N1MM and Commander, just not with WSJT-X.  I don't know what else to try.  I am not using an LP Bridge.  I realize that when I select a different band from the dropdown in WSJT-X that the radio should change to the chosen band and frequency.  That is not happening here with the K3.  As stated before, I am using a microHAM MK II and it works with Commander and JT65-HF flawlessly.  It just isn't working with WSJT-X.

        Dave, KC8V

        --- In wsjtgroup@yahoogroups.com, "KD8LCD Cinci" <kd8lcd@...> wrote:

        Switch to that band and frequency Is pretty much all it was setup to do



        Band and frequency, it's not meant to be a full blown Cat control,



        It is just a quick convince frequency/band switching control





        KD8LCD

        From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf
        Of Dan Bates
        Sent: Thursday, March 28, 2013 8:49 PM
        To: 'Sebastian, W4AS'; 'WSJT Group'
        Subject: RE: [wsjtgroup] CAT CONTROL NOT WORKING.





        Well it does seem to be working on the K3 now.  Don't know what I did, but
        When I select a new band on the dropdown, it switches the K3 to that band
        and frequency.



        Dan n5tm



        From: Sebastian, W4AS [mailto:w4as@...]
        Sent: Thursday, March 28, 2013 7:11 PM
        To: WSJT Group
        Subject: Re: [wsjtgroup] CAT CONTROL NOT WORKING.





        Yes and no.

        If I select K3 from the list of rigs, CAT doesn't work for me on my K3.
        However, if I select Kenwood TS-2000, then it does work. I think I read
        somewhere the CAT commands for the K3 are similar to a TS-2000.

        However, I'm using LP Bridge so perhaps that has something to do with it.

        73 de Sebastian, W4AS

        On Mar 28, 2013, at 6:08 PM, dachema <dchema@...
        <mailto:dchema%40gmail.com> > wrote:



        Has anyone had any luck getting CAT control to work with the Elecraft K3?
        It is not working for me. When I change the frequency in the dropdown in
        WSJT-X, the display on the radio does not change. My settings are COM2,
        38400, N81 using Commander from DXLab and a microham MK II. It appears there
        is no communication between the software and the K3.

        73,
        Dave, KC8V

        --- In wsjtgroup@yahoogroups.com <mailto:wsjtgroup%40yahoogroups.com> ,
        "g4ilo" <julian.g4ilo@> wrote:

        It doesn't work properly with my K3 under WinXP either. You can change
        band using the drop-down above the level control but if you use the VFO or
        band buttons on the rig the changes are not reflected in the program.

        I tried K2 and some of the Kenwood options as well with the same result.
        Perhaps it isn't meant to work in that direction?

        Julian, G4ILO

        --- In wsjtgroup@yahoogroups.com <mailto:wsjtgroup%40yahoogroups.com> ,
        "Dan Bates" <n5tm@> wrote:

        Same thing here trying to run with K3. PTT works fine, but there appears
        to
        be no communications with the radio. I would assume the frequency would
        indicate the K3 dial frequency but it just stays on the dropdown setting
        (ie
        14078).



        K3 com settings: 38400 N,8,1



        Dan n5tm





        ------------------------------------

        To unsubscribe, send an email to:
        wsjtgroup-unsubscribe@yahoogroups.com

        WSJTGroup HomePage http://www.meteorscatter.org/





        Yahoo! Groups Links






        ------------------------------------

        To unsubscribe, send an email to:
        wsjtgroup-unsubscribe@yahoogroups.com

        WSJTGroup HomePage http://www.meteorscatter.org/





        Yahoo! Groups Links

        <*> To visit your group on the web, go to:
             http://groups.yahoo.com/group/wsjtgroup/

        <*> Your email settings:
             Individual Email | Traditional

        <*> To change settings online go to:
             http://groups.yahoo.com/group/wsjtgroup/join
             (Yahoo! ID required)

        <*> To change settings via email:
             wsjtgroup-digest@yahoogroups.com
             wsjtgroup-fullfeatured@yahoogroups.com

        <*> To unsubscribe from this group, send an email to:
             wsjtgroup-unsubscribe@yahoogroups.com

        <*> Your use of Yahoo! Groups is subject to:
             http://docs.yahoo.com/info/terms/



      Your message has been successfully submitted and would be delivered to recipients shortly.