Loading ...
Sorry, an error occurred while loading the content.
 

Re: WSJT 9.1 "Error: sh: KVASD_g95: not found" Fix?

Expand Messages
  • larryj_75
    Problem Solved. Thanks to KD, W5YR! The problem was that binary KVASD_g95 was not in a directory included in my $PATH. Here s what I did to verify and
    Message 1 of 2 , Nov 27, 2011
      Problem Solved. Thanks to KD, W5YR! The problem was that binary KVASD_g95 was not in a directory included in my $PATH. Here's what I did to verify and then fix the problem.

      1. First I verified that $PATH environmental variable DID NOT include the directory where KVASD_g95 was located:
      lj@lian2:~$ echo $PATH
      /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

      lj@lian2:~$ locate KVASD_g95
      /home/lj/wsjt/wsjt-code/KVASD_g95
      ...

      2. So I put a copy of KVASD_95 in /usr/local/bin which IS in the $PATH:
      lj@lian2:~$ ls -al /usr/local/bin
      total 424
      drwxr-xr-x 2 lj root 4096 2011-11-27 07:46 .
      drwxr-xr-x 10 root root 4096 2010-04-29 06:17 ..
      -rwxr-xr-x 1 lj lj 425598 2011-11-21 14:38 KVASD_g95

      3. Then I verified that my copy KVASD_g95 was in a directory included in the $PATH variable;
      lj@lian2:~$ whereis KVASD_g95
      KVASD_g95: /usr/local/bin/KVASD_g95

      4. I also changed the ownership of the /usr/local/bin to my local user.:
      lj@lian2:~$ sudo chown lj /usr/local/bin

      5. Next I should determine why all my object code (*.o files) are dumped into the wsjt_code directory. Must be something wrong with the configure. I would expect that the output from the compilation would be dumped in a separate directory, say /usr/local/bin for example. Also it's odd that the WSJT binary wasn't found and read from the source code directory where all the other files are. Must be that KVASD_g95 is not invoked with ./KVASD_95

      So the problem wasn't a 64bit vs 32 bit problem after all.

      Larry W0AY



      --- In wsjtgroup@yahoogroups.com, "larryj_75" <larry@...> wrote:
      >
      > 1. When I start WSJT 9.1 r2473 in a terminal, an error is kicked back:
      > sh: KVASD_g95: not foundError in KV decoder, or no KV decoder
      > present.Return code: 32512. Will use BM algorithm.
      > 2. I assumed the error is caused because the binary KVASD_95 was
      > compiled for 32 bit systems and my 64bit Ubuntu 10.04 doesn't know what
      > to do with a 32 bit compiled binary which is not supported in my
      > installed 64 bit compatibility ia32-libs. The utility ldd seems to show
      > that KVASD_95 was compiled using 32 bit libraries.
      > lj@lian2:~/wsjt/wsjt-code$ ldd -v KVASD_g95 linux-gate.so.1 =>
      > (0xf771c000) libm.so.6 => /lib32/libm.so.6 (0xf76d9000) libc.so.6 =>
      > /lib32/libc.so.6 (0xf757f000) /lib/ld-linux.so.2 (0xf771d000)
      > Version information: ./KVASD_g95: libm.so.6 (GLIBC_2.0) =>
      > /lib32/libm.so.6 libc.so.6 (GLIBC_2.2) => /lib32/libc.so.6 libc.so.6
      > (GLIBC_2.1) => /lib32/libc.so.6 libc.so.6 (GCC_3.0) => /lib32/libc.so.6
      > libc.so.6 (GLIBC_2.0) => /lib32/libc.so.6 /lib32/libm.so.6:
      > ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2 libc.so.6
      > (GLIBC_2.1.3) => /lib32/libc.so.6 libc.so.6 (GLIBC_2.0) =>
      > /lib32/libc.so.6 /lib32/libc.so.6: ld-linux.so.2 (GLIBC_PRIVATE) =>
      > /lib/ld-linux.so.2 ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
      > ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
      > 3. However on my system, I can invoke KVASD_g95:
      > lj@lian2:~/wsjt/wsjt-code$ ./KVASD_g95KVASD is s soft-decision decoder
      > for the Reed Solomon codeRS(63,12) over GF(64). The driver is
      > Copyright(C) 2005 byJoseph H Taylor, Jr., K1JT. The decoding algorithm
      > isused under licence from CodeVector Technologies, LLC, andis protected
      > under US patent 6,634,007.
      > KVASD may be used freely by anyone for the purpose offacilitating
      > communication by Amateur Radio. Any otheruse is strictly prohibited.
      > Usage: kvasd [-q] [-v]
      > 4. I thought that installing "lib32gfortran3" Runtime library for GNU
      > Fortran applications (32bit)" from the package lib32fortran3 would fix
      > the problem. It didn't.
      >
      > 5. Can anyone see why I am getting the "sh: KVASD_g95: not found"
      > error? And a fix?
      > Tnx LarryJ W0AY
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.