Loading ...
Sorry, an error occurred while loading the content.

Rate In/Out

Expand Messages
  • Dave
    I ve not yet been able to get my head round what goes on with the soundcard Rate In and Rate Out settings in WSJT. I understand that soundcards have various
    Message 1 of 12 , Aug 17 2:26 PM
    • 0 Attachment
      I've not yet been able to get my head round what goes on with the soundcard
      Rate In and Rate Out settings in WSJT.

      I understand that soundcards have various perameters around dividing input
      rates, clock values and the like, but the two values in the bottom left of
      my WSJT screen just seem to have a life of their own at times...

      Most of the time, using 1.0 for In and 1.007 for Out seems OK, but then it
      seems that the two values go off on their own, causing a red display just
      below the received signals window in the main screen. Usually this only
      lasts for a short while, but today I saw the values 1.0363 (In) and 1.0438
      (Out) for a while after a decode.

      Is this something I should worry about? What effect does it have and what,
      if anything, can I do to rectify the problem?

      Thanks - Dave (G0DJA)
    • Jerry
      Dave.. The latest PC I have hooked up seems to be working OK.. The Rx Window on mine shows Red .. 1.000 1.000 but the lower Left shows 1.0046 and 1.001.. so
      Message 2 of 12 , Aug 17 2:48 PM
      • 0 Attachment
        Dave.. The latest PC I have hooked up seems to be working OK.. The Rx Window on mine shows 'Red'.. 1.000  1.000  but the lower Left shows 1.0046 and 1.001.. so maybe I am not hearing what I should either ?  Looking forward to your responses !
        Jerry
        VE6CPP VE6Jee/p
        DN39or

        On 8/17/2011 3:26 PM, Dave wrote:  

        I've not yet been able to get my head round what goes on with the soundcard
        Rate In and Rate Out settings in WSJT.

        I understand that soundcards have various perameters around dividing input
        rates, clock values and the like, but the two values in the bottom left of
        my WSJT screen just seem to have a life of their own at times...

        Most of the time, using 1.0 for In and 1.007 for Out seems OK, but then it
        seems that the two values go off on their own, causing a red display just
        below the received signals window in the main screen. Usually this only
        lasts for a short while, but today I saw the values 1.0363 (In) and 1.0438
        (Out) for a while after a decode.

        Is this something I should worry about? What effect does it have and what,
        if anything, can I do to rectify the problem?

        Thanks - Dave (G0DJA)

      • w5uwb2@aol.com
        The rate in/out will go bonkers (and then recover to original state slowly) whenever (in my case) D4 updates my clock time. I have D4 set at 10 minutes. I
        Message 3 of 12 , Aug 17 4:30 PM
        • 0 Attachment
          The rate in/out will go bonkers (and then recover to original state slowly) whenever (in my case) D4 updates my clock time. I have D4 set at 10 minutes. I doubt that things go awry when the rates deviate briefly from the settings. Hasn't botheered my EME efforts.
           
          73 John W5UWB
           
          In a message dated 8/17/2011 9:48:26 P.M. GMT Standard Time, jer.sieg@... writes:


          Dave.. The latest PC I have hooked up seems to be working OK.. The Rx Window on mine shows 'Red'.. 1.000  1.000  but the lower Left shows 1.0046 and 1.001.. so maybe I am not hearing what I should either ?  Looking forward to your responses !
          Jerry
          VE6CPP VE6Jee/p
          DN39or

          On 8/17/2011 3:26 PM, Dave wrote:
           

          I've not yet been able to get my head round what goes on with the soundcard
          Rate In and Rate Out settings in WSJT.

          I understand that soundcards have various perameters around dividing input
          rates, clock values and the like, but the two values in the bottom left of
          my WSJT screen just seem to have a life of their own at times...

          Most of the time, using 1.0 for In and 1.007 for Out seems OK, but then it
          seems that the two values go off on their own, causing a red display just
          below the received signals window in the main screen. Usually this only
          lasts for a short while, but today I saw the values 1.0363 (In) and 1.0438
          (Out) for a while after a decode.

          Is this something I should worry about? What effect does it have and what,
          if anything, can I do to rectify the problem?

          Thanks - Dave (G0DJA)

        • David Hilton-Jones
          Dave No idea why it periodically goes bonkers, but it does for no obvious rhyme or reason. I have often noticed that if the figures are significantly
          Message 4 of 12 , Aug 17 11:29 PM
          • 0 Attachment

            Dave

             

            No idea why it periodically goes bonkers, but it does for no obvious rhyme or reason.

             

            I have often noticed that if the figures are “significantly” different to what you have set there may be no decode – but if you change the set figures to match and re-decode the same period, then it will decode fine. “Significant” seems fairly critical.


            David, G4YTL

             

             

            From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf Of w5uwb2@...
            Sent: 18 August 2011 00:31
            To: jer.sieg@...; dave@...
            Cc: wsjtgroup@yahoogroups.com
            Subject: Re: [wsjtgroup] Rate In/Out

             

             

            The rate in/out will go bonkers (and then recover to original state slowly) whenever (in my case) D4 updates my clock time. I have D4 set at 10 minutes. I doubt that things go awry when the rates deviate briefly from the settings. Hasn't botheered my EME efforts.

             

            73 John W5UWB

             

            In a message dated 8/17/2011 9:48:26 P.M. GMT Standard Time, jer.sieg@... writes:



            Dave.. The latest PC I have hooked up seems to be working OK.. The Rx Window on mine shows 'Red'.. 1.000  1.000  but the lower Left shows 1.0046 and 1.001.. so maybe I am not hearing what I should either ?  Looking forward to your responses !
            Jerry
            VE6CPP VE6Jee/p
            DN39or

            On 8/17/2011 3:26 PM, Dave wrote:

             

            I've not yet been able to get my head round what goes on with the soundcard
            Rate In and Rate Out settings in WSJT.

            I understand that soundcards have various perameters around dividing input
            rates, clock values and the like, but the two values in the bottom left of
            my WSJT screen just seem to have a life of their own at times...

            Most of the time, using 1.0 for In and 1.007 for Out seems OK, but then it
            seems that the two values go off on their own, causing a red display just
            below the received signals window in the main screen. Usually this only
            lasts for a short while, but today I saw the values 1.0363 (In) and 1.0438
            (Out) for a while after a decode.

            Is this something I should worry about? What effect does it have and what,
            if anything, can I do to rectify the problem?

            Thanks - Dave (G0DJA)

          • John Lemay
            Dave My figures change significantly while decoding is in progress but return to 1.0 or very close before the next decode is required. John G4ZTR _____ From:
            Message 5 of 12 , Aug 18 12:08 AM
            • 0 Attachment

              Dave

               

              My figures change significantly while decoding is in progress but return to 1.0 or very close before the next decode is required.

               

              John G4ZTR

               


              From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf Of Dave
              Sent: 17 August 2011 22:26
              To: WSJT GROUP
              Subject: [wsjtgroup] Rate In/Out

               

               

              I've not yet been able to get my head round what goes on with the soundcard
              Rate In and Rate Out settings in WSJT.

              I understand that soundcards have various perameters around dividing input
              rates, clock values and the like, but the two values in the bottom left of
              my WSJT screen just seem to have a life of their own at times...

              Most of the time, using 1.0 for In and 1.007 for Out seems OK, but then it
              seems that the two values go off on their own, causing a red display just
              below the received signals window in the main screen. Usually this only
              lasts for a short while, but today I saw the values 1.0363 (In) and 1.0438
              (Out) for a while after a decode.

              Is this something I should worry about? What effect does it have and what,
              if anything, can I do to rectify the problem?

              Thanks - Dave (G0DJA)


              __________ Information from ESET NOD32 Antivirus, version of virus signature database 6387 (20110817) __________

              The message was checked by ESET NOD32 Antivirus.

              http://www.eset.com


              __________ Information from ESET NOD32 Antivirus, version of virus signature database 6387 (20110817) __________

              The message was checked by ESET NOD32 Antivirus.

              http://www.eset.com
            • Dave
              ... Dave No idea why it periodically goes bonkers, but it does for no obvious rhyme or reason. I have often noticed that if the figures are significantly
              Message 6 of 12 , Aug 18 12:31 AM
              • 0 Attachment
                 
                ----- Original Message -----
                 
                 

                Dave

                 

                No idea why it periodically goes bonkers, but it does for no obvious rhyme or reason.

                 

                I have often noticed that if the figures are “significantly” different to what you have set there may be no decode – but if you change the set figures to match and re-decode the same period, then it will decode fine. “Significant” seems fairly critical.


                David, G4YTL

                 

                 

                From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf Of w5uwb2@...
                Sent: 18 August 2011 00:31
                To: jer.sieg@...; dave@...
                Cc: wsjtgroup@yahoogroups.com
                Subject: Re: [wsjtgroup] Rate In/Out

                 

                 

                The rate in/out will go bonkers (and then recover to original state slowly) whenever (in my case) D4 updates my clock time. I have D4 set at 10 minutes. I doubt that things go awry when the rates deviate briefly from the settings. Hasn't botheered my EME efforts.

                 

                73 John W5UWB

                 

                 
                I'd not thought about D4 and the clock change, that could account for the wild excursions. Thanks.
                 
                However, the more subtle changes, which alter slowly over time, and drift higher and lower than what I set in the Options box still worry me at times.
                 
                Dave (G0DJA)
                 
                 
                 
              • Bruce Brackin
                GM Dave - There have been a number of threads on drifting sound card sampling rates over the years. Below is a note Joe sent that may be of help. The same
                Message 7 of 12 , Aug 18 3:48 AM
                • 0 Attachment
                  GM Dave - There have been a number of threads on drifting sound card
                  sampling rates over the years. Below is a note Joe sent that may be of
                  help. The same info should apply for Ver 9. Part of the problem can be
                  other programs calling on the clock. The occasional excursion should
                  not be a problem.

                  All of my setups have used the simple on board sound systems and they
                  have done well and stable. The one name brand card I tried would never
                  settle in on a rate and both TX and RX numbers were constantly drifting
                  well above and below 1.000 no matter what I tried.

                  Some have found trying a different driver (newer or older) helped with
                  their sampling rate problems. Loading an earlier driver version cured a
                  problem for me on the mobile laptop.

                  Joe has some similar info the the change notes.
                  http://physics.princeton.edu/pulsar/K1JT/UpdateHistory.txt
                  #4 in the "Changes in WSJT 5.9.0: November 16, 2005" section

                  GL - Bruce N5SIX
                  -----------------

                  Group Message #4796 - 5/20/2008
                  The WSJT6 "Rate In" and "Rate Out" numbers normally need to
                  be set just once. (If you change sound cards, do it again.)
                  Otherwise, you can generally ignore the displayed numbers.

                  If the displayed numbers wander around, it is MUCH more
                  likely that, for some reason, the Windows clock is updating
                  in an irregular way. If you see no warning messages in the
                  WSJT6 console window, it's very unlikely that there is
                  anything unstable about your audio sampling rate.

                  If your system allows you to set "Sample Rate Conversion
                  Quality", set it to maximum. (In Win/XP, go to Control
                  Panel -> Sounds and Audio Devices -> Speaker settings ->
                  Advanced -> Performance.)

                  Also, if your Windows version offers "Performance Options",
                  set "Processor scheduling" for best performance of
                  "Background Services". (In Win/XP, go to Control Panel ->
                  System -> Advanced -> Performance -> Advanced.)

                  -- 73, Joe, K1JT
                • Dave
                  ... From: Bruce Brackin ... Thanks Bruce, I m effectively using an outboard soundcard, as I use a US Interface Navigator, so the drivers are the ones that I
                  Message 8 of 12 , Aug 18 8:17 AM
                  • 0 Attachment
                    ----- Original Message -----
                    From: "Bruce Brackin"

                    > All of my setups have used the simple on board sound systems and they
                    > have done well and stable. The one name brand card I tried would never
                    > settle in on a rate and both TX and RX numbers were constantly drifting
                    > well above and below 1.000 no matter what I tried.
                    >
                    > Some have found trying a different driver (newer or older) helped with
                    > their sampling rate problems. Loading an earlier driver version cured a
                    > problem for me on the mobile laptop.


                    ----------------------------------------------------------------------------
                    > If your system allows you to set "Sample Rate Conversion
                    > Quality", set it to maximum. (In Win/XP, go to Control
                    > Panel -> Sounds and Audio Devices -> Speaker settings ->
                    > Advanced -> Performance.)
                    >
                    > Also, if your Windows version offers "Performance Options",
                    > set "Processor scheduling" for best performance of
                    > "Background Services". (In Win/XP, go to Control Panel ->
                    > System -> Advanced -> Performance -> Advanced.)


                    Thanks Bruce,

                    I'm effectively using an outboard soundcard, as I use a US Interface
                    Navigator, so the drivers are the ones that I updated after installing to
                    origonal drivers. I'll check to see if there are any updates available. If
                    not, I may reinstate an old interface that used the onboard soundcard and
                    compare the two. For other data modes, the Navigator seemed far superior to
                    the onboard soundcard and simple isolation interface.

                    On the settings advised by Joe, as per above, I'm not sure the sample rate
                    conversion quality applies to offboard systems like the Navigator, but I'll
                    ask on the Navigator forum just in case.

                    On my version of XP, when I look at System>Advanced>Performance>Advanced,
                    there are two options under Adjust for best performance of: 'Programs' or
                    'Background Services'. At present it's set to 'Programs'.

                    Maybe I'm trying to run too much on this PC? I've wondered in the ast about
                    getting something with little else on it other than an operating system and
                    WSJT, but not got round to doing anything about it. Plus, It would mean
                    going back to a KVM switch, and that can cause it's own issues with extra
                    wiring for RF to get into, of course.

                    Cheers - Dave (G0DJA)
                  • Bill VanAlstyne W5WVO
                    I had my own issues with this, and it was undoubtedly me who started one of those threads a few years ago that Bruce refers to. An RTC reset program (such as
                    Message 9 of 12 , Aug 19 2:30 AM
                    • 0 Attachment
                      I had my own issues with this, and it was undoubtedly me who started one of those threads a few years ago that Bruce refers to. An RTC reset program (such as D4 – I now use Meinberg) kicking into operation is one known reason for the WSJT correction readings in the lower-left corner to go bonkers. BUT – the readings will (should) return to their original values within the next four or five seconds or so. Now, if you have your RTC reset program set to kick in every ten seconds, this could definitely give the impression of the numbers being completely whacko all the time. (Resetting the RTC that frequently BTW is completely unnecessary unless your PC is WAAAAY overloaded – in which case you shouldn’t be using it for any time-sensitive applications like WSJT in the first place. Upgrade time!)
                       
                      So to check and see if your sound card sample clocks are behaving, turn OFF the RTC reset program (including the RTC reset program built into Windows Vista and 7) and watch the numbers. They should both stabilize to some value within 30 seconds or less. If either number does NOT ever stabilize, then you have a problem, and it is time to replace that sound card (if it is “replaceable”) or bypass it by installing an outboard USB-connected sound device. In 2008, when I first started with WSJT, I had a sound card whose transmit clock correction number would not ever stabilize, and this caused my encoded FSK441 signals to be difficult for others to decode. Replacing the old ISA-bus Sound Blaster sound card in my PC cleared this up.
                       
                      The number you observe for both transmit and receive clock corrections would ideally be zero – but if that were always the case, there would be no need for a correction factor! The correction factor – the number you see when the board and WSJT software have stabilized with respect to each other – is a factor of how the codec in the sound card driver was implemented. This means that there are certain fairly typical correction factors you will see. As the bad codecs gradually get weeded out of the driver development pipeline, seeing 0.0000 for both numbers, receive and transmit, is becoming more and more typical (i.e., no correction needed). A correction factor of 0.0068 or 0.0069 is also fairly common, or used to be anyway. Whatever it is, enter it in the Setup dialog, restart WSJT, and all should be fine. And once you’ve verified that it is stable with your RTC reset program (like D4) turned off, don’t forget to turn it back on. Then, when you observe the clock factors “going walkabout” (as I used to refer to it) whenever the time program kicks in, rest assured (per Joe) that this does NOT reflect anything going wrong with how WSJT is encoding or decoding. It’s an artifact of the RTC being reset by the time program.
                       
                      Just as an aside, for anybody still using the obsolete Dimension 4 (D4) RTC time reset client – or worse yet, the default built-in client in Windows Vista or Windows 7, which is TERRIBLE – I strongly recommend the Meinberg NTP client. It is literally a couple orders of magnitude more accurate than anything else out there for the PC. Computed correction factors of less than 10 milliseconds are typical once NTP gets the computer’s RTC “tuned in”. Google “Meinberg” to find it and also to find sites with more detailed information about how it works, probably more than you ever wanted to know. :-)
                       
                      Bill W5WVO
                       
                       
                      Sent: Thursday, August 18, 2011 10:48
                      To: Dave
                      Subject: Re: [wsjtgroup] Rate In/Out - K1JT notes
                       
                       

                      GM Dave - There have been a number of threads on drifting sound card
                      sampling rates over the years. Below is a note Joe sent that may be of
                      help. The same info should apply for Ver 9. Part of the problem can be
                      other programs calling on the clock. The occasional excursion should
                      not be a problem.

                      All of my setups have used the simple on board sound systems and they
                      have done well and stable. The one name brand card I tried would never
                      settle in on a rate and both TX and RX numbers were constantly drifting
                      well above and below 1.000 no matter what I tried.

                      Some have found trying a different driver (newer or older) helped with
                      their sampling rate problems. Loading an earlier driver version cured a
                      problem for me on the mobile laptop.

                      Joe has some similar info the the change notes.
                      http://physics.princeton.edu/pulsar/K1JT/UpdateHistory.txt
                      #4 in the "Changes in WSJT 5.9.0: November 16, 2005" section

                      GL - Bruce N5SIX
                      -----------------

                      Group Message #4796 - 5/20/2008
                      The WSJT6 "Rate In" and "Rate Out" numbers normally need to
                      be set just once. (If you change sound cards, do it again.)
                      Otherwise, you can generally ignore the displayed numbers.

                      If the displayed numbers wander around, it is MUCH more
                      likely that, for some reason, the Windows clock is updating
                      in an irregular way. If you see no warning messages in the
                      WSJT6 console window, it's very unlikely that there is
                      anything unstable about your audio sampling rate.

                      If your system allows you to set "Sample Rate Conversion
                      Quality", set it to maximum. (In Win/XP, go to Control
                      Panel -> Sounds and Audio Devices -> Speaker settings ->
                      Advanced -> Performance.)

                      Also, if your Windows version offers "Performance Options",
                      set "Processor scheduling" for best performance of
                      "Background Services". (In Win/XP, go to Control Panel ->
                      System -> Advanced -> Performance -> Advanced.)

                      -- 73, Joe, K1JT

                    • Dave
                      ... Sent: Wednesday, August 17, 2011 9:26 PM Subject: [wsjtgroup] Rate In/Out ... I think I ve found the solution to my problem. Use Firefox instead of Opera!
                      Message 10 of 12 , Sep 11, 2011
                      • 0 Attachment
                        ----- Original Message -----
                        Sent: Wednesday, August 17, 2011 9:26 PM
                        Subject: [wsjtgroup] Rate In/Out


                        > I've not yet been able to get my head round what goes on with the
                        > soundcard
                        > Rate In and Rate Out settings in WSJT.

                        I think I've found the solution to my problem.

                        Use Firefox instead of Opera!

                        I shut down everything, I deleted old files, cleared the cache, cleaned the
                        registry, all no good. Then I closed Opera and used Firefox instead... As
                        soon as I did this, Dimension 4 stopped having to adjust the clock by up to
                        6 seconds every 10 minutes, the Rate In/Out in WSJT stopped altering and the
                        red warnings stopped appearing. OK, I'll admit that the Rate In/Out still
                        does still alter, but not by much.

                        I've no idea why or how, but it seems the Opera browser was doing something
                        wierd to the PC clock.

                        Dave (G0DJA)
                      • Dave
                        ... From: Dave ... Sorry, that should be spelt weird . Dave (G0DJA)
                        Message 11 of 12 , Sep 11, 2011
                        • 0 Attachment
                          ----- Original Message -----
                          From: "Dave" <dave@...>
                          > wierd to the PC clock.

                          Sorry, that should be spelt 'weird'.

                          Dave (G0DJA)
                        • Jim Malone
                          Dave, I am now using D4 or Meinberg for my PC clock synchronization in a way that keeps me in time yet minimize the wandering . I start the D4 program
                          Message 12 of 12 , Sep 12, 2011
                          • 0 Attachment
                            Dave,

                            I am now using D4 or Meinberg for my PC clock synchronization in a way that keeps me in time yet minimize the " wandering " .

                            I start the D4 program after I turn on my PC I look at the correction factor in the lower screen and note when the sync took place. If that sync occurred in and around the time I started the D4 I know I got a true sync . 

                            I then exit the program . I have found in my case constant corrections affect WSJT. It has been better to get a sync and shut D4 off.

                            Sometimes I look at the history to were the timing has skewed, it should be close to the zero seconds point after awhile. The chart represents seconds of error on the "Y" axis and date on the "x" axis . Every once in awhile you can see large corrections.

                              73  Jim 

                            Sent from my iPad

                            On Sep 11, 2011, at 5:40 PM, Dave <dave@...> wrote:

                             


                            ----- Original Message -----
                            From: "Dave" <dave@...>
                            > wierd to the PC clock.

                            Sorry, that should be spelt 'weird'.

                            Dave (G0DJA)

                          Your message has been successfully submitted and would be delivered to recipients shortly.