Loading ...
Sorry, an error occurred while loading the content.

Another error message

Expand Messages
  • Bob KD7YZ
    I worked around the previous, now during decode segment, I get the access-denied message. I very recently installed Windows-7 and have had many issues with me
    Message 1 of 4 , May 11, 2011
    • 0 Attachment
      I worked around the previous, now during decode segment, I get the
      access-denied message.

      I very recently installed Windows-7 and have had many issues with me not
      understanding why many folders require me to give Admin-Priv's

      ******************************************************************
      WSJT Version 9.02 r2226 , by K1JT
      Revision date: 2010-10-25 13:46:52 -0400 (Mon, 25 Oct 2010)
      Run date: Wed May 11 18:47:31 2011 UTC

      Audio Input Output Device Name
      Device Channels Channels
      ------------------------------------------------------------------
      0 2 0 Microsoft Sound Mapper - Input
      1 2 0 EMU Input (E-MU 0404 | USB)
      2 2 0 Microphone (USB Audio CODEC )
      3 0 2 Microsoft Sound Mapper - Output
      4 0 2 Speakers (High Definition Audio
      5 0 2 USB Audio Codec (USB Audio CODE
      6 0 2 EMU Digital Output USB (E-MU 04

      User requested devices: Input = 1 Output = 5
      Default devices: Input = 0 Output = 3
      Will open devices: Input = 1 Output = 5
      Audio streams running normally.
      ******************************************************************
      Access is denied.
      Error in KV decoder, or no KV decoder present.
      Return code: 1. Will use BM algorithm.
      Access is denied.
      Access is denied.
      Access is denied.
      Access is denied.
      Access is denied.
      Access is denied.
    • Bob KD7YZ
      Mike, K6MKF, mentioned that , in Windows-7, you have to put the WSJT stuff into a separate folder off the root, C: , which I did, and it works fine. thanks
      Message 2 of 4 , May 11, 2011
      • 0 Attachment
        Mike, K6MKF, mentioned that , in Windows-7, you have to put the WSJT
        stuff into a separate folder off the root, C:\, which I did, and it
        works fine.

        thanks
      • Barry Garratt
        Glad that solved it for you Bob but the statement you have to put it in a separate folder off the root is not correct. It is C: Program Files
        Message 3 of 4 , May 11, 2011
        • 0 Attachment

          Glad that solved it for you Bob but the statement you have to put it in a separate folder off the root is not correct. It is "C:\Program Files (x86)\WSJT9\WSJT9.EXE" on both of my Windows 7, 64 bit machines and runs just fine.

           

          That said whatever works for you is what you need to do. I noticed in your setup you are using one device for receive and a different device for transmit. Never tried that but again if it’s working that way for you that’s all that matters isn’t it.

           

          Barry KS7DX

           

           

          From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf Of Bob KD7YZ
          Sent: Wednesday, May 11, 2011 3:40 PM
          To: WSJT
          Subject: Re: [wsjtgroup] Another error message --- solved

           

           

          Mike, K6MKF, mentioned that , in Windows-7, you have to put the WSJT
          stuff into a separate folder off the root, C:\, which I did, and it
          works fine.

          thanks

        • Bill VanAlstyne W5WVO
          The back-story here is that Microsoft made a change when it came out with Vista, and carried it forward with Windows7. The change concerned what is “legal”
          Message 4 of 4 , May 12, 2011
          • 0 Attachment
            The back-story here is that Microsoft made a change when it came out with Vista, and carried it forward with Windows7. The change concerned what is “legal” to do in the Program Files (or Program Files (x86)) directory and its substructure of application folders. Before Vista, a user could write to a file within that structure with no special permissions. So any application that included writing data to a file could keep that file right next to the executable files in the application’s main folder under Program Files.
             
            With Vista and Windows7, users aren’t allowed to write ANYTHING under Program Files UNLESS that user is the Administrator. Note that this means “ADMINISTRATOR,” not “named user with full administrator privileges.” They are not the same for these purposes in Vista and Windows 7.
             
            Applications that are “Vista/Windows7 compatible” do not store user-writable files under Program Files. Years ago, so I’ve been told, Microsoft provided numerous broadly-distributed white papers and knowledge-base articles describing to application developers and programmers how user file-writing should now be done. Nevertheless, there continues to be software out there (like WSJT) where the user is asked to store data in files under the Program Files structure. And that’s when you get those errors from Vista or Windows7.
             
            So -- When installing an application that requires the user to write to one or more files that are stored under Program Files, there are two choices:
             
            (1) You can create a special folder in parallel with Program Files and Program Files (x86) called – whatever you like. Say, “Ham Radio Software”. When installing ham radio software, change the path statement by replacing “Program Files (x86)” with “Ham Radio Software”. Even if an application DOESN’T need to write to a file in the application folder, it will still work fine under the new structure thus created. Windows doesn’t know anything about the new folder architecture you just created, and hence doesn’t have any “laws” against doing stuff in it.
             
            (2) Alternatively, yes, you can install it in the default Program Files (x86) folder. However, to prevent error conditions from occurring when writing to files (like CALL3.TXT, for example), change the properties of the executable (WSJT9.EXE), or even just the short-cut icon on your desktop, by selecting “Run as Administrator” from the Properties dialog. You do this by right-clicking the executable file or the shortcut and selecting Properties  at the bottom of the drop-down menu. Then select the Compatibility tab and click “Run this program as an administrator.”) From now on (assuming default Vista/Windows7 settings), when launching the program, you will get a dialog box asking you if it’s OK to run the modified program. You can set Windows to not warn you about this every time and thus get rid of this annoying intermediary dialog, but this is a system-wide setting and is generally not a good idea, as it defeats an important level of Windows system security. Up to you.
             
            Really, the best approach is (1) above. Simple, transparent, and no need to change anything in Microsoft’s security protocol.
             
            Bill W5WVO
             
            Sent: Thursday, May 12, 2011 01:01
            Subject: RE: [wsjtgroup] Another error message --- solved
             
             

            Glad that solved it for you Bob but the statement you have to put it in a separate folder off the root is not correct. It is "C:\Program Files (x86)\WSJT9\WSJT9.EXE" on both of my Windows 7, 64 bit machines and runs just fine.

            That said whatever works for you is what you need to do. I noticed in your setup you are using one device for receive and a different device for transmit. Never tried that but again if it’s working that way for you that’s all that matters isn’t it.

            Barry KS7DX

            From: wsjtgroup@yahoogroups.com [mailto:wsjtgroup@yahoogroups.com] On Behalf Of Bob KD7YZ
            Sent: Wednesday, May 11, 2011 3:40 PM
            To: WSJT
            Subject: Re: [wsjtgroup] Another error message --- solved

             

            Mike, K6MKF, mentioned that , in Windows-7, you have to put the WSJT
            stuff into a separate folder off the root, C:\, which I did, and it
            works fine.

            thanks

          Your message has been successfully submitted and would be delivered to recipients shortly.