Loading ...
Sorry, an error occurred while loading the content.

Re: [wsjtgroup] WSJT under Linux

Expand Messages
  • Joe Taylor
    Hi Harry -- I hope you will receive some input from others, but I will give you a few comments based on my own experience with WSJT running on Linux. I am
    Message 1 of 2 , Feb 20, 2006
    • 0 Attachment
      Hi Harry --

      I hope you will receive some input from others, but I will give you a
      few comments based on my own experience with WSJT running on Linux.

      I am taking the liberty of sending a copy of this email also to the WSJT
      developers email list, wsjt-devel@.... (This is a public
      list, anyone can subscribe; you don't need to be a WSJT developer
      yourself, but this is the best place to go with programming or
      performance questions on WSJT.)

      Harry Popov wrote:
      > Any one who succeeded to run wsjt under Linux?

      As far as I am aware, about 6-8 people have compiled and run WSJT for Linux.

      > I did compile wsjt 5.9.2 r115. Program works fine while I try to decode
      > old recorded files. I have problems while trying to use it on the air.
      > Here are the problems on my side:
      >
      > 1. If program is started but doing nothing, it is very unstable and
      > stops working. Not the same if in monitor or auto mode. Freezes but
      > after much longer time.

      I have seen no problems like this, and I do not think others on the
      wsjt-devel reflector have either. (If anyone has relevant experience,
      please speak up and copy Harry on your reply!)

      > 2.Strange behavior in monitor or auto mode. While WSJT SPEC shows the
      > noise and input bursts they never appear in the main program spectrum
      > window while WSJT compiled with --enable-alsa. But first period appear
      > in the main window after many periods while compiled with --enable-oss.

      Again, I have not seen anything like this behavior. On my Linux
      machine, WSJT looks and behaves just like the Windows version.

      > 3. While with alsa in/out ratio of my sound card is 4.0000 and it is
      > 2.0000 with oss . The same figures under Windows are 1.0000 / 1.0068 and
      > they are the correct values for my sound card.

      This is definitely not right. On my machine both numbers are 1.0000.

      > 4. Some periods it decodes while clicking over wslt.spec, some time does
      > not. Unpredictable behavior.

      I am not sure that I understand what you are saying. I see no anomalous
      behavior when using the mouse to force decodes, in any of the WSJT modes.

      > I am using IBM ThinkPad T600X notebook PIII 500Mhz 192RAM. My Linux
      > distribution is Ubuntu 5.04 Hoary.
      >
      > Does any one know whether the developers ever connected the software to
      > real radio or just played with records?

      I have left my WSJT/Linux running for more than a week, using the new
      "simulation" mode and exchanging JT65 messages with another computer
      running WSJT/Windows. This procedure exercises nearly all of the
      real-time capabilities and requirements of the program. I have seen no
      crashes or unpredictable behavior.

      > If any one have more success than me please contact me personally. I
      > would like to share experience with you.
      >
      > 73, Harry Popov LZ1BB

      Harry, the other developers and I will be very happy to share our
      experiences with you. I'm sure that we can help you solve the problems
      you have had. Maybe you could post a follow-up message to the
      wsjt-devel list, telling us what compiler versions, etc., you have used.

      -- 73, Joe, K1JT
    Your message has been successfully submitted and would be delivered to recipients shortly.