Loading ...
Sorry, an error occurred while loading the content.
 

Re: [wsjtgroup] WSJTX r3508 broken?

Expand Messages
  • Larry Mundinger
    ... What packages need to be installed? Larry, KG4Q
    Message 1 of 4 , Jul 29, 2013
      On 07/29/2013 06:51 AM, Edson W. R. Pereira wrote:
      >
      > You are correct. We have started using Qt5 for development.
      >
      >
      What packages need to be installed?

      Larry, KG4Q
    • Joe Taylor
      Hi Dave, ... The best place for queries like yours is the wsjt-devel list at Berlios: Wsjt-devel mailing list Wsjt-devel@lists.berlios.de
      Message 2 of 4 , Jul 29, 2013
        Hi Dave,

        K2LYV wrote:
        > I updated my source for wsjtx via the berlios.de repository. I upgraded a few files. When I tried compiling, which has been no problem until now, I get a message:
        >
        > Fatal error: QtWidgets: No such file or directory
        >
        > indeed there is no QtWidgets directory in the /usr/include/qt4 chain.
        >
        > Was there an upgrade to Qt5 by the development team?

        The best place for queries like yours is the wsjt-devel list at Berlios:

        Wsjt-devel mailing list
        Wsjt-devel@...
        https://lists.berlios.de/mailman/listinfo/wsjt-devel

        For the record: we necessarily take the point of view that those who
        compile these programs on their own

        1. will be knowledgeable about programming and compilation procedures,

        2. will work with "released" revisions of the code,

        3. or at least will pay attention to SVN log messages and other traffic
        on wsjt-devel, so they will know what's going on and why.

        We welcome the interest and enthusiasm of all intrepid souls who build
        WSJT-X on their own computers. Some modify the code to suit their own
        requirements, and some have helped us to improve the code base.

        Your all-volunteer development team makes no effort to provide a
        complete "paint-by-numbers" recipe that will inevitably lead to a
        correctly built executable program.

        To answer your original question:

        WSJT-X v1.1 r3508 builds without problems with either Qt 4.x or Qt 5.x.
        You need to activate one or the other of the following statements in
        wsjtx.pro:

        DEFINES = QT4
        DEFINES = QT5

        As already noted, the Development team is switching over to Qt5.

        -- Joe, K1JT
      Your message has been successfully submitted and would be delivered to recipients shortly.