Loading ...
Sorry, an error occurred while loading the content.

Re: [wsjtgroup] Compiling wsjtx 1.1 on OS X

Expand Messages
  • Joe Taylor
    Hi Ivan, The best place for queries like yours is the wsjt-devel list at Berlios: Wsjt-devel mailing list Wsjt-devel@lists.berlios.de
    Message 1 of 2 , Jul 27 8:57 AM
    • 0 Attachment
      Hi Ivan,

      The best place for queries like yours is the wsjt-devel list at Berlios:

      Wsjt-devel mailing list
      Wsjt-devel@...
      https://lists.berlios.de/mailman/listinfo/wsjt-devel

      You can get the needed help there.

      -- 73, Joe, K1JT

      On 7/27/2013 9:12 AM, ireeder wrote:
      > Dear Group,
      >
      > I set out recently to get WSJT-X 1.1 working on OS X. In the lib
      > directory, after applying a few needed tweaks to the makefile, I am
      > almost successful.
      >
      > When compiling jt9, however, I'm unable to get past the following error:
      >
      > g++ -o jt9 jt9.o jt9a.o jt9b.o jt9c.o libjt9.a -lfftw3f -lgfortran
      > -framework QtCore -m64
      > Undefined symbols for architecture x86_64:
      > "_main", referenced from:
      > start in crt1.10.6.o
      > ld: symbol(s) not found for architecture x86_64
      > collect2: ld returned 1 exit status
      > make: *** [jt9] Error 1
      >
      > I'm necessarily compiling with -m64 as my QtCore library is only 64-bit.
      >
      > Any ideas how I can get past this?
      >
      > tu es 73,
      > Ivan NN4IR
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.