Loading ...
Sorry, an error occurred while loading the content.
 

Re: [wsjtgroup] JT ALERT X NOT WORKING WITH JT9

Expand Messages
  • Laurie, VK3AMA
    Randy, I know you have this resolved by setting JT-Alert-X to run in Win7 Compatibility mode, but thought I would respond here for the benefit of future
    Message 1 of 2 , May 24 12:06 AM
      Randy,

      I know you have this resolved by setting JT-Alert-X to run in Win7
      Compatibility mode, but thought I would respond here for the benefit of
      future message archive searches.

      Unfortunately, your the only one reporting this specific issue.

      JT-Alert-X can be installed anywhere, it is happy in the "Program
      Files..." directory tree as all files it writes are stored outside that
      path.
      You previously indicated that JT-Alert-X did work for JT-9 decodes, so
      something has changed in your Windows environment.

      The lack of decoded callsigns is due to JT-Alert-X failing to locate the
      WSJT-X decodes file. The path to that file is determined by reading the
      installation path of WSJT-X from the Registry. You have confirmed that
      the necessary registry keys are present, as I would expect after you
      have done a WSJT-X install or upgrade.

      The only conclusion I can reach is that a security setting or process is
      preventing JT-Alert-X from reading the necessary registry entry. What
      that is is unknown, but I suspect something to do with the UAC (User
      Account Control) of Win7.

      There wont be any adverse effects to JT-Alert-X operation due to the
      Compatibility setting.

      de Laurie VK3AMA

      On 23/05/2013 10:24 AM, k5rcd@... wrote:
      > Laurie:
      > I hate to keep bugging you but this is making me crazy. I previously
      > posted on the ham apps group and you addressed it there. Now I have
      > posted on the wsjt group as it seems to be related to something in
      > that program.
      > In any event, I did as you suggest. both keys are present in registry
      > as you outlined below. I disabled anti virus (avast) and ran the
      > program but it didn’t help. I even re downloaded the latest version of
      > wsjtx with anti virus disabled but again no luck.
      > It bugs me that it worked previously but I don’t know exactly when or
      > what I did to cause the problem. Surely someone else must be having
      > this problem.
      > I am at my wits end. What can it possibly be?
      > System restore won’t help. I already tried going back as far as my
      > system will allow and that did not help.
      > I have wsjtx installed as C:/wsjtx and JT Alert installed in Program
      > files X86 as before. Is there an issue there? I even tried installing
      > wsjtx in Program files X86 with no luck.
      > Thanks,
      > Randy
      > K5RCD
      > *From:* Laurie, VK3AMA <mailto:groups05@...>
      > *Sent:* Wednesday, May 22, 2013 6:16 PM
      > *To:* randy376582512 <mailto:k5rcd@...>
      > *Subject:* Re: [wsjtgroup] JT ALERT X NOT WORKING WITH JT9
      > Randy,
      >
      > Please post JT-Alert support questions to the Ham-Apps Yahoo Group. I
      > don't regularly check other groups.
      >
      > JT-Alert determines the location of the wsjt-x configuration file by
      > reading the registry getting the "InstallLocation" value written by the
      > wsjt-x installer. Either that key is missing or something is preventing
      > JT-Alert from reading the registry (anti-virus software perhaps).
      >
      > Please check you registry to see if the "InstallLocation" key exists at...
      > for X64
      > "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\wsjtx_is1"
      > for X32
      > "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\wsjtx_is1"
      >
      > If the key is present, then JT-Alert is being blocked. Try running
      > temporarily with your virus software disabled to confirm ir anti-virus
      > is source of block.
      >
      > If the key is not present. Try installing wsjt-x with your anti-virus
      > software temporarily disabled or white-listing wsjt-x in your anti-virus
      > software before installing wsjt-x.
      >
      > If your running the latest JT-Alert-X (2.2.3), try starting wsjt-x
      > before starting JT-Alert-X as JT-Alert-X attempts to determine the
      > wsjt-x configuration location from the running wsjt-x process, but that
      > technique is not 100% reliable as reading process information can be
      > affected by OS security settings.
      >
      > de Laurie VK3AMA
      >
      >
      > On 23/05/2013 8:49 AM, randy376582512 wrote:
      > > Running Windows 7 WSJTX v0.99 r3297 and TT Alert 2.23
      > >
      > > JT Alert seems to run properly except It will not display any
      > callsigns decoded by JT9.
      > >
      > > I contacted Laurie VK3AMA and he said:
      > > "Randy,
      > >
      > > JT-Alert-X is not displaying WSJT-X decodes because it cannot locate
      > the WSJT-X configuration file. That tells JT-Alert where to locate the
      > decodes file. Without that file, JT-Alert will never see decodes.
      > >
      > > It appears you installed WSJT-X and either moved /renamed the
      > install folder or ran a registry cleaner that removed the entry for
      > the WSJT-X installation.
      > > easiest fix is to reinstall WSJT-X.
      > > de Laurie, VK3AMA"
      > >
      > > I have deleted both JT Alert and WSJTX and reinstalled both with no
      > luck, latest version of WSJTX didn't cure the problem. JT Alert for
      > JT65HF works fine, but not JT Alert X
      > >
      > > WSJTX is installed as C:/WSJTX and JT alert in Program files X86
      > >
      > > What can be wrong ?
      > > HELP me fix it PLEASE!!!!!
      > >
      > > Randy
      > > K5RCD
      > >
    Your message has been successfully submitted and would be delivered to recipients shortly.