Loading ...
Sorry, an error occurred while loading the content.

RE: [wsjtgroup] Re: WSJT-X v3251 'Open Rig Failed' [1 Attachment]

Expand Messages
  • Rick Langford
    Try vspmngr You may also be able to then use ddutil Create a vsp one end to radio other gets set to the rig control in dfutil Then set your other vsp ports
    Message 1 of 1 , May 13, 2013
    • 0 Attachment
      Try vspmngr

      You may also be able to then use ddutil

      Create a vsp one end to radio other gets set to the rig control in dfutil

      Then set your other vsp ports pairs one end to application other end to dditil as a rcp

      Ddytil then hands off the routing between the rig and other applications
      Us flex users have been doing this for a while and it works very well

      Example I can run hrd logbook and or dm780 with the hrd front end psdr is much better for the sdr rigs
      Along with the logbook running tracking mofe and frequency I can also at same time run wsjtx and jt65 and various other applications sporting rig control of ptt frequency



      From: KD7YZ Bob
      Sent: 5/13/2013 3:07 PM
      To: wsjtgroup@yahoogroups.com
      Subject: [wsjtgroup] Re: WSJT-X v3251 'Open Rig Failed' [1 Attachment]

       


      I have done some more testing on this dual-use of single CAT Com-Port.

      Rig is K3 fwiw. I am using Dx-Labs "Commander", which reads and sets certain frequencies and parameters of the K3. The designated port is Com14 .

      So I run Virtual Serial Port Emulator, by Eterologic. I assign COM2 (Virtual) to watch Com14 .

      First I run Commander and have it assigned to COM2 (the virtual) .
      Commander operates correctly; reads the frequency of K3, sets "CW" and co forth.

      Close Commander. Verify is is closed by looking through Task Manager.

      Run WSJTx, JT9 . Assign it to look at COM2 .. If this is not possible due to rig-open problem, I edit the "INI" and delete the section of lines dealing with CAT and COM ports.

      WSJTx functions just fine looking thru the virtual port to the K3.

      Run Commander now. Eventually, sooner or in a minute or so, WSJTx locks up while Commander works through it.

      If OTOH I start Commander first, still using the virtual port COM2, and THEN "try" to run WJTx, there is the immediate Error about open rig and so forth. Kill it with TM .

      Commander is still working.

      Now then, I winder if any other program(s) will work using VSPE and the virtual port COM2 which points to the logical port COM14.

      So I run FLDIGI. I set it to look at COM2 and Voilla! she's a workin' along with Commander who's also looking at COM14 (K3) through Virtual Port COM2 . The setup is through the Hamlib tab, K3 & COM2.

      Close FLDigi. Open "K3 Utility". Assign COM2. Works while Commander is also running thru COM2.

      Keep them open and open "Omni-Rig Client". Make changes to "FREQA". Note K3 has changed frequency on VFO-a.

      Leave all three communicating with K3 through COM2 and open WSJTx. Note
      Open Rig Failed, error. See screenshot of it, attached to this, and likely
      viewable in the Files section via the Yahoo Group interface. Otherwise as me and I will email same screenshot.

      --
      73,
      Bob KD7YZ
      http://www.qrz.com/db/KD7YZ


      [The entire original message is not included.]
    Your message has been successfully submitted and would be delivered to recipients shortly.