Loading ...
Sorry, an error occurred while loading the content.

Hiding of Dock/Menu when SS loads

Expand Messages
  • ted_m_p_lee
    John -- what did you do to have the dock and menu bar be hidden when SheepShaver starts up? I replaced the version of SS in your package with the latest one
    Message 1 of 3 , Apr 19, 2013
    • 0 Attachment
      John -- what did you do to have the dock and menu bar be hidden when SheepShaver starts up? I replaced the version of SS in your package with the latest one on the emaculation site. It works just fine, and, with my fix gets positioned right, but the dock and menu bar are not hidden like they are with yours. Obviously it's not something in the startup Applescript, so I assume you added some properties to the SS file itself.

      Ted
    • ted_m_p_lee
      Nevermind. I figured it out. There is a property in the plist for your app that isn t in the emaculation version -- LSUIPresentationMode (or something
      Message 2 of 3 , Apr 19, 2013
      • 0 Attachment
        Nevermind. I figured it out. There is a property in the plist for your app that isn't in the emaculation version -- "LSUIPresentationMode" (or something like that) -- I haven't tried adding that to the emaculation version yet, but I'm sure that'll do it. (A Google search told me what it does.) Tweaking this computer sure is a lot of fun!

        --- In wordperfectmac@yahoogroups.com, "ted_m_p_lee" <tmplee@...> wrote:
        >
        > John -- what did you do to have the dock and menu bar be hidden when SheepShaver starts up? I replaced the version of SS in your package with the latest one on the emaculation site. It works just fine, and, with my fix gets positioned right, but the dock and menu bar are not hidden like they are with yours. Obviously it's not something in the startup Applescript, so I assume you added some properties to the SS file itself.
        >
        > Ted
        >
      • ted_m_p_lee
        This a nevernevermind! The newer (July 2012) build of SS has that screen color problem -- if the SS window is hidden or minimized, when you bring it back the
        Message 3 of 3 , Apr 19, 2013
        • 0 Attachment
          This a nevernevermind! The newer (July 2012) build of SS has that screen color problem -- if the SS window is hidden or minimized, when you bring it back the colors are wrong. (noted in the read me.) That seems to include just repositioning the window. That problem doesn't seem to be present in the build in your package, so I'm going to go back to it after all.

          --- In wordperfectmac@yahoogroups.com, "ted_m_p_lee" <tmplee@...> wrote:
          >
          > Nevermind. I figured it out. There is a property in the plist for your app that isn't in the emaculation version -- "LSUIPresentationMode" (or something like that) -- I haven't tried adding that to the emaculation version yet, but I'm sure that'll do it. (A Google search told me what it does.) Tweaking this computer sure is a lot of fun!
          >
          > --- In wordperfectmac@yahoogroups.com, "ted_m_p_lee" <tmplee@> wrote:
        Your message has been successfully submitted and would be delivered to recipients shortly.