Loading ...
Sorry, an error occurred while loading the content.
 

Re: [wpmac] [ANN] WP Regular Expression Search 3.0

Expand Messages
  • J.J. McVeigh
    ... I downloaded and installed the updated version, and when I try to launch the WP Regex Search applet, I get this error message: ==== Error -877 Classic
    Message 1 of 6 , Jan 19, 2011
      John R wrote:

      >This is a substantial update to to a much more powerful tool for
      >finding and replacing text than is provided by WP's (or any
      >program's, including Word's) Find/Change command. Think of it as
      >Find/Change on steroids. It can make life easier and save a lot of
      >time.
      >
      >New features in this version: stays open after a search or replace
      >operation is completed, to facilitate further search. Remembers
      >recent search and replace patterns you used, for fast recall. Choice
      >of two search entry dialogs to enhance legibility or complete
      >visibility. You can copy found strings and parenthetical
      >subexpressions to the clipboard.
      >
      >In addition, a lot of things have been done under the hood, and the
      >application runs much faster and cleaner. It's IMHO the most elegant
      >thing I've ever written.
      >
      >Runs on Intel with SheepShaver, PPC Macs with Classic, and legacy
      >Macs with OS 7.5-9.2.
      >
      >This was briefly posted yesterday, then taken down for an
      >enhancement. Now posted for keeps with a creation date of 18 January
      >2011, as "Regex Search 3.0.sit" in the Files section here.

      I downloaded and installed the updated version, and when I try to
      launch the WP Regex Search applet, I get this error message:

      ====

      Error -877

      Classic environment will not launch that application.

      [OK]

      =====

      However, I can launch the Script by clicking on the Script Addition.

      --
      John Joseph McVeigh
      Butler, Maryland, USA
    • John R
      What OS are you on? Also, have you tried restarting? I would also, if you haven t done it recently, rebuild the Classic desktop. This is done in System
      Message 2 of 6 , Jan 19, 2011
        What OS are you on? Also, have you tried restarting?

        I would also, if you haven't done it recently, rebuild the Classic desktop. This is done in System Preferences > Classic > Advanced.

        John R.



        --- In wordperfectmac@yahoogroups.com, "J.J. McVeigh" <kd4vs@...> wrote:

        > I downloaded and installed the updated version, and when I try to
        > launch the WP Regex Search applet, I get this error message:
        >
        > ====
        >
        > Error -877
        >
        > Classic environment will not launch that application.
        >
        > [OK]
        >
        > =====
        >
        > --
        > John Joseph McVeigh
        > Butler, Maryland, USA
        >
      • J.J. McVeigh
        ... Sorry, I meant to include such information in my prior message. My main OS is 10.4.11 on a Dual G5 Power mac. The Classic OS is OS 9.2.2 I took your
        Message 3 of 6 , Jan 20, 2011
          John R wrote:

          >What OS are you on? Also, have you tried restarting?
          >
          >I would also, if you haven't done it recently, rebuild the Classic
          >desktop. This is done in System Preferences > Classic > Advanced.

          Sorry, I meant to include such information in my prior message.

          My main OS is 10.4.11 on a Dual G5 Power mac.
          The Classic OS is OS 9.2.2

          I took your suggestions. I restarted the computer (not merely
          Classic), then I rebuilt the Classic desktop. All is now well.

          Thank you for the suggestions.

          --
          John Joseph McVeigh
          Butler, Maryland, USA
        • John R
          ... Cool! Here s a more general description of this, for others. Any of us on OSX may have forgotten the need to, once a month or so, rebuild the desktop as
          Message 4 of 6 , Feb 1, 2011
            --- In wordperfectmac@yahoogroups.com, "J.J. McVeigh" <kd4vs@...> wrote:

            > I took your suggestions. I restarted the computer (not
            > merely Classic), then I rebuilt the Classic desktop. All is now well.

            Cool! Here's a more general description of this, for others.

            Any of us on OSX may have forgotten the need to, once a month or so, rebuild the desktop as preventative maintenance. As well, if icons aren't doing what they should, files disappear etc., rebuild the desktop. It only takes a minute.

            To rebuild the desktop using my SheepShaver package:

            Find Desktop Reset in the Utilities folder and double-click it. After a few seconds a dialog will say that desktop files have been moved to the trash, and will offer to restart. Do so. During the restart, new desktop files will be created. After the operation, you can empty the trash.

            To rebuild the Classic desktop:

            Go to System Preferences > Classic > Advanced, and click Rebuild Desktop.

            To rebuild the desktop on a pre-OSX machine:

            Restart, holding down the Command and Option keys, until a dialog offers to rebuild the desktop.


            John R.
          Your message has been successfully submitted and would be delivered to recipients shortly.