Loading ...
Sorry, an error occurred while loading the content.

SS install updated (was: run old educational games on new macs)

Expand Messages
  • John R
    ... There was a bug in my installer that caused SheepShaver s window to be the wrong size. That s been fixed. Please download SheepShaver-WordPerfect Install
    Message 1 of 11 , Feb 1, 2010
    • 0 Attachment
      --- In wordperfectmac@yahoogroups.com, "John R" <johnrethorst@...> wrote:
      >
      > --- In wordperfectmac@yahoogroups.com, "aharbell" <aharbell@> wrote:

      > > And, if, (hopelessly) I am allowed to go with SheepShaver, could it be tweaked to better match what we have now? Specifically, how do I put in the tweak to get the wide shallow window to be the right size?
      >
      > Set window size in SheepShaver's prefs.

      There was a bug in my installer that caused SheepShaver's window to be the
      wrong size. That's been fixed. Please download SheepShaver-WordPerfect Install 1.2.2.dmg from the SheepShaver and Basilisk folder in the Links section here.

      John R.
    • David Schmalz
      I imagine the tech people are really concerned about emulators that would be running Windows under something like Parallels or VM Ware out of fear that they
      Message 2 of 11 , Feb 1, 2010
      • 0 Attachment
        I imagine the "tech people" are really concerned about emulators that
        would be running Windows under something like Parallels or VM Ware
        out of fear that they would not have control of their network and
        whatever licenses would be needed for software and antivirus
        programs. If you assure them that the Sheepshaver installation will
        not have a network connection and that you are only installing the
        software for which you already have the licenses, they should not
        have any basis for an objection to your doing so. As was said
        earlier, it cannot "damage" your Mac or its software. If they still
        prohibit the installation, they are just obstructionists who need to
        be overruled by whoever has authority over them (and in my opinion,
        they should be replaced with someone more competent).

        Good luck,

        David

        On Jan 30, 2010, at 11:49 AM, aharbell wrote:

        > he said the 'tech people' will not allow us to use an emulator on
        > school machines



        [Non-text portions of this message have been removed]
      • Dennis Supanich
        I used your installer, and every time I start up Sheepshaver the software automatically runs a disk utility and tells me I need to repair the disk image on the
        Message 3 of 11 , Feb 1, 2010
        • 0 Attachment
          I used your installer, and every time I start up Sheepshaver the software
          automatically runs a disk utility and tells me I need to repair the disk
          image on the OS X side. But, when I do that, the OS X disk utility says
          there¹s nothing wrong with the disk. It looks like everything¹s fine
          without running the repair. Should I just ignore it? I have disabled it
          for now by removing the script that runs the disk utility from the startup
          items folder.

          How about installing a newer system over the OS 7.5 you are using, like 8.1?
          Can it be done? Will that break anything? I tried to do it already, but the
          system wouldn¹t let me modify the startup disk, which is normal behavior.
          Is there some way of starting up from the installer CD, or maybe creating
          another drive that would contain the installer and start up with that, so I
          could modify the existing startup disk?
        • em315
          Actually, people have experienced file and folder corruption by trying to access the Unix folder from Sheepshaver and OS X at the same time; this was a
          Message 4 of 11 , Feb 1, 2010
          • 0 Attachment
            Actually, people have experienced file and folder corruption by trying to access the "Unix" folder from Sheepshaver and OS X at the same time; this was a notorious problem in earlier releases of Sheepshaver, and it's impossible to be certain that the bug no longer exists. There are many discussions of it on the old emaculation.com forums. BUT....

            The way around this problem is NOT to set up a "Unix" folder in the Sheepshaver prefs (after getting all your software on to the Sheepshaver drive), so that there is no communication at all between the Sheepshaver drive and the rest of the system. That definitely would be one-hundred-percent safe.



            --- In wordperfectmac@yahoogroups.com, David Schmalz <ddschmalz@...> wrote:
            >
            > I imagine the "tech people" are really concerned about emulators that
            > would be running Windows under something like Parallels or VM Ware
            > out of fear that they would not have control of their network and
            > whatever licenses would be needed for software and antivirus
            > programs. If you assure them that the Sheepshaver installation will
            > not have a network connection and that you are only installing the
            > software for which you already have the licenses, they should not
            > have any basis for an objection to your doing so. As was said
            > earlier, it cannot "damage" your Mac or its software. If they still
            > prohibit the installation, they are just obstructionists who need to
            > be overruled by whoever has authority over them (and in my opinion,
            > they should be replaced with someone more competent).
            >
            > Good luck,
            >
            > David
            >
            > On Jan 30, 2010, at 11:49 AM, aharbell wrote:
            >
            > > he said the 'tech people' will not allow us to use an emulator on
            > > school machines
            >
            >
            >
            > [Non-text portions of this message have been removed]
            >
          • John R
            ... Try clicking Repair in the Disk First Aid window itself, rather than going over to OSX. Odd that one utility should find an error and the other not. Did
            Message 5 of 11 , Feb 1, 2010
            • 0 Attachment
              --- In wordperfectmac@yahoogroups.com, Dennis Supanich <acsadmin@...> wrote:
              >
              > I used your installer, and every time I start up Sheepshaver the software
              > automatically runs a disk utility and tells me I need to repair the disk
              > image on the OS X side. But, when I do that, the OS X disk utility says
              > there¹s nothing wrong with the disk. It looks like everything¹s fine
              > without running the repair. Should I just ignore it? I have disabled it
              > for now by removing the script that runs the disk utility from the startup
              > items folder.

              Try clicking Repair in the Disk First Aid window itself, rather than going
              over to OSX.

              Odd that one utility should find an error and the other not.

              Did this behavior start when you first installed, or only later on?

              Anyone else getting this with the 1.2.2 Installer?

              > How about installing a newer system over the OS 7.5 you are using, like 8.1?
              > Can it be done? Will that break anything?

              No, that's fine.

              > I tried to do it already, but the
              > system wouldn¹t let me modify the startup disk, which is normal behavior.
              > Is there some way of starting up from the installer CD, or maybe creating
              > another drive that would contain the installer and start up with that, so I
              > could modify the existing startup disk?

              Use SS Prefs to create a new volume, whatever size you want. Then insert
              your installer CD and install the OS on the new volume.

              John R.
            • em315
              ... Same problem with the disk here; the errors never get fixed, no matter how often I run Repair.
              Message 6 of 11 , Feb 1, 2010
              • 0 Attachment
                --- In wordperfectmac@yahoogroups.com, "John R" <johnrethorst@...> wrote:
                Same problem with the disk here; the errors never get fixed, no matter how often I run Repair.

                > --- In wordperfectmac@yahoogroups.com, Dennis Supanich <acsadmin@> wrote:
                > >
                > > I used your installer, and every time I start up Sheepshaver the software
                > > automatically runs a disk utility and tells me I need to repair the disk
                > > image on the OS X side. But, when I do that, the OS X disk utility says
                > > there¹s nothing wrong with the disk. It looks like everything¹s fine
                > > without running the repair. Should I just ignore it? I have disabled it
                > > for now by removing the script that runs the disk utility from the startup
                > > items folder.
                >
                > Try clicking Repair in the Disk First Aid window itself, rather than going
                > over to OSX.
                >
                > Odd that one utility should find an error and the other not.
                >
                > Did this behavior start when you first installed, or only later on?
                >
                > Anyone else getting this with the 1.2.2 Installer?
                >
              • Bruce G
                ... I can see some of the issues that the tech people have. I should point out that unlike Parallels or VMWare or even Wine that Sheepshaver is very unrefined.
                Message 7 of 11 , Feb 2, 2010
                • 0 Attachment
                  --- In wordperfectmac@yahoogroups.com, David Schmalz <ddschmalz@...> wrote:
                  >
                  > I imagine the "tech people" are really concerned about emulators that
                  > would be running Windows under something like Parallels or VM Ware
                  > out of fear that they would not have control of their network and
                  > whatever licenses would be needed for software and antivirus
                  > programs. If you assure them that the Sheepshaver installation will
                  > not have a network connection and that you are only installing the
                  > software for which you already have the licenses, they should not
                  > have any basis for an objection to your doing so. As was said
                  > earlier, it cannot "damage" your Mac or its software. If they still
                  > prohibit the installation, they are just obstructionists who need to
                  > be overruled by whoever has authority over them (and in my opinion,
                  > they should be replaced with someone more competent).
                  >
                  > Good luck,
                  >
                  > David
                  >
                  > On Jan 30, 2010, at 11:49 AM, aharbell wrote:
                  >
                  > > he said the 'tech people' will not allow us to use an emulator on
                  > > school machines

                  I can see some of the issues that the tech people have.

                  I should point out that unlike Parallels or VMWare or even Wine that Sheepshaver is very unrefined. It has problems interacting with files stored on Intel mac main drive and is not the easiest thing in the world to use. That translates into more work for the IT guys which is not something yo really want.

                  Furthermore there is the issue of having an emulator for just one program when there are alternatives like OpenOffice and older versions of MSword that can at least get to the text of the Wordperfect file.
                • Dennis Supanich
                  Responding to your questions concerning the disk repair issue noted below: 1. This problem came up the first time I ran SS. Note that SS crashed the first
                  Message 8 of 11 , Feb 2, 2010
                  • 0 Attachment
                    Responding to your questions concerning the disk repair issue noted below:

                    1. This problem came up the first time I ran SS. Note that SS crashed
                    the first time I ran it, probably because I had another SS installation on
                    my HD. After I removed it your install of SS ran fine, but with the disk
                    repair problem I noted. I tried trashing the entire thing and reinstalling,
                    but that didn¹t change anything.

                    2. I did try running disk repair in the SS window. First, the process
                    stalls with an alert that says the test was interrupted because another
                    program is using the disk (no other programs were actually running). If I
                    verify again and then repair, the repair ³works.² But when I shut down and
                    restart, the utility finds the same damage to the disk

                    I¹m curious about this issue, but the fact is that SS seems to be running
                    just fine.

                    Thanks for your help.
                  • Daniell Mattern
                    ... I reported a similar problem a few months ago (Core 2 Duo iMac, Snow Leopard). I just ignored the message and WP seemed to work okay, but I haven t been
                    Message 9 of 11 , Feb 2, 2010
                    • 0 Attachment
                      >--- In wordperfectmac@yahoogroups.com, Dennis Supanich <acsadmin@...> wrote:
                      >>
                      >> I used your installer, and every time I start up Sheepshaver the software
                      >> automatically runs a disk utility and tells me I need to repair the disk
                      >> image on the OS X side. But, when I do that, the OS X disk utility says
                      >> there's nothing wrong with the disk. It looks like everything's fine
                      >> without running the repair. Should I just ignore it? I have disabled it
                      >> for now by removing the script that runs the disk utility from the startup
                      >> items folder.
                      >
                      >Try clicking Repair in the Disk First Aid window itself, rather than going
                      >over to OSX.
                      >
                      >Odd that one utility should find an error and the other not.
                      >
                      >Did this behavior start when you first installed, or only later on?
                      >
                      >Anyone else getting this with the 1.2.2 Installer?
                      >

                      I reported a similar problem a few months ago (Core 2 Duo iMac, Snow
                      Leopard). I just ignored the message and WP seemed to work okay, but
                      I haven't been back in SS to give it a long-time trial.

                      -- Dan
                    Your message has been successfully submitted and would be delivered to recipients shortly.