Loading ...
Sorry, an error occurred while loading the content.

Trouble getting started with SheepShaver

Expand Messages
  • danmattern
    Hello, all. I am now embarking on the adventure of migrating from my trusty PowerMac with OS 9 and WordPerfect to an Intel Core 2 Duo iMac with Snow Leopard
    Message 1 of 14 , Nov 5, 2009
    • 0 Attachment
      Hello, all.

      I am now embarking on the adventure of migrating from my trusty PowerMac with OS 9 and WordPerfect to an Intel Core 2 Duo iMac with Snow Leopard 10.6.1. I have followed the SheepShaver threads on this list over the years and was looking forward to giving it a try. Today I downloaded the SS-WP 1.1 file and I think I followed the "Install Read Me" instructions. (The Setup pane in SheepShaver Prefs does not show the full path to the volume.dmg file; otherwise everything seems okay.) I restarted my Mac and tried to launch SS. Its icon appears in the Dock and it takes over the top menu bar with its name and a Window menu, but putting the cursor in the menu bar gives a spinning ball. I have to force quit. I have a 49-page report from the force-quit if anyone would find that helpful. Any diagnostics or advice would be welcome.

      -- Dan
    • John R
      ... The SheepShaver Prefs window expands; the volume.dmg can be put anywhere your user account can write to, e.g. your Home or Shared folders. ... First,
      Message 2 of 14 , Nov 5, 2009
      • 0 Attachment
        --- In wordperfectmac@yahoogroups.com, "danmattern" <mattern@...> wrote:

        > I am now embarking on the adventure of migrating from my trusty
        > PowerMac with OS 9 and WordPerfect to an Intel Core 2 Duo iMac
        > with Snow Leopard 10.6.1. I have followed the SheepShaver threads
        > on this list over the years and was looking forward to giving it a try.
        > Today I downloaded the SS-WP 1.1 file and I think I followed the
        > "Install Read Me" instructions. (The Setup pane in SheepShaver Prefs
        > does not show the full path to the volume.dmg file; otherwise
        > everything seems okay.)

        The SheepShaver Prefs window expands; the volume.dmg can be put
        anywhere your user account can write to, e.g. your Home or Shared
        folders.

        > I restarted my Mac and tried to launch SS. Its icon appears in the
        > Dock and it takes over the top menu bar with its name and a
        > Window menu, but putting the cursor in the menu bar gives a
        >spinning ball. I have to force quit. I have a 49-page report from
        > the force-quit if anyone would find that helpful. Any diagnostics
        > or advice would be welcome.

        First, download the latest SheepShaver build:
        http://www.xs4all.nl/~ronaldpr/sheepshaverforum/SheepShaver_UB_20091025.zip

        This fixes a problem in the 18 October build having to do with crash
        at startup, so this may correct your issue.

        Just for a clean reinstall, get the free EasyFind utility from Version Tracker
        and delete SheepShaver's prefs file. It's invisible, at the root of your Home
        folder, entitled ".sheepshaver_prefs".

        BTW I hope to release a much-improved installer for SheepShaver this
        weekend, obviating initial use of the SheepShaver Prefs utility. Install
        should be automatic.

        John R.
      • Daniell L. Mattern
        ... I just tried this build, but it bounces once in the dock and quits, which is less successful than the 1/4/08 build in SS-WP 1.1 that at least gets to a
        Message 3 of 14 , Nov 6, 2009
        • 0 Attachment
          >First, download the latest SheepShaver build:
          >http://www.xs4all.nl/~ronaldpr/sheepshaverforum/SheepShaver_UB_20091025.zip
          >
          >This fixes a problem in the 18 October build having to do with crash
          >at startup, so this may correct your issue.

          I just tried this build, but it bounces once in the dock and quits,
          which is less successful than the 1/4/08 build in SS-WP 1.1 that at
          least gets to a menu bar. Are there other builds that would be worth
          trying? Is there any problem with having several builds sitting in my
          user area?

          >Just for a clean reinstall, get the free EasyFind utility from Version Tracker
          >and delete SheepShaver's prefs file. It's invisible, at the root of your Home
          >folder, entitled ".sheepshaver_prefs".

          Tried this, but no improvement.

          >BTW I hope to release a much-improved installer for SheepShaver this
          >weekend, obviating initial use of the SheepShaver Prefs utility. Install
          >should be automatic.
          >
          >John R.
          >

          Maybe that will help. Thanks for your suggestions.

          -- Dan
        • Ricki Tannen
          I am so frustrated by the same things happening over and over again, I am about to drop Wordperfect from my life and get Word for Mac. Does anyone have any
          Message 4 of 14 , Nov 6, 2009
          • 0 Attachment
            I am so frustrated by the same things happening over and over again, I am
            about to drop Wordperfect from my life and get Word for Mac. Does anyone
            have any experience with the parrrallel software for handling this in an
            easier fashion. A computer techie said that was the way to run wordperfect
            on a Mac without having the sheeepsaver or rebooting problems.
            Ricki
          • David Schmalz
            Ricki, I have Sheepshaver running WordPerfect adequately well but it did take quite a bit of tinkering. I think I have about five different virtual disks from
            Message 5 of 14 , Nov 7, 2009
            • 0 Attachment
              Ricki,

              I have Sheepshaver running WordPerfect adequately well but it did
              take quite a bit of tinkering. I think I have about five different
              virtual disks from all of the times I tried various sound control
              panels and different versions of OS9. For me, trying to get it to
              work is kind of FUN (I'm afraid I'm just too much of a geek), but if
              it is a chore to you, your other options are much easier to set up
              and very stable.

              If you have an Intel Mac, you can either use Word for Mac or use
              WordPefect for Windows with Parallels or a similar product called
              VMWare Fusion.

              I use Word for Mac, and it's OK. (I certainly prefer it to Word for
              Windows since they changed the familiar drop down menus to the
              "ribbon" where I can’t find anything when I need it). I also have
              Parallels and WordPerfect for Windows running on my Macbook, and
              while there is nothing wrong with it, I find that I almost always
              never use it. Parallels was very easy to set up.

              Of course, you have to buy those products, but there are also a
              couple of other options that won’t cost you anything. One option is
              to use Open Office, which works quite well in my opinion. It has the
              same general features as Word or WordPerfect and can open and save
              files in various formats, and it is a regular Mac program so it
              doesn’t need Parallels.

              Another thing to look at is VirtualBox, which does the same things as
              Parallels (or Fusion) with a few less features, but it is also free.
              You could run WordPerfect for Windows under that.

              If you have a Power PC Mac, you can use Virtual PC and run
              WordPerfect for Windows. On my 933 mHz Mac Quicksilver using
              Microsoft Virtual PC version 7 and Windows XP, it isn’t real snappy,
              but it runs WordPerfect just fine. I found a copy on eBay with
              Windows XP Home, and Windows activated without any problem. Even the
              older Virtual PC version 5.04 with Windows 98 ran WordPerfect well
              for me.

              David
            • Daniell L. Mattern
              Update on my first attempts at SheepShaver: I was originally working with the 10/18/2009 build and the SS-WP 1.1 installation instructions. When I read that
              Message 6 of 14 , Nov 11, 2009
              • 0 Attachment
                Update on my first attempts at SheepShaver:

                I was originally working with the 10/18/2009 build and the SS-WP 1.1
                installation instructions. When I read that that build had trouble
                launching (mine bounced once in the Dock and quit), I downloaded the
                10/25/2009 build and worked with that. I already had a
                SheepShaverPrefs file created with the locations of my Mac OS ROM and
                volume.dmg files entered, so I left those files in my SheepShaver
                folder. The emaculation.com instructions suggested that the various
                files could be anywhere, so I put the 11/25/2009 build in its own
                folder. This opened a SheepShaver window and menu bar and then froze.
                What I discovered (through an emaculation hint) was that if the
                SheepShaver program and the Mac OS ROM and volume.dmg files were IN
                THE SAME FOLDER, SheepShaver then launched. What a pleasure to see
                the OS 7 window open on the shiny new iMac screen!

                There is, however, one additional issue. DiskFirstAid runs from
                SheepShaver and finds an error in the SheepShaver volume (Invalid
                BTree Header, 0, 0) which it urges me to repair with OSX Disk
                Utility. Disk Utility does not find anything to repair. Disk First
                Aid (back in SheepShaver) says it repairs the problem successfully,
                but the problem is still there upon Verifying. Practically, this may
                not be a problem. WordPerfect launches very quickly, as does another
                Classic program I use; a third program crashed once but has worked
                since. If anyone has advice about whether (and how) I need to fix the
                BTree, I'd appreciate it.

                John R's upcoming automatic installer for SheepShaver may help keep
                others from making my folder-location mistake. Perhaps it will also
                help my BTree problem. To try the new installation, will I need to
                delete any of my current SheepShaver files to keep them from
                conflicting?

                Thanks.

                -- Dan
              • John R
                ... Try using Disk First Aid to repair, twice in a row. John R.
                Message 7 of 14 , Nov 12, 2009
                • 0 Attachment
                  --- In wordperfectmac@yahoogroups.com, "Daniell L. Mattern" <mattern@...> wrote:
                  >
                  > DiskFirstAid runs from
                  > SheepShaver and finds an error in the SheepShaver volume (Invalid
                  > BTree Header, 0, 0) which it urges me to repair with OSX Disk
                  > Utility. Disk Utility does not find anything to repair. Disk First
                  > Aid (back in SheepShaver) says it repairs the problem successfully,
                  > but the problem is still there upon Verifying.

                  Try using Disk First Aid to repair, twice in a row.

                  John R.
                • Dave Schlicher
                  I have a similar problem (Invalid sibling link, 4, 23), but Disk First Aid keeps saying it s unable to repair it. Dave Schlicher
                  Message 8 of 14 , Nov 12, 2009
                  • 0 Attachment
                    I have a similar problem (Invalid sibling link, 4, 23), but Disk First Aid keeps saying it's unable to repair it.

                    Dave Schlicher


                    On Nov 12, 2009, at 6:22 AM, John R wrote:

                    >
                    >
                    > --- In wordperfectmac@yahoogroups.com, "Daniell L. Mattern" <mattern@...> wrote:
                    > >
                    > > DiskFirstAid runs from
                    > > SheepShaver and finds an error in the SheepShaver volume (Invalid
                    > > BTree Header, 0, 0) which it urges me to repair with OSX Disk
                    > > Utility. Disk Utility does not find anything to repair. Disk First
                    > > Aid (back in SheepShaver) says it repairs the problem successfully,
                    > > but the problem is still there upon Verifying.
                    >
                    > Try using Disk First Aid to repair, twice in a row.
                    >
                    > John R.
                  • John R
                    After you quit SheepShaver and open its volume in OSX, what does Disk Utility say? John R.
                    Message 9 of 14 , Nov 12, 2009
                    • 0 Attachment
                      After you quit SheepShaver and open its volume in OSX, what does
                      Disk Utility say?

                      John R.



                      --- In wordperfectmac@yahoogroups.com, Dave Schlicher <daveschlicher@...> wrote:
                      >
                      > I have a similar problem (Invalid sibling link, 4, 23), but Disk First Aid keeps saying it's unable to repair it.
                      >
                      > Dave Schlicher
                      >
                      >
                      > On Nov 12, 2009, at 6:22 AM, John R wrote:
                      >
                      > >
                      > >
                      > > --- In wordperfectmac@yahoogroups.com, "Daniell L. Mattern" <mattern@> wrote:
                      > > >
                      > > > DiskFirstAid runs from
                      > > > SheepShaver and finds an error in the SheepShaver volume (Invalid
                      > > > BTree Header, 0, 0) which it urges me to repair with OSX Disk
                      > > > Utility. Disk Utility does not find anything to repair. Disk First
                      > > > Aid (back in SheepShaver) says it repairs the problem successfully,
                      > > > but the problem is still there upon Verifying.
                      > >
                      > > Try using Disk First Aid to repair, twice in a row.
                      > >
                      > > John R.
                      >
                    • Dave Schlicher
                      John, First off, thanks for your help. When Mac OS X 10.6.2 s Disk Utility tries to repair the disk it says: Verify and Repair volume “SheepShaver”
                      Message 10 of 14 , Nov 12, 2009
                      • 0 Attachment
                        John,

                        First off, thanks for your help.

                        When Mac OS X 10.6.2's Disk Utility tries to repair the disk it says:

                        Verify and Repair volume “SheepShaver”
                        Checking non-journaled HFS Plus Volume.
                        Checking extents overflow file.
                        Checking catalog file.
                        Invalid sibling link
                        Rebuilding catalog B-tree.
                        The volume SheepShaver could not be repaired.
                        Volume repair complete.
                        Updating boot support partitions for the volume as required.
                        Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

                        BTW, I should add that this disk has never passed the startup check by Disk First Aid.

                        Any ideas would be much appreciated.
                        Thanks,
                        Dave Schlicher


                        On Nov 12, 2009, at 3:21 PM, John R wrote:

                        > After you quit SheepShaver and open its volume in OSX, what does
                        > Disk Utility say?
                        >
                        > John R.
                        >
                        > --- In wordperfectmac@yahoogroups.com, Dave Schlicher <daveschlicher@...> wrote:
                        > >
                        > > I have a similar problem (Invalid sibling link, 4, 23), but Disk First Aid keeps saying it's unable to repair it.
                        > >
                        > > Dave Schlicher
                        > >
                        > >
                        > > On Nov 12, 2009, at 6:22 AM, John R wrote:
                        > >
                        > > >
                        > > >
                        > > > --- In wordperfectmac@yahoogroups.com, "Daniell L. Mattern" <mattern@> wrote:
                        > > > >
                        > > > > DiskFirstAid runs from
                        > > > > SheepShaver and finds an error in the SheepShaver volume (Invalid
                        > > > > BTree Header, 0, 0) which it urges me to repair with OSX Disk
                        > > > > Utility. Disk Utility does not find anything to repair. Disk First
                        > > > > Aid (back in SheepShaver) says it repairs the problem successfully,
                        > > > > but the problem is still there upon Verifying.
                        > > >
                        > > > Try using Disk First Aid to repair, twice in a row.
                        > > >
                        > > > John R.
                        > >
                        >
                        >
                      • Daniell L. Mattern
                        For me, Disk Utility says: The volume SheepShaver appears to be OK. Using Disk First Aid twice (or three times) in a row didn t help. -- Dan
                        Message 11 of 14 , Nov 13, 2009
                        • 0 Attachment
                          For me, Disk Utility says:
                          "The volume SheepShaver appears to be OK."
                          Using Disk First Aid twice (or three times) in a row didn't help.

                          -- Dan

                          >After you quit SheepShaver and open its volume in OSX, what does
                          >Disk Utility say?
                          >
                          >John R.
                          >
                          >--- In wordperfectmac@yahoogroups.com, Dave Schlicher
                          ><daveschlicher@...> wrote:
                          >>
                          >> I have a similar problem (Invalid sibling link, 4, 23), but Disk
                          >>First Aid keeps saying it's unable to repair it.
                          >>
                          >> Dave Schlicher
                          >>
                          >>
                          > > On Nov 12, 2009, at 6:22 AM, John R wrote:
                          > >
                          > > > --- In wordperfectmac@yahoogroups.com, "Daniell L. Mattern"
                          ><mattern@> wrote:
                          >> > >
                          >> > > DiskFirstAid runs from
                          >> > > SheepShaver and finds an error in the SheepShaver volume (Invalid
                          >> > > BTree Header, 0, 0) which it urges me to repair with OSX Disk
                          >> > > Utility. Disk Utility does not find anything to repair. Disk First
                          >> > > Aid (back in SheepShaver) says it repairs the problem successfully,
                          >> > > but the problem is still there upon Verifying.
                          >> >
                          >> > Try using Disk First Aid to repair, twice in a row.
                          >> >
                          > > > John R.
                          >>
                          >
                        • Steve Kane
                          ... This happened on my system after I had opened the Sheepshaver volume.dmg in Mac OS X. I quit Sheepshaver, dragged a new copy of the Sheepshaver.dmg from
                          Message 12 of 14 , Nov 13, 2009
                          • 0 Attachment
                            On Nov 13, 2009, at 10:12 AM, Daniell L. Mattern wrote:

                            > For me, Disk Utility says:
                            > "The volume SheepShaver appears to be OK."
                            > Using Disk First Aid twice (or three times) in a row didn't help.

                            This happened on my system after I had opened the Sheepshaver
                            volume.dmg in Mac OS X.

                            I quit Sheepshaver, dragged a new copy of the Sheepshaver.dmg from the
                            install folder in the Sheepshaver folder, restarted Sheepshaver and
                            Disk Utility now reports no errors.

                            As long as I don't ever open the Sheepshaver.dmg in Mac OS X the
                            problem does not return. If I open the Sheepshaver.dmg in Mac OS X the
                            problem comes back.

                            Am I not supposed to open the Sheepshaver.dmg in Mac OS X?
                          • John R
                            ... There should be no problem at all with that. It s the most efficient way to copy files to and from the SS volume. John R.
                            Message 13 of 14 , Nov 14, 2009
                            • 0 Attachment
                              --- In wordperfectmac@yahoogroups.com, Steve Kane <skane-l@...> wrote:

                              > Am I not supposed to open the Sheepshaver.dmg in Mac OS X?

                              There should be no problem at all with that. It's the most efficient way
                              to copy files to and from the SS volume.

                              John R.
                            • Alexander Wold
                              I, too, have an error noted when disk doctor works, showing 0, 0 block problem. Have for years, on several computers. It has never caused a problem. Alexander
                              Message 14 of 14 , Nov 14, 2009
                              • 0 Attachment
                                I, too, have an error noted when disk doctor works, showing 0, 0 block
                                problem. Have for years, on several computers. It has never caused a
                                problem.

                                Alexander Wold
                                Albuquerque, NM
                              Your message has been successfully submitted and would be delivered to recipients shortly.