Loading ...
Sorry, an error occurred while loading the content.

Re: Note Editor Macro

Expand Messages
  • John Rethorst
    Hi Rick, My PPC/Classic machine is in the shop; I ll test NE 5.0 as soon as it comes back. I also plan to update NE for any necessary changes with SheepShaver.
    Message 1 of 6 , Jun 24, 2008
    • 0 Attachment
      Hi Rick,

      My PPC/Classic machine is in the shop; I'll test NE 5.0 as soon as
      it comes back.

      I also plan to update NE for any necessary changes with SheepShaver.

      John R.




      --- In wordperfectmac@yahoogroups.com, logres@... wrote:
      >
      > Apologies if this message shows up twice. I tried posting it thru Yahoo groups but it
      went to a moderator.
      >
      > I'm having some trouble with John's Note Editor macro. I've used this before, but it's
      been awhile. I'm attempting to copy endnotes to a separate file. The first few times I did
      this, I succeeded in creating the note editor file and copying the notes, but they all came
      out as Roman numerals in the editor document. (They're in Arabic numerals in the WP
      document.) I tried to go into the Editor Options to change this, but kept getting a
      message saying that I had to have a note editor document as the front window. (It was.)
      >
      > I tried to start over by creating a new note editor document, and this time,
      WordPerfect crashed when it tried to save it. Happened every time. It didn't matter
      whether I'd already gone into the Finder and trashed the file or not. I went out and
      downloaded the latest version of the macro (5.0) to be sure I had that, but it didn't help.
      >
      > Nothing that I've tried so far has worked; it always crashes on the note editor file save.
      So far, I have:
      > Quit WordPerfect and restarted it.
      > Trashed the preferences file.
      > Rebuilt the Classic desktop
      > Restarted Classic
      > Replaced the library file with a copy of a clean one, and then reinstalled the macros
      > Restarted OSX.
      >
      > Any ideas? And, assuming I ever do get this macro to run again, how do I get arabic
      numbered endnotes? It happens with all my files.
      >
      > I'm running Classic under 10.4.11.
      > Rick Albright
      >
    • Rick Albright
      Thanks, John. I m using what I think is an older version of the macro, and it works just fine. This one, when you create the note editor file, prompts you to
      Message 2 of 6 , Jun 24, 2008
      • 0 Attachment
        Thanks, John. I'm using what I think is an older version of the
        macro, and it works just fine. This one, when you create the note
        editor file, prompts you to add the word "endnotes" to the file name
        but doesn't say that it's case sensitive (which I think the later
        version does say)--though I've been careful to do so. Also, this
        version puts a line at the top stating that it's a note editor file
        for [filename]. (I don't recall the newer version doing that.) On a
        different Mac from the one I normally use, the endnotes still came
        out in Roman, but I was able to go into endnote options, answer "no"
        to the question about whether I wanted to use letters instead of
        numbers, and they magically transformed into Arabic numbers. (Though
        earlier today I ran the macro on my G3 laptop and they came out
        Arabic by default. Go figure.)

        I'm not sure what was causing my crashing problem. I had trashed
        prefs files several times, unsuccessfully. I think I cured my
        disappearing endnote number problem, though. For some reason, when I
        edited the endnote style to make the notes double-spaced, I think I
        lost the space after the endnote number. It's actually hard to see
        this clearly in the endnote window, without turning on "reveal
        codes" (which I know that I can do in an endnote window, though it
        reduces the size of the text space in the window, and I didn't want
        to resize the note window), so I didn't notice it until I copied the
        notes into a file using the endnotes->text macro. I surmise that,
        without this space, when I opened the endnote, the number symbol was
        probably being highlighted and it was disappearing, though I thought
        that it was doing it before I typed or pasted any text--though I
        could be mistaken. At any rate, making sure there's a space seems to
        have cured this problem.

        So, my solution is to copy the notes into the note editor, use the
        table to text function (though the only way I can properly select the
        entire table to make this option available is to use the shift-opt-T
        command--clicking and dragging won't do it) so that I can produce a
        file that will enable longer notes to wrap to following pages, and
        then I have to remember to select all the text and left justify it,
        as the numbers are right justified and end up on lines by themselves
        if I don't. The process is actually quicker than it sounds.

        Sorry for the long explanation. The important thing is, it seems to
        be working now, and I'm not panicking with 5 days to go to a book
        deadline. Well, at least I'm not panicking about *that.*

        Thanks again. When I'm done with this project, I'll check it out
        again with the 5.0 version. It's possible that it might even work
        this time.

        Best,
        Rick Albright

        On Jun 24, 2008, at 9:26 PM, John Rethorst wrote:

        > Hi Rick,
        >
        > My PPC/Classic machine is in the shop; I'll test NE 5.0 as soon as
        > it comes back.
        >
        > I also plan to update NE for any necessary changes with SheepShaver.
        >
        > John R.
        >
      • John Rethorst
        ... Rick, sorry to take so long to get to this, but I can t duplicate it, at least in SheepShaver on Intel (my PPC Mac is currently down). Note Editor 5.0 runs
        Message 3 of 6 , Aug 9, 2008
        • 0 Attachment
          --- In wordperfectmac@yahoogroups.com, logres@... wrote:

          > I'm having some trouble with John's Note Editor macro. I've used this
          > before, but it's been awhile. I'm attempting to copy endnotes to a
          > separate file. The first few times I did this, I succeeded in creating the
          > note editor file and copying the notes, but they all came out as Roman
          > numerals in the editor document. (They're in Arabic numerals in the
          > WP document.) I tried to go into the Editor Options to change this,
          > but kept getting a message saying that I had to have a note editor
          > document as the front window. (It was.)

          > Any ideas? And, assuming I ever do get this macro to run again,
          > how do I get arabic numbered endnotes? It happens with all my files.

          Rick, sorry to take so long to get to this, but I can't duplicate it,
          at least in SheepShaver on Intel (my PPC Mac is currently down). Note
          Editor 5.0 runs as it should.

          > I'm using what I think is an older version of the macro, and it works
          > just fine.

          > I'm not sure what was causing my crashing problem. I had trashed
          > prefs files several times, unsuccessfully. I think I cured my
          > disappearing endnote number problem, though. For some reason, when I
          > edited the endnote style to make the notes double-spaced, I think I
          > lost the space after the endnote number.

          One possibility that suggests itself is that the Endnote style in your
          Library has become corrupted. I would delete it from the Library and
          make a new one (just name it "Endnote" and it will work).

          BTW edit the Endnote style to make text within notes double-spaced;
          edit the Document style (or whatever body text style you're using) to
          change distance between notes. This is problematic with WP's endnotes
          though, while Note Editor can put any amount of space, e.g. single
          space, between endnotes.

          > The important thing is, it seems to be working now, and I'm not
          > panicking with 5 days to go to a book deadline. Well, at least I'm
          > not panicking about *that.*

          First things first.

          > Thanks again. When I'm done with this project, I'll check it out
          > again with the 5.0 version. It's possible that it might even work
          > this time.

          Please check out Note Editor 5.0.1, which I've just posted.

          John R.
        • John Rethorst
          ... In Tools Outlining... , do you have custom settings for Outline Style? John R.
          Message 4 of 6 , Aug 10, 2008
          • 0 Attachment
            > > I'm having some trouble with John's Note Editor macro. I've used this
            > > before, but it's been awhile. I'm attempting to copy endnotes to a
            > > separate file. The first few times I did this, I succeeded in creating the
            > > note editor file and copying the notes, but they all came out as Roman
            > > numerals in the editor document. (They're in Arabic numerals in the
            > > WP document.)

            In Tools > Outlining... , do you have custom settings for Outline Style?

            John R.
          • Rick Albright
            John, thanks again for all your help. I will certainly try out the new note editor. I m not sure what was going on. I was having intermittent issues with the
            Message 5 of 6 , Aug 11, 2008
            • 0 Attachment
              John, thanks again for all your help. I will certainly try out the
              new note editor.

              I'm not sure what was going on. I was having intermittent issues with
              the note editor on two different Macs, a G3 iBook and a G4 mini
              (working with the files on both)--though the mini was originally
              configured using the WordPerfect files from the iBook; therefore, if
              that Endnote style was corrupted in some way, I probably transmitted
              it to the other machine. So I'll have to try out your suggestion
              about creating a new Endnote style.

              I don't recall ever changing any of the outline styles, and have
              rarely used the outline function, though I know that a number of our
              list members are quite enthusiastic about it.

              While my roman numeral problem went away (as did the more serious
              crashing problem), the only issue that remained was when my
              copyeditor emailed the other day to say that a number of my endnotes
              had the number "1" showing up after the endnote number. Not all of
              them, just enough that she thought it must have been deliberate. I
              had noticed these showing up when I was printing notes or moving them
              over to a separate file via Note Editor, and thought I had deleted
              them, but either I missed some of them, or they reappeared. There
              doesn't seem to be any pattern to which notes got the extra numbers,
              but my theory is that these were the notes that, at the time I had
              been editing them (in WordPerfect's note function, not the editor),
              my endnote numbers were disappearing (and I was clicking on the #
              icon on the editing window. So now that I've had time to reflect, it
              does seem like it could be some kind of corruption problem. However,
              please don't waste any time trying to duplicate it. It's not a
              pressing issue now, and if it happens again, you've given me some
              ideas about how I might resolve it.

              Thanks again. You've more than earned a mention in the
              "Acknowledgments" page of my book (an obscure academic book on 19th
              century Gothic and sensation fiction that will be published in
              limited numbers, end up on a few college library shelves, and likely
              be read by nearly no one!)
              ~Rick Albright
            Your message has been successfully submitted and would be delivered to recipients shortly.