Loading ...
Sorry, an error occurred while loading the content.

Table to text

Expand Messages
  • Rick Albright
    I m a little rusty in my WP table handling because I haven t worked with tables for awhile. For some reason, I can t get table to text to work--it s grayed
    Message 1 of 3 , Aug 15, 2007
    • 0 Attachment
      I'm a little rusty in my WP table handling because I haven't worked
      with tables for awhile. For some reason, I can't get "table to text"
      to work--it's grayed out no matter what I do. I've tried selecting
      all, and also using John's suggestion from a previous discussion
      about triple clicking in the corner and dragging to the opposite
      corner, but nothing works. Text to table is available, but not table
      to text.

      By the way, it's probably important to mention that the file I'm
      using was created by John's Note editor to put all my endnotes in a
      file. I saw that the table was protected, and turned this off, but
      still no change. (I'm also working with a copy of this file so that
      it doesn't interfere with the workings of the macro.)

      Alternatively, maybe there's a better way to do what I want to do. I
      like the macro's ability to put all my endnotes into a file to give
      me more control over them. However, some of my endnotes are lengthy,
      and because they're in a table (even though invisible), WP won't wrap
      them from one page to the next but will force a page break so that it
      can get the whole note on the same page. As a result, I have pages
      that when printed have variable, and sometimes large, bottom margins.
      (There doesn't seem to be a way in WP to have it automatically wrap
      large cells across pages.)

      I should note here that I previously tried using the "endnotes to
      text" macro but (1) it actually _removes_ all the notes from the
      original file, and, more importantly, it doesn't keep the endnote
      numbers properly in the target file. I end up with a whole series of
      1's, and then will periodically see a series of ascending (but
      incorrect) endnote numbers before it reverts to 1's again. So I gave
      up on that macro.

      Any suggestions would be appreciated.
      --Rick Albright
      logres@...
    • John Rethorst
      ... Try assigning a keystroke to the Select Table command in Prefs Keyboard, a good idea in any case. If Table to Text still doesn t activate, try tossing
      Message 2 of 3 , Aug 15, 2007
      • 0 Attachment
        --- In wordperfectmac@yahoogroups.com, Rick Albright <logres@...> wrote:
        >
        > I'm a little rusty in my WP table handling because I haven't worked
        > with tables for awhile. For some reason, I can't get "table to text"
        > to work--it's grayed out no matter what I do. I've tried selecting
        > all, and also using John's suggestion from a previous discussion
        > about triple clicking in the corner and dragging to the opposite
        > corner, but nothing works. Text to table is available, but not table
        > to text.

        Try assigning a keystroke to the Select Table command in
        Prefs > Keyboard, a good idea in any case. If Table to Text
        still doesn't activate, try tossing your Preferences (USA) file.

        > By the way, it's probably important to mention that the file I'm
        > using was created by John's Note editor to put all my endnotes in a
        > file. I saw that the table was protected, and turned this off, but
        > still no change. (I'm also working with a copy of this file so that
        > it doesn't interfere with the workings of the macro.)

        Tables are protected by default when created. This shouldn't
        matter if no cells are locked.

        > Alternatively, maybe there's a better way to do what I want to do. I
        > like the macro's ability to put all my endnotes into a file to give
        > me more control over them. However, some of my endnotes are lengthy,
        > and because they're in a table (even though invisible), WP won't wrap
        > them from one page to the next but will force a page break so that it
        > can get the whole note on the same page. As a result, I have pages
        > that when printed have variable, and sometimes large, bottom margins.
        > (There doesn't seem to be a way in WP to have it automatically wrap
        > large cells across pages.)

        Note Editor lets you move endnotes from the note editor file into the
        document. This way you have the advantage of Note Editor for working
        with notes, and as a last step you can copy them back into the document.
        WP won't break a table cell across a page break, but an actual endnote
        should break.

        BTW people often try to edit aspects of endnote/footnote behavior by
        editing the endnote or footnote styles. Those style sheets govern only
        what's in a note. To do something like remove the default double space
        between notes, edit your Document style (or whatever style you're using
        for body text in your file) and set endnote or footnote options there.

        > I should note here that I previously tried using the "endnotes to
        > text" macro but (1) it actually _removes_ all the notes from the
        > original file, and, more importantly, it doesn't keep the endnote
        > numbers properly in the target file. I end up with a whole series of
        > 1's, and then will periodically see a series of ascending (but
        > incorrect) endnote numbers before it reverts to 1's again. So I gave
        > up on that macro.

        That macro works fine here. I wonder if a new Preferences (USA) file
        will help, or whether more surgery is needed. As a first step, try
        replacing the Endnotes > Text macro from the Document Experts
        collection, in the Files section here.

        John R.
      • Rick Albright
        Thanks, John. For some reason, the select table command via the keyboard worked better than trying to select by clicking and dragging and I was able to use
        Message 3 of 3 , Aug 19, 2007
        • 0 Attachment
          Thanks, John. For some reason, the "select table" command via the
          keyboard worked better than trying to select by clicking and dragging
          and I was able to use table to text successfully. (I actually just
          used the default keyboard command of shift-option-T to select the
          table. I'd forgotten about this shortcut, which is easy to do,
          because there are just so many of them.) Maybe it just won't work
          unless you select the table exactly, and, because it spanned quite a
          few pages, it was difficult to do precisely by the click-and-drag
          method. Happily, the keyboard command does it.

          BTW, even with a fresh prefs file and after recopying the endnotes -
          >text macro, I ran a test of it and the first 31 endnotes in my file
          were all numbered "1." After that, they numbered normally, but of
          course they were off by that many. Ultimately, this didn't matter,
          because your note editor (plus table to text) got the job done--and
          without completely removing the endnotes from the document, so it was
          a much better solution.

          thanks again for your help.
          Rick Albright

          On Aug 15, 2007, at 8:23 PM, John Rethorst wrote:

          > --- In wordperfectmac@yahoogroups.com, Rick Albright <logres@...>
          > wrote:
          > >
          > > I'm a little rusty in my WP table handling because I haven't worked
          > > with tables for awhile. For some reason, I can't get "table to text"
          > > to work--it's grayed out no matter what I do. I've tried selecting
          > > all, and also using John's suggestion from a previous discussion
          > > about triple clicking in the corner and dragging to the opposite
          > > corner, but nothing works. Text to table is available, but not table
          > > to text.
          >
          > Try assigning a keystroke to the Select Table command in
          > Prefs > Keyboard, a good idea in any case. If Table to Text
          > still doesn't activate, try tossing your Preferences (USA) file.
          >
          > > By the way, it's probably important to mention that the file I'm
          > > using was created by John's Note editor to put all my endnotes in a
          > > file. I saw that the table was protected, and turned this off, but
          > > still no change. (I'm also working with a copy of this file so that
          > > it doesn't interfere with the workings of the macro.)
          >
          > Tables are protected by default when created. This shouldn't
          > matter if no cells are locked.
          >
          > > Alternatively, maybe there's a better way to do what I want to do. I
          > > like the macro's ability to put all my endnotes into a file to give
          > > me more control over them. However, some of my endnotes are lengthy,
          > > and because they're in a table (even though invisible), WP won't
          > wrap
          > > them from one page to the next but will force a page break so
          > that it
          > > can get the whole note on the same page. As a result, I have pages
          > > that when printed have variable, and sometimes large, bottom
          > margins.
          > > (There doesn't seem to be a way in WP to have it automatically wrap
          > > large cells across pages.)
          >
          > Note Editor lets you move endnotes from the note editor file into the
          > document. This way you have the advantage of Note Editor for working
          > with notes, and as a last step you can copy them back into the
          > document.
          > WP won't break a table cell across a page break, but an actual endnote
          > should break.
          >
          > BTW people often try to edit aspects of endnote/footnote behavior by
          > editing the endnote or footnote styles. Those style sheets govern only
          > what's in a note. To do something like remove the default double space
          > between notes, edit your Document style (or whatever style you're
          > using
          > for body text in your file) and set endnote or footnote options there.
          >
          > > I should note here that I previously tried using the "endnotes to
          > > text" macro but (1) it actually _removes_ all the notes from the
          > > original file, and, more importantly, it doesn't keep the endnote
          > > numbers properly in the target file. I end up with a whole series of
          > > 1's, and then will periodically see a series of ascending (but
          > > incorrect) endnote numbers before it reverts to 1's again. So I gave
          > > up on that macro.
          >
          > That macro works fine here. I wonder if a new Preferences (USA) file
          > will help, or whether more surgery is needed. As a first step, try
          > replacing the Endnotes > Text macro from the Document Experts
          > collection, in the Files section here.
          >
          > John R.
          >
          >
          >

          =========================================================
          "No nation could preserve its freedom in the midst of continual
          warfare."
          --James Madison, 1793

          Rick Albright
          logres@...
        Your message has been successfully submitted and would be delivered to recipients shortly.