Loading ...
Sorry, an error occurred while loading the content.

WordPerfect 3.5 under OS X 10.3.9 - preferences

Expand Messages
  • Tom Frere
    I ve installed WordPerfect 3.5 at work, and I want to use the same macros (and buttons for macros) that I have at home (running it native under OS 9.2.2). I
    Message 1 of 10 , May 27, 2005
    • 0 Attachment
      I've installed WordPerfect 3.5 at work, and I want to use the same
      macros (and buttons for macros) that I have at home (running it native
      under OS 9.2.2).

      I copied my WordPerfect preferences folder from home into the System
      Folder--Preferences Folder at work, but WordPerfect doesn't see the
      preferences after re-starting the Classic or the OS X environments.

      Any suggestions?
    • John Rethorst
      ... Copy your Library file - the one in System Folder Preferences WordPerfect, named e.g. Library (USA) - from home to work. BTW you say you ve installed
      Message 2 of 10 , May 27, 2005
      • 0 Attachment
        On May 27, 2005, at 11:43 AM, Tom Frere wrote:

        > I've installed WordPerfect 3.5 at work, and I want to use the same
        > macros (and buttons for macros) that I have at home (running it native
        > under OS 9.2.2).
        >
        > I copied my WordPerfect preferences folder from home into the System
        > Folder--Preferences Folder at work, but WordPerfect doesn't see the
        > preferences after re-starting the Classic or the OS X environments.

        Copy your Library file - the one in System Folder > Preferences >
        WordPerfect, named e.g. "Library (USA)" - from home to work.

        BTW you say you've installed WP 3.5 - do you mean 3.5e, the last
        (downloadable) version, with the updater? If not, download it from the
        Links section here, as well as the OS 8/9 updater, and install that.
        More stable and more features than the original 3.5. Make a copy of
        your Library file first, and use it to replace the Library file that
        the new installation will create.

        John R.
      • Tom Frere
        ... Already did that! I assumed both files were needed. No effect. Is there something in OS X that is interfering? I was able to do this at a previous
        Message 3 of 10 , May 31, 2005
        • 0 Attachment
          > Copy your Library file - the one in System Folder > Preferences >
          > WordPerfect, named e.g. "Library (USA)" - from home to work.


          Already did that! I assumed both files were needed. No effect. Is
          there something in OS X that is interfering? I was able to do this at
          a previous workplace where I had a dual-boot G4. Now I'm running a
          single-boot G5.

          BTW I'm using a version I bought on CD, 3.5, not 3.5e.


          > Make a copy of
          > your Library file first, and use it to replace the Library file that
          > the new installation will create.
          >
          > John R.
        • Steve Kane
          ... Check the Classic Preference Pane in System Preferences. Under the Advanced tab look to see if the following is checked or unchecked: Use Mac OS 9
          Message 4 of 10 , May 31, 2005
          • 0 Attachment
            On May 31, 2005, at 2:01 PM, Tom Frere wrote:

            > > Copy your Library file - the one in System Folder > Preferences >
            > > WordPerfect, named e.g. "Library (USA)" - from home to work.
            >
            >
            > Already did that! I assumed both files were needed. No effect. Is
            > there something in OS X that is interfering? I was able to do this at
            > a previous workplace where I had a dual-boot G4. Now I'm running a
            > single-boot G5.

            Check the Classic Preference Pane in System Preferences. Under the
            Advanced tab look to see if the following is checked or unchecked: "Use
            Mac OS 9 preferences from your home."
            There are two places that your WordPerfect preference files may be:
            hard drive/System Folder/Preferences/WordPerfect
            OR
            hard drive/Users/your user
            folder/Library/Classic/Preferences/WordPerfect
            depending on whether this is checked or not. It cannot be changed while
            Classic is running.
          • John Rethorst
            ... Nothing in X that would interfere - WP runs without problems in classic. Support for classic has actually improved in Tiger. I wonder if you ve put WP s
            Message 5 of 10 , May 31, 2005
            • 0 Attachment
              > >> I've installed WordPerfect 3.5 at work, and I want to use the same
              > >> macros (and buttons for macros) that I have at home (running it
              > native
              > >> under OS 9.2.2).
              >
              > >> I copied my WordPerfect preferences folder from home into the System
              > >> Folder--Preferences Folder at work, but WordPerfect doesn't see the
              > >> preferences after re-starting the Classic or the OS X environments.

              > > Copy your Library file - the one in System Folder > Preferences >
              > > WordPerfect, named e.g. "Library (USA)" - from home to work.
              >
              > Already did that! I assumed both files were needed. No effect. Is
              > there something in OS X that is interfering? I was able to do this at
              > a previous workplace where I had a dual-boot G4. Now I'm running a
              > single-boot G5.

              Nothing in X that would interfere - WP runs without problems in
              classic. Support for classic has actually improved in Tiger. I wonder
              if you've put WP's library in the right place, or if another copy of
              the Library is still the one being used.

              > BTW I'm using a version I bought on CD, 3.5, not 3.5e.

              I would replace that with a downloaded copy of 3.5e, patched with the
              OS 8/9/Classic updater.

              John R.
            • Geoff Gilbert
              Tom I assume you only have one System Folder on this new machine. Geoff
              Message 6 of 10 , May 31, 2005
              • 0 Attachment
                Tom

                I assume you only have one System Folder on this new machine.

                Geoff

                > > Copy your Library file - the one in System Folder > Preferences >
                >> WordPerfect, named e.g. "Library (USA)" - from home to work.
                >
                >
                >Already did that! I assumed both files were needed. No effect. Is
                >there something in OS X that is interfering? I was able to do this at
                >a previous workplace where I had a dual-boot G4. Now I'm running a
                >single-boot G5.
                >
                >BTW I'm using a version I bought on CD, 3.5, not 3.5e.
                >
                >
                >> Make a copy of
                >> your Library file first, and use it to replace the Library file that
                >> the new installation will create.
                >>
                >> John R.
                >
                >
                >
                >
                >
                >Yahoo! Groups Links
                >
                >
                >
                >
              • Tom Frere
                I noticed in my preferences that Classic was set to Turn off extensions so I changed it to Open Extensions Manager and restarted Classic. Then I re-copied
                Message 7 of 10 , May 31, 2005
                • 0 Attachment
                  I noticed in my preferences that Classic was set to "Turn off
                  extensions" so I changed it to "Open Extensions Manager" and restarted
                  Classic.

                  Then I re-copied the preferences files from home to my hard drive at
                  work and---nope! WordPerfect created two new preferences files dated
                  today.

                  Also, the choice "Use Mac OS 9 Preferences from home" is greyed out
                  (cannot be selected or deselected).

                  I looked in my Users folder and there isn't a folder called "Classic"
                  inside "Library."

                  Thanks for the prompt replies!


                  --- In wordperfectmac@yahoogroups.com, Steve Kane <skane@s...> wrote:

                  >
                  > Check the Classic Preference Pane in System Preferences. Under the
                  > Advanced tab look to see if the following is checked or unchecked: "Use
                  > Mac OS 9 preferences from your home."
                  > There are two places that your WordPerfect preference files may be:
                  > hard drive/System Folder/Preferences/WordPerfect
                  > OR
                  > hard drive/Users/your user
                  > folder/Library/Classic/Preferences/WordPerfect
                  > depending on whether this is checked or not. It cannot be changed while
                  > Classic is running.
                • Steve Kane
                  ... How are you copying the WordPerfect preference files? Are you putting them on a usb flash drive? If so, the drive may be dos fat 16 formatted. A dos
                  Message 8 of 10 , May 31, 2005
                  • 0 Attachment
                    On May 31, 2005, at 4:47 PM, Tom Frere wrote:

                    > I noticed in my preferences that Classic was set to "Turn off
                    > extensions" so I changed it to "Open Extensions Manager" and restarted
                    > Classic.
                    >
                    > Then I re-copied the preferences files from home to my hard drive at
                    > work and---nope! WordPerfect created two new preferences files dated
                    > today.
                    >
                    > Also, the choice "Use Mac OS 9 Preferences from home" is greyed out
                    > (cannot be selected or deselected).
                    >
                    > I looked in my Users folder and there isn't a folder called "Classic"
                    > inside "Library."

                    How are you copying the WordPerfect preference files? Are you putting
                    them on a usb "flash" drive? If so, the drive may be dos fat 16
                    formatted. A dos formatted drive does not transfer the "resource fork"
                    of the file if there is one. I don't know specifically if the
                    WordPerfect preference files have resource forks or not, but many files
                    created by Classic applications do have resource forks.

                    If you are using a usb flash drive, open Apple's Disk Utility and click
                    on the drive name then click on the Info button. Disk Utility will tell
                    you how it is formatted. If it is indeed formatted as a dos drive you
                    can do either of two things:

                    1) You could reformat the drive as a Mac OS Extended drive, but if you
                    do this then the drive CANNOT be read from or written to by a pc
                    running Windows, until it is reformatted by a pc running Windows as a
                    dos drive (this may or may not be important to you).

                    OR

                    2) You could compress the WordPerfect preference files that you want to
                    copy over before you copy them to the usb flash drive. Compressing the
                    files will preserve all the attributes of the files. When you then
                    expand the files on the other Mac they should be recognized by
                    WordPerfect as valid preference files.
                  • John Rethorst
                    ... WP s Preferences file does have a resource fork. John R.
                    Message 9 of 10 , May 31, 2005
                    • 0 Attachment
                      On May 31, 2005, at 3:03 PM, Steve Kane wrote:

                      > How are you copying the WordPerfect preference files? Are you putting
                      > them on a usb "flash" drive? If so, the drive may be dos fat 16
                      > formatted. A dos formatted drive does not transfer the "resource fork"
                      > of the file if there is one. I don't know specifically if the
                      > WordPerfect preference files have resource forks or not,

                      WP's Preferences file does have a resource fork.

                      John R.
                    • John Rethorst
                      ... That part of the prefpane could be better designed. Classic will turn off extensions only if you have it set that way in the Advanced pane _and_ click
                      Message 10 of 10 , May 31, 2005
                      • 0 Attachment
                        On May 31, 2005, at 2:47 PM, Tom Frere wrote:

                        > I noticed in my preferences that Classic was set to "Turn off
                        > extensions" so I changed it to "Open Extensions Manager" and restarted
                        > Classic.

                        That part of the prefpane could be better designed. Classic will turn
                        off extensions only if you have it set that way in the Advanced pane
                        _and_ click "Restart Classic" just to the right of that setting.
                        Restarting classic in the Start/Stop pane will not turn off extensions.

                        > Then I re-copied the preferences files from home to my hard drive at
                        > work and---nope! WordPerfect created two new preferences files dated
                        > today.

                        Where are they? Why two? IAC it's the Library you need. Did WP create a
                        new one? Quit WP and replace the new one with the one from home (as
                        Steve said, you need to be sure you're copying the entire file,
                        including the resource fork. WP's library as well as prefs file has a
                        resource fork).

                        > Also, the choice "Use Mac OS 9 Preferences from home" is greyed out
                        > (cannot be selected or deselected).

                        That selection can only be made when classic is not running.

                        John R.
                      Your message has been successfully submitted and would be delivered to recipients shortly.