Loading ...
Sorry, an error occurred while loading the content.

Re: Macro help

Expand Messages
  • John Rethorst
    ... When I run it, I don t get the Not Valid error (if you have a window open when run, do you get that error before the menu appears, or after you ve made a
    Message 1 of 12 , May 10, 2005
    • 0 Attachment
      --- In wordperfectmac@yahoogroups.com, RjC <rjtc@o...> wrote:

      > I entered the macro lines you provided as instructed,
      > however, when I Run the macro I get an error message
      > "Macro Terminated:command not valid here". Any
      > thoughts?

      When I run it, I don't get the Not Valid error (if you have
      a window open when run, do you get that error before
      the menu appears, or after you've made a choice from it?),
      but I get a Label Not Found error when I choose the second
      menu item. This is because in the Case line you have "SFCC"
      and the second Label is "SFC", while they must match exactly.

      Also note that this part of the code must conclude with a

      Label (continue)

      I've put the corrected macro in a file in the Temporary_Items
      folder at the top of the Files section here. Let us know how
      that runs.

      John
    • rjtc5
      John: again thank you. I made the changes you referenced (ie. SFCC to SFC and ended that section of the macro w/ Label (continue)), and running the macro w/ a
      Message 2 of 12 , May 11, 2005
      • 0 Attachment
        John: again thank you.

        I made the changes you referenced (ie. SFCC to SFC and ended
        that section of the macro w/ Label (continue)), and running the
        macro w/ a document open. Unfortunateley, I am still getting the
        "Macro Terminated: This command not valid here". I'm not
        entirely sure what to look for so it may be something simple.
        Apologies for the hand holding. rich



        --- In wordperfectmac@yahoogroups.com, "John Rethorst"
        <jrethorst@y...> wrote:
        > --- In wordperfectmac@yahoogroups.com, RjC <rjtc@o...>
        wrote:
        >
        > > I entered the macro lines you provided as instructed,
        > > however, when I Run the macro I get an error message
        > > "Macro Terminated:command not valid here". Any
        > > thoughts?
        >
        > When I run it, I don't get the Not Valid error (if you have
        > a window open when run, do you get that error before
        > the menu appears, or after you've made a choice from it?),
        > but I get a Label Not Found error when I choose the second
        > menu item. This is because in the Case line you have "SFCC"
        > and the second Label is "SFC", while they must match exactly.
        >
        > Also note that this part of the code must conclude with a
        >
        > Label (continue)
        >
        > I've put the corrected macro in a file in the Temporary_Items
        > folder at the top of the Files section here. Let us know how
        > that runs.
        >
        > John
      • John Rethorst
        ... At the top of the macro, add this line: Step (On) Now when you run the macro, you ll see a new window at the bottom of your screen with the line of macro
        Message 3 of 12 , May 11, 2005
        • 0 Attachment
          On May 11, 2005, at 10:25 AM, rjtc5 wrote:

          > I made the changes you referenced (ie. SFCC to SFC and ended
          > that section of the macro w/ Label (continue)), and  running the
          > macro w/ a document open.   Unfortunateley, I am still getting the 
          > "Macro Terminated: This command not valid here".

          At the top of the macro, add this line:

          Step (On)

          Now when you run the macro, you'll see a new window at the bottom of
          your screen with the line of macro code that's about to be executed.
          Press any key to execute that line, and you'll see the next line appear
          in the window. Continue stepping through it until you get the error.
          What line produces it?

          John R.
        • rjtc5
          Update: I copied the part of the macro we are working on into another copy and it works to a point. The dialog box comes up to choose email address , but,
          Message 4 of 12 , May 11, 2005
          • 0 Attachment
            Update: I copied the part of the macro we are working on into
            another copy and it works to a point. The dialog box comes up
            to "choose email address", but, once I make a selection the
            macro hangs up or stops. It actually puts the email address into
            the header, however, it does not continue w/ the rest of the
            letterhead? Any thoughts? Thanks, rich

            --- In wordperfectmac@yahoogroups.com, "rjtc5" <rjtc@o...>
            wrote:
            > John: again thank you.
            >
            > I made the changes you referenced (ie. SFCC to SFC and
            ended
            > that section of the macro w/ Label (continue)), and running the
            > macro w/ a document open. Unfortunateley, I am still getting
            the
            > "Macro Terminated: This command not valid here". I'm not
            > entirely sure what to look for so it may be something simple.
            > Apologies for the hand holding. rich
            >
            >
            >
            > --- In wordperfectmac@yahoogroups.com, "John Rethorst"
            > <jrethorst@y...> wrote:
            > > --- In wordperfectmac@yahoogroups.com, RjC <rjtc@o...>
            > wrote:
            > >
            > > > I entered the macro lines you provided as instructed,
            > > > however, when I Run the macro I get an error message
            > > > "Macro Terminated:command not valid here". Any
            > > > thoughts?
            > >
            > > When I run it, I don't get the Not Valid error (if you have
            > > a window open when run, do you get that error before
            > > the menu appears, or after you've made a choice from it?),
            > > but I get a Label Not Found error when I choose the second
            > > menu item. This is because in the Case line you have
            "SFCC"
            > > and the second Label is "SFC", while they must match
            exactly.
            > >
            > > Also note that this part of the code must conclude with a
            > >
            > > Label (continue)
            > >
            > > I've put the corrected macro in a file in the Temporary_Items
            > > folder at the top of the Files section here. Let us know how
            > > that runs.
            > >
            > > John
          • rjtc5
            john - added the step (on) line at the top of macro (that is a pretty cool tool). Anyway, it hangs up at the line beginning with Menu (Var01; choose
            Message 5 of 12 , May 11, 2005
            • 0 Attachment
              john - added the "step (on)" line at the top of macro (that is a
              pretty cool tool). Anyway, it hangs up at the line beginning with
              "Menu (Var01; "choose email address .....". Any thoughts.


              --- In wordperfectmac@yahoogroups.com, "rjtc5" <rjtc@o...>
              wrote:
              > Update: I copied the part of the macro we are working on into
              > another copy and it works to a point. The dialog box comes up
              > to "choose email address", but, once I make a selection the
              > macro hangs up or stops. It actually puts the email address
              into
              > the header, however, it does not continue w/ the rest of the
              > letterhead? Any thoughts? Thanks, rich
              >
              > --- In wordperfectmac@yahoogroups.com, "rjtc5" <rjtc@o...>
              > wrote:
              > > John: again thank you.
              > >
              > > I made the changes you referenced (ie. SFCC to SFC and
              > ended
              > > that section of the macro w/ Label (continue)), and running
              the
              > > macro w/ a document open. Unfortunateley, I am still getting
              > the
              > > "Macro Terminated: This command not valid here". I'm not
              > > entirely sure what to look for so it may be something simple.
              > > Apologies for the hand holding. rich
              > >
              > >
              > >
              > > --- In wordperfectmac@yahoogroups.com, "John Rethorst"
              > > <jrethorst@y...> wrote:
              > > > --- In wordperfectmac@yahoogroups.com, RjC <rjtc@o...>
              > > wrote:
              > > >
              > > > > I entered the macro lines you provided as instructed,
              > > > > however, when I Run the macro I get an error message
              > > > > "Macro Terminated:command not valid here". Any
              > > > > thoughts?
              > > >
              > > > When I run it, I don't get the Not Valid error (if you have
              > > > a window open when run, do you get that error before
              > > > the menu appears, or after you've made a choice from it?),
              > > > but I get a Label Not Found error when I choose the second
              > > > menu item. This is because in the Case line you have
              > "SFCC"
              > > > and the second Label is "SFC", while they must match
              > exactly.
              > > >
              > > > Also note that this part of the code must conclude with a
              > > >
              > > > Label (continue)
              > > >
              > > > I've put the corrected macro in a file in the
              Temporary_Items
              > > > folder at the top of the Files section here. Let us know how
              > > > that runs.
              > > >
              > > > John
            • John Rethorst
              ... Does it hang in the macro I put in Files Temporary_Items here? (BTW small update is now there). John R.
              Message 6 of 12 , May 11, 2005
              • 0 Attachment
                --- In wordperfectmac@yahoogroups.com, "rjtc5" <rjtc@o...> wrote:
                > john - added the "step (on)" line at the top of macro (that is a
                > pretty cool tool). Anyway, it hangs up at the line beginning with
                > "Menu (Var01; "choose email address .....".

                Does it hang in the macro I put in Files > Temporary_Items here?
                (BTW small update is now there).

                John R.
              • rjtc5
                I don t know . I had a problem installing that macro. With the document open, I go through the process to install (Edit/Prefs/Librarian/set Resource
                Message 7 of 12 , May 11, 2005
                • 0 Attachment
                  I don't know . I had a problem installing that macro. With the
                  document open, I go through the process to install
                  (Edit/Prefs/Librarian/set Resource drop-down to macros),
                  however, nothing shows in the window to the right which I can
                  copy to my library? After I updated my macro using the edit
                  command under Tools>Macro and ran into problems I wanted to
                  give yours a shot, but, found I was not able to copy into the
                  library. rich


                  --- In wordperfectmac@yahoogroups.com, "John Rethorst"
                  <jrethorst@y...> wrote:
                  > --- In wordperfectmac@yahoogroups.com, "rjtc5" <rjtc@o...>
                  wrote:
                  > > john - added the "step (on)" line at the top of macro (that is a
                  > > pretty cool tool). Anyway, it hangs up at the line beginning
                  with
                  > > "Menu (Var01; "choose email address .....".
                  >
                  > Does it hang in the macro I put in Files > Temporary_Items
                  here?
                  > (BTW small update is now there).
                  >
                  > John R.
                • John Rethorst
                  [Taken off-list due to detailed trouble-shooting and fixed. I ll post a summary.] John R.
                  Message 8 of 12 , May 12, 2005
                  • 0 Attachment
                    [Taken off-list due to detailed trouble-shooting and fixed.
                    I'll post a summary.]

                    John R.
                  Your message has been successfully submitted and would be delivered to recipients shortly.