Loading ...
Sorry, an error occurred while loading the content.

7701Re: Question about macro variables

Expand Messages
  • John R
    Mar 10 9:48 PM
    • 0 Attachment
      The program was written in Utah.

      John R.



      --- In wordperfectmac@yahoogroups.com, "em315" <em315@...> wrote:
      >
      > Here is a mystery that I hope a macro expert can solve.
      >
      > I'm trying to write a macro that sets the default zoom (magnification) level for all windows.
      >
      > Here's a series of experiments. First I created an empty template called "New Document Template" in the Templates folder. I did this so that an OnOpenDocument macro would work on new documents as well as existing ones.
      >
      > Then I created an "OnOpenDocument" macro that contains these lines:
      >
      > Assign (GlobalVar30;135)
      > Magnification (GlobalVar30)
      >
      > This worked perfectly. All new and existing documents open at the zoom level of 135%.
      >
      > Then I created an "OnStartUp" macro (to run when WP starts up) with this line:
      >
      > Assign (GlobalVar30;135)
      >
      > And I changed the "OnOpenDocument" macro so that it had only this line:
      >
      > Magnification (GlobalVar30)
      >
      > I closed down WP, started it up again - and the first blank opens at a zoom level of 3663%.
      >
      > All later documents and windows open at 135%.
      >
      > The same thing happens if I start up WP by clicking on a document icon; it opens at 3663%.
      >
      > If I close the document and reopen it, it opens at 135%, correctly.
      >
      > What is making the first document open at 3663%?
      >
    • Show all 3 messages in this topic