Loading ...
Sorry, an error occurred while loading the content.

Re: [wn-similarity] Problems installing Wordnet::Similarity on Windows - Activestate Perl

Expand Messages
  • ted pedersen
    Thanks for the update! I really appreciate your efforts to put Windows installation instructions together on your blog. This is an area where we have limited
    Message 1 of 2 , Sep 26, 2005
    • 0 Attachment
      Thanks for the update! I really appreciate your efforts to put Windows
      installation instructions together on your blog. This is an area where we
      have limited experience (actually, no experience, to be really honest
      about it) so your help and that of other Windows users is truly
      appreciated.

      I will go ahead and also forward this to the wn-perl@yahoogroups.com list,
      since it sounds like it might bear more upon WordNet::QueryData than it
      does WordNet::Similarity (although I find it strange that QueryData works
      ok on its own, but then fails with Similarity). In any case,
      WordNet::QueryData and WordNet::Similarity are two different projects,
      although Similarity certainly depends on QueryData.

      BTW, I notice from your blog that you are using WordNet 2.0 with QueryData
      1.39. I *think* those might be incompatible - I *think* 1.39 only supports
      2.1, and for 2.0 you should back off to QueryData 1.38. This is what can
      be confirmed or denied via wn-perl.

      Cordially,
      Ted

      On Sun, 25 Sep 2005, rschurchill_uk wrote:


      > I had a few issues getting Wordnet::Similarity installed on Windows
      > under Activstate Perl, due to what is probably, a makefile issue in
      > Wordnet::QueryData. The windows version of Wordnet uses different
      > filenames in the /dict directory than it's UNIX counterpart.
      > Wordnet::QueryData works fine on it's own but when trying to make
      > Wordnet::Similarity, path errors occur.
      >
      > I fixed the problem but I haven't delved any deeper to figure out why
      > the wrong filenames were in Wordnet::QueryData. I've published an
      > installation guide for Windows users on my blog.
      >
      > http://spaces.msn.com/members/outside-world/
      >
      >
      > Richard Churchill
      >
      >

      --
      Ted Pedersen
      http://www.d.umn.edu/~tpederse
    • Jason Rennie
      You ve got it right, Ted. 1.39 goes with WN 2.1. Use 1.38 with WN 1.7.1 or 2.0. Use 1.26 with WN 1.6 or 1.7. This is all detailed on the QueryData web page
      Message 2 of 2 , Sep 26, 2005
      • 0 Attachment
        You've got it right, Ted.  1.39 goes with WN 2.1.  Use 1.38 with WN 1.7.1 or 2.0.  Use 1.26 with WN 1.6 or 1.7.  This is all detailed on the QueryData web page under "Download."

        Jason

      Your message has been successfully submitted and would be delivered to recipients shortly.