Loading ...
Sorry, an error occurred while loading the content.

291Re: [wn-perl] Perl 5.8.6

Expand Messages
  • Ben Haskell
    Jul 24 6:08 PM
    • 0 Attachment
      Hi Garrett --

      It looks as though you have two versions of Perl installed, and your
      v5.8.0 perl is listed before your v5.8.6 perl in your PATH variable. Or at
      least, it's the one being found. (Could be an aliasing issue: perl
      pointing to perl5.8.0 or something similar.)

      I performed the following test on our Solaris machine here, which still
      has a v5.6.0 perl installed:

      # set environment variable to intentionally find the wrong Config.pm
      $ export PERL5LIB=/usr/csl/perl/lib/5.8.0/sun4-solaris-thread-multi
      $ perl5.6.0 -MConfig
      Perl lib version (v5.8.0) doesn't match executable version (v5.6.0) at
      /usr/csl/perl/lib/5.8.0/sun4-solaris-thread-multi/Config.pm line 21.

      So, not WN::QD's fault.

      Best of luck.
      -- Ben Haskell
      -- WordNet Technical Support Specialist

      On Sun, 24 Jul 2005, Garrett Heifrin wrote:

      >
      > Hi,
      >
      > I installed NMake, and when I try Makefile.pl, I get the following
      > error message. Is it that QueryData is not compatible with Perl
      > 5.8.6? If not, should I get an earlier version of Perl, and, if so,
      > which is most compatible?
      >
      > C:\WordNet-QueryData-1.38>perl Makefile.pl
      > Perl lib version (v5.8.6) doesn't match executable version (v5.8.0) at
      > C:\Perl\lib\Config.pm line 32.
      >
      > Thanks,
      > Garrett
    • Show all 3 messages in this topic