Loading ...
Sorry, an error occurred while loading the content.

xhtml + php

Expand Messages
  • bagus@oranye.net
    is it allowed to discuss about xhtml in here? since it is based on the xml which is the mother of wml =) i try to combined xhtml + php to create my page more
    Message 1 of 15 , Jul 31, 2003
    • 0 Attachment
      is it allowed to discuss about xhtml in here?
      since it is based on the xml which is the mother of wml =)

      i try to combined xhtml + php to create my page more dinamic
      when i validate using validate.w3.org its ok, but browsing through mobile
      phone (7650) it failed
      the source is:

      <?header("Content-type: text/html");?>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
      "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
      <html>
      <head><title>hi</title></head>
      <body>
      <p>

      <?
      echo "hi!";
      ?>

      </p>
      </body>
      </html>

      when i use <? and <?php always give the same error
      if this is not the place, maybe someone knows the proper place is?

      TIA
    • Ankem, Balaji
      Change the content type from html to xhtml and try again. Application/xhtml+xml Balaji ... From: bagus@oranye.net [mailto:bagus@oranye.net] Sent: Thursday 31
      Message 2 of 15 , Aug 1, 2003
      • 0 Attachment
        Change the content type from html to xhtml and try again.

        Application/xhtml+xml

        Balaji


        -----Original Message-----
        From: bagus@... [mailto:bagus@...]
        Sent: Thursday 31 July 2003 19:17
        To: wmlprogramming@yahoogroups.com
        Subject: [wmlprogramming] xhtml + php


        is it allowed to discuss about xhtml in here?
        since it is based on the xml which is the mother of wml =)

        i try to combined xhtml + php to create my page more dinamic when i
        validate using validate.w3.org its ok, but browsing through mobile phone
        (7650) it failed the source is:

        <?header("Content-type: text/html");?>
        <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
        <html>
        <head><title>hi</title></head>
        <body>
        <p>

        <?
        echo "hi!";
        ?>

        </p>
        </body>
        </html>

        when i use <? and <?php always give the same error
        if this is not the place, maybe someone knows the proper place is?

        TIA


        Please read the FAQ before you ask questions:
        http://www.thewirelessfaq.com

        Visit http://groups.yahoo.com/group/wmlprogramming for archive and
        subscription options

        Your use of Yahoo! Groups is subject to
        http://docs.yahoo.com/info/terms/
      • Bruno PIERRE
        i think that you must use this DTD for the mobile phone
        Message 3 of 15 , Aug 1, 2003
        • 0 Attachment
          i think that you must use this DTD for the mobile phone
          <!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN"
          "http://www.wapforum.org/DTD/xhtml-mobile10.dtd" >

          or perhaps without any DTD

          did you try with a static page?

          ----- Original Message -----
          From: <bagus@...>
          To: <wmlprogramming@yahoogroups.com>
          Sent: Thursday, July 31, 2003 7:16 PM
          Subject: [wmlprogramming] xhtml + php


          > is it allowed to discuss about xhtml in here?
          > since it is based on the xml which is the mother of wml =)
          >
          > i try to combined xhtml + php to create my page more dinamic
          > when i validate using validate.w3.org its ok, but browsing through mobile
          > phone (7650) it failed
          > the source is:
          >
          > <?header("Content-type: text/html");?>
          > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
          > "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
          > <html>
          > <head><title>hi</title></head>
          > <body>
          > <p>
          >
          > <?
          > echo "hi!";
          > ?>
          >
          > </p>
          > </body>
          > </html>
          >
          > when i use <? and <?php always give the same error
          > if this is not the place, maybe someone knows the proper place is?
          >
          > TIA
          >
          >
          > Please read the FAQ before you ask questions:
          http://www.thewirelessfaq.com
          >
          > Visit http://groups.yahoo.com/group/wmlprogramming for archive and
          subscription options
          >
          > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
          >
        • luca passani
          you have not configured your PHP properly. The server is serving PHP files, not XHTML file. Look at your page with a web browser and see for yourself luca
          Message 4 of 15 , Aug 1, 2003
          • 0 Attachment
            you have not configured your PHP properly. The server is serving PHP files,
            not XHTML file. Look at your page with a web browser and see for yourself

            luca

            bagus@... wrote:
            >
            > is it allowed to discuss about xhtml in here?
            > since it is based on the xml which is the mother of wml =)
            >
            > i try to combined xhtml + php to create my page more dinamic
            > when i validate using validate.w3.org its ok, but browsing through mobile
            > phone (7650) it failed
            > the source is:
            >
            > <?header("Content-type: text/html");?>
            > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
            > "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
            > <html>
            > <head><title>hi</title></head>
            > <body>
            > <p>
            >
            > <?
            > echo "hi!";
            > ?>
            >
            > </p>
            > </body>
            > </html>
            >
            > when i use <? and <?php always give the same error
            > if this is not the place, maybe someone knows the proper place is?
            >
            > TIA
            >
          • bagus@oranye.net
            ... in static page
            Message 5 of 15 , Aug 1, 2003
            • 0 Attachment
              > did you try with a static page?

              in static page

              <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
              "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
              <html>
              <head><title>hi</title></head>
              <body>
              <p>
              hi
              </p>
              </body>
              </html>

              run well when i use .html or .php extension
            • luca passani
              bagus, please fix your PHP install before you post again. luca
              Message 6 of 15 , Aug 1, 2003
              • 0 Attachment
                bagus, please fix your PHP install before you post again.

                luca

                bagus@... wrote:
                >
                > > did you try with a static page?
                >
                > in static page
                >
                > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
                > "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
                > <html>
                > <head><title>hi</title></head>
                > <body>
                > <p>
                > hi
                > </p>
                > </body>
                > </html>
                >
                > run well when i use .html or .php extension
                >
              • bagus@oranye.net
                ... i m sorry, can u explain this because i create wml+php and it work find TIA
                Message 7 of 15 , Aug 1, 2003
                • 0 Attachment
                  >
                  > bagus, please fix your PHP install before you post again.
                  >
                  > luca

                  i'm sorry, can u explain this
                  because i create wml+php and it work find

                  TIA
                • luca passani
                  post the URL of your test or, alternatively, visit you PHP page with internet explorer, do a view- source and post what you see luca
                  Message 8 of 15 , Aug 1, 2003
                  • 0 Attachment
                    post the URL of your test or, alternatively, visit you PHP page with
                    internet explorer, do a view->source and post what you see

                    luca

                    bagus@... wrote:
                    >
                    > >
                    > > bagus, please fix your PHP install before you post again.
                    > >
                    > > luca
                    >
                    > i'm sorry, can u explain this
                    > because i create wml+php and it work find
                    >
                    > TIA
                    >
                    > Please read the FAQ before you ask questions: http://www.thewirelessfaq.com
                    >
                    > Visit http://groups.yahoo.com/group/wmlprogramming for archive and subscription options
                    >
                    > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                  • bagus@oranye.net
                    ... http://xxx.oranye.net/index.php
                    Message 9 of 15 , Aug 1, 2003
                    • 0 Attachment
                      >
                      > post the URL of your test or, alternatively, visit you PHP page with
                      > internet explorer, do a view->source and post what you see
                      >
                      > luca

                      http://xxx.oranye.net/index.php

                      <?php header("Content-type: text/html"); ?>
                      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3
                      org/TR/xhtml1/DTD/xhtml1-strict.dtd">
                      <html>
                      <head><title>hi</title></head>
                      <body>
                      <p>
                      <?php echo "hi"; ?>
                      </p>
                      </body>
                      </html>

                      http://xxx.oranye.net/index.html

                      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3
                      org/TR/xhtml1/DTD/xhtml1-strict.dtd">
                      <html>
                      <head><title>hi</title></head>
                      <body>
                      <p>
                      hi
                      </p>
                      </body>
                      </html>
                    • luca passani
                      from http://validator.w3.org/check?uri=http%3A%2F%2Fxxx.oranye.net%2Findex.php This Page Is Valid XHTML 1.0 Strict! so, what s your problem? luca
                      Message 10 of 15 , Aug 1, 2003
                      • 0 Attachment
                        from

                        http://validator.w3.org/check?uri=http%3A%2F%2Fxxx.oranye.net%2Findex.php

                        This Page Is Valid XHTML 1.0 Strict!

                        so, what's your problem?

                        luca


                        bagus@... wrote:
                        >
                        > >
                        > > post the URL of your test or, alternatively, visit you PHP page with
                        > > internet explorer, do a view->source and post what you see
                        > >
                        > > luca
                        >
                        > http://xxx.oranye.net/index.php
                        >
                        > <?php header("Content-type: text/html"); ?>
                        > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3
                        > org/TR/xhtml1/DTD/xhtml1-strict.dtd">
                        > <html>
                        > <head><title>hi</title></head>
                        > <body>
                        > <p>
                        > <?php echo "hi"; ?>
                        > </p>
                        > </body>
                        > </html>
                        >
                        > http://xxx.oranye.net/index.html
                        >
                        > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3
                        > org/TR/xhtml1/DTD/xhtml1-strict.dtd">
                        > <html>
                        > <head><title>hi</title></head>
                        > <body>
                        > <p>
                        > hi
                        > </p>
                        > </body>
                        > </html>
                        >
                        > Please read the FAQ before you ask questions: http://www.thewirelessfaq.com
                        >
                        > Visit http://groups.yahoo.com/group/wmlprogramming for archive and subscription options
                        >
                        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                      • bagus@oranye.net
                        ... index.html can be access from mobile phone (nokia 7650) but index.php can t
                        Message 11 of 15 , Aug 1, 2003
                        • 0 Attachment
                          >
                          > from
                          >
                          > http://validator.w3.org/check?uri=http%3A%2F%2Fxxx.oranye.net%2Findex.php
                          >
                          > This Page Is Valid XHTML 1.0 Strict!
                          >
                          >so, what's your problem?
                          >
                          > luca

                          index.html can be access from mobile phone (nokia 7650) but index.php can't
                        • luca passani
                          7650 is NOT a WAP2 phone, so it is NOT supposed to read XHTML of any kind luca
                          Message 12 of 15 , Aug 1, 2003
                          • 0 Attachment
                            7650 is NOT a WAP2 phone, so it is NOT supposed to read XHTML of any kind

                            luca

                            bagus@... wrote:
                            >
                            > >
                            > > from
                            > >
                            > > http://validator.w3.org/check?uri=http%3A%2F%2Fxxx.oranye.net%2Findex.php
                            > >
                            > > This Page Is Valid XHTML 1.0 Strict!
                            > >
                            > >so, what's your problem?
                            > >
                            > > luca
                            >
                            > index.html can be access from mobile phone (nokia 7650) but index.php can't
                          • Ed Alkema
                            Did anyone have a go at the script to update the wurfl? http://www.thewirelessfaq.com/uaupdate.asp You can try the script it won t change the existing WURFL it
                            Message 13 of 15 , Aug 3, 2003
                            • 0 Attachment
                              Did anyone have a go at the script to update the wurfl?
                              http://www.thewirelessfaq.com/uaupdate.asp
                              You can try the script it won't change the existing WURFL it will just
                              sent out an email showing what changes you requested.
                              So checkt it out and let me know what you think.

                              Ed
                            • J.Luis Narbona Moreno
                              Maybe you could use Opera Browser for 7650 that supports XHTML? ... From: luca passani To: Sent: Friday,
                              Message 14 of 15 , Aug 4, 2003
                              • 0 Attachment
                                Maybe you could use Opera Browser for 7650 that supports XHTML?

                                ----- Original Message -----
                                From: "luca passani" <passani@...>
                                To: <wmlprogramming@yahoogroups.com>
                                Sent: Friday, August 01, 2003 6:44 PM
                                Subject: Re: [wmlprogramming] xhtml + php


                                >
                                > 7650 is NOT a WAP2 phone, so it is NOT supposed to read XHTML of any kind
                                >
                                > luca
                                >
                                > bagus@... wrote:
                                > >
                                > > >
                                > > > from
                                > > >
                                > > >
                                http://validator.w3.org/check?uri=http%3A%2F%2Fxxx.oranye.net%2Findex.php
                                > > >
                                > > > This Page Is Valid XHTML 1.0 Strict!
                                > > >
                                > > >so, what's your problem?
                                > > >
                                > > > luca
                                > >
                                > > index.html can be access from mobile phone (nokia 7650) but index.php
                                can't
                                >
                                > Please read the FAQ before you ask questions:
                                http://www.thewirelessfaq.com
                                >
                                > Visit http://groups.yahoo.com/group/wmlprogramming for archive and
                                subscription options
                                >
                                > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                                >
                                >
                              • Andrea Trasatti
                                Bagus, you need to set the proper content type, as Balaji told you: Application/xhtml+xml Regards, Andrea ... ==================== Andrea Trasatti Bware
                                Message 15 of 15 , Aug 25, 2003
                                • 0 Attachment
                                  Bagus, you need to set the proper content type, as Balaji told you:
                                  Application/xhtml+xml

                                  Regards,
                                  Andrea

                                  On 1 Aug 2003 at 16:32, bagus@... wrote:

                                  > >
                                  > > from
                                  > >
                                  > > http://validator.w3.org/check?uri=http%3A%2F%2Fxxx.oranye.net%2Findex.php
                                  > >
                                  > > This Page Is Valid XHTML 1.0 Strict!
                                  > >
                                  > >so, what's your problem?
                                  > >
                                  > > luca
                                  >
                                  > index.html can be access from mobile phone (nokia 7650) but index.php can't
                                  >
                                  >
                                  > Please read the FAQ before you ask questions: http://www.thewirelessfaq.com
                                  >
                                  > Visit http://groups.yahoo.com/group/wmlprogramming for archive and subscription options
                                  >
                                  > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
                                  >
                                  >



                                  ====================
                                  Andrea Trasatti
                                  Bware Technologies
                                  http://www.bware.it
                                Your message has been successfully submitted and would be delivered to recipients shortly.