Loading ...
Sorry, an error occurred while loading the content.

problem with logfile-format: url + user-agent

Expand Messages
  • W. M.
    Hi webalizers! I have a problem with the cs-uri-stem entries in my webalizer-stats. Look at my logfile (W3C-Format under IIS4) After url information
    Message 1 of 3 , Jan 7, 2002
    • 0 Attachment
      Hi webalizers!

      I have a problem with the cs-uri-stem entries in my webalizer-stats. Look at
      my logfile (W3C-Format under IIS4)

      After url information user-agent is seperated by a comma (e.g.
      /top.htm,+Mozilla/4.0+(compatible.........). I don't know how to supress
      this.

      Webalizer interprets this whole string as url in the TopUrl and TopUrlK
      stats. I get for each page accessed by different browsers an extra entry in
      my stats.

      Is it a problem of webalizer or can i suppress output of user-agent after
      url?


      This is my logfile:

      Software: Microsoft Internet Information Server 4.0
      #Version: 1.0
      #Date: 2002-01-07 10:12:05
      #Fields: date time c-ip cs-method cs-uri-stem sc-status sc-bytes cs-bytes
      time-taken cs(User-Agent) cs(Referer)
      2002-01-07 10:12:05 194.112.133.47 GET
      /top.htm,+Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+98;+Win+9x+4.90;+Q312461),+-
      200 1133 409 181
      Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+98;+Win+9x+4.90;+Q312461) -
      2002-01-07 10:12:08 194.112.133.47 GET
      /top.htm,+Mozilla/4.0+(compatible;+MSIE+5.5;+Windows+98;+Win+9x+4.90;+Q312461),+http://www.aon.at/top.htm
      200 3175 325 220
      Mozilla/4.0+(compatible;+MSIE+5.5;+Windows+98;+Win+9x+4.90;+Q312461) -


      This is the resulting stat:

      Top 3 von 3 URLs

      # Anfragen kb URL

      1 3 60.00% 1 10.94% /
      2 1 20.00% 3 65.64% /top.htm,+Mozilla/4.0+(compatible
      3 1 20.00% 1 23.42% /top.htm,+Mozilla/4.0+(compatible


      wasiko



      _________________________________________________________________
      Send and receive Hotmail on your mobile device: http://mobile.msn.com
    • Kees de Keizer
      ... I ve searched the MS Knowledge Base about this problem, but I couldn t find an answer about this. But that doesn t mean that it is not there... ... It s in
      Message 2 of 3 , Jan 9, 2002
      • 0 Attachment
        Op 07-01-2002 schreef W. M.:

        > I have a problem with the cs-uri-stem entries in my webalizer
        > stats. Look at my logfile (W3C-Format under IIS4)
        > After url information user-agent is seperated by a comma (e.g.
        > /top.htm,+Mozilla/4.0+(compatible.........). I don't know how
        > to supress this.

        I've searched the MS Knowledge Base about this problem, but
        I couldn't find an answer about this. But that doesn't mean
        that it is not there...

        > Webalizer interprets this whole string as url in the TopUrl
        > and TopUrlK stats. I get for each page accessed by different
        > browsers an extra entry in my stats.
        > Is it a problem of webalizer or can i suppress output of
        > user-agent after url?

        It's in the logfile, so it's not a webalizer problem. But if
        it makes you feel better: I've the same problem on one of my
        IIS4 servers.
        --
        Kees de Keizer NT Administrator T: +31-10-2448344
        Wirehub! Internet PGP: 0x24E3770B F: +31-10-2448356
        http://www.wirehub.net/ mailto:kees.de.keizer@...
        What a way to run a business! [The Phantom]
      • Kees de Keizer
        ... It took me a while, but now I know how to correct this: + Edit the WWW Properties + Select the ISAPI Filters property sheet. + Remove the msnewlog entry
        Message 3 of 3 , May 1, 2002
        • 0 Attachment
          W. M. wrote on 07-01-2002:

          > I have a problem with the cs-uri-stem entries in my webalizer-stats.
          > Look at my logfile (W3C-Format under IIS4)
          > After url information user-agent is seperated by a comma (e.g.
          > /top.htm,+Mozilla/4.0+(compatible.........). I don't know how to supress
          > this.

          It took me a while, but now I know how to correct this:

          + Edit the WWW Properties
          + Select the ISAPI Filters property sheet.
          + Remove the 'msnewlog' entry
          + Restart the server

          From now the entries in the logfiles will be normal again.
          --
          Kees de Keizer NT Administrator T: +31-10-2448344
          Wirehub! Internet PGP: 0x24E3770B F: +31-10-2448356
          http://www.wirehub.net/ mailto:kees.de.keizer@...
          Will someone tear these two apart [Les Miz]
        Your message has been successfully submitted and would be delivered to recipients shortly.